]> git.pld-linux.org Git - packages/freevo.git/blob - freevo.spec
3f8e24cbba2991ffeca3bf0836517d4ebad03277
[packages/freevo.git] / freevo.spec
1 Summary:        Freevo - open-source home theatre PC platform
2 Summary(pl):    Freevo - zestaw kina domowego oparty na platformie PC i otwartych ¼ród³ach
3 Name:           freevo
4 Version:        1.6.0
5 Release:        1
6 License:        GPL
7 Group:          Applications/Multimedia
8 Source0:        http://dl.sourceforge.net/freevo/%{name}-%{version}.tar.gz
9 # Source0-md5:  c454414a2453817ae5a73241d61fac2f
10 Source1:        %{name}-boot_config
11 URL:            http://freevo.sourceforge.net/
12 BuildRequires:  python-Imaging >= 1.1.4
13 BuildRequires:  python-Twisted >= 2.0.1-1
14 BuildRequires:  python-devel
15 BuildRequires:  python-elementtree
16 BuildRequires:  python-mmpython >= 0.4.9
17 BuildRequires:  python-pygame >= 1.5.6
18 BuildRequires:  rpm-pythonprov
19 %pyrequires_eq  python-libs
20 Requires:       aumix >= 2.8
21 Requires:       lsdvd
22 Requires:       mplayer
23 Requires:       python-Imaging >= 1.1.4
24 Requires:       python-TwistedWeb
25 Requires:       python-mmpython >= 0.4.9
26 Requires:       python-pygame >= 1.5.6
27 #Suggests:      tvtime
28 #Suggests:      xine-ui
29 #Suggests:      xmltv
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Freevo is a Linux application that turns a PC with a TV capture card
35 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
36 other applications such as xine, mplayer, tvtime and mencoder to play
37 and record video and audio.
38
39 %description -l pl
40 Freevo to linuksowa aplikacja zamieniaj±ca PC z kart± telewizyjn±
41 i/lub wyj¶ciem TV-out na samodzieln± multimedialn± szafê graj±c± /
42 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak xine,
43 mplayer, tvtime i mencoder s³u¿±ce do odtwarzania i nagrywania obrazu
44 i d¼wiêku.
45
46 %package boot
47 Summary:        Files to enable a standalone Freevo system (started from initscript)
48 Summary(pl):    Pliki do w³±czania samodzielnego systemu Freevo (uruchamiane z initscriptów)
49 Group:          Applications/Multimedia
50 Requires(post,preun):   /sbin/chkconfig
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       rc-scripts
53
54 %description boot
55 Freevo is a Linux application that turns a PC with a TV capture card
56 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
57 other applications such as mplayer and mencoder to play and record
58 video and audio.
59
60 Note: This installs the initscripts necessary for a standalone Freevo
61 system.
62
63 %description boot -l pl
64 Freevo to linuksowa aplikacja zamieniaj±ca PC z kart± telewizyjn±
65 i/lub wyj¶ciem TV-out na samodzieln± multimedialn± szafê graj±c± /
66 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak xine,
67 mplayer, tvtime i mencoder s³u¿±ce do odtwarzania i nagrywania obrazu
68 i d¼wiêku.
69
70 Ten pakiet instaluje skrypty inicjalizuj±ce potrzebne do samodzielnego
71 systemu Freevo.
72
73 %prep
74 %setup -q
75
76 find . -name CVS | xargs rm -rf
77 find . -name ".cvsignore" | xargs rm -f
78 find . -name "*.pyc" | xargs rm -f
79 find . -name "*.pyo" | xargs rm -f
80 find . -name "*.py" | xargs chmod 644
81
82 %build
83 env CFLAGS="%{rpmcflags}" \
84 python setup.py build
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 python setup.py install \
89         --root=$RPM_BUILD_ROOT \
90         --record=INSTALLED_FILES
91
92 install local_conf.py.example $RPM_BUILD_ROOT%{_docdir}
93
94 install -d $RPM_BUILD_ROOT%{_datadir}/freevo/contrib/lirc
95 cp -av contrib/lirc $RPM_BUILD_ROOT%{_datadir}/freevo/contrib
96 install -d $RPM_BUILD_ROOT%{_sysconfdir}/freevo
97 ## The following is needed to let RPM know that the files should be backed up
98 touch $RPM_BUILD_ROOT%{_sysconfdir}/freevo/freevo.conf
99 #
100 ## boot scripts
101 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
102 install -d $RPM_BUILD_ROOT%{_bindir}
103 install boot/freevo $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
104 install boot/freevo_dep $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
105 install boot/recordserver $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/freevo_recordserver
106 install boot/webserver $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/freevo_webserver
107 install boot/recordserver_init $RPM_BUILD_ROOT%{_bindir}/freevo_recordserver_init
108 install boot/webserver_init $RPM_BUILD_ROOT%{_bindir}/freevo_webserver_init
109 install -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/freevo/boot_config
110 #
111 #
112 install -d $RPM_BUILD_ROOT/var/log/freevo
113 install -d $RPM_BUILD_ROOT/var/cache/freevo
114 install -d $RPM_BUILD_ROOT/var/cache/freevo/{thumbnails,audio}
115 install -d $RPM_BUILD_ROOT/var/cache/xmltv/logos
116
117 %find_lang %{name}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post
123 if [ "$1" = 1 ]; then
124         echo "Remember to run 'freevo setup' after installing!"
125 fi
126
127 %post boot
128 # Add the service, but don't automatically invoke it
129 # user has to enable it via ntsysv
130 /sbin/chkconfig --add freevo
131 /sbin/chkconfig --level 234 freevo off
132 #/sbin/chkconfig --add freevo_dep
133 /sbin/chkconfig --add freevo_recordserver
134 /sbin/chkconfig --level 234 freevo_recordserver off
135 /sbin/chkconfig --add freevo_webserver
136 /sbin/chkconfig --level 234 freevo_webserver off
137
138 %preun boot
139 if [ "$1" = 0 ] ; then
140         /sbin/chkconfig --del freevo
141 #       /sbin/chkconfig --del freevo_dep
142         /sbin/chkconfig --del freevo_recordserver
143         /sbin/chkconfig --del freevo_webserver
144 fi
145
146 %files -f %{name}.lang
147 %defattr(644,root,root,755)
148 %doc ChangeLog FAQ INSTALL README TODO Docs local_conf.py.example
149 %doc contrib/lirc
150 %{_docdir}/local_conf.py.example
151 %attr(755,root,root) %{_bindir}/freevo
152 #%dir %{_docdir}/installation
153 #%dir %{_docdir}/plugin_writing
154 %{_datadir}/freevo
155 %dir %{_sysconfdir}/freevo
156 %attr(1777,root,root) %dir /var/log/freevo
157 %attr(1777,root,root) %dir /var/cache/freevo
158 %attr(1777,root,root) %dir /var/cache/freevo/audio
159 %attr(1777,root,root) %dir /var/cache/freevo/thumbnails
160 %attr(1777,root,root) %dir /var/cache/xmltv
161 %attr(1777,root,root) %dir /var/cache/xmltv/logos
162 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freevo/freevo.conf
163 #%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freevo/record_config.py
164 %{py_sitescriptdir}/freevo
165 %dir %{_datadir}/fxd
166 %{_datadir}/fxd/webradio.fxd
167
168 %files boot
169 %defattr(644,root,root,755)
170 %attr(754,root,root) /etc/rc.d/init.d/*
171 %attr(755,root,root) %{_bindir}/freevo_*
172 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freevo/boot_config
This page took 0.086465 seconds and 3 git commands to generate.