]> git.pld-linux.org Git - packages/freevo.git/blob - freevo.spec
automatic change: use py_build/py_install macros
[packages/freevo.git] / freevo.spec
1 Summary:        Freevo - open-source home theatre PC platform
2 Summary(pl.UTF-8):      Freevo - zestaw kina domowego oparty na platformie PC i otwartych źródłach
3 Name:           freevo
4 Version:        1.7.2
5 Release:        6
6 License:        GPL
7 Group:          Applications/Multimedia
8 Source0:        http://dl.sourceforge.net/freevo/%{name}-%{version}.tar.gz
9 # Source0-md5:  1c05c080cd89d70e07e393f74aaa1730
10 Source1:        %{name}-boot_config
11 Patch0:         %{name}-setup.py-elementtree.patch
12 Patch1:         %{name}-xmltv.py.patch
13 URL:            http://freevo.sourceforge.net/
14 BuildRequires:  python-BeautifulSoup
15 BuildRequires:  python-PIL >= 1.1.4
16 BuildRequires:  python-TwistedCore >= 2.0.1-1
17 BuildRequires:  python-TwistedWeb
18 BuildRequires:  python-devel
19 BuildRequires:  python-elementtree
20 BuildRequires:  python-kaa-imlib2
21 BuildRequires:  python-kaa-metadata
22 BuildRequires:  python-mmpython >= 0.4.9
23 BuildRequires:  python-pygame >= 1.5.6
24 BuildRequires:  python-libxml2
25 BuildRequires:  rpm-pythonprov
26 %pyrequires_eq  python-libs
27 Requires:       aumix >= 2.8
28 Requires:       lsdvd
29 Requires:       mplayer
30 Requires:       python-Numeric
31 Requires:       python-PIL >= 1.1.4
32 Requires:       python-TwistedWeb
33 Requires:       python-kaa-metadata
34 Requires:       python-kaa-imlib2
35 Requires:       python-mmpython >= 0.4.9
36 Requires:       python-numpy
37 Requires:       python-pygame >= 1.5.6
38 #Suggests:      tvtime
39 #Suggests:      xine-ui
40 #Suggests:      xmltv
41 BuildArch:      noarch
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Freevo is a Linux application that turns a PC with a TV capture card
46 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
47 other applications such as xine, mplayer, tvtime and mencoder to play
48 and record video and audio.
49
50 %description -l pl.UTF-8
51 Freevo to linuksowa aplikacja zamieniająca PC z kartą telewizyjną
52 i/lub wyjściem TV-out na samodzielną multimedialną szafę grającą /
53 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak xine,
54 mplayer, tvtime i mencoder służące do odtwarzania i nagrywania obrazu
55 i dźwięku.
56
57 %package boot
58 Summary:        Files to enable a standalone Freevo system (started from initscript)
59 Summary(pl.UTF-8):      Pliki do włączania samodzielnego systemu Freevo (uruchamiane z initscriptów)
60 Group:          Applications/Multimedia
61 Requires(post,preun):   /sbin/chkconfig
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       rc-scripts
64
65 %description boot
66 Freevo is a Linux application that turns a PC with a TV capture card
67 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
68 other applications such as mplayer and mencoder to play and record
69 video and audio.
70
71 Note: This installs the initscripts necessary for a standalone Freevo
72 system.
73
74 %description boot -l pl.UTF-8
75 Freevo to linuksowa aplikacja zamieniająca PC z kartą telewizyjną
76 i/lub wyjściem TV-out na samodzielną multimedialną szafę grającą /
77 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak xine,
78 mplayer, tvtime i mencoder służące do odtwarzania i nagrywania obrazu
79 i dźwięku.
80
81 Ten pakiet instaluje skrypty inicjalizujące potrzebne do samodzielnego
82 systemu Freevo.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p0
88
89 find . -name CVS | xargs rm -rf
90 find . -name ".cvsignore" | xargs rm -f
91 find . -name "*.pyc" | xargs rm -f
92 find . -name "*.pyo" | xargs rm -f
93 find . -name "*.py" | xargs chmod 644
94
95 %build
96 env %py_build
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 %py_install \
101         --record=INSTALLED_FILES
102
103 install local_conf.py.example $RPM_BUILD_ROOT%{_docdir}
104
105 install -d $RPM_BUILD_ROOT%{_datadir}/freevo/contrib/lirc
106 cp -av contrib/lirc $RPM_BUILD_ROOT%{_datadir}/freevo/contrib
107 install -d $RPM_BUILD_ROOT%{_sysconfdir}/freevo
108 ## The following is needed to let RPM know that the files should be backed up
109 touch $RPM_BUILD_ROOT%{_sysconfdir}/freevo/freevo.conf
110 #
111 ## boot scripts
112 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
113 install -d $RPM_BUILD_ROOT%{_bindir}
114 install boot/freevo $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
115 install boot/freevo_dep $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
116 install boot/recordserver $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/freevo_recordserver
117 install boot/webserver $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/freevo_webserver
118 install boot/recordserver_init $RPM_BUILD_ROOT%{_bindir}/freevo_recordserver_init
119 install boot/webserver_init $RPM_BUILD_ROOT%{_bindir}/freevo_webserver_init
120 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/freevo/boot_config
121 #
122 #
123 install -d $RPM_BUILD_ROOT/var/log/freevo
124 install -d $RPM_BUILD_ROOT/var/cache/freevo
125 install -d $RPM_BUILD_ROOT/var/cache/freevo/{thumbnails,audio}
126 install -d $RPM_BUILD_ROOT/var/cache/xmltv/logos
127
128 mv $RPM_BUILD_ROOT%{_datadir}/locale/{no,nb}
129 %find_lang %{name}
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post
135 if [ "$1" = 1 ]; then
136         echo "Remember to run 'freevo setup' after installing!"
137 fi
138
139 %post boot
140 # Add the service, but don't automatically invoke it
141 # user has to enable it via ntsysv
142 /sbin/chkconfig --add freevo
143 /sbin/chkconfig --level 234 freevo off
144 #/sbin/chkconfig --add freevo_dep
145 /sbin/chkconfig --add freevo_recordserver
146 /sbin/chkconfig --level 234 freevo_recordserver off
147 /sbin/chkconfig --add freevo_webserver
148 /sbin/chkconfig --level 234 freevo_webserver off
149
150 %preun boot
151 if [ "$1" = 0 ] ; then
152         /sbin/chkconfig --del freevo
153 #       /sbin/chkconfig --del freevo_dep
154         /sbin/chkconfig --del freevo_recordserver
155         /sbin/chkconfig --del freevo_webserver
156 fi
157
158 %files -f %{name}.lang
159 %defattr(644,root,root,755)
160 %doc ChangeLog FAQ INSTALL README TODO Docs local_conf.py.example
161 %doc contrib/lirc
162 %{_docdir}/local_conf.py.example
163 %attr(755,root,root) %{_bindir}/freevo
164 #%dir %{_docdir}/installation
165 #%dir %{_docdir}/plugin_writing
166 %{_datadir}/freevo
167 %dir %{_sysconfdir}/freevo
168 %attr(1777,root,root) %dir /var/log/freevo
169 %attr(1777,root,root) %dir /var/cache/freevo
170 %attr(1777,root,root) %dir /var/cache/freevo/audio
171 %attr(1777,root,root) %dir /var/cache/freevo/thumbnails
172 %attr(1777,root,root) %dir /var/cache/xmltv
173 %attr(1777,root,root) %dir /var/cache/xmltv/logos
174 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freevo/freevo.conf
175 #%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freevo/record_config.py
176 %{py_sitescriptdir}/freevo
177 #%dir %{_datadir}/fxd
178 #%{_datadir}/fxd/webradio.fxd
179
180 %files boot
181 %defattr(644,root,root,755)
182 %attr(754,root,root) /etc/rc.d/init.d/*
183 %attr(755,root,root) %{_bindir}/freevo_*
184 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freevo/boot_config
This page took 0.107745 seconds and 3 git commands to generate.