]> git.pld-linux.org Git - packages/freetype1.git/blob - freetype1.spec
- ugly hack to make it build with recent autotools
[packages/freetype1.git] / freetype1.spec
1 # TODO:
2 # - fix build with libtool-2
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # don't build static libraries
6 #
7 Summary:        Truetype font rasterizer
8 Summary(pl.UTF-8):      Rasteryzer fontów Truetype
9 Name:           freetype1
10 Version:        1.3.1
11 Release:        16
12 License:        BSD-like
13 Group:          Libraries
14 Source0:        ftp://ftp.freetype.org/freetype/freetype1/freetype-%{version}.tar.gz
15 # Source0-md5:  9a9e7ad00c1ef6dfbf8f8e19ceefb300
16 Patch0:         freetype-DESTDIR.patch
17 Patch1:         freetype-autoconf.patch
18 Patch2:         %{name}-po.patch
19 Patch3:         freetype-gcc33.patch
20 Patch4:         %{name}-parallel-make.patch
21 Patch5:         %{name}-link.patch
22 Patch6:         format-security.patch
23 Patch7:         gcc10.patch
24 URL:            http://freetype.sourceforge.net/freetype1/index.html
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  gettext-tools
28 BuildRequires:  libtool
29 BuildRequires:  xorg-lib-libX11-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The FreeType engine is a free and portable TrueType font rendering
34 engine. It has been developed to provide TrueType support to a great
35 variety of platforms and environments.
36
37 Note that FreeType is a *library*. It is not a font server for your
38 favorite platform, even though it was designed to be used in many of
39 them. Note also that it is *not* a complete text-rendering library.
40 Its purpose is simply to open and manage font files, as well as load,
41 hint and render individual glyphs efficiently. You can also see it as
42 a "TrueType driver" for a higher-level library, though rendering text
43 with it is extremely easy, as demo-ed by the test programs.
44
45 %description -l pl.UTF-8
46 FreeType jest biblioteką służącą do rasteryzacji fontów TrueType. Jest
47 to jedynie biblioteka, a nie serwer fontów, chociaż została ona
48 zaprojektowana do używania także w takich serwerach. Nie jest to też
49 kompletna biblioteka do rasteryzacji tekstu. Jej celem jest tylko
50 odczytywanie i zarządzanie plikami z fontami oraz wczytywanie i
51 wykonywanie hintingu i rasteryzacji poszczególnych glifów. Może być
52 także uważana za "sterownik TrueType" dla bibliotek wyższego poziomu,
53 jednak użycie samej biblioteki FreeType do rasteryzacji jest bardzo
54 proste, co można zobaczyć w programach demonstracyjnych.
55
56 %package devel
57 Summary:        Header files and development documentation
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki freetype i dokumentacja
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Provides:       freetype-devel = %{version}
62
63 %description devel
64 This package includes the header files documentations and libraries
65 necessary to develop applications that use freetype.
66
67 %description devel -l pl.UTF-8
68 Pakiet ten zawiera pliki nagłówkowe oraz biblioteki niezbędne przy
69 kompilowaniu programów wykorzystujących bibliotekę freetype.
70
71 %package static
72 Summary:        Freetype static libraries
73 Summary(pl.UTF-8):      Biblioteki statyczne freetype
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76 Provides:       freetype-static = %{version}
77
78 %description static
79 Static freetype libraries.
80
81 %description static -l pl.UTF-8
82 Biblioteki statyczne freetype.
83
84 %package progs
85 Summary:        Freetype library utilities
86 Summary(pl.UTF-8):      Programy użytkowe freetype
87 Group:          Applications
88 Requires:       %{name} = %{version}-%{release}
89 Provides:       freetype-progs = %{version}
90 Obsoletes:      freetype-utils
91 Obsoletes:      freetype-tools
92
93 %description progs
94 Freetype library utilites:
95 - ftimer - a simple performance timer for the engine,
96 - fzoom - very simple glyph viewer,
97 - ftlint - program will hint each glyph of a font file, at a given
98   point size,
99 - ftwiew - display all glyphs in a given font, applying hinting to
100   each one,
101 - fdump - a simple TrueType font or collection dumper,
102 - ftstring - a simple program to show off string text generation.
103 - ftstrpn - convert a rendered text string into the PGM or PBM format,
104 - fterror - small test program. Tests the gettext() functionality for
105   internationalized messages.
106
107 %description progs -l pl.UTF-8
108 Przykładowe aplikacje wykorzystujące freetype:
109 - ftimer - narzędzie mierzące szybkość silnika
110 - fzoom - prosta przeglądarka glifów
111 - ftlint - program robiący hinting każdego glifu z fontu przy podanym
112   rozmiarze
113 - ftview - program wyświetlający z hintingiem wszystkie glify z fontu
114 - fdump - narzędzie zrzucające dane z fontu lub zestawu fontów TT
115 - ftstring - prosty program obrazujący generowanie tekstu
116 - ftstrpn - konwerter zrenderowanego tekstu na format PGM/PBM
117 - fterror - prosty program testujący działanie gettext() w
118   zlokalizowanych komunikatach.
119
120 %prep
121 %setup -q -n freetype-%{version}
122 %patch0 -p1
123 %patch1 -p1
124 %patch2 -p1
125 %patch3 -p1
126 %patch4 -p1
127 %patch5 -p1
128 %patch6 -p1
129 %patch7 -p1
130
131 %build
132 install /usr/share/automake/missing .
133 %{__gettextize}
134 # gettextize stupidity (doesn't see intl/Makefile in next lines after AC_OUTPUT)
135 sed -e 's@\(AC_OUTPUT.*\) intl/Makefile@\1@' \
136         -e 's@AM_GNU_GETTEXT.*@AM_GNU_GETTEXT([external])@' \
137         -e 's@intl/Makefile@@' \
138         configure.in > configure.in.tmp
139 mv -f configure.in.tmp configure.in
140 %{__libtoolize}
141 %{__aclocal}
142 %{__autoconf}
143 # Ugly hack to avoid error:
144 # configure: error: cannot find required auxiliary files: compile missing
145 #
146 # Proper way would be to use automake which creates these files,
147 # but then it fails complaining that no Makefile.am exists
148 touch compile missing
149 %configure \
150         %{?with_static_libs:--enable-static} \
151         --with-gnu-ld
152 %{__make}
153
154 cd contrib
155 # ttf2pfb ttf2pk don't build
156 for bdir in ttf2bdf ttfbanner; do
157         cd $bdir
158         %{__libtoolize}
159         %{__aclocal}
160         %{__autoconf}
161         %configure
162         %{__make} -j1
163         cd ..
164 done
165
166 %install
167 rm -rf $RPM_BUILD_ROOT
168
169 %{__make} install \
170         DESTDIR=$RPM_BUILD_ROOT
171
172 %find_lang freetype
173
174 # resolve conflict with freetype-demos-2.*
175 mv -f $RPM_BUILD_ROOT%{_bindir}/{ftdump,ft1dump}
176 mv -f $RPM_BUILD_ROOT%{_bindir}/{ftlint,ft1lint}
177 mv -f $RPM_BUILD_ROOT%{_bindir}/{ftview,ft1view}
178 mv -f $RPM_BUILD_ROOT%{_bindir}/{fttimer,ft1timer}
179
180 for bdir in ttf2bdf ttfbanner; do
181         %{__make} install -C contrib/$bdir \
182                 DESTDIR=$RPM_BUILD_ROOT
183 done
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %post   -p /sbin/ldconfig
189 %postun -p /sbin/ldconfig
190
191 %files -f freetype.lang
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/libttf.so.*.*.*
194 %attr(755,root,root) %ghost %{_libdir}/libttf.so.2
195
196 %files devel
197 %defattr(644,root,root,755)
198 %doc howto/unix.txt README announce docs/{*.txt,FAQ,TODO,credits}
199 %attr(755,root,root) %{_libdir}/libttf.so
200 %{_libdir}/libttf.la
201 %{_includedir}/*
202
203 %if %{with static_libs}
204 %files static
205 %defattr(644,root,root,755)
206 %{_libdir}/lib*.a
207 %endif
208
209 %files progs
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_bindir}/f*
212 %attr(755,root,root) %{_bindir}/ttf*
213 %{_mandir}/man1/ttf2bdf.1*
This page took 0.074983 seconds and 4 git commands to generate.