]> git.pld-linux.org Git - packages/freetype1.git/blob - freetype1.spec
- new URL
[packages/freetype1.git] / freetype1.spec
1 # TODO:
2 # - fix build with libtool-2
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # don't build static libraries
6 #
7 Summary:        Truetype font rasterizer
8 Summary(pl.UTF-8):      Rasteryzer fontów Truetype
9 Name:           freetype1
10 Version:        1.3.1
11 Release:        11
12 License:        BSD-like
13 Group:          Libraries
14 Source0:        ftp://ftp.freetype.org/freetype/freetype1/freetype-%{version}.tar.gz
15 # Source0-md5:  9a9e7ad00c1ef6dfbf8f8e19ceefb300
16 Patch0:         freetype-DESTDIR.patch
17 Patch1:         freetype-autoconf.patch
18 Patch2:         %{name}-po.patch
19 Patch3:         freetype-gcc33.patch
20 URL:            http://freetype.sourceforge.net/freetype1/index.html
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  gettext-devel
24 BuildRequires:  libtool
25 BuildRequires:  xorg-lib-libX11-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The FreeType engine is a free and portable TrueType font rendering
30 engine. It has been developed to provide TrueType support to a great
31 variety of platforms and environments.
32
33 Note that FreeType is a *library*. It is not a font server for your
34 favorite platform, even though it was designed to be used in many of
35 them. Note also that it is *not* a complete text-rendering library.
36 Its purpose is simply to open and manage font files, as well as load,
37 hint and render individual glyphs efficiently. You can also see it as
38 a "TrueType driver" for a higher-level library, though rendering text
39 with it is extremely easy, as demo-ed by the test programs.
40
41 %description -l pl.UTF-8
42 FreeType jest biblioteką służącą do rasteryzacji fontów TrueType. Jest
43 to jedynie biblioteka, a nie serwer fontów, chociaż została ona
44 zaprojektowana do używania także w takich serwerach. Nie jest to też
45 kompletna biblioteka do rasteryzacji tekstu. Jej celem jest tylko
46 odczytywanie i zarządzanie plikami z fontami oraz wczytywanie i
47 wykonywanie hintingu i rasteryzacji poszczególnych glifów. Może być
48 także uważana za "sterownik TrueType" dla bibliotek wyższego poziomu,
49 jednak użycie samej biblioteki FreeType do rasteryzacji jest bardzo
50 proste, co można zobaczyć w programach demonstracyjnych.
51
52 %package devel
53 Summary:        Header files and development documentation
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki freetype i dokumentacja
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Provides:       freetype-devel = %{version}
58
59 %description devel
60 This package includes the header files documentations and libraries
61 necessary to develop applications that use freetype.
62
63 %description devel -l pl.UTF-8
64 Pakiet ten zawiera pliki nagłówkowe oraz biblioteki niezbędne przy
65 kompilowaniu programów wykorzystujących bibliotekę freetype.
66
67 %package static
68 Summary:        Freetype static libraries
69 Summary(pl.UTF-8):      Biblioteki statyczne freetype
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72 Provides:       freetype-static = %{version}
73
74 %description static
75 Static freetype libraries.
76
77 %description static -l pl.UTF-8
78 Biblioteki statyczne freetype.
79
80 %package progs
81 Summary:        Freetype library utilities
82 Summary(pl.UTF-8):      Programy użytkowe freetype
83 Group:          Applications
84 Requires:       %{name} = %{version}-%{release}
85 Provides:       freetype-progs = %{version}
86 Obsoletes:      freetype-utils
87 Obsoletes:      freetype-tools
88
89 %description progs
90 Freetype library utilites:
91 - ftimer - a simple performance timer for the engine,
92 - fzoom - very simple glyph viewer,
93 - ftlint - program will hint each glyph of a font file, at a given
94   point size,
95 - ftwiew - display all glyphs in a given font, applying hinting to
96   each one,
97 - fdump - a simple TrueType font or collection dumper,
98 - ftstring - a simple program to show off string text generation.
99 - ftstrpn - convert a rendered text string into the PGM or PBM format,
100 - fterror - small test program. Tests the gettext() functionality for
101   internationalized messages.
102
103 %description progs -l pl.UTF-8
104 Przykładowe aplikacje wykorzystujące freetype:
105 - ftimer - narzędzie mierzące szybkość silnika
106 - fzoom - prosta przeglądarka glifów
107 - ftlint - program robiący hinting każdego glifu z fontu przy podanym
108   rozmiarze
109 - ftview - program wyświetlający z hintingiem wszystkie glify z fontu
110 - fdump - narzędzie zrzucające dane z fontu lub zestawu fontów TT
111 - ftstring - prosty program obrazujący generowanie tekstu
112 - ftstrpn - konwerter zrenderowanego tekstu na format PGM/PBM
113 - fterror - prosty program testujący działanie gettext() w
114   zlokalizowanych komunikatach.
115
116 %prep
117 %setup -q -n freetype-%{version}
118 %patch0 -p1
119 %patch1 -p1
120 %patch2 -p1
121 %patch3 -p1
122
123 %build
124 install /usr/share/automake/missing .
125 %{__gettextize}
126 # gettextize stupidity (doesn't see intl/Makefile in next lines after AC_OUTPUT)
127 sed -e 's@\(AC_OUTPUT.*\) intl/Makefile@\1@' configure.in > configure.in.tmp
128 mv -f configure.in.tmp configure.in
129 %{__libtoolize}
130 %{__aclocal}
131 %{__autoconf}
132 %configure \
133         %{?with_static_libs:--enable-static} \
134         --with-gnu-ld
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 %find_lang freetype
144
145 # resolve conflict with freetype-demos-2.*
146 mv -f $RPM_BUILD_ROOT%{_bindir}/{ftdump,ft1dump}
147 mv -f $RPM_BUILD_ROOT%{_bindir}/{ftlint,ft1lint}
148 mv -f $RPM_BUILD_ROOT%{_bindir}/{ftview,ft1view}
149 mv -f $RPM_BUILD_ROOT%{_bindir}/{fttimer,ft1timer}
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %files -f freetype.lang
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/lib*so.*.*
160
161 %files devel
162 %defattr(644,root,root,755)
163 %doc howto/unix.txt README announce docs/{*.txt,FAQ,TODO,credits}
164 %attr(755,root,root) %{_libdir}/lib*.so
165 %{_libdir}/lib*.la
166 %{_includedir}/*
167
168 %if %{with static_libs}
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/lib*.a
172 %endif
173
174 %files progs
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_bindir}/f*
This page took 0.056951 seconds and 3 git commands to generate.