]> git.pld-linux.org Git - packages/freetds.git/blob - freetds.spec
1ee7a1b2b5b2e97703da302bf3f8432c550dbfd9
[packages/freetds.git] / freetds.spec
1 #
2 # Conditional build:
3 # _with_msdblib - use MS-style dblib
4 #
5 # %%define tdsver - protocol version; valid versions:
6 # 4.2 (used by Sybase SQLServer <= 10 and MS SQL Server 6.5)
7 # 4.6
8 # 5.0 (used by Sybase SQLServer >= 11)
9 # 7.0 (used by MS SQL Server 7.0) [default]
10 # 8.0 (not finished yet!)
11
12 %{!?tdsver:%define tdsver 7.0}
13
14 Summary:        Free implementation of Sybase's db-lib
15 Summary(pl):    Wolnodostêpna implementacja db-lib firmy Sybase
16 Name:           freetds
17 Version:        0.60
18 Release:        2
19 License:        LGPL
20 Group:          Libraries
21 Source0:        ftp://ftp.ibiblio.org/pub/Linux/ALPHA/freetds/stable/%{name}-%{version}.tgz
22 Patch0:         %{name}-nolibnsl.patch
23 URL:            http://www.freetds.org/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  glib-devel
27 BuildRequires:  libtool
28 BuildRequires:  unixODBC-devel
29 Requires(post): /sbin/ldconfig
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _sysconfdir     /etc/tds
33
34 %description
35 FreeTDS is a free (open source) implementation of Sybase's db-lib,
36 ct-lib, and ODBC libraries (which can be used also to work with MS SQL
37 databases). Currently, dblib and ctlib are most mature. Both of these
38 libraries have several programs known to compile and run against them.
39 ODBC is not quite as mature, but may work depending on your needs.
40
41 %description -l pl
42 FreeTDS to wolnodostêpna (z otwartymi ¼ród³ami) implementacja
43 bibliotek db-lib, ct-lib i ODBC firmy Sybase (których mo¿na u¿ywaæ
44 tak¿e do pracy z bazami MS SQL). Aktualnie najlepiej dzia³aj± dblib i
45 ctlib - istnieje trochê programów, o których wiadomo, ¿e kompiluj± siê
46 i dzia³aj± z tymi bibliotekami. ODBC nie jest jeszcze na tyle
47 skoñczony, ale mo¿e dzia³aæ w zale¿no¶ci od potrzeb.
48
49 %package devel
50 Summary:        FreeTDS header files
51 Summary(pl):    Pliki nag³ówkowe FreeTDS
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}
54
55 %description devel
56 FreeTDS header files.
57
58 %description devel -l pl
59 Pliki nag³ówkowe FreeTDS.
60
61 %package static
62 Summary:        FreeTDS static libraries
63 Summary(pl):    Statyczne biblioteki FreeTDS
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}
66
67 %description static
68 FreeTDS static libraries.
69
70 %description static -l pl
71 Statyczne biblioteki FreeTDS.
72
73 %prep
74 %setup -q
75 %patch -p1
76
77 %build
78 %{__libtoolize}
79 %{__aclocal}
80 %{__autoconf}
81 %{__automake}
82 %configure \
83         --with-tdsver=%{tdsver} \
84         %{?_with_msdblib:--with-msdblib} \
85         --with-unixodbc
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT \
93         ETC=$RPM_BUILD_ROOT%{_sysconfdir}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 /sbin/ldconfig
100 if [ -f /etc/freetds.conf ]; then
101         mv -f /etc/freetds.conf %{_sysconfdir}/freetds.conf
102 fi
103
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc AUTHORS BUGS ChangeLog README* TODO
109 %attr(755,root,root) %{_libdir}/lib*.so.*.*
110 %attr(755,root,root) %{_bindir}/*
111 %dir %{_sysconfdir}
112 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freetds.conf
113 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/locales.conf
114 %{_mandir}/man1/*
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/lib*.so
119 %{_libdir}/lib*.la
120 %{_includedir}/*
121
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/lib*.a
This page took 0.035515 seconds and 3 git commands to generate.