]> git.pld-linux.org Git - packages/freeradius.git/blob - freeradius.spec
- removed second BuildRoot definition
[packages/freeradius.git] / freeradius.spec
1 # FIXME: find a way of getting rid of "-" on versions ... rpm will be happy
2 Summary:        High-performance and highly configurable RADIUS server
3 Summary(pl):    Szybki i wysoce konfigurowalny serwer RADIUS.
4 Name:           freeradius
5 Version:        0.1
6 Release:        0
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        ftp://ftp.freeradius.org/pub/radius/%{name}-%{version}.tar.gz
12 URL:            http://www.freeradius.org/
13 Prereq:         /sbin/chkconfig
14 # FIXME: snmpwalk, snmpget and rusers POSSIBLY needed by checkrad
15 Requires:       libtool
16 BuildRequires:  libltdl-devel
17 BuildRequires:  openldap-devel
18 #someone's help needed:split&test into %{name}-{mysql,pgsql,common,devel,static,ldap,pam?} hunter.
19 BuildRequires:  mysql-devel
20 BuildRequires:  postgresql-devel
21 BuildRequires:  pam-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23 Obsoletes:      cistron-radius
24
25 %define         _localstatedir  /var/radius
26
27 # FIXME: won't be good to include these contrib examples?
28 # Source1:      http://www.ping.de/~fdc/radius/radacct-replay
29 # Source2:      http://www.ping.de/~fdc/radius/radlast-0.03
30 # Source3:      ftp://ftp.freeradius.org/pub/radius/contrib/radwho.cgi
31
32 %description
33 The FreeRADIUS Server Project is an attempt to create a
34 high-performance and highly configurable GPL'd RADIUS server. It is
35 generally similar to the Livingston 2.0 RADIUS server, but has a lot
36 more features, and is much more configurable.
37
38 %description(pl)
39 Projekt FreeRadius ma na celu stworzenie szybkiego i wysoce
40 konfigurowalnego serwera RADIUS na licencji GPL. Ten jest podobny do
41 Livingston 2.0 RADIUS server ale ma o wiele wiêcej ficzersów i jest
42 bardziej podatny na konfiguracjê.
43
44 %prep 
45 %setup -q
46
47 # FIXME: some folks prefer -dist files ... rename them or not?
48 #cd raddb
49 #chmod 640 clients naspasswd radiusd.conf.in
50 #cd ..
51
52 %build
53 CFLAGS="%{rpmcflags}" 
54 #libtoolize --copy --force
55 #aclocal
56 #autoconf
57 #automake -a -c
58
59 %configure2_13 --localstatedir=%{_localstatedir} \
60         --with-threads \
61         --with-thread-pool \
62         --with-gnu-ld \
63         --disable-ltdl-install
64 %{__make}
65
66 libtool --finish %{_libdir}
67
68 %install
69 # prepare $RPM_BUILD_ROOT
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{logrotate.d,pam.d,rc.d/init.d}
72
73 # install files
74 %{__make} install R=$RPM_BUILD_ROOT
75 # done here & put noreplace in %files to avoid messing up existing installations
76 for i in radutmp radwtmp  radius.log radwatch.log checkrad.log
77 do
78   touch  $RPM_BUILD_ROOT%{_localstatedir}/log/$i
79   echo  $RPM_BUILD_ROOT%{_localstatedir}/log/$i
80   #who the hell should own logfiles/ and what sgid should have radiusd ?
81 # do we need %{_sysconfdir}/shadow do be +r for wheel ? or better use PAM ?
82   # Hunter
83 done
84
85
86 # remove unneeded stuff
87 %{__rm} -f $RPM_BUILD_ROOT%{_prefix}/{man/man8/builddbm.8,sbin/rc.radiusd}
88
89 cd redhat
90 install -m 555 rc.radiusd-redhat $RPM_BUILD_ROOT/etc/rc.d/init.d/radiusd
91 install radiusd-logrotate $RPM_BUILD_ROOT/etc/logrotate.d/radiusd
92 install radiusd-pam       $RPM_BUILD_ROOT/etc/pam.d/radius
93 cd ..
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 /sbin/chkconfig --add radiusd.init
100
101 %preun
102 if [ "$1" = "0" ]; then
103         /sbin/chkconfig --del radiusd.init
104 fi
105
106 %files
107 %defattr(644,root,root,755)
108 %doc doc/ChangeLog doc/README* todo/ COPYRIGHT INSTALL
109 %config /etc/pam.d/radius
110 %config /etc/logrotate.d/radiusd
111 %config /etc/rc.d/init.d/radiusd
112 %config %{_sysconfdir}/raddb/*
113 %{_mandir}/*
114 %attr(755,root,root) %{_bindir}/*
115 %attr(755,root,root) %{_sbindir}/*
116 %{_libdir}/*
117 %dir %{_localstatedir}/log/radacct/
118 %config(missingok noreplace) %{_localstatedir}/log/checkrad.log
119 %config(missingok noreplace) %{_localstatedir}/log/radwatch.log
120 %config(missingok noreplace) %{_localstatedir}/log/radius.log
121 %config(missingok noreplace) %{_localstatedir}/log/radwtmp
122 %config(missingok noreplace) %{_localstatedir}/log/radutmp
This page took 0.099734 seconds and 4 git commands to generate.