]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
a9f4a0a9d1e0be550ae90356207531f4da5f2c4f
[packages/fox.git] / fox.spec
1 Summary:        The FOX C++ GUI Toolkit
2 Summary(pl):    FOX - toolkit graficzny w C++
3 Name:           fox
4 Version:        1.2.13
5 Release:        1
6 License:        LGPL
7 Group:          X11/Libraries
8 Source0:        http://www.fox-toolkit.org/ftp/%{name}-%{version}.tar.gz
9 # Source0-md5:  497a6c5880501e502d87a2e4a7c36d29
10 Patch0:         %{name}-opt.patch
11 Patch1:         %{name}-link.patch
12 URL:            http://www.fox-toolkit.org/fox.html
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  bzip2-devel
17 BuildRequires:  libjpeg-devel
18 BuildRequires:  libpng-devel
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  libtool
22 BuildRequires:  xcursor-devel
23 Requires:       OpenGL
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
27
28 %description
29 FOX is a C++-Based Library for Graphical User Interface Development
30 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
31 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
32 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
33 graphics. Subclassing of basic FOX widgets allows for easy extension
34 beyond the built-in widgets by application writers.
35
36 %description -l pl
37 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
38 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
39 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
40 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obs³ugê
41 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
42 rozszerzanie.
43
44 %package progs
45 Summary:        FOX example applications
46 Summary(pl):    Przyk³ady aplikacji w FOX
47 Group:          X11/Applications
48 Requires:       %{name} = %{version}-%{release}
49 Obsoletes:      %{name}-example-apps
50
51 %description progs
52 Editor and file browser, written with FOX.
53
54 %description progs -l pl
55 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
56
57 %package devel
58 Summary:        Header files for FOX library
59 Summary(pl):    Pliki nag³ówkowe biblioteki FOX
60 Group:          X11/Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       OpenGL-devel
63 Requires:       bzip2-devel
64 Requires:       libjpeg-devel
65 Requires:       libpng-devel
66 Requires:       libstdc++-devel
67 Requires:       libtiff-devel
68 Requires:       xcursor-devel
69
70 %description devel
71 Header files for FOX library.
72
73 %description devel -l pl
74 Pliki nag³ówkowe biblioteki FOX.
75
76 %package static
77 Summary:        FOX static libraries
78 Summary(pl):    Biblioteki statyczne FOX
79 Group:          X11/Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 FOX static libraries.
84
85 %description static -l pl
86 Biblioteki statyczne FOX.
87
88 %package doc
89 Summary:        Development documentation for FOX library
90 Summary(pl):    Dokumentacja programisty do biblioteki FOX
91 Group:          X11/Development/Libraries
92
93 %description doc
94 Development documentation for FOX library.
95
96 %description doc -l pl
97 Dokumentacja programisty do biblioteki FOX.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103
104 %build
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoconf}
108 %{__automake}
109 LDFLAGS="%{rpmldflags} -L/usr/X11R6/%{_lib}"
110 %configure \
111         --with-opengl \
112         %{?debug:--enable-debug}%{!?_debug:--enable-release}
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT%{_datadir}
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 ln -sf libFOX-1.2.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
123
124 rm -f doc/Makefile* doc/*/Makefile*
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS LICENSE_ADDENDUM README
135 %attr(755,root,root) %{_libdir}/lib*.so.*.*
136
137 %files progs
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_bindir}/adie
140 %attr(755,root,root) %{_bindir}/calculator
141 %attr(755,root,root) %{_bindir}/PathFinder
142 %attr(755,root,root) %{_bindir}/shutterbug
143
144 %files devel
145 %defattr(644,root,root,755)
146 %doc ADDITIONS TRACING
147 %attr(755,root,root) %{_bindir}/fox-config
148 %attr(755,root,root) %{_bindir}/reswrap
149 %attr(755,root,root) %{_libdir}/lib*.so
150 %{_libdir}/lib*.la
151 %{_mandir}/man1/*
152 %{_includedir}/fox-1.2
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/lib*.a
157
158 %files doc
159 %defattr(644,root,root,755)
160 %doc doc/*
This page took 0.095343 seconds and 3 git commands to generate.