]> git.pld-linux.org Git - packages/fonts-TTF-microsoft-tahoma.git/blob - fonts-TTF-microsoft-tahoma.spec
- updated to new CVS layout
[packages/fonts-TTF-microsoft-tahoma.git] / fonts-TTF-microsoft-tahoma.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package (requires Windows license)
4 #
5 %define         base_name               fonts-TTF-microsoft-tahoma
6 Summary:        Microsoft Tahoma TrueType font
7 Summary(pl.UTF-8):      Font TrueType Tahoma firmy Microsoft
8 %if %{with license_agreement}
9 Name:           %{base_name}
10 %else
11 Name:           %{base_name}-installer
12 %endif
13 Version:        20020525
14 %define         _rel    4
15 Release:        %{_rel}%{?with_license_agreement:wla}
16 # part of IE update - requires Windows license to use
17 License:        Windows EULA
18 Group:          Fonts
19 %if %{with license_agreement}
20 Source0:        http://download.microsoft.com/download/ie6sp1/finrel/6_sp1/W98NT42KMeXP/EN-US/IELPKTH.CAB
21 # NoSource0-md5: 358584cddb75ac90472c25f01b308ebe
22 NoSource:       0
23 BuildRequires:  cabextract
24 Requires(post,postun):  fontpostinst
25 Requires:       %{_fontsdir}/TTF
26 %else
27 Source1:        http://svn.pld-linux.org/svn/license-installer/license-installer.sh
28 # Source1-md5:  4fb1600353dd57fe088e0b12fb0ecac2
29 Requires:       cabextract
30 Requires:       rpm-build-tools >= 4.4.35
31 %endif
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         ttffontsdir     %{_fontsdir}/TTF
36
37 %description
38 Microsoft Tahoma TrueType font.
39
40 %description -l pl.UTF-8
41 Font TrueType Tahoma firmy Microsoft.
42
43 %prep
44 %if %{with license_agreement}
45 %setup -q -c -T
46 %{_bindir}/cabextract -L %{SOURCE0}
47 %endif
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 %if !%{with license_agreement}
52 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
53
54 sed -e '
55         s/@BASE_NAME@/%{base_name}/g
56         s/@TARGET_CPU@/%{_target_cpu}/g
57         s-@VERSION@-%{version}-g
58         s-@RELEASE@-%{release}-g
59         s,@USE_DISTFILES@,no,g
60         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
61         s,@DATADIR@,%{_datadir}/%{base_name},g
62 ' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
63
64 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
65
66 %else
67 install -d $RPM_BUILD_ROOT%{ttffontsdir}
68 install *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
69 %endif
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %if %{with license_agreement}
75 %post
76 fontpostinst TTF
77
78 %postun
79 fontpostinst TTF
80
81 %else
82 %post
83 echo "
84 License issues made us not to include inherent files into this package
85 by default (You need Windows license). If you want to create full
86 working package please build it with the following command:
87
88 %{_bindir}/%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
89 "
90 %endif
91
92 %files
93 %defattr(644,root,root,755)
94 %if %{with license_agreement}
95 %{ttffontsdir}/*
96 %else
97 %attr(755,root,root) %{_bindir}/%{base_name}.install
98 %{_datadir}/%{base_name}
99 %endif
This page took 0.081582 seconds and 3 git commands to generate.