]> git.pld-linux.org Git - packages/fonts-TTF-microsoft-arialunicode.git/blob - fonts-TTF-microsoft-arialunicode.spec
1f00b31d1495c3fe0a5ddb5debe517e426389705
[packages/fonts-TTF-microsoft-arialunicode.git] / fonts-TTF-microsoft-arialunicode.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package (may require MS Office license?)
4 #
5 %define         base_name               fonts-TTF-Microsoft-ArialUnicode
6 %define         rel                     3
7 Summary:        Microsoft Arial Unicode TrueType font
8 Summary(pl.UTF-8):      Font TrueType Arial Unicode firmy Microsoft
9 %if %{with license_agreement}
10 Name:           %{base_name}
11 %else
12 Name:           %{base_name}-installer
13 %endif
14 Version:        1.0
15 Release:        %{rel}%{?with_license_agreement:wla}
16 # part of MS Office - may require Office license to use
17 License:        ?
18 Group:          Fonts
19 %if %{with license_agreement}
20 # also at http://dl.sourceforge.net/corefonts/
21 Source0:        http://orwell.ru/download/aruniupd.exe
22 # NoSource0-md5: 1bef548eb449a0b24ad1c0b8e9d5f2ba
23 BuildRequires:  cabextract
24 Requires(post,postun):  fontpostinst
25 Requires:       %{_fontsdir}/TTF
26 %else
27 Source0:        http://svn.pld-linux.org/svn/license-installer/license-installer.sh
28 # Source0-md5:  329c25f457fea66ec502b7ef70cb9ede
29 Requires:       cabextract
30 Requires:       rpm-build-tools >= 4.4.37
31 Requires:       rpmbuild(macros) >= 1.544
32 %endif
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         ttffontsdir     %{_fontsdir}/TTF
37
38 %description
39 Microsoft Arial Unicode TrueType font.
40 %if !%{with license_agreement}
41 License issues made us not to include inherent files into this package
42 by default (it probably requires MS Office license). If you want to
43 create full working package please build it with one of the following
44 command:
45
46 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
47 %endif
48
49 %description -l pl.UTF-8
50 Font TrueType Arial Unicode firmy Microsoft.
51 %if !%{with license_agreement}
52 Kwestie licencji zmusiły nas do niedołączania do tego pakietu istotnych
53 plików (prawdopodobnie wymaga licencji na MS Office). Jeśli chcesz stworzyć
54 w pełni funkcjonalny pakiet, zbuduj go za pomocą polecenia:
55
56 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
57 %endif
58
59 %prep
60 %if %{with license_agreement}
61 %setup -q -c -T
62 /usr/bin/cabextract -L %{SOURCE0}
63 %endif
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %if !%{with license_agreement}
68 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
69
70 sed -e '
71         s/@BASE_NAME@/%{base_name}/g
72         s/@TARGET_CPU@/%{_target_cpu}/g
73         s-@VERSION@-%{version}-g
74         s-@RELEASE@-%{release}-g
75         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
76         s,@DATADIR@,%{_datadir}/%{base_name},g
77 ' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
78
79 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
80
81 %else
82 install -d $RPM_BUILD_ROOT%{ttffontsdir}
83 install *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
84 %endif
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %if %{with license_agreement}
90 %post
91 fontpostinst TTF
92
93 %postun
94 fontpostinst TTF
95
96 %else
97 %post
98 echo "
99 License issues made us not to include inherent files into this package
100 by default (it probably requires Windows license). If you want to
101 create full working package please build it with the following command:
102
103 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
104 "
105 %endif
106
107 %files
108 %defattr(644,root,root,755)
109 %if %{with license_agreement}
110 %{ttffontsdir}/*
111 %else
112 %attr(755,root,root) %{_bindir}/%{base_name}.install
113 %{_datadir}/%{base_name}
114 %endif
This page took 0.047399 seconds and 3 git commands to generate.