]> git.pld-linux.org Git - packages/fluxbox.git/blob - fluxbox.spec
- more verbose files
[packages/fluxbox.git] / fluxbox.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2          # disable imlib2 (pixmap themes) support
4 #
5 Summary:        Fluxbox - a windowmanager that is based on Blackbox
6 Summary(de.UTF-8):      Fluxbox - ein weiterer Window Manager für X
7 Summary(pl.UTF-8):      Mały i szybki zarządca okien dla X Window oparty o Blackbox
8 Summary(pt_BR.UTF-8):   Fluxbox é um gerenciador de janelas baseado no Blackbox
9 Name:           fluxbox
10 Version:        1.3.1
11 Release:        0.1
12 Epoch:          1
13 License:        MIT-like
14 Group:          X11/Window Managers
15 Source0:        http://downloads.sourceforge.net/fluxbox/%{name}-%{version}.tar.bz2
16 # Source0-md5:  0eaa940a69c0a876a520bb85d67b8bec
17 Source1:        %{name}.desktop
18 Source2:        %{name}-xsession.desktop
19 Source3:        %{name}-pld.style
20 Source4:        %{name}-pld.jpg
21 Source5:        %{name}.menu
22 URL:            http://fluxbox.org/
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake
25 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.0.0}
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool
28 BuildRequires:  xorg-lib-libXft-devel
29 BuildRequires:  xorg-lib-libXinerama-devel
30 %{?with_imlib2:BuildRequires:   xorg-lib-libXpm-devel}
31 BuildRequires:  xorg-lib-libXrandr-devel
32 Requires(post): vfmg >= 0.9.95
33 Requires:       vfmg >= 0.9.16-3
34 Provides:       blackbox
35 Obsoletes:      blackbox
36 Conflicts:      filesystem < 3.0-20
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _sysconfdir     /etc/X11/%{name}
40 %define         _wmpropsdir     /usr/share/gnome/wm-properties
41
42 %description
43 Fluxbox is yet another windowmanager for X. It's based on the Blackbox
44 0.61.1 code. Fluxbox looks like blackbox and handles styles, colors,
45 window placement and similar thing exactly like blackbox (100%
46 theme/style compatibility). So what's the difference between fluxbox
47 and blackbox then? The answer is: LOTS! Have a look at the homepage
48 for more info ;)
49
50 %description -l pl.UTF-8
51 Fluxbox jest zarządcą okien dla X Window opartym na Blackboksie
52 0.61.1. Jego zaletą jest estetyczny i szybki interfejs z wieloma
53 pulpitami i prostym menu. Wbudowano weń także algorytm rysowania
54 dekoracji okien, które mogą być jednokolorowe, gradientowe lub
55 trójwymiarowe.
56
57 %description -l pt_BR.UTF-8
58 Fluxbox é um gerenciador de janelas para X. Ele é baseado no código do
59 Blackbox 0.61.1. Fluxbox tem a aparência do blackbox e pode utilizar
60 seus estilos, cores e temas. Então qual a diferença entre o fluxbox e
61 o blackbox?
62
63 %description -l de.UTF-8
64 Fluxbox ist ein weiterer Window Manager für X basierend auf dem
65 Quellcode von Blackbox 0.61.1. Fluxbox ähnelt Blackbox und behandelt
66 Styles, Farben, Fensterplatzierungen und ähnliche Dinge genauso wie
67 Blackbox. Es ist somit 100% kompatibel zu den Blackbox Themes und
68 Styles.
69
70 %prep
71 %setup -q
72
73 echo "session.screen0.antialias: true" >> data/init.in
74
75 %build
76 %{__libtoolize}
77 %{__aclocal} -I .
78 %{__autoheader}
79 %{__autoconf}
80 %{__automake}
81 %configure \
82         --enable-slit \
83         --enable-gnome \
84         --enable-xinerama \
85         --enable-nls \
86         --enable-xft \
87         --enable-randr \
88         %{?with_imlib2:--enable-imlib2}
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT{%{_datadir}/{xsessions,wallpapers,%{name}/styles},%{_wmpropsdir}} \
95         $RPM_BUILD_ROOT%{_sysconfdir}
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}
101 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/xsessions/%{name}.desktop
102 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/%{name}/styles/PLD
103 install %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/wallpapers
104 install %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/fluxbox/menu
105 touch $RPM_BUILD_ROOT%{_sysconfdir}/menu2
106
107 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/fluxbox/nls/no*
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 # generate initial menu
114 [ -f /etc/sysconfig/vfmg ] && . /etc/sysconfig/vfmg
115 [ "$FLUXBOX" = yes -o "$FLUXBOX" = 1 -o ! -f %{_sysconfdir}/menu2 ] && \
116         vfmg fluxbox > %{_sysconfdir}/menu2 2>/dev/null ||:
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
121 %attr(755,root,root) %{_bindir}/fbrun
122 %attr(755,root,root) %{_bindir}/fbsetbg
123 %attr(755,root,root) %{_bindir}/fbsetroot
124 %attr(755,root,root) %{_bindir}/fluxbox
125 %attr(755,root,root) %{_bindir}/fluxbox-generate_menu
126 %attr(755,root,root) %{_bindir}/fluxbox-remote
127 %attr(755,root,root) %{_bindir}/fluxbox-update_configs
128 %attr(755,root,root) %{_bindir}/startfluxbox
129 %dir %{_sysconfdir}
130 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/menu2
131 %dir %{_datadir}/fluxbox
132 %{_datadir}/fluxbox/[!n]*
133 %dir %{_datadir}/fluxbox/nls
134 %{_datadir}/fluxbox/nls/C
135 %lang(be) %{_datadir}/fluxbox/nls/be*
136 %lang(bg) %{_datadir}/fluxbox/nls/bg*
137 %lang(cs) %{_datadir}/fluxbox/nls/cs*
138 %lang(da) %{_datadir}/fluxbox/nls/da*
139 %lang(de) %{_datadir}/fluxbox/nls/de*
140 %lang(el) %{_datadir}/fluxbox/nls/el*
141 %lang(en) %{_datadir}/fluxbox/nls/en*
142 %lang(es) %{_datadir}/fluxbox/nls/es*
143 %lang(et) %{_datadir}/fluxbox/nls/et*
144 %lang(fi) %{_datadir}/fluxbox/nls/fi*
145 %lang(fr) %{_datadir}/fluxbox/nls/fr*
146 %lang(it) %{_datadir}/fluxbox/nls/it*
147 %lang(ja) %{_datadir}/fluxbox/nls/ja*
148 %lang(ko) %{_datadir}/fluxbox/nls/ko*
149 %lang(lv) %{_datadir}/fluxbox/nls/lv*
150 %lang(mk) %{_datadir}/fluxbox/nls/mk_MK*
151 %lang(nb) %{_datadir}/fluxbox/nls/nb*
152 %lang(nl) %{_datadir}/fluxbox/nls/nl*
153 %lang(pl) %{_datadir}/fluxbox/nls/pl*
154 %lang(pt_BR) %{_datadir}/fluxbox/nls/pt_BR*
155 %lang(pt) %{_datadir}/fluxbox/nls/pt_PT*
156 %lang(ru) %{_datadir}/fluxbox/nls/ru*
157 %lang(sk) %{_datadir}/fluxbox/nls/sk*
158 %lang(sl) %{_datadir}/fluxbox/nls/sl*
159 %lang(sv) %{_datadir}/fluxbox/nls/sv*
160 %lang(tr) %{_datadir}/fluxbox/nls/tr*
161 %lang(uk) %{_datadir}/fluxbox/nls/uk*
162 %lang(vi) %{_datadir}/fluxbox/nls/vi*
163 %lang(zh_CN) %{_datadir}/fluxbox/nls/zh_CN*
164 %lang(zh_TW) %{_datadir}/fluxbox/nls/zh_TW*
165 %{_datadir}/xsessions/%{name}.desktop
166 %{_wmpropsdir}/fluxbox.desktop
167 %{_datadir}/wallpapers/*.jpg
168 %{_mandir}/man1/*.1*
169 %{_mandir}/man5/*.5*
This page took 0.042696 seconds and 4 git commands to generate.