]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- with readline bcond
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_with     ladcca          # enable ladcca sesion managment support
4 %bcond_with     readline        # build with readline lib line editing
5 %bcond_with     sse             # use the SSE instructions of Pentium3+ or Athlon XP
6 %bcond_without  static_libs     # don't build static library
7 #
8 %ifarch pentium3 pentium4 %{x8664}
9 %define         with_sse        1
10 %endif
11 #
12 Summary:        FluidSynth - a software, real-time synthesizer
13 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
14 Name:           fluidsynth
15 Version:        1.0.8
16 Release:        2
17 License:        LGPL
18 Group:          Applications/Sound
19 Source0:        http://savannah.nongnu.org/download/fluid/%{name}-%{version}.tar.gz
20 # Source0-md5:  e2abfd2e69fd8b28d965df968d7d44ee
21 Patch0:         %{name}-build.patch
22 URL:            http://www.fluidsynth.org/
23 BuildRequires:  alsa-lib-devel >= 0.9.0
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 BuildRequires:  jack-audio-connection-kit-devel
27 %{?with_ladcca:BuildRequires:   ladcca-devel < 0.4.0}
28 %{?with_ladcca:BuildRequires:   ladcca-devel >= 0.3.1}
29 BuildRequires:  ladspa-devel
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig
32 %{?with_readline:BuildRequires: readline-devel}
33 BuildRequires:  rpmbuild(macros) >= 1.213
34 Requires:       alsa-lib
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Fluid Synth is a software, real-time synthesizer based on the
39 Soundfont 2 specifications.
40
41 %description -l pl.UTF-8
42 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
43 oparty na specyfikacji Soundfont 2.
44
45 %package devel
46 Summary:        Development files for the FluidSynth
47 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 %{?with_readline:Requires:      readline-devel}
51
52 %description devel
53 This package contains the header files necessary to develop
54 applications using FluidSynth.
55
56 %description devel -l pl.UTF-8
57 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
58 kompilacji aplikacji korzystających z bibliotek FluidSynth.
59
60 %package static
61 Summary:        Static FluidSynth library
62 Summary(pl.UTF-8):      Statyczna wersje biblioteki FluidSynth
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 This package contains static version of the FluidSynth library.
68
69 %description static -l pl.UTF-8
70 Ten pakiet zawiera bibliotekę statyczną FluidSynth.
71
72 %prep
73 %setup -q
74 %patch0 -p1
75
76 %build
77 %{__libtoolize}
78 %{__aclocal}
79 %{__autoconf}
80 %{__autoheader}
81 %{__automake}
82
83 %configure \
84         %{!?with_ladcca:--disable-ladcca} \
85         %{!?with_static_libs:--disable-static} \
86         %{?with_sse:--enable-SSE} \
87         --enable-coreaudio \
88         --enable-jack-support \
89         --enable-ladspa \
90         --enable-profiling \
91         %{!?with_readline:--without-readline}
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc ChangeLog README
111 %attr(755,root,root) %{_bindir}/fluidsynth
112 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.1
114 %{_mandir}/man1/fluidsynth.1*
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libfluidsynth.so
119 %{_libdir}/libfluidsynth.la
120 %{_includedir}/fluidsynth.h
121 %{_includedir}/%{name}
122 %{_pkgconfigdir}/fluidsynth.pc
123
124 %if %{with static_libs}
125 %files static
126 %defattr(644,root,root,755)
127 %{_libdir}/libfluidsynth.a
128 %endif
This page took 0.099941 seconds and 4 git commands to generate.