]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- Suggest: soundfont-fluid (package is useless without any soundfont)
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_with     ladcca          # enable ladcca sesion managment support
4 %bcond_with     readline        # build with readline lib line editing
5 %bcond_with     sse             # use the SSE instructions of Pentium3+ or Athlon XP
6 %bcond_without  static_libs     # don't build static library
7 #
8 %ifarch pentium3 pentium4 %{x8664}
9 %define         with_sse        1
10 %endif
11 #
12 Summary:        FluidSynth - a software, real-time synthesizer
13 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
14 Name:           fluidsynth
15 Version:        1.0.8
16 Release:        3
17 License:        LGPL
18 Group:          Applications/Sound
19 Source0:        http://savannah.nongnu.org/download/fluid/%{name}-%{version}.tar.gz
20 # Source0-md5:  e2abfd2e69fd8b28d965df968d7d44ee
21 Patch0:         %{name}-build.patch
22 URL:            http://www.fluidsynth.org/
23 BuildRequires:  alsa-lib-devel >= 0.9.0
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 BuildRequires:  jack-audio-connection-kit-devel
27 %{?with_ladcca:BuildRequires:   ladcca-devel < 0.4.0}
28 %{?with_ladcca:BuildRequires:   ladcca-devel >= 0.3.1}
29 BuildRequires:  ladspa-devel
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig
32 %{?with_readline:BuildRequires: readline-devel}
33 BuildRequires:  rpmbuild(macros) >= 1.213
34 Requires:       alsa-lib
35 Suggests:       soundfont-fluid
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Fluid Synth is a software, real-time synthesizer based on the
40 Soundfont 2 specifications.
41
42 %description -l pl.UTF-8
43 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
44 oparty na specyfikacji Soundfont 2.
45
46 %package devel
47 Summary:        Development files for the FluidSynth
48 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 %{?with_readline:Requires:      readline-devel}
52
53 %description devel
54 This package contains the header files necessary to develop
55 applications using FluidSynth.
56
57 %description devel -l pl.UTF-8
58 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
59 kompilacji aplikacji korzystających z bibliotek FluidSynth.
60
61 %package static
62 Summary:        Static FluidSynth library
63 Summary(pl.UTF-8):      Statyczna wersje biblioteki FluidSynth
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 This package contains static version of the FluidSynth library.
69
70 %description static -l pl.UTF-8
71 Ten pakiet zawiera bibliotekę statyczną FluidSynth.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76
77 %build
78 %{__libtoolize}
79 %{__aclocal}
80 %{__autoconf}
81 %{__autoheader}
82 %{__automake}
83
84 %configure \
85         %{!?with_ladcca:--disable-ladcca} \
86         %{!?with_static_libs:--disable-static} \
87         %{?with_sse:--enable-SSE} \
88         --enable-coreaudio \
89         --enable-jack-support \
90         --enable-ladspa \
91         --enable-profiling \
92         %{!?with_readline:--without-readline}
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc ChangeLog README
112 %attr(755,root,root) %{_bindir}/fluidsynth
113 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.1
115 %{_mandir}/man1/fluidsynth.1*
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libfluidsynth.so
120 %{_libdir}/libfluidsynth.la
121 %{_includedir}/fluidsynth.h
122 %{_includedir}/%{name}
123 %{_pkgconfigdir}/fluidsynth.pc
124
125 %if %{with static_libs}
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libfluidsynth.a
129 %endif
This page took 0.035097 seconds and 4 git commands to generate.