]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- tabs in preamble
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_with     ladcca  # enable ladcca sesion managment support
4 %bcond_with     sse     # use the SSE instructions of Pentium3+ or Athlon XP
5 #
6 %ifarch pentium3 pentium4 %{x8664}
7 %define         with_sse        1
8 %endif
9 #
10 %define         rversion 1.0.7
11 #
12 Summary:        FluidSynth - a software, real-time synthesizer
13 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
14 Name:           fluidsynth
15 Version:        1.0.7a
16 Release:        2
17 License:        LGPL
18 Group:          Applications/Sound
19 Source0:        http://savannah.nongnu.org/download/fluid/%{name}-%{version}.tar.gz
20 # Source0-md5:  0f73d47990d859f19b8e9840bdab5c60
21 URL:            http://www.fluidsynth.org/
22 BuildRequires:  alsa-lib-devel >= 0.9.0
23 BuildRequires:  automake
24 BuildRequires:  jack-audio-connection-kit-devel
25 %{?with_ladcca:BuildRequires:   ladcca-devel < 0.4.0}
26 %{?with_ladcca:BuildRequires:   ladcca-devel >= 0.3.1}
27 BuildRequires:  ladspa-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpmbuild(macros) >= 1.213
30 Requires:       alsa-lib
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Fluid Synth is a software, real-time synthesizer based on the
35 Soundfont 2 specifications.
36
37 %description -l pl.UTF-8
38 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
39 oparty na specyfikacji Soundfont 2.
40
41 %package devel
42 Summary:        Development files for the FluidSynth
43 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 This package contains the header files necessary to develop
49 applications using FluidSynth.
50
51 %description devel -l pl.UTF-8
52 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
53 kompilacji aplikacji korzystających z bibliotek FluidSynth.
54
55 %package static
56 Summary:        Static FluidSynth library
57 Summary(pl.UTF-8):      Statyczna wersje biblioteki FluidSynth
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 This package contains static version of the FluidSynth library.
63
64 %description static -l pl.UTF-8
65 Ten pakiet zawiera bibliotekę statyczną FluidSynth.
66
67 %prep
68 %setup -qn %{name}-%{rversion}
69
70 %build
71 cp /usr/share/automake/config.sub .
72
73 %configure \
74         %{!?with_ladcca:--disable-ladcca} \
75         %{?with_sse:--enable-SSE} \
76         --enable-coreaudio \
77         --enable-jack-support \
78         --enable-ladspa \
79         --enable-midishare \
80         --enable-profiling
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc ChangeLog README
100 %attr(755,root,root) %{_bindir}/*
101 %attr(755,root,root) %{_libdir}/lib%{name}.so.*.*.*
102 %{_mandir}/man1/*
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/lib%{name}.so
107 %{_libdir}/lib%{name}.la
108 %{_includedir}/%{name}.h
109 %{_includedir}/%{name}
110 %{_pkgconfigdir}/fluidsynth.pc
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/lib%{name}.a
This page took 0.056101 seconds and 4 git commands to generate.