]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- updated to 1.1.5
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_with     ladcca          # enable ladcca sesion managment support
4 %bcond_with     readline        # build with readline lib line editing
5 %bcond_with     sse             # use the SSE instructions of Pentium3+ or Athlon XP
6 %bcond_without  static_libs     # don't build static library
7 #
8 %ifarch pentium3 pentium4 %{x8664}
9 %define         with_sse        1
10 %endif
11 #
12 Summary:        FluidSynth - a software, real-time synthesizer
13 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
14 Name:           fluidsynth
15 Version:        1.1.5
16 Release:        1
17 License:        LGPL
18 Group:          Applications/Sound
19 Source0:        http://downloads.sourceforge.net/fluidsynth/%{name}-%{version}.tar.bz2
20 # Source0-md5:  835b98b0ddedbb9cc24b53d66cf900c3
21 URL:            http://www.fluidsynth.org/
22 BuildRequires:  alsa-lib-devel >= 0.9.0
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake
25 BuildRequires:  gettext-devel
26 BuildRequires:  glib2-devel
27 BuildRequires:  jack-audio-connection-kit-devel
28 %{?with_ladcca:BuildRequires:   ladcca-devel < 0.4.0}
29 %{?with_ladcca:BuildRequires:   ladcca-devel >= 0.3.1}
30 BuildRequires:  ladspa-devel
31 BuildRequires:  lash-devel
32 BuildRequires:  libsndfile-devel >= 1.0.18
33 BuildRequires:  libtool
34 BuildRequires:  pkgconfig
35 BuildRequires:  portaudio-devel >= 19
36 BuildRequires:  pulseaudio-devel >= 0.9.8
37 %{?with_readline:BuildRequires: readline-devel}
38 BuildRequires:  rpmbuild(macros) >= 1.213
39 Requires:       alsa-lib
40 Suggests:       soundfont-fluid
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Fluid Synth is a software, real-time synthesizer based on the
45 Soundfont 2 specifications.
46
47 %description -l pl.UTF-8
48 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
49 oparty na specyfikacji Soundfont 2.
50
51 %package devel
52 Summary:        Development files for the FluidSynth
53 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       alsa-lib-devel >= 0.9.0
57 Requires:       jack-audio-connection-kit-devel
58 Requires:       lash-devel
59 Requires:       libsndfile-devel >= 1.0.18
60 Requires:       portaudio-devel >= 19
61 Requires:       pulseaudio-devel >= 0.9.8
62 %{?with_readline:Requires:      readline-devel}
63
64 %description devel
65 This package contains the header files necessary to develop
66 applications using FluidSynth.
67
68 %description devel -l pl.UTF-8
69 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
70 kompilacji aplikacji korzystających z bibliotek FluidSynth.
71
72 %package static
73 Summary:        Static FluidSynth library
74 Summary(pl.UTF-8):      Statyczna wersje biblioteki FluidSynth
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 This package contains static version of the FluidSynth library.
80
81 %description static -l pl.UTF-8
82 Ten pakiet zawiera bibliotekę statyczną FluidSynth.
83
84 %prep
85 %setup -q
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93
94 %configure \
95         %{!?with_ladcca:--disable-ladcca} \
96         %{!?with_static_libs:--disable-static} \
97         %{?with_sse:--enable-SSE} \
98         --enable-coreaudio \
99         --enable-jack-support \
100         --enable-ladspa \
101         --enable-profiling \
102         %{!?with_readline:--without-readline}
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfluidsynth.la
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc ChangeLog README
124 %attr(755,root,root) %{_bindir}/fluidsynth
125 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.1
127 %{_mandir}/man1/fluidsynth.1*
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libfluidsynth.so
132 %{_includedir}/fluidsynth.h
133 %{_includedir}/%{name}
134 %{_pkgconfigdir}/fluidsynth.pc
135
136 %if %{with static_libs}
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libfluidsynth.a
140 %endif
This page took 0.035544 seconds and 4 git commands to generate.