]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- rebuild with readline 5.0
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_with     ladcca  # enable ladcca sesion managment support
4 %bcond_with     sse     # use the SSE instructions of Pentium3+ or Athlon XP
5 #
6 %ifarch pentium3 pentium4 %{x8664}
7 %define         with_sse        1
8 %endif
9 #
10 Summary:        FluidSynth is a software, real-time synthesizer
11 Summary(pl):    FluidSynth to programowy syntezator dzia³aj±cy w czasie rzeczywistym
12 Name:           fluidsynth
13 Version:        1.0.6
14 Release:        2
15 License:        LGPL
16 Group:          Applications/Sound
17 Source0:        http://savannah.nongnu.org/download/fluid/%{name}-%{version}.tar.gz
18 # Source0-md5:  f18fd54d3f877a547b8455d2b6c7b177
19 URL:            http://www.fluidsynth.org/
20 BuildRequires:  alsa-lib-devel >= 0.9.0
21 BuildRequires:  automake
22 BuildRequires:  jack-audio-connection-kit-devel
23 %{?with_ladcca:BuildRequires:   ladcca-devel >= 0.3.1}
24 %{?with_ladcca:BuildRequires:   ladcca-devel < 0.4.0}
25 BuildRequires:  ladspa-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpmbuild(macros) >= 1.213
28 Requires:       alsa-lib
29 # supports also Mac OS X Darwin, so probably it is easy to extend
30 ExclusiveArch:  %{ix86} %{x8664}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Fluid Synth is a software, real-time synthesizer based on the
35 Soundfont 2 specifications.
36
37 %description -l pl
38 Fluid Synth to programowy, dzia³aj±cy w czasie rzeczywistym syntezator
39 oparty na specyfikacji Soundfont 2.
40
41 %package devel
42 Summary:        Development files for the FluidSynth
43 Summary(pl):    Pliki nag³ówkowe dla FluidSynth
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 This package contains the header files necessary to develop
49 applications using FluidSynth.
50
51 %description devel -l pl
52 Pakiet ten zawiera pliki nag³ówkowe potrzebne do tworzenia i
53 kompilacji aplikacji korzystaj±cych z bibliotek FluidSynth.
54
55 %package static
56 Summary:        Static FluidSynth library
57 Summary(pl):    Statyczna wersje biblioteki FluidSynth
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 This package contains static version of the FluidSynth library.
63
64 %description static -l pl
65 Ten pakiet zawiera bibliotekê statyczn± FluidSynth.
66
67 %prep
68 %setup -q
69
70 %build
71
72 cp /usr/share/automake/config.sub .
73
74 %configure \
75         %{!?with_ladcca:--disable-ladcca} \
76         %{?with_sse:--enable-SSE} \
77         --enable-coreaudio \
78         --enable-jack-support \
79         --enable-ladspa \
80         --enable-midishare \
81         --enable-profiling
82         
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc ChangeLog README
101 %{_mandir}/man1/*
102 %attr(755,root,root) %{_bindir}/*
103 %attr(755,root,root) %{_libdir}/lib%{name}.so.*.*.*
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/lib%{name}.so
108 %attr(755,root,root) %{_libdir}/lib%{name}.la
109 %{_includedir}/%{name}.h
110 %{_includedir}/%{name}
111 %{_libdir}/pkgconfig/fluidsynth.pc
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/lib%{name}.a
This page took 0.074126 seconds and 4 git commands to generate.