]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- lt/ac/am; added -build.patch; BR: autoconf, libtool
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_with     ladcca          # enable ladcca sesion managment support
4 %bcond_with     sse             # use the SSE instructions of Pentium3+ or Athlon XP
5 %bcond_without  static_libs     # don't build static library
6 #
7 %ifarch pentium3 pentium4 %{x8664}
8 %define         with_sse        1
9 %endif
10 #
11 Summary:        FluidSynth - a software, real-time synthesizer
12 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
13 Name:           fluidsynth
14 Version:        1.0.8
15 Release:        1
16 License:        LGPL
17 Group:          Applications/Sound
18 Source0:        http://savannah.nongnu.org/download/fluid/%{name}-%{version}.tar.gz
19 # Source0-md5:  e2abfd2e69fd8b28d965df968d7d44ee
20 Patch0:         %{name}-build.patch
21 URL:            http://www.fluidsynth.org/
22 BuildRequires:  alsa-lib-devel >= 0.9.0
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake
25 BuildRequires:  jack-audio-connection-kit-devel
26 %{?with_ladcca:BuildRequires:   ladcca-devel < 0.4.0}
27 %{?with_ladcca:BuildRequires:   ladcca-devel >= 0.3.1}
28 BuildRequires:  ladspa-devel
29 BuildRequires:  libtool
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpmbuild(macros) >= 1.213
32 Requires:       alsa-lib
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Fluid Synth is a software, real-time synthesizer based on the
37 Soundfont 2 specifications.
38
39 %description -l pl.UTF-8
40 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
41 oparty na specyfikacji Soundfont 2.
42
43 %package devel
44 Summary:        Development files for the FluidSynth
45 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 This package contains the header files necessary to develop
51 applications using FluidSynth.
52
53 %description devel -l pl.UTF-8
54 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
55 kompilacji aplikacji korzystających z bibliotek FluidSynth.
56
57 %package static
58 Summary:        Static FluidSynth library
59 Summary(pl.UTF-8):      Statyczna wersje biblioteki FluidSynth
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 This package contains static version of the FluidSynth library.
65
66 %description static -l pl.UTF-8
67 Ten pakiet zawiera bibliotekę statyczną FluidSynth.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72
73 %build
74 %{__libtoolize}
75 %{__aclocal}
76 %{__autoconf}
77 %{__autoheader}
78 %{__automake}
79
80 %configure \
81         %{!?with_ladcca:--disable-ladcca} \
82         %{!?with_static_libs:--disable-static} \
83         %{?with_sse:--enable-SSE} \
84         --enable-coreaudio \
85         --enable-jack-support \
86         --enable-ladspa \
87         --enable-profiling \
88         --without-readline
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc ChangeLog README
108 %attr(755,root,root) %{_bindir}/fluidsynth
109 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
110 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.1
111 %{_mandir}/man1/fluidsynth.1*
112
113 %files devel
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_libdir}/libfluidsynth.so
116 %{_libdir}/libfluidsynth.la
117 %{_includedir}/fluidsynth.h
118 %{_includedir}/%{name}
119 %{_pkgconfigdir}/fluidsynth.pc
120
121 %if %{with static_libs}
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libfluidsynth.a
125 %endif
This page took 0.061237 seconds and 4 git commands to generate.