]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
a8acbc1cf2754d5700b5db2f76a6a3b781b17b0e
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_without  lash            # LASH support (GPL)
4 %bcond_with     midishare       # MidiShare support
5 %bcond_without  portaudio       # portaudio support
6 %bcond_without  readline        # readline line editing (GPL)
7 %bcond_without  systemd         # systemd notify support
8 #
9 Summary:        FluidSynth - a software, real-time synthesizer
10 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
11 Name:           fluidsynth
12 Version:        2.2.4
13 Release:        1
14 %if %{with lash} || %{with readline}
15 License:        GPL v2+ (enforced by lash/readline), LGPL v2+ (fluidsynth itself)
16 %else
17 License:        LGPL v2+
18 %endif
19 Group:          Applications/Sound
20 #Source0Download: https://github.com/FluidSynth/fluidsynth/releases
21 Source0:        https://github.com/FluidSynth/fluidsynth/archive/v%{version}/%{name}-%{version}.tar.gz
22 # Source0-md5:  ef180422258a1696a651f84f4de9a737
23 URL:            https://www.fluidsynth.org/
24 BuildRequires:  SDL2-devel >= 2
25 BuildRequires:  alsa-lib-devel >= 0.9.1
26 BuildRequires:  cmake >= 3.12.0
27 BuildRequires:  dbus-devel >= 1.0.0
28 BuildRequires:  gettext-tools
29 BuildRequires:  glib2-devel >= 1:2.26.0
30 BuildRequires:  jack-audio-connection-kit-devel
31 BuildRequires:  ladspa-devel
32 %{?with_lash:BuildRequires:     lash-devel >= 0.3}
33 # OpenMP 4.0
34 BuildRequires:  libgomp-devel >= 6:4.9
35 BuildRequires:  libinstpatch-devel >= 1.1.0
36 BuildRequires:  libsndfile-devel >= 1.0.18
37 %{?with_midishare:BuildRequires:        midishare-devel}
38 BuildRequires:  pkgconfig
39 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
40 BuildRequires:  pulseaudio-devel >= 0.9.8
41 %{?with_readline:BuildRequires: readline-devel}
42 BuildRequires:  rpmbuild(macros) >= 1.213
43 %{?with_systemd:BuildRequires:  systemd-devel >= 1:209}
44 Requires:       alsa-lib >= 0.9.1
45 Requires:       glib2 >= 1:2.26.0
46 Requires:       libsndfile >= 1.0.18
47 Suggests:       soundfont-fluid
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Fluid Synth is a software, real-time synthesizer based on the
52 Soundfont 2 specifications.
53
54 %description -l pl.UTF-8
55 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
56 oparty na specyfikacji Soundfont 2.
57
58 %package devel
59 Summary:        Development files for the FluidSynth
60 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       alsa-lib-devel >= 0.9.1
64 Requires:       dbus-devel >= 1.0.0
65 Requires:       glib2-devel >= 1:2.26.0
66 Requires:       jack-audio-connection-kit-devel
67 %{?with_lash:Requires:  lash-devel >= 0.3}
68 Requires:       libsndfile-devel >= 1.0.18
69 %{?with_midishare:Requires: midishare-devel}
70 %{?with_portaudio:Requires:     portaudio-devel >= 19}
71 Requires:       pulseaudio-devel >= 0.9.8
72 %{?with_readline:Requires: readline-devel}
73 Obsoletes:      fluidsynth-static < 2
74
75 %description devel
76 This package contains the header files necessary to develop
77 applications using FluidSynth.
78
79 %description devel -l pl.UTF-8
80 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
81 kompilacji aplikacji korzystających z bibliotek FluidSynth.
82
83 %prep
84 %setup -q
85
86 %build
87 mkdir -p build
88 cd build
89 %cmake .. \
90         -Denable-midishare=%{with midishare} \
91         -Denable-lash=%{with lash} \
92         -Denable-portaudio=%{with portaudio} \
93         -Denable-readline=%{with readline} \
94         %{!?with_systemd:-Denable-systemd=OFF}
95
96 # define missing in autotools suite
97 echo '#define DEFAULT_SOUNDFONT "%{_datadir}/soundfonts/default.sf2"' >> src/config.h
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 cd build
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS README.md THANKS TODO
117 %attr(755,root,root) %{_bindir}/fluidsynth
118 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.3
120 %{_mandir}/man1/fluidsynth.1*
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/libfluidsynth.so
125 %{_includedir}/fluidsynth.h
126 %{_includedir}/fluidsynth
127 %{_pkgconfigdir}/fluidsynth.pc
This page took 0.076858 seconds and 3 git commands to generate.