]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
47ca9adef87d58e5e5c0fc895abcf68153c5b424
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_with     ladcca          # enable ladcca sesion managment support
4 %bcond_with     readline        # build with readline lib line editing
5 %bcond_with     sse             # use the SSE instructions of Pentium3+ or Athlon XP
6 %bcond_without  static_libs     # don't build static library
7 #
8 %ifarch pentium3 pentium4 %{x8664}
9 %define         with_sse        1
10 %endif
11 #
12 Summary:        FluidSynth - a software, real-time synthesizer
13 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
14 Name:           fluidsynth
15 Version:        1.1.1
16 Release:        1
17 License:        LGPL
18 Group:          Applications/Sound
19 Source0:        http://savannah.nongnu.org/download/fluid/%{name}-%{version}.tar.gz
20 # Source0-md5:  0db3da78028d255026230809c6e21b44
21 URL:            http://www.fluidsynth.org/
22 BuildRequires:  alsa-lib-devel >= 0.9.0
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake
25 BuildRequires:  gettext-devel
26 BuildRequires:  glib2-devel
27 BuildRequires:  jack-audio-connection-kit-devel
28 %{?with_ladcca:BuildRequires:   ladcca-devel < 0.4.0}
29 %{?with_ladcca:BuildRequires:   ladcca-devel >= 0.3.1}
30 BuildRequires:  ladspa-devel
31 BuildRequires:  libtool
32 BuildRequires:  pkgconfig
33 %{?with_readline:BuildRequires: readline-devel}
34 BuildRequires:  rpmbuild(macros) >= 1.213
35 Requires:       alsa-lib
36 Suggests:       soundfont-fluid
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Fluid Synth is a software, real-time synthesizer based on the
41 Soundfont 2 specifications.
42
43 %description -l pl.UTF-8
44 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
45 oparty na specyfikacji Soundfont 2.
46
47 %package devel
48 Summary:        Development files for the FluidSynth
49 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 %{?with_readline:Requires:      readline-devel}
53
54 %description devel
55 This package contains the header files necessary to develop
56 applications using FluidSynth.
57
58 %description devel -l pl.UTF-8
59 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
60 kompilacji aplikacji korzystających z bibliotek FluidSynth.
61
62 %package static
63 Summary:        Static FluidSynth library
64 Summary(pl.UTF-8):      Statyczna wersje biblioteki FluidSynth
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 This package contains static version of the FluidSynth library.
70
71 %description static -l pl.UTF-8
72 Ten pakiet zawiera bibliotekę statyczną FluidSynth.
73
74 %prep
75 %setup -q
76
77 %build
78 %{__libtoolize}
79 %{__aclocal}
80 %{__autoconf}
81 %{__autoheader}
82 %{__automake}
83
84 %configure \
85         %{!?with_ladcca:--disable-ladcca} \
86         %{!?with_static_libs:--disable-static} \
87         %{?with_sse:--enable-SSE} \
88         --enable-coreaudio \
89         --enable-jack-support \
90         --enable-ladspa \
91         --enable-profiling \
92         %{!?with_readline:--without-readline}
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc ChangeLog README
112 %attr(755,root,root) %{_bindir}/fluidsynth
113 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.1
115 %{_mandir}/man1/fluidsynth.1*
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libfluidsynth.so
120 %{_libdir}/libfluidsynth.la
121 %{_includedir}/fluidsynth.h
122 %{_includedir}/%{name}
123 %{_pkgconfigdir}/fluidsynth.pc
124
125 %if %{with static_libs}
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libfluidsynth.a
129 %endif
This page took 0.088134 seconds and 3 git commands to generate.