]> git.pld-linux.org Git - packages/fltk2.git/blob - fltk2.spec
78fc3d06501514fc9d5e7239c78f3ca2eb156025
[packages/fltk2.git] / fltk2.spec
1 %define         _name           fltk
2 %define         _snap           r6671
3 %define         _version        2.0
4 Summary:        Fast Light Tool Kit 2.x
5 Summary(pl.UTF-8):      FLTK - "lekki" X11 toolkit wersja 2.x
6 Summary(pt_BR.UTF-8):   Interface gráfica em C++ para X, OpenGL e Windows
7 Name:           fltk2
8 Version:        2.0.%{_snap}
9 Release:        1
10 License:        LGPL with amendments (see COPYING)
11 Group:          X11/Libraries
12 Source0:        http://ftp.easysw.com/pub/fltk/snapshots/%{_name}-%{_version}.x-%{_snap}.tar.bz2
13 # Source0-md5:  6bcef5fd51eb3bc4dd0702f3ae6da6ba
14 URL:            http://www.fltk.org/
15 BuildRequires:  autoconf
16 BuildRequires:  cairo-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  rpmbuild(macros) >= 1.315
19 BuildRequires:  xorg-lib-libX11-devel
20 BuildRequires:  xorg-lib-libXext-devel
21 BuildRequires:  xorg-lib-libXinerama-devel
22 BuildRequires:  xorg-util-makedepend
23 Obsoletes:      fltk
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd
28 C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and
29 Microsoft(r) Windows(r) NT 4.0, 95, or 98. It was originally developed
30 by Mr. Bill Spitzak and is currently maintained by a small group of
31 developers across the world with a central repository in the US. This
32 is a development version of incoming 2.x release.
33
34 %description -l pl.UTF-8
35 Fast Light Tool Kit ("FLTK", wymawiane "fultik"), jest rozprowadzanym
36 na licencji LGPL narzędziem do tworzenia graficznych interfejsów
37 użytkownika w C++ dla X (UNIX(r)), OpenGL(r), i Microsoft(r)
38 Windows(r) NT 4.0, 95, oraz 98. Jego pierwotnym autorem jest pan Bill
39 Spitzak; obecnie pakiet jest rozwijany przez niewielką grupę
40 deweloperów z różnych stron świata (centralne repozytorium znajduje
41 się w USA). To jest rozwojowa wersja FLTK nadchodzącej wersji 2.x.
42
43 %description -l pt_BR.UTF-8
44 A Fast Light Tool Kit ("FLTK", pronuncia-se "fulltick") é uma
45 ferramenta e interface gráfica feita em C++ para desenvolver
46 aplicativos para o X, OpenGL e Windows.
47
48 %package devel
49 Summary:        FLTK2 development files
50 Summary(pl.UTF-8):      Narzędzia programistyczne dla FLTK2
51 Summary(pt_BR.UTF-8):   Arquivos de inclusão para o FLTK2
52 Group:          X11/Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       libstdc++-devel
55 Obsoletes:      fltk-devel
56
57 %description devel
58 FLTK 2.x development files.
59
60 %description devel -l pl.UTF-8
61 Narzędzia programistyczne dla FLTK 2.x.
62
63 %description devel -l pt_BR.UTF-8
64 Arquivos de inclusão para o FLTK 2.x.
65
66 %package static
67 Summary:        FLTK2 static library
68 Summary(pl.UTF-8):      Biblioteka FLTK2 konsolidowana statycznie
69 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o FLTK2
70 Group:          X11/Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 FLTK2 static library.
75
76 %description static -l pl.UTF-8
77 Biblioteka FLTK2 konsolidowana statycznie.
78
79 %description static -l pt_BR.UTF-8
80 Bibliotecas estáticas para o FLTK2.
81
82 %prep
83 %setup -q -n %{_name}-%{_version}.x-%{_snap}
84
85 %build
86 %{__sed} -i -e '/fltk2-config/s/^\t/\t$(DESTDIR)/' fluid/Makefile
87 %{__autoconf}
88 %configure \
89         --enable-cairo \
90         --enable-shared \
91         --enable-threads \
92         --enable-xinerama \
93         --with-x \
94         --enable-xft \
95         --with-optim="%{rpmcxxflags}"
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 install -d $RPM_BUILD_ROOT%{_mandir}/man{1,3}
103
104 %{__make} install \
105         prefix=$RPM_BUILD_ROOT%{_prefix} \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 # install man by hand
109 %{__mv} documentation/fltk2-config.man $RPM_BUILD_ROOT%{_mandir}/man1/fltk2-config.1
110 %{__mv} documentation/fluid.man $RPM_BUILD_ROOT%{_mandir}/man1/fluid.1
111 %{__mv} documentation/fltk.man $RPM_BUILD_ROOT%{_mandir}/man3/fltk.3
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc CHANGES COPYING CREDITS README
122 %attr(755,root,root) %{_libdir}/libfltk2.so.*.*
123 %attr(755,root,root) %{_libdir}/libfltk2_gl.so.*.*
124 %attr(755,root,root) %{_libdir}/libfltk2_glut.so.*.*
125 %attr(755,root,root) %{_libdir}/libfltk2_images.so.*.*
126
127 %files devel
128 %defattr(644,root,root,755)
129 %doc documentation/*.{html,gif,jpg}
130 %attr(755,root,root) %{_bindir}/fltk2-config
131 %attr(755,root,root) %{_bindir}/fluid2
132 %attr(755,root,root) %{_libdir}/libfltk2.so
133 %attr(755,root,root) %{_libdir}/libfltk2_gl.so
134 %attr(755,root,root) %{_libdir}/libfltk2_glut.so
135 %attr(755,root,root) %{_libdir}/libfltk2_images.so
136 %dir %{_includedir}/fltk
137 %dir %{_includedir}/fltk/compat
138 %dir %{_includedir}/fltk/compat/FL
139 %{_includedir}/fltk/*.[hr]
140 %{_includedir}/fltk/compat/FL/*.[hH]
141 %{_mandir}/man1/fltk2-config.1*
142 %{_mandir}/man1/fluid.1*
143 %{_mandir}/man3/fltk.3*
144
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libfltk2.a
148 %{_libdir}/libfltk2_gl.a
149 %{_libdir}/libfltk2_glut.a
150 %{_libdir}/libfltk2_images.a
This page took 0.078796 seconds and 3 git commands to generate.