]> git.pld-linux.org Git - packages/fltk.git/blob - fltk.spec
d908956ecb117287f20db2c1e447f98bc5e61c80
[packages/fltk.git] / fltk.spec
1 #
2 # Conditional build:
3 # _without_gl   - without OpenGL support
4 #
5 Summary:        Fast Light Tool Kit
6 Summary(pl):    FLTK - "lekki" X11 toolkit
7 Summary(pt_BR): Interface gráfica em C++ para X, OpenGL e Windows
8 Name:           fltk
9 Version:        1.1.3
10 Release:        1
11 License:        LGPL with amendments (see COPYING)
12 Group:          X11/Libraries
13 Source0:        ftp://ftp.easysw.com/pub/%{name}/%{version}/%{name}-%{version}-source.tar.bz2
14 Source1:        http://www.fltk.org/doc-1.1/%{name}.ps.gz
15 Patch0:         %{name}-link.patch
16 URL:            http://www.fltk.org/
17 %{!?_without_gl:BuildRequires: OpenGL-devel}
18 BuildRequires:  XFree86-devel >= 3.3.6
19 BuildRequires:  gcc-c++
20 %{!?_without_gl:Requires: OpenGL}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22 Obsoletes:      libfltk1.1
23
24 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
25
26 %description
27 The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd
28 C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and
29 Microsoft(r) Windows(r) NT 4.0, 95, or 98. It was originally developed
30 by Mr. Bill Spitzak and is currently maintained by a small group of
31 developers across the world with a central repository in the US.
32
33 %description -l pl
34 Fast Light Tool Kit ("FLTK", wymawiane "faltik"), jest rozprowadzanym
35 na licencji LGPL narzêdziem do tworzenia graficznych interfejsów
36 u¿ytkownika w C++ dla X (UNIX(r)), OpenGL(r), i Microsoft(r)
37 Windows(r) NT 4.0, 95, oraz 98. Jego pierwotnym autorem jest pan Bill
38 Spitzak; obecnie pakiet jest rozwijany przez niewielk± grupê
39 deweloperów z ró¿nych stron ¶wiata (centralne repozytorium znajduje
40 siê w USA).
41
42 %description -l pt_BR
43 A Fast Light Tool Kit ("FLTK", pronuncia-se "fulltick") é uma
44 ferramenta e interface gráfica feita em C++ para desenvolver
45 aplicativos para o X, OpenGL e Windows.
46
47 %package devel
48 Summary:        FLTK development files
49 Summary(pl):    Narzêdzia programistyczne dla FLTK
50 Summary(pt_BR): Arquivos de inclusão para o FLTK
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}
53 Obsoletes:      libfltk1.1-devel
54
55 %description devel
56 FLTK development files.
57
58 %description devel -l pl
59 Narzêdzia programistyczne dla FLTK.
60
61 %description devel -l pt_BR
62 Arquivos de inclusão para o FLTK.
63
64 %package static
65 Summary:        FLTK static library
66 Summary(pl):    Biblioteka FLTK linkowana statycznie
67 Summary(pt_BR): Bibliotecas estáticas para o FLTK
68 Group:          X11/Development/Libraries
69 Requires:       %{name}-devel = %{version}
70
71 %description static
72 FLTK static library.
73
74 %description static -l pl
75 Biblioteka FLTK linkowana statycznie.
76
77 %description static -l pt_BR
78 Bibliotecas estáticas para o FLTK.
79
80 %prep
81 %setup -q
82 %patch -p1
83
84 install %{SOURCE1} .
85
86 %build
87 CPPFLAGS="-I/usr/X11R6/include"
88 %configure \
89         --enable-shared \
90         --with-x \
91         %{?_without_gl:--disable-gl}
92
93 %{__make} depend
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/FL,%{_libdir},%{_mandir}/man{1,3}}
99
100 %{__make} install \
101         libdir=$RPM_BUILD_ROOT%{_libdir} \
102         includedir=$RPM_BUILD_ROOT%{_includedir} \
103         bindir=$RPM_BUILD_ROOT%{_bindir}
104
105 install documentation/fltk-config.man $RPM_BUILD_ROOT%{_mandir}/man1/fltk-config.1
106 install documentation/fluid.man $RPM_BUILD_ROOT%{_mandir}/man1/fluid.1
107 install documentation/fltk.man $RPM_BUILD_ROOT%{_mandir}/man3/fltk.3
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 # note: COPYING contains amendments to LGPL, so don't remove!
118 %doc CHANGES COPYING CREDITS README
119 %attr(755,root,root) %{_libdir}/lib*.so.*.*
120
121 %files devel
122 %defattr(644,root,root,755)
123 %doc documentation/*.{html,gif,jpg} fltk.ps.gz
124 %attr(755,root,root) %{_bindir}/fltk-config
125 %attr(755,root,root) %{_bindir}/fluid
126 %attr(755,root,root) %{_libdir}/libfltk.so
127 %{_includedir}/FL
128 %{_mandir}/man[13]/*
129
130 %files static
131 %defattr(644,root,root,755)
132 %attr(644,root,root) %{_libdir}/lib*.a
This page took 0.064755 seconds and 3 git commands to generate.