]> git.pld-linux.org Git - packages/fltk.git/blob - fltk.spec
410e2527a64792ea31160d9a4af4d7653e9b519e
[packages/fltk.git] / fltk.spec
1 #
2 # Conditional build:
3 # _without_gl   - without OpenGL libraries
4 # _without_xft  - without Xft support
5 #
6 Summary:        Fast Light Tool Kit
7 Summary(pl):    FLTK - "lekki" X11 toolkit
8 Summary(pt_BR): Interface gráfica em C++ para X, OpenGL e Windows
9 Name:           fltk
10 Version:        1.1.3
11 Release:        1
12 License:        LGPL with amendments (see COPYING)
13 Group:          X11/Libraries
14 Source0:        ftp://ftp.easysw.com/pub/%{name}/%{version}/%{name}-%{version}-source.tar.bz2
15 # Source0-md5: f32b4acc456d567a6bd554ac03c24055
16 Source1:        http://www.fltk.org/doc-1.1/%{name}.ps.gz
17 Patch0:         %{name}-link.patch
18 Patch1:         %{name}-acfix.patch
19 URL:            http://www.fltk.org/
20 %{!?_without_gl:BuildRequires: OpenGL-devel}
21 BuildRequires:  XFree86-devel >= 3.3.6
22 BuildRequires:  autoconf
23 BuildRequires:  libstdc++-devel
24 %{!?_without_xft:BuildRequires: xft-devel}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26 Obsoletes:      libfltk1.1
27
28 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
29
30 %description
31 The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd
32 C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and
33 Microsoft(r) Windows(r) NT 4.0, 95, or 98. It was originally developed
34 by Mr. Bill Spitzak and is currently maintained by a small group of
35 developers across the world with a central repository in the US.
36
37 %description -l pl
38 Fast Light Tool Kit ("FLTK", wymawiane "faltik"), jest rozprowadzanym
39 na licencji LGPL narzêdziem do tworzenia graficznych interfejsów
40 u¿ytkownika w C++ dla X (UNIX(r)), OpenGL(r), i Microsoft(r)
41 Windows(r) NT 4.0, 95, oraz 98. Jego pierwotnym autorem jest pan Bill
42 Spitzak; obecnie pakiet jest rozwijany przez niewielk± grupê
43 deweloperów z ró¿nych stron ¶wiata (centralne repozytorium znajduje
44 siê w USA).
45
46 %description -l pt_BR
47 A Fast Light Tool Kit ("FLTK", pronuncia-se "fulltick") é uma
48 ferramenta e interface gráfica feita em C++ para desenvolver
49 aplicativos para o X, OpenGL e Windows.
50
51 %package devel
52 Summary:        FLTK development files
53 Summary(pl):    Narzêdzia programistyczne dla FLTK
54 Summary(pt_BR): Arquivos de inclusão para o FLTK
55 Group:          X11/Development/Libraries
56 Requires:       %{name} = %{version}
57 Obsoletes:      libfltk1.1-devel
58
59 %description devel
60 FLTK development files.
61
62 %description devel -l pl
63 Narzêdzia programistyczne dla FLTK.
64
65 %description devel -l pt_BR
66 Arquivos de inclusão para o FLTK.
67
68 %package static
69 Summary:        FLTK static library
70 Summary(pl):    Biblioteka FLTK linkowana statycznie
71 Summary(pt_BR): Bibliotecas estáticas para o FLTK
72 Group:          X11/Development/Libraries
73 Requires:       %{name}-devel = %{version}
74
75 %description static
76 FLTK static library.
77
78 %description static -l pl
79 Biblioteka FLTK linkowana statycznie.
80
81 %description static -l pt_BR
82 Bibliotecas estáticas para o FLTK.
83
84 %package gl
85 Summary:        FLTK GL library
86 Summary(pl):    Biblioteka FLTK GL
87 Group:          X11/Libraries
88 Requires:       %{name} = %{version}
89 Requires:       OpenGL
90
91 %description gl
92 FLTK GL library.
93
94 %description gl -l pl
95 Biblioteka FLTK GL.
96
97 %package gl-devel
98 Summary:        Header files for FLTK GL library
99 Summary(pl):    Pliki nag³ówkowe biblioteki FLTK GL
100 Group:          X11/Development/Libraries
101 Requires:       %{name}-devel = %{version}
102 Requires:       %{name}-gl = %{version}
103
104 %description gl-devel
105 Header files for FLTK GL library.
106
107 %description gl-devel -l pl
108 Pliki nag³ówkowe biblioteki FLTK GL.
109
110 %package gl-static
111 Summary:        FLTK GL static library
112 Summary(pl):    Statyczna biblioteka FLTK GL
113 Group:          X11/Development/Libraries
114 Requires:       %{name}-gl-devel = %{version}
115 Requires:       %{name}-static = %{version}
116
117 %description gl-static
118 FLTK GL static library.
119
120 %description gl-static -l pl
121 Statyczna biblioteka FLTK GL.
122
123 %prep
124 %setup -q
125 %patch0 -p1
126 %patch1 -p1
127
128 install %{SOURCE1} .
129
130 %build
131 CPPFLAGS="-I/usr/X11R6/include"
132 CXXFLAGS="%{rpmcflags} -I/usr/include/freetype2"
133 # no "-s" in LDFLAGS, they are propagated to fltk-config
134 # (together with -L/usr/X11R6/lib, so cannot be removed)
135 LDFLAGS=" "
136 %{__autoconf}
137 %configure \
138         --enable-shared \
139         --with-x \
140         %{?_without_gl:--disable-gl} \
141         %{!?_without_xft:--enable-xft}
142
143 %{__make} depend
144 %{__make}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/FL,%{_libdir},%{_mandir}/man{1,3}}
149
150 %{__make} install \
151         libdir=$RPM_BUILD_ROOT%{_libdir} \
152         includedir=$RPM_BUILD_ROOT%{_includedir} \
153         bindir=$RPM_BUILD_ROOT%{_bindir}
154
155 install documentation/fltk-config.man $RPM_BUILD_ROOT%{_mandir}/man1/fltk-config.1
156 install documentation/fluid.man $RPM_BUILD_ROOT%{_mandir}/man1/fluid.1
157 install documentation/fltk.man $RPM_BUILD_ROOT%{_mandir}/man3/fltk.3
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 # note: COPYING contains amendments to LGPL, so don't remove!
168 %doc CHANGES COPYING CREDITS README
169 %attr(755,root,root) %{_libdir}/libfltk.so.*.*
170 %attr(755,root,root) %{_libdir}/libfltk_forms.so.*.*
171 %attr(755,root,root) %{_libdir}/libfltk_images.so.*.*
172
173 %files devel
174 %defattr(644,root,root,755)
175 %doc documentation/*.{html,gif,jpg} fltk.ps.gz
176 %attr(755,root,root) %{_bindir}/fltk-config
177 %attr(755,root,root) %{_bindir}/fluid
178 %attr(755,root,root) %{_libdir}/libfltk.so
179 %attr(755,root,root) %{_libdir}/libfltk_forms.so
180 %attr(755,root,root) %{_libdir}/libfltk_images.so
181 %{_includedir}/FL
182 %exclude %{_includedir}/FL/Fl_Gl_Window.*
183 %exclude %{_includedir}/FL/gl*
184 %{_mandir}/man[13]/*
185
186 %files static
187 %defattr(644,root,root,755)
188 %attr(644,root,root) %{_libdir}/libfltk.a
189 %attr(644,root,root) %{_libdir}/libfltk_forms.a
190 %attr(644,root,root) %{_libdir}/libfltk_images.a
191
192 %if 0%{!?_without_gl:1}
193 %files gl
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libfltk_gl.so.*.*
196
197 %files gl-devel
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_libdir}/libfltk_gl.so
200 %{_includedir}/FL/Fl_Gl_Window.*
201 %{_includedir}/FL/gl*
202
203 %files gl-static
204 %defattr(644,root,root,755)
205 %attr(644,root,root) %{_libdir}/libfltk_gl.a
206 %endif
This page took 0.070164 seconds and 3 git commands to generate.