]> git.pld-linux.org Git - packages/flashrom.git/blob - flashrom.spec
40b60708f5bb2d5825ef5ef4b905ef9ede5e8054
[packages/flashrom.git] / flashrom.spec
1 Summary:        Tool Flashing your BIOS from the Unix/Linux command line
2 Summary(pl.UTF-8):      Narzędzie do upgrade BIOS z lini poleceń Unix/Linux
3 Name:           flashrom
4 Version:        0.9.0
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/Communications
8 Source0:        http://qa.coreboot.org/releases/%{name}-%{version}.tar.gz
9 # Source0-md5:  2211590202aead416eb649c9348b35b3
10 URL:            http://www.coreboot.org/Flashrom
11 BuildRequires:  coreutils
12 BuildRequires:  glibc-headers
13 BuildRequires:  pciutils-devel
14 BuildRequires:  rpm-build >= 4.3-0.20030610.21
15 BuildRequires:  zlib-devel
16 ExclusiveArch:  %{ix86} %{x8664}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _sbindir                /sbin
20
21 %description
22 flashrom is a utility for identifying, reading, writing, verifying and
23 erasing flash chips. It's often used to flash BIOS / EFI / coreboot /
24 firmware images.
25     - Supports more than 160 flash chips, 75 chipsets, 100 mainboards, and
26       10 PCI devices which can be used as external programmers.
27     - Supports parallel, LPC, FWH and SPI flash interfaces and various
28       chip packages (DIP32, PLCC32, DIP8, SO8/SOIC8, TSOP32, TSOP40 and
29       more)
30     - No physical access needed, root access is sufficient.
31     - No bootable floppy disk, bootable CD-ROM or other media needed.
32     - No keyboard or monitor needed. Simply reflash remotely via SSH.
33     - No instant reboot needed. Reflash your chip in a running system,
34       verify it, be happy. The new firmware will be present next time you
35       boot.
36     - Crossflashing and hotflashing is possible as long as the flash chips
37       are electrically and logically compatible (same protocol). Great for
38       recovery.
39     - Scriptability. Reflash a whole pool of identical machines at the
40       same time from the command line. It is recommended to check flashrom
41       output and error codes.
42     - Speed. flashrom is often much faster than most vendor flash tools.
43     - Portability. Supports Linux, FreeBSD, DragonFly BSD, Solaris, Mac OS
44       X, and other Unix-like OSes.
45
46 %description -l pl.UTF-8
47 flashrom to narzędzie do identyfikacji, odczytu, zapisu, weryfikacji
48 i kasowania układów flash. Jest często używany do programowania
49 BIOS / EFI / coreboot / firmware z pliku.
50      - Obsługuje ponad 160 chipów flash, 75 chipsetów, 100 płyt
51        głównych i 10 urządzeń PCI, które mogą być wykorzystane jako
52        zewnętrzne programatory.
53      - Wspiera układy flash równoległe, LPC, SPI i FWH o różnych
54        obudowach/wyprowadzeniach (DIP32, PLCC32, DIP8, SO8/SOIC8, TSOP32,
55        TSOP40 i inne)
56      - Nie potrzeba fizycznego dostępu, wystarczy dostęp do konta root.
57      - Nie potrzebuje bootowalnej dyskietki, rozruchowego dysku CD-ROM lub
58        innych nośników.
59      - Niekonieczne ani klawiatura lub monitor. Wystarczy przeprogramować
60        zdalnie poprzez SSH.
61      - Nie ma potrzeby ponownego uruchamiania komputera. Zaprogramuj swój
62        chip w uruchomionym systemie, zweryfikuj, bądź szczęśliwy. Nowy
63        firmware będzie dostępny przy następnym bootowaniu.
64      - Crossflashing i hotflashing jest możliwe tak długo, jak układy
65        flash są elektrycznie i logicznie kompatybilne (ten sam protokół).
66        Świetna metoda do przywracania sprzętu z źle zaprogramowanym
67        firmware/BIOS.
68      - Prosta możliwość tworzenia skryptów do wielokrotnego
69        programowania. Programowanie identycznych maszyn w tym samym czasie z
70        linii poleceń. Zaleca się sprawdzanie komunikatów programu flashrom
71        i kodów błędów.
72      - Szybkość. flashrom jest często znacznie szybszy niż większość
73        sprzedawanych narzędzi dp flashowania.
74      - Wszechstronność. Wspiera Linux, FreeBSD, Dragonfly BSD, Solaris,
75        Mac OS X i inne systemy operacyjne oparte na Unix.
76
77 %prep
78 %setup -q
79 %{__sed} -i -e 's,__LIB_DIR_,%{_libdir},g' Makefile
80
81 %build
82 %{__make} \
83         CC='%{__cc}' \
84         CFLAGS='%{rpmcflags}' \
85         LDFLAGS='%{rpmldflags} -lpci -lz'
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT%{_sbindir}
90 install %{name} $RPM_BUILD_ROOT%{_sbindir}
91 install -d $RPM_BUILD_ROOT%{_mandir}/man8
92 install %{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc README COPYING
100 %attr(755,root,root) %{_sbindir}/flashrom
101 %{_mandir}/man8/flashrom.8*
This page took 0.087669 seconds and 3 git commands to generate.