]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
8f16ba39129048ee4984427cb34bc8e3d1359f1a
[packages/flac.git] / flac.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  xmms            # don't build XMMS plugin
5 %bcond_with     sse2            # SSE2 instructions
6
7 %ifarch %{x8664} x32 pentium4
8 %define with_sse2       1
9 %endif
10 Summary:        Free Lossless Audio Codec
11 Summary(pl.UTF-8):      Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
12 Name:           flac
13 Version:        1.4.0
14 Release:        1
15 License:        BSD (libFLAC/libFLAC++), GPL v2+ (programs and plugins)
16 Group:          Libraries
17 Source0:        https://downloads.xiph.org/releases/flac/%{name}-%{version}.tar.xz
18 # Source0-md5:  f3c395e936156c3a63add169dec629a5
19 URL:            https://xiph.org/flac/
20 BuildRequires:  autoconf >= 2.60
21 BuildRequires:  automake >= 1:1.11
22 BuildRequires:  doxygen
23 # for AM_ICONV
24 BuildRequires:  gettext-tools
25 BuildRequires:  libogg-devel >= 2:1.0
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool >= 2:2
28 %{?with_xmms:BuildRequires:     rpmbuild(macros) >= 1.125}
29 BuildRequires:  tar >= 1:1.22
30 %{?with_xmms:BuildRequires:     xmms-devel >= 0.9.5.1}
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
36
37 %description -l pl.UTF-8
38 FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
39 przez Josha Coalsona.
40
41 %package devel
42 Summary:        FLAC - development files
43 Summary(pl.UTF-8):      FLAC - pliki nagłówkowe
44 License:        BSD
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       libogg-devel >= 2:1.0
48
49 %description devel
50 The package contains the development header files for FLAC libraries.
51
52 %description devel -l pl.UTF-8
53 Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
54
55 %package static
56 Summary:        FLAC - static libraries
57 Summary(pl.UTF-8):      FLAC - biblioteki statyczne
58 License:        BSD
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 The package contains FLAC static libraries.
64
65 %description static -l pl.UTF-8
66 Ten pakiet zawiera biblioteki statyczne FLAC.
67
68 %package c++
69 Summary:        FLAC++ - C++ API for FLAC codec
70 Summary(pl.UTF-8):      FLAC++ - API C++ do kodeka FLAC
71 Group:          Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description c++
75 FLAC++ - C++ API for FLAC codec.
76
77 %description c++ -l pl.UTF-8
78 FLAC++ - API C++ do kodeka FLAC.
79
80 %package c++-devel
81 Summary:        Header files for FLAC++ library
82 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FLAC++
83 Group:          Development/Libraries
84 Requires:       %{name}-c++ = %{version}-%{release}
85 Requires:       %{name}-devel = %{version}-%{release}
86 Requires:       libstdc++-devel
87
88 %description c++-devel
89 Header files for FLAC++ library.
90
91 %description c++-devel -l pl.UTF-8
92 Pliki nagłówkowe biblioteki FLAC++.
93
94 %package c++-static
95 Summary:        Static FLAC++ library
96 Summary(pl.UTF-8):      Statyczna biblioteka FLAC++
97 Group:          Development/Libraries
98 Requires:       %{name}-c++-devel = %{version}-%{release}
99
100 %description c++-static
101 Static FLAC++ library.
102
103 %description c++-static -l pl.UTF-8
104 Statyczna biblioteka FLAC++.
105
106 %package -n xmms-input-flac
107 Summary:        Free Lossless Audio Codec - XMMS plugin
108 Summary(pl.UTF-8):      Wtyczka FLAC dla XMMS
109 License:        GPL v2+
110 Group:          Libraries
111 Requires:       %{name} = %{version}-%{release}
112 Requires:       xmms >= 0.9.5.1
113
114 %description -n xmms-input-flac
115 FLAC input plugin for XMMS.
116
117 %description -n xmms-input-flac -l pl.UTF-8
118 Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
119
120 %prep
121 %setup -q
122
123 %{__rm} m4/ogg.m4
124
125 %build
126 %{__libtoolize}
127 %{__aclocal} -I m4
128 %{__autoconf}
129 %{__autoheader}
130 %{__automake}
131 %configure \
132         --disable-silent-rules \
133         %{!?with_sse2:--disable-sse} \
134         %{?with_static_libs:--enable-static} \
135         %{!?with_xmms:--disable-xmms-plugin}
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 # packaged as %doc in -devel
145 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
146
147 %if %{with xmms}
148 %{__rm} $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
149 %if %{with static_libs}
150 %{__rm} $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.a
151 %endif
152 %endif
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post   -p /sbin/ldconfig
158 %postun -p /sbin/ldconfig
159
160 %post   c++ -p /sbin/ldconfig
161 %postun c++ -p /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 %doc AUTHORS COPYING.Xiph README.md
166 %attr(755,root,root) %{_bindir}/flac
167 %attr(755,root,root) %{_bindir}/metaflac
168 %attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libFLAC.so.12
170 %{_mandir}/man1/flac.1*
171 %{_mandir}/man1/metaflac.1*
172
173 %files devel
174 %defattr(644,root,root,755)
175 %doc doc/api/*.{html,png} doc/images/logo*.{gif,svg}
176 %attr(755,root,root) %{_libdir}/libFLAC.so
177 %{_libdir}/libFLAC.la
178 %{_includedir}/FLAC
179 %{_pkgconfigdir}/flac.pc
180 %{_aclocaldir}/libFLAC.m4
181
182 %if %{with static_libs}
183 %files static
184 %defattr(644,root,root,755)
185 %{_libdir}/libFLAC.a
186 %endif
187
188 %files c++
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libFLAC++.so.10
192
193 %files c++-devel
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libFLAC++.so
196 %{_libdir}/libFLAC++.la
197 %{_includedir}/FLAC++
198 %{_pkgconfigdir}/flac++.pc
199 %{_aclocaldir}/libFLAC++.m4
200
201 %if %{with static_libs}
202 %files c++-static
203 %defattr(644,root,root,755)
204 %{_libdir}/libFLAC++.a
205 %endif
206
207 %if %{with xmms}
208 %files -n xmms-input-flac
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{xmms_input_plugindir}/libxmms-flac.so
211 %endif
This page took 0.056633 seconds and 2 git commands to generate.