]> git.pld-linux.org Git - packages/fish.git/blob - fish.spec
c1ffb2c764b8ea8009e5a577fd997bd1acbad46a
[packages/fish.git] / fish.spec
1 Summary:        fish - A friendly interactive shell
2 Summary(pl.UTF-8):      fish - przyjazna interaktywna powłoka
3 Name:           fish
4 Version:        2.6.0
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/Shells
8 Source0:        http://fishshell.com/files/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  ce9d8cc2a34d172a94cfa3ef9988937c
10 URL:            http://fishshell.com/
11 BuildRequires:  autoconf >= 2.60
12 BuildRequires:  doxygen
13 BuildRequires:  gettext-tools
14 BuildRequires:  ncurses-devel
15 BuildRequires:  rpmbuild(macros) >= 1.462
16 Suggests:       python
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 fish is a shell geared towards interactive use. Its features are
21 focused on user friendlieness and discoverability. The language syntax
22 is simple but incompatible with other shell languages.
23
24 %description -l pl.UTF-8
25 fish jest powłoką nastawioną na interaktywne używanie. Jego cechą jest
26 przyjazne nastawienie dla użytkownika. Składnia języka jest prosta ale
27 nie jest zgodna z innymi językami powłoki.
28
29 %prep
30 %setup -q
31
32 %build
33 %{__aclocal}
34 %{__autoconf}
35 %{__autoheader}
36 %configure
37
38 %{__make} V=1
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 %{__make} install \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
46 # no -devel package yet
47 %{__rm} $RPM_BUILD_ROOT%{_npkgconfigdir}/fish.pc
48
49 %find_lang %{name}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post -p <lua>
55 %lua_add_etc_shells %{_bindir}/fish
56
57 %preun -p <lua>
58 if arg[2] == 0 then
59         %lua_remove_etc_shells %{_bindir}/fish
60 end
61
62 %files -f %{name}.lang
63 %defattr(644,root,root,755)
64 %doc README.md user_doc/html/*.{html,css,png}
65 %dir %{_sysconfdir}/fish
66 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fish/config.fish
67 %attr(755,root,root) %{_bindir}/fish
68 %attr(755,root,root) %{_bindir}/fish_indent
69 %attr(755,root,root) %{_bindir}/fish_key_reader
70 %{_mandir}/man1/fish.1*
71 %{_mandir}/man1/fish_indent.1*
72 %{_mandir}/man1/fish_key_reader.1*
73 %dir %{_datadir}/%{name}
74 %{_datadir}/%{name}/config.fish
75 %{_datadir}/%{name}/__fish_build_paths.fish
76 %dir %{_datadir}/%{name}/completions
77 %{_datadir}/%{name}/completions/..fish
78 %{_datadir}/%{name}/completions/*.fish
79 %{_datadir}/%{name}/vendor_completions.d
80 %dir %{_datadir}/%{name}/functions
81 %{_datadir}/%{name}/functions/*.fish
82 %{_datadir}/%{name}/man
83 %dir %{_datadir}/%{name}/tools
84 %attr(755,root,root) %{_datadir}/%{name}/tools/create_manpage_completions.py
85 %{_datadir}/%{name}/tools/deroff.py
86 %dir %{_datadir}/%{name}/tools/web_config
87 %{_datadir}/%{name}/tools/web_config/delete.png
88 %{_datadir}/%{name}/tools/web_config/favicon.png
89 %{_datadir}/%{name}/tools/web_config/fishconfig.css
90 %{_datadir}/%{name}/tools/web_config/index.html
91 %{_datadir}/%{name}/tools/web_config/js
92 %{_datadir}/%{name}/tools/web_config/partials
93 %{_datadir}/%{name}/tools/web_config/sample_prompts
94 %attr(755,root,root) %{_datadir}/%{name}/tools/web_config/webconfig.py
This page took 0.029198 seconds and 3 git commands to generate.