]> git.pld-linux.org Git - packages/fish.git/blob - fish.spec
26b1df49522002a5801072d9c0c14f5d78ac04f5
[packages/fish.git] / fish.spec
1 Summary:        fish - A friendly interactive shell
2 Summary(pl.UTF-8):      fish - przyjazna interaktywna powłoka
3 Name:           fish
4 Version:        2.1.1
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/Shells
8 Source0:        http://fishshell.com/files/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  0251e6e5f25d1f326e071425ea1dee22
10 URL:            http://fishshell.com/
11 BuildRequires:  autoconf >= 2.50
12 BuildRequires:  doxygen
13 BuildRequires:  gettext-devel
14 BuildRequires:  ncurses-devel
15 Requires:       man-db
16 Suggests:       xsel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 fish is a shell geared towards interactive use. Its features are
21 focused on user friendlieness and discoverability. The language syntax
22 is simple but incompatible with other shell languages.
23
24 %description -l pl.UTF-8
25 fish jest powłoką nastawioną na interaktywne używanie. Jego cechą jest
26 przyjazne nastawienie dla użytkownika. Składnia języka jest prosta ale
27 nie jest zgodna z innymi językami powłoki.
28
29 %prep
30 %setup -q
31
32 %build
33 %{__aclocal}
34 %{__autoconf}
35 %{__autoheader}
36 %configure
37
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 %{__make} install \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
46
47 %find_lang %{name}
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post
53 umask 022
54 if [ ! -f /etc/shells ]; then
55         echo "%{_bindir}/fish" >> /etc/shells
56 else
57         grep -q '^%{_bindir}/fish$' /etc/shells || echo "%{_bindir}/fish" >> /etc/shells
58 fi
59
60 %preun
61 if [ "$1" = "0" ]; then
62         umask 022
63         grep -v '^%{_bindir}/fish$' /etc/shells > /etc/shells.new
64         mv -f /etc/shells.new /etc/shells
65 fi
66
67 %files -f %{name}.lang
68 %defattr(644,root,root,755)
69 %doc CHANGELOG README.md user_doc/html/*.{html,css,png}
70 %attr(755,root,root) %{_bindir}/fish*
71 %attr(755,root,root) %{_bindir}/mimedb
72 %{_datadir}/%{name}
73 %dir %{_sysconfdir}/fish
74 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fish/config.fish
75 %{_mandir}/man1/fish*.1*
76 %{_mandir}/man1/mimedb.1*
This page took 0.065195 seconds and 3 git commands to generate.