]> git.pld-linux.org Git - packages/firestarter.git/blob - firestarter.spec
- unified, config() for pam.d file
[packages/firestarter.git] / firestarter.spec
1 Summary:        A GNOME firewall tool
2 Summary(pl):    Narzêdzie do konfiguracji firewalla dzia³aj±ce w ¶rodowisku GNOME
3 Name:           firestarter
4 Version:        1.0.3
5 Release:        0.2
6 License:        GPL
7 Group:          X11/Applications/Networking
8 Source0:        http://dl.sourceforge.net/firestarter/%{name}-%{version}.tar.gz
9 # Source0-md5:  f46860a9e16dac4b693bd05f16370b03
10 Source1:        %{name}.init
11 Patch0:         %{name}-acfix.patch
12 Patch1:         %{name}-desktop.patch
13 Patch2:         %{name}-locale_names.patch
14 URL:            http://firestarter.sourceforge.net/
15 BuildRequires:  autoconf >= 2.50
16 BuildRequires:  automake
17 BuildRequires:  gettext-devel
18 BuildRequires:  gtk+2-devel >= 1:2.0.0
19 BuildRequires:  libgnome-devel >= 2.0.0
20 BuildRequires:  libgnomeui-devel >= 2.0.0
21 BuildRequires:  libtool
22 BuildRequires:  sed >= 4.0
23 Requires(post,preun):   /sbin/chkconfig
24 Requires:       iptables
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 FireStarter is an easy-to-use, yet powerful, Linux firewall tool for
29 GNOME. Use it to quickly set up a secure environment using the
30 firewall creation wizard, or use it's monitoring and administrating
31 features with your old firewall scripts.
32
33 %description -l pl
34 FireStarter jest ³atwym w u¿yciu, lecz potê¿nym narzêdziem do
35 konfiguracji firewalla dzia³aj±cym w ¶rodowisku GNOME. Mo¿esz go u¿yæ,
36 by szybko stworzyæ bezpieczne ¶rodowisko korzystaj±c z kreatora
37 tworzenia firewalla, lub skorzystaæ z jego mo¿liwo¶ci monitorowania i
38 administrowania wraz z istniej±cymi regu³ami firewalla.
39
40 %prep
41 %setup -q
42 #%patch0 -p0 # really required?
43 %patch1 -p1
44 %patch2 -p1
45
46 mv -f po/{no,nb}.po
47
48 %build
49 %{__libtoolize}
50 %{__aclocal}
51 %{__autoconf}
52 %{__automake}
53 %configure
54 %{__sed} -i 's/xml::\/etc\//xml::\$PREFIX\/etc\//' Makefile
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d}
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT \
63         Applicationsdir=%{_desktopdir}
64
65 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/firestarter
66 install firestarter.pam $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/firestarter
67
68 install -d $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound
69 install -d $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound
70 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/configuration
71 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/events-filter-hosts
72 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/events-filter-ports
73 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/firestarter.sh
74 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/firewall
75 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/sysctl-tuning
76 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/user-pre
77 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/user-post
78 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/allow-from
79 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/allow-service
80 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/forward
81 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/setup
82 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-from
83 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-service
84 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-to
85 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-from
86 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-service
87 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-to
88 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/setup
89
90 %find_lang %{name} --with-gnome
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post
96 %gconf_schema_install firestarter.schemas
97 %update_desktop_database_post
98 /sbin/chkconfig --add firestarter
99 if [ -f /var/lock/subsys/firestarter ]; then
100         /etc/rc.d/init.d/firestarter restart 1>&2
101 else
102         echo "Run \"/etc/rc.d/init.d/firestarter start\" to start firestarter."
103 fi
104
105 %preun
106 if [ $1 = 0 ]; then
107     %gconf_schema_uninstall firestarter.schemas
108         if [ -f /var/lock/subsys/firestarter ]; then
109                 /etc/rc.d/init.d/firestarter stop 1>&2
110         fi
111         /sbin/chkconfig --del firestarter
112 fi
113
114 %postun 
115 %update_desktop_database_postun
116
117 %files -f %{name}.lang
118 %defattr(644,root,root,755)
119 %doc README ChangeLog AUTHORS TODO CREDITS
120 %attr(755,root,root) %{_bindir}/firestarter
121 %attr(754,root,root) /etc/rc.d/init.d/*
122 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/firestarter
123 %{_desktopdir}/firestarter.desktop
124 %{_datadir}/%{name}
125 %{_pixmapsdir}/*
126
127 %dir %{_sysconfdir}/%{name}
128 %dir %{_sysconfdir}/%{name}/inbound
129 %dir %{_sysconfdir}/%{name}/outbound
130 %attr(754,root,root) %{_sysconfdir}/%{name}/firestarter.sh
131 %config(noreplace) %{_sysconfdir}/%{name}/inbound/*
132 %config(noreplace) %{_sysconfdir}/%{name}/outbound/*
133 %config(noreplace) %{_sysconfdir}/%{name}/configuration
134 %config(noreplace) %{_sysconfdir}/%{name}/events-filter-*
135 %config(noreplace) %{_sysconfdir}/%{name}/firewall
136 %config(noreplace) %{_sysconfdir}/%{name}/non-routables
137 %config(noreplace) %{_sysconfdir}/%{name}/sysctl-tuning
138 %config(noreplace) %{_sysconfdir}/%{name}/user-*
139
140 %{_sysconfdir}/gconf/schemas/*
This page took 0.090909 seconds and 4 git commands to generate.