]> git.pld-linux.org Git - packages/firestarter.git/blob - firestarter.spec
- updated file list and files' attributes
[packages/firestarter.git] / firestarter.spec
1
2 Summary:        A GNOME firewall tool
3 Summary(pl):    Narzêdzie do konfiguracji firewalla dzia³aj±ce w ¶rodowisku GNOME
4 Name:           firestarter
5 Version:        1.0.3
6 Release:        0.2
7 License:        GPL
8 Group:          X11/Applications/Networking
9 Source0:        http://dl.sourceforge.net/firestarter/%{name}-%{version}.tar.gz
10 # Source0-md5:  f46860a9e16dac4b693bd05f16370b03
11 Source1:        %{name}.init
12 Patch0:         %{name}-acfix.patch
13 Patch1:         %{name}-desktop.patch
14 Patch2:         %{name}-locale_names.patch
15 URL:            http://firestarter.sourceforge.net/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake
18 BuildRequires:  gettext-devel
19 BuildRequires:  gtk+2-devel >= 1:2.0.0
20 BuildRequires:  libgnome-devel >= 2.0.0
21 BuildRequires:  libgnomeui-devel >= 2.0.0
22 BuildRequires:  libtool
23 BuildRequires:  sed >= 4.0
24 Requires(post,preun):   /sbin/chkconfig
25 Requires:       iptables
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 FireStarter is an easy-to-use, yet powerful, Linux firewall tool for
30 GNOME. Use it to quickly set up a secure environment using the
31 firewall creation wizard, or use it's monitoring and administrating
32 features with your old firewall scripts.
33
34 %description -l pl
35 FireStarter jest ³atwym w u¿yciu, lecz potê¿nym narzêdziem do
36 konfiguracji firewalla dzia³aj±cym w ¶rodowisku GNOME. Mo¿esz go u¿yæ,
37 by szybko stworzyæ bezpieczne ¶rodowisko korzystaj±c z kreatora
38 tworzenia firewalla, lub skorzystaæ z jego mo¿liwo¶ci monitorowania i
39 administrowania wraz z istniej±cymi regu³ami firewalla.
40
41 %prep
42 %setup -q
43 #%patch0 -p0 # really required?
44 %patch1 -p1
45 %patch2 -p1
46
47 mv -f po/{no,nb}.po
48
49 %build
50 %{__libtoolize}
51 %{__aclocal}
52 %{__autoconf}
53 %{__automake}
54 %configure
55 %{__sed} -i 's/xml::\/etc\//xml::\$PREFIX\/etc\//' Makefile
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d}
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT \
64         Applicationsdir=%{_desktopdir}
65
66 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/firestarter
67 install firestarter.pam ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/firestarter
68
69
70 install -d ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/inbound/
71 install -d ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/outbound/
72 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/configuration
73 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/events-filter-hosts
74 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/events-filter-ports
75 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/firestarter.sh
76 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/firewall
77 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/sysctl-tuning
78 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/user-pre
79 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/user-post
80 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/inbound/allow-from
81 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/inbound/allow-service
82 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/inbound/forward
83 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/inbound/setup
84 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/outbound/allow-from
85 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/outbound/allow-service
86 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/outbound/allow-to
87 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/outbound/deny-from
88 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/outbound/deny-service
89 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/outbound/deny-to
90 touch ${RPM_BUILD_ROOT}/%{_sysconfdir}/firestarter/outbound/setup
91
92 %find_lang %{name} --with-gnome
93
94 %post
95 %gconf_schema_install firestarter.schemas
96 %update_desktop_database_post
97 /sbin/chkconfig --add firestarter
98 if [ -f /var/lock/subsys/firestarter ]; then
99         /etc/rc.d/init.d/firestarter restart 1>&2
100 else
101         echo "Run \"/etc/rc.d/init.d/firestarter start\" to start firestarter."
102 fi
103
104 %preun
105 if [ $1 = 0 ]; then
106     %gconf_schema_uninstall firestarter.schemas
107         if [ -f /var/lock/subsys/firestarter ]; then
108                 /etc/rc.d/init.d/firestarter stop 1>&2
109         fi
110         /sbin/chkconfig --del firestarter
111 fi
112
113 %postun 
114 %update_desktop_database_postun
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files -f %{name}.lang
120 %defattr(644,root,root,755)
121 %doc README ChangeLog AUTHORS TODO CREDITS
122 %attr(755,root,root) %{_bindir}/firestarter
123 %attr(754,root,root) /etc/rc.d/init.d/*
124 %{_sysconfdir}/pam.d/firestarter
125 %{_desktopdir}/firestarter.desktop
126 %{_datadir}/%{name}
127 %{_pixmapsdir}/*
128
129 %dir %{_sysconfdir}/%{name}
130 %dir %{_sysconfdir}/%{name}/inbound
131 %dir %{_sysconfdir}/%{name}/outbound
132 %attr(754,root,root) %{_sysconfdir}/%{name}/firestarter.sh
133 %config(noreplace) %{_sysconfdir}/%{name}/inbound/*
134 %config(noreplace) %{_sysconfdir}/%{name}/outbound/*
135 %config(noreplace) %{_sysconfdir}/%{name}/configuration
136 %config(noreplace) %{_sysconfdir}/%{name}/events-filter-*
137 %config(noreplace) %{_sysconfdir}/%{name}/firewall
138 %config(noreplace) %{_sysconfdir}/%{name}/non-routables
139 %config(noreplace) %{_sysconfdir}/%{name}/sysctl-tuning
140 %config(noreplace) %{_sysconfdir}/%{name}/user-*
141
142 %{_sysconfdir}/gconf/schemas/*
This page took 0.310171 seconds and 4 git commands to generate.