]> git.pld-linux.org Git - packages/firestarter.git/blob - firestarter.spec
fab12e7eb9ff7e5a112f26d8a1e05472ba9070e1
[packages/firestarter.git] / firestarter.spec
1 Summary:        A GNOME firewall tool
2 Summary(pl.UTF-8):      Narzędzie do konfiguracji firewalla działające w środowisku GNOME
3 Name:           firestarter
4 Version:        1.0.3
5 Release:        5
6 License:        GPL
7 Group:          X11/Applications/Networking
8 Source0:        http://dl.sourceforge.net/firestarter/%{name}-%{version}.tar.gz
9 # Source0-md5:  f46860a9e16dac4b693bd05f16370b03
10 Source1:        %{name}.init
11 Patch0:         %{name}-desktop.patch
12 Patch1:         %{name}-locale_names.patch
13 Patch2:         %{name}-script.patch
14 URL:            http://www.fs-security.com/
15 BuildRequires:  autoconf >= 2.50
16 BuildRequires:  automake
17 BuildRequires:  gettext-devel
18 BuildRequires:  gtk+2-devel >= 1:2.0.0
19 BuildRequires:  intltool
20 BuildRequires:  libgnome-devel >= 2.0.0
21 BuildRequires:  libgnomeui-devel >= 2.0.0
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRequires:  sed >= 4.0
25 Requires(post,preun):   /sbin/chkconfig
26 Requires:       iptables
27 # sr@Latn vs. sr@latin
28 Conflicts:      glibc-misc < 6:2.7
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 FireStarter is an easy-to-use, yet powerful, Linux firewall tool for
33 GNOME. Use it to quickly set up a secure environment using the
34 firewall creation wizard, or use it's monitoring and administrating
35 features with your old firewall scripts.
36
37 %description -l pl.UTF-8
38 FireStarter jest łatwym w użyciu, lecz potężnym narzędziem do
39 konfiguracji firewalla działającym w środowisku GNOME. Możesz go użyć,
40 by szybko stworzyć bezpieczne środowisko korzystając z kreatora
41 tworzenia firewalla, lub skorzystać z jego możliwości monitorowania i
42 administrowania wraz z istniejącymi regułami firewalla.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47 %patch1 -p1
48 %patch2 -p1
49
50 mv -f po/{no,nb}.po
51
52 %build
53 %{__libtoolize}
54 %{__aclocal}
55 %{__autoconf}
56 %{__automake}
57 %configure
58 %{__sed} -i 's/xml::\/etc\//xml::\$PREFIX\/etc\//' Makefile
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d}
64 install -d $RPM_BUILD_ROOT%{_sbindir}
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT \
68         Applicationsdir=%{_desktopdir}
69
70 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/firestarter
71 install firestarter.pam $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/firestarter
72
73 install -d $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound
74 install -d $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound
75 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/configuration
76 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/events-filter-hosts
77 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/events-filter-ports
78 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/firestarter.sh
79 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/firewall
80 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/sysctl-tuning
81 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/user-pre
82 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/user-post
83 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/allow-from
84 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/allow-service
85 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/forward
86 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/setup
87 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-from
88 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-service
89 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-to
90 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-from
91 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-service
92 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-to
93 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/setup
94
95 mv $RPM_BUILD_ROOT%{_bindir}/firestarter $RPM_BUILD_ROOT%{_sbindir}
96
97 echo -e "#!/bin/sh
98 if [ -x %{_bindir}/gksudo ] ; then
99         gksudo -g %{_sbindir}/firestarter
100 elif [ -x %{_bindir}/kdesu ] ; then
101         kdesu %{_sbindir}/firestarter
102 else
103         %{_sbindir}/firestarter
104 fi" > $RPM_BUILD_ROOT%{_bindir}/firestarter
105
106 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
107         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
108 %find_lang %{name} --with-gnome
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post
114 %gconf_schema_install firestarter.schemas
115 %update_desktop_database_post
116 /sbin/chkconfig --add firestarter
117 if [ -f /var/lock/subsys/firestarter ]; then
118         /etc/rc.d/init.d/firestarter restart 1>&2
119 else
120         echo "Run \"/etc/rc.d/init.d/firestarter start\" to start firestarter."
121 fi
122
123 %preun
124 if [ $1 = 0 ]; then
125     %gconf_schema_uninstall firestarter.schemas
126         if [ -f /var/lock/subsys/firestarter ]; then
127                 /etc/rc.d/init.d/firestarter stop 1>&2
128         fi
129         /sbin/chkconfig --del firestarter
130 fi
131
132 %postun
133 %update_desktop_database_postun
134
135 %files -f %{name}.lang
136 %defattr(644,root,root,755)
137 %doc README ChangeLog AUTHORS TODO CREDITS
138 %attr(755,root,root) %{_bindir}/firestarter
139 %attr(755,root,root) %{_sbindir}/firestarter
140 %attr(754,root,root) /etc/rc.d/init.d/*
141 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/firestarter
142 %{_desktopdir}/firestarter.desktop
143 %{_datadir}/%{name}
144 %{_pixmapsdir}/*
145 %dir %attr(700,root,root) %{_sysconfdir}/%{name}
146 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/inbound
147 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/outbound
148 %config(noreplace) %attr(700,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/firestarter.sh
149 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/inbound/*
150 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/outbound/*
151 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/configuration
152 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/events-filter-*
153 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/firewall
154 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/non-routables
155 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/sysctl-tuning
156 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/user-*
157 %{_sysconfdir}/gconf/schemas/*
This page took 0.05711 seconds and 2 git commands to generate.