]> git.pld-linux.org Git - packages/firestarter.git/blob - firestarter.spec
- unify, use %service macro, rc-script deps, updated initscript; rel 6
[packages/firestarter.git] / firestarter.spec
1 Summary:        A GNOME firewall tool
2 Summary(pl.UTF-8):      Narzędzie do konfiguracji firewalla działające w środowisku GNOME
3 Name:           firestarter
4 Version:        1.0.3
5 Release:        6
6 License:        GPL
7 Group:          X11/Applications/Networking
8 Source0:        http://downloads.sourceforge.net/firestarter/%{name}-%{version}.tar.gz
9 # Source0-md5:  f46860a9e16dac4b693bd05f16370b03
10 Source1:        %{name}.init
11 Patch0:         %{name}-desktop.patch
12 Patch1:         %{name}-locale_names.patch
13 Patch2:         %{name}-script.patch
14 URL:            http://www.fs-security.com/
15 BuildRequires:  autoconf >= 2.50
16 BuildRequires:  automake
17 BuildRequires:  gettext-devel
18 BuildRequires:  gtk+2-devel >= 1:2.0.0
19 BuildRequires:  intltool
20 BuildRequires:  libgnome-devel >= 2.0.0
21 BuildRequires:  libgnomeui-devel >= 2.0.0
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRequires:  rpmbuild(macros) >= 1.268
25 BuildRequires:  sed >= 4.0
26 Requires(post,preun):   /sbin/chkconfig
27 Requires:       iptables
28 Requires:       rc-scripts
29 # sr@Latn vs. sr@latin
30 Conflicts:      glibc-misc < 6:2.7
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 FireStarter is an easy-to-use, yet powerful, Linux firewall tool for
35 GNOME. Use it to quickly set up a secure environment using the
36 firewall creation wizard, or use it's monitoring and administrating
37 features with your old firewall scripts.
38
39 %description -l pl.UTF-8
40 FireStarter jest łatwym w użyciu, lecz potężnym narzędziem do
41 konfiguracji firewalla działającym w środowisku GNOME. Możesz go użyć,
42 by szybko stworzyć bezpieczne środowisko korzystając z kreatora
43 tworzenia firewalla, lub skorzystać z jego możliwości monitorowania i
44 administrowania wraz z istniejącymi regułami firewalla.
45
46 %prep
47 %setup -q
48 %patch0 -p1
49 %patch1 -p1
50 %patch2 -p1
51
52 mv -f po/{no,nb}.po
53
54 %build
55 %{__intltoolize}
56 %{__libtoolize}
57 %{__aclocal}
58 %{__autoconf}
59 %{__automake}
60 %configure
61 %{__sed} -i 's/xml::\/etc\//xml::\$PREFIX\/etc\//' Makefile
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d}
67 install -d $RPM_BUILD_ROOT%{_sbindir}
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT \
71         Applicationsdir=%{_desktopdir}
72
73 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/firestarter
74 cp -a firestarter.pam $RPM_BUILD_ROOT/etc/pam.d/firestarter
75
76 install -d $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound
77 install -d $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound
78 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/configuration
79 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/events-filter-hosts
80 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/events-filter-ports
81 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/firestarter.sh
82 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/firewall
83 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/sysctl-tuning
84 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/user-pre
85 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/user-post
86 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/allow-from
87 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/allow-service
88 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/forward
89 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/setup
90 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-from
91 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-service
92 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-to
93 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-from
94 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-service
95 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-to
96 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/setup
97
98 mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/firestarter
99
100 # TODO: use .desktop magic for this
101 cat <<'EOF' > $RPM_BUILD_ROOT%{_bindir}/firestarter
102 #!/bin/sh
103 if [ -x %{_bindir}/gksudo ] ; then
104         exec gksudo -g %{_sbindir}/firestarter
105 elif [ -x %{_bindir}/kdesu ] ; then
106         exec kdesu %{_sbindir}/firestarter
107 else
108         exec %{_sbindir}/firestarter
109 fi
110 EOF
111
112 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
113         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
114 %find_lang %{name} --with-gnome
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post
120 %gconf_schema_install firestarter.schemas
121 %update_desktop_database_post
122 /sbin/chkconfig --add firestarter
123 %service firestarter restart
124
125 %preun
126 if [ "$1" = 0 ]; then
127         %gconf_schema_uninstall firestarter.schemas
128         %service firestarter stop
129         /sbin/chkconfig --del firestarter
130 fi
131
132 %postun
133 %update_desktop_database_postun
134
135 %files -f %{name}.lang
136 %defattr(644,root,root,755)
137 %doc README ChangeLog AUTHORS TODO CREDITS
138 %attr(755,root,root) %{_bindir}/firestarter
139 %attr(755,root,root) %{_sbindir}/firestarter
140 %attr(754,root,root) /etc/rc.d/init.d/firestarter
141 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/firestarter
142 %{_sysconfdir}/gconf/schemas/firestarter.schemas
143 %{_desktopdir}/firestarter.desktop
144 %{_pixmapsdir}/firestarter.png
145 %{_datadir}/%{name}
146 %dir %attr(700,root,root) %{_sysconfdir}/%{name}
147 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/inbound
148 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/outbound
149 %config(noreplace) %attr(700,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/firestarter.sh
150 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/inbound/*
151 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/outbound/*
152 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/configuration
153 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/events-filter-*
154 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/firewall
155 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/non-routables
156 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/sysctl-tuning
157 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/user-*
This page took 0.087046 seconds and 3 git commands to generate.