]> git.pld-linux.org Git - packages/findutils.git/blob - findutils.spec
- obsolete
[packages/findutils.git] / findutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        GNU Find Utilities (find, xargs)
6 Summary(de):    GNU-Suchprogramme (find, xargs)
7 Summary(es):    Utilitarios de búsqueda de la GNU
8 Summary(fr):    Utilitaires de recherche de GNU (find, xargs)
9 Summary(pl):    Narzêdzia GNU do odnajdywania plików (find, xargs)
10 Summary(pt_BR): Utilitários de procura da GNU
11 Summary(tr):    GNU dosya arama araçlarý
12 Name:           findutils
13 Version:        4.2.6
14 Release:        1
15 Epoch:          1
16 License:        GPL
17 Group:          Applications/File
18 Source0:        ftp://alpha.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz
19 # Source0-md5:  af3dcc34e46c30496ec942812fcd0cd5
20 #Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
21 Source1:        %{name}-non-english-man-pages.tar.bz2
22 # Source1-md5:  e76388b0c3218eec3557d05ccd6d6515
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-mktemp.patch
25 Patch2:         %{name}-pl.po-update.patch
26 Patch3:         %{name}-setlocale.patch
27 Patch4:         %{name}-selinux.patch
28 Patch5:         %{name}-man-selinux.patch
29 URL:            http://www.gnu.org/software/findutils/
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  gettext-devel
33 %{?with_selinux:BuildRequires:  libselinux-devel}
34 BuildRequires:  texinfo
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The findutils package contains programs which will help you locate
39 files on your system. The find utility searches through a hierarchy of
40 directories looking for files which match a certain set of criteria
41 (such as a filename pattern). The locate utility searches a database
42 (create by updatedb) to quickly find a file matching a given pattern.
43 The xargs utility builds and executes command lines from standard
44 input arguments (usually lists of file names generated by the find
45 command).
46
47 %description -l de
48 Das findutils-Paket enthält Programme, die dabei helfen, Dateien auf
49 Ihrem System zu finden. Das Find-Utility durchsucht die
50 Verzeichnishierarchie nach Dateien, die zu bestimmten Kriterien (z.B.
51 Dateiname) passen. Das locate-Utility durchsucht eine Datenbank
52 (erzeugt durch updatedb), um die Dateien schneller finden zu können.
53 xargs konstruiert Kommandozeilen von der Standardeingabe (z.B.
54 Dateilisten, die von find erzeugt werden), und führt sie aus.
55
56 %description -l es
57 Este paquete contiene programas para ayúdalo a localizar archivos en
58 tu sistema. El programa find puede pesquisar, a través de una
59 jerarquía de directorios, buscando por archivos que obedezcan a un
60 cierto conjunto de criterios (como nombre de archivo modelo).
61
62 %description -l fr
63 Ce package contient des programmes pour vous aider à localiser des
64 fichiers sur votre système. Le programme find peut rechercher à
65 travers une hiérarchie de répertoires des fichiers conformes à
66 certains critères (comme un type de nom).
67
68 %description -l pl
69 W pakiecie znajduj± siê narzêdzia pozwalaj±ce na poszukiwanie
70 okre¶lonych plików. Program find s³u¿y do poszukiwania w drzewie
71 katalogów plików o okre¶lonych parametrach, jak nazwa, uprawnienia,
72 typ czy data ostatniej modyfikacji.
73
74 %description -l pt_BR
75 Esse pacote contém programas para ajudá-lo a localizar arquivos em seu
76 sistema. O programa find pode procurar através de uma hierarquia de
77 diretórios procurando por arquivos que obedeçam um certo conjunto de
78 critérios (como nome de arquivo modelo).
79
80 %description -l tr
81 Bu pakette yer alan yazýlýmlar sisteminizde yer alan dosyalarý
82 bulabilmeniz için hazýrlanmýþlardýr. find programý ile belirli
83 özellikleri olan bir yazýlýmý bir dizin hiyerarþisi altýnda
84 arayabilirsiniz.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91 %patch3 -p1
92 %{?with_selinux:%patch4 -p1}
93 # patch5 is applied in install stage
94
95 %{__perl} -pi -e 's/_jy_FIND LIBOBJS_NORMALIZE/_jy_FINDLIBOBJS_NORMALIZE/' m4/findlib.m4
96
97 %build
98 %{__aclocal} -I gnulib/m4 -I m4
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
113 %{?with_selinux:patch -p0 -d $RPM_BUILD_ROOT%{_mandir} < %{PATCH5}}
114
115 # xargs is wanted in /bin
116 install -d $RPM_BUILD_ROOT/bin
117 mv $RPM_BUILD_ROOT%{_bindir}/xargs $RPM_BUILD_ROOT/bin
118
119 # unpackaged locate
120 rm -f $RPM_BUILD_ROOT%{_bindir}/{locate,updatedb} \
121         $RPM_BUILD_ROOT%{_libdir}/{bigram,code,frcode} \
122         $RPM_BUILD_ROOT%{_mandir}/{,*/}man?/{locate.1,updatedb.1,locatedb.5}*
123
124 %find_lang %{name}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post
130 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
131
132 %postun
133 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
134
135 %files -f %{name}.lang
136 %defattr(644,root,root,755)
137 %doc NEWS README TODO ChangeLog
138 %attr(755,root,root) %{_bindir}/find
139 %attr(755,root,root) /bin/xargs
140
141 %{_mandir}/man1/[fx]*
142 %lang(de) %{_mandir}/de/man1/[fx]*
143 %lang(es) %{_mandir}/es/man1/[fx]*
144 %lang(fi) %{_mandir}/fi/man1/[fx]*
145 %lang(fr) %{_mandir}/fr/man1/[fx]*
146 %lang(hu) %{_mandir}/hu/man1/[fx]*
147 %lang(it) %{_mandir}/it/man1/[fx]*
148 %lang(ja) %{_mandir}/ja/man1/[fx]*
149 %lang(nl) %{_mandir}/nl/man1/[fx]*
150 %lang(pl) %{_mandir}/pl/man1/[fx]*
151 %lang(zh_CN) %{_mandir}/zh_CN/man1/[fx]*
152 %{_infodir}/find.info*
This page took 0.039379 seconds and 3 git commands to generate.