]> git.pld-linux.org Git - packages/fillets-ng.git/blob - fillets-ng.spec
- updated to 0.9.3
[packages/fillets-ng.git] / fillets-ng.spec
1
2 %define _game_ver       0.9.3
3 %define _data_ver       0.9.2
4
5 Summary:        Fish Fillets - Next Generation
6 Summary(pl.UTF-8):      Fish Fillets - Next Generation (linuksowy port gry)
7 Name:           fillets-ng
8 Version:        %{_game_ver}
9 Release:        1
10 License:        GPL v2+
11 Group:          X11/Applications/Games
12 Source0:        http://downloads.sourceforge.net/fillets/%{name}-%{version}.tar.gz
13 # Source0-md5:  292555608dd0f24d7bb3a072ab0f7ea5
14 Source1:        http://downloads.sourceforge.net/fillets/%{name}-data-%{_data_ver}.tar.gz
15 # Source1-md5:  00ea835425e5b1ca9fc3f110b40ff581
16 Source2:        %{name}.desktop
17 Source3:        %{name}.png
18 URL:            http://fillets.sourceforge.net/
19 BuildRequires:  SDL-devel >= 1.2.0
20 BuildRequires:  SDL_image-devel
21 BuildRequires:  SDL_mixer-devel
22 BuildRequires:  SDL_ttf-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  fribidi-devel
26 BuildRequires:  lua50-devel
27 BuildRequires:  sed >= 4.0
28 Requires:       %{name}-data = %{version}-%{release}
29 Suggests:       %{name}-intro = %{version}-%{release}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define _gamedatadir    %{_datadir}/games/%{name}
33
34 %description
35 Fish Fillets NG is a Linux port of wonderful puzzle game Fish Fillets
36 from ALTAR interactive. Fish Fillets NG is strictly a puzzle game. The
37 goal in every of the seventy levels is always the same: find a safe
38 way out.
39
40 %description -l pl.UTF-8
41 Fish Fillets NG to port wspaniałej gry logicznej Fish Fillets
42 napisanej przez ALTAR interactive. To gra na myślenie. Zadanie gracza
43 w każdym z siedemdziesięciu poziomów jest zawsze takie same: odnaleźć
44 bezpieczne wyjście.
45
46 %package docs
47 Summary:        A manual for Fish Fillets NG
48 Summary(pl.UTF-8):      Instrukcja do gry Fish Fillets NG
49 Group:          X11/Applications/Games
50 Requires:       %{name} = %{version}-%{release}
51
52 %description docs
53 A manual for Fish Fillets NG.
54
55 %description docs -l pl.UTF-8
56 Instrukcja do gry Fish Fillets.
57
58 %package data
59 Summary:        Data files for Fish Fillets NG
60 Summary(pl.UTF-8):      Pliki z danymi do gry Fish Fillets NG
61 Group:          X11/Applications/Games
62 Requires:       %{name} = %{version}-%{release}
63
64 %description data
65 Data files for Fish Fillets NG.
66
67 %description data -l pl.UTF-8
68 Pliki z danymi do gry Fish Fillets NG.
69
70 %package intro
71 Summary:        Introduction video to Fish Fillets NG game
72 Summary(pl.UTF-8):      Film wprowadzający do gry Fish Fillets NG
73 Group:          X11/Applications/Games
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       mplayer
76
77 %description intro
78 Introduction video to Fish Fillets NG game.
79
80 %description intro -l pl.UTF-8
81 Film wprowadzający do gry Fish Fillets NG.
82
83 %prep
84 %setup -q -a1
85
86 %build
87 %{__aclocal}
88 %{__autoconf}
89 %{__automake}
90
91 %configure \
92         --with-lua=/usr/include/lua50
93
94 # Now isn't that nasty? but I don't know how to do this better
95 find -name Makefile -exec \
96         %{__sed} -i 's|LUA_LIBS = -L/usr/include/lua50 -llua -llualib|LUA_LIBS = -llua50 -llualib50|' {} \
97         \;
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_desktopdir},%{_pixmapsdir}}
103 install -d $RPM_BUILD_ROOT%{_gamedatadir}
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT \
107         bindir=%{_bindir}
108
109 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
110 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
111 cp -Rfa %{name}-data-%{_data_ver}/{images,font,music,script,sound} $RPM_BUILD_ROOT%{_gamedatadir}
112 cp -Rfa %{name}-data-%{_data_ver}/doc $RPM_BUILD_ROOT%{_datadir}/%{name}
113 mv $RPM_BUILD_ROOT%{_bindir}/fillets $RPM_BUILD_ROOT%{_bindir}/fillets.bin
114 cat > $RPM_BUILD_ROOT%{_bindir}/fillets << EOF
115 #!/bin/sh
116
117 %{_bindir}/fillets.bin systemdir=%{_gamedatadir} \$@
118 EOF
119
120 install %{name}-data-%{_data_ver}/images/menu/intro.mpg $RPM_BUILD_ROOT%{_gamedatadir}
121 cat > $RPM_BUILD_ROOT%{_desktopdir}/fillets-ng-intro.desktop << EOF
122 [Desktop Entry]
123 Name=Fish Fillets Intro
124 Comment=Fish Fillets NG - Introduction
125 Comment[pl]=Fish Fillets NG - Wprowadzenie
126 Exec=mplayer -fs %{_gamedatadir}/intro.mpg
127 Icon=fillets-ng.png
128 Terminal=false
129 Type=Application
130 Encoding=UTF-8
131 Categories=Game;LogicGame;
132 # vi: encoding=utf-8
133 EOF
134
135 find $RPM_BUILD_ROOT%{_gamedatadir} -type d -fprintf %{name}.dirs '%%%%dir %{_gamedatadir}/%%P\n'
136
137 rm -rf $RPM_BUILD_ROOT%{_gamedatadir}/images/menu/intro.mpg
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p      /sbin/postshell
143 -/usr/sbin/fix-info-dir -c %{_infodir}
144
145 %postun -p      /sbin/postshell
146 -/usr/sbin/fix-info-dir -c %{_infodir}
147
148 %files
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog NEWS TODO
151 %attr(755,root,root) %{_bindir}/*
152 %dir %{_datadir}/%{name}
153 %{_mandir}/man6/fillets.*
154 %{_desktopdir}/%{name}.desktop
155 %{_pixmapsdir}/%{name}.png
156
157 %files data -f %{name}.dirs
158 %defattr(644,root,root,755)
159 %doc %{_gamedatadir}/images/menu/flags/copyright
160 %{_gamedatadir}/font/*
161 %{_gamedatadir}/images/*.png
162 %{_gamedatadir}/images/*/*.png
163 %{_gamedatadir}/images/*/*/*.png
164 %{_gamedatadir}/images/*/*/*/*.png
165 %{_gamedatadir}/images/*/*/*/*/*.png
166 %{_gamedatadir}/music/*.ogg
167 %{_gamedatadir}/script/*.lua
168 %{_gamedatadir}/script/*/*.lua
169 %{_gamedatadir}/sound/*/*.ogg
170 %{_gamedatadir}/sound/*/*/*.ogg
171 %{_gamedatadir}/sound/*/*/*/*.ogg
172
173 %files docs
174 %defattr(644,root,root,755)
175 %dir %{_datadir}/%{name}/doc
176 %{_datadir}/%{name}/doc/html
177
178 %files intro
179 %defattr(644,root,root,755)
180 %{_gamedatadir}/intro.mpg
181 %{_desktopdir}/%{name}-intro.desktop
This page took 0.09177 seconds and 4 git commands to generate.