]> git.pld-linux.org Git - packages/fillets-ng.git/blob - fillets-ng.spec
- updated to game and datas to 1.0.0
[packages/fillets-ng.git] / fillets-ng.spec
1
2 %define _game_ver       1.0.0
3 %define _data_ver       1.0.0
4
5 Summary:        Fish Fillets - Next Generation
6 Summary(pl.UTF-8):      Fish Fillets - Next Generation (linuksowy port gry)
7 Name:           fillets-ng
8 Version:        %{_game_ver}
9 Release:        1
10 License:        GPL v2+
11 Group:          X11/Applications/Games
12 Source0:        http://downloads.sourceforge.net/fillets/%{name}-%{version}.tar.gz
13 # Source0-md5:  276bb416d7f8bf9ef0969fd7a3c42d52
14 Source1:        http://downloads.sourceforge.net/fillets/%{name}-data-%{_data_ver}.tar.gz
15 # Source1-md5:  94684229b554468efe7e0b0cc5185e5e
16 Source2:        %{name}.desktop
17 Source3:        %{name}.png
18 URL:            http://fillets.sourceforge.net/
19 BuildRequires:  SDL-devel >= 1.2.0
20 BuildRequires:  SDL_image-devel
21 BuildRequires:  SDL_mixer-devel
22 BuildRequires:  SDL_ttf-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  fribidi-devel
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  lua50-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  sed >= 4.0
30 Requires:       %{name}-data = %{version}-%{release}
31 Suggests:       %{name}-intro = %{version}-%{release}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define _gamedatadir    %{_datadir}/games/%{name}
35
36 %description
37 Fish Fillets NG is a Linux port of wonderful puzzle game Fish Fillets
38 from ALTAR interactive. Fish Fillets NG is strictly a puzzle game. The
39 goal in every of the seventy levels is always the same: find a safe
40 way out.
41
42 %description -l pl.UTF-8
43 Fish Fillets NG to port wspaniałej gry logicznej Fish Fillets
44 napisanej przez ALTAR interactive. To gra na myślenie. Zadanie gracza
45 w każdym z siedemdziesięciu poziomów jest zawsze takie same: odnaleźć
46 bezpieczne wyjście.
47
48 %package docs
49 Summary:        A manual for Fish Fillets NG
50 Summary(pl.UTF-8):      Instrukcja do gry Fish Fillets NG
51 Group:          X11/Applications/Games
52 Requires:       %{name} = %{version}-%{release}
53
54 %description docs
55 A manual for Fish Fillets NG.
56
57 %description docs -l pl.UTF-8
58 Instrukcja do gry Fish Fillets.
59
60 %package data
61 Summary:        Data files for Fish Fillets NG
62 Summary(pl.UTF-8):      Pliki z danymi do gry Fish Fillets NG
63 Group:          X11/Applications/Games
64 Requires:       %{name} = %{version}-%{release}
65
66 %description data
67 Data files for Fish Fillets NG.
68
69 %description data -l pl.UTF-8
70 Pliki z danymi do gry Fish Fillets NG.
71
72 %package intro
73 Summary:        Introduction video to Fish Fillets NG game
74 Summary(pl.UTF-8):      Film wprowadzający do gry Fish Fillets NG
75 Group:          X11/Applications/Games
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       mplayer
78
79 %description intro
80 Introduction video to Fish Fillets NG game.
81
82 %description intro -l pl.UTF-8
83 Film wprowadzający do gry Fish Fillets NG.
84
85 %prep
86 %setup -q -a1
87
88 %build
89 %{__aclocal}
90 %{__autoconf}
91 %{__automake}
92
93 %configure \
94         --with-lua=/usr/include/lua50
95
96 # Now isn't that nasty? but I don't know how to do this better
97 find -name Makefile -exec \
98         %{__sed} -i 's|LUA_LIBS = -L/usr/include/lua50 -llua -llualib|LUA_LIBS = -llua50 -llualib50|' {} \
99         \;
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_desktopdir},%{_pixmapsdir}}
105 install -d $RPM_BUILD_ROOT%{_gamedatadir}
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT \
109         bindir=%{_bindir}
110
111 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
112 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
113 cp -Rfa %{name}-data-%{_data_ver}/{images,font,music,script,sound} $RPM_BUILD_ROOT%{_gamedatadir}
114 cp -Rfa %{name}-data-%{_data_ver}/doc $RPM_BUILD_ROOT%{_datadir}/%{name}
115 mv $RPM_BUILD_ROOT%{_bindir}/fillets $RPM_BUILD_ROOT%{_bindir}/fillets.bin
116 cat > $RPM_BUILD_ROOT%{_bindir}/fillets << EOF
117 #!/bin/sh
118
119 %{_bindir}/fillets.bin systemdir=%{_gamedatadir} \$@
120 EOF
121
122 install %{name}-data-%{_data_ver}/images/menu/intro.mpg $RPM_BUILD_ROOT%{_gamedatadir}
123 cat > $RPM_BUILD_ROOT%{_desktopdir}/fillets-ng-intro.desktop << EOF
124 [Desktop Entry]
125 Name=Fish Fillets Intro
126 Comment=Fish Fillets NG - Introduction
127 Comment[pl]=Fish Fillets NG - Wprowadzenie
128 Exec=mplayer -fs %{_gamedatadir}/intro.mpg
129 Icon=fillets-ng.png
130 Terminal=false
131 Type=Application
132 Encoding=UTF-8
133 Categories=Game;LogicGame;
134 # vi: encoding=utf-8
135 EOF
136
137 find $RPM_BUILD_ROOT%{_gamedatadir} -type d -fprintf %{name}.dirs '%%%%dir %{_gamedatadir}/%%P\n'
138
139 %{__rm} -r $RPM_BUILD_ROOT%{_gamedatadir}/images/menu/intro.mpg
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p      /sbin/postshell
145 -/usr/sbin/fix-info-dir -c %{_infodir}
146
147 %postun -p      /sbin/postshell
148 -/usr/sbin/fix-info-dir -c %{_infodir}
149
150 %files
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog NEWS TODO
153 %attr(755,root,root) %{_bindir}/*
154 %dir %{_datadir}/%{name}
155 %{_mandir}/man6/fillets.*
156 %{_desktopdir}/%{name}.desktop
157 %{_pixmapsdir}/%{name}.png
158
159 %files data -f %{name}.dirs
160 %defattr(644,root,root,755)
161 %doc %{_gamedatadir}/images/menu/flags/copyright
162 %{_gamedatadir}/font/*
163 %{_gamedatadir}/images/*.png
164 %{_gamedatadir}/images/*/*.png
165 %{_gamedatadir}/images/*/*/*.png
166 %{_gamedatadir}/images/*/*/*/*.png
167 %{_gamedatadir}/images/*/*/*/*/*.png
168 %{_gamedatadir}/music/*.ogg
169 %{_gamedatadir}/script/*.lua
170 %{_gamedatadir}/script/*/*.lua
171 %{_gamedatadir}/sound/*/*.ogg
172 %{_gamedatadir}/sound/*/*/*.ogg
173 %{_gamedatadir}/sound/*/*/*/*.ogg
174
175 %files docs
176 %defattr(644,root,root,755)
177 %dir %{_datadir}/%{name}/doc
178 %{_datadir}/%{name}/doc/html
179
180 %files intro
181 %defattr(644,root,root,755)
182 %{_gamedatadir}/intro.mpg
183 %{_desktopdir}/%{name}-intro.desktop
This page took 0.138743 seconds and 4 git commands to generate.