]> git.pld-linux.org Git - packages/filesystem.git/blob - filesystem.spec
- add browser-plugins dirs; rel 13
[packages/filesystem.git] / filesystem.spec
1
2 %define         _enable_debug_packages  0
3
4 Summary:        Common directories
5 Summary(pl):    Wspólne katalogi
6 Name:           filesystem
7 Version:        3.0
8 Release:        13
9 License:        GPL
10 Group:          Base
11 BuildRequires:  automake
12 Requires:       FHS >= 2.3-15
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 # directory for "privilege separation" chroot
16 %define         _privsepdir     /usr/share/empty
17 # directory for *.idl files (for CORBA implementations)
18 %define         _idldir         /usr/share/idl
19
20 %description
21 This package contains common directories for packages that extend
22 some programs functionality, but don't require them themselves.
23
24 %description -l pl
25 Ten pakiet zawiera wspólne katalogi dla pakietów rozszerzaj±cych
26 funkcjonalno¶æ programów, ale nie wymagaj±cych ich.
27
28 %package debuginfo
29 Summary:        Common directories for debug information
30 Summary(pl):    Wspólne katalogi dla plików z informacjami dla debuggera
31 Group:          Development/Debug
32 Requires:       %{name} = %{version}-%{release}
33
34 %description debuginfo
35 This package provides common directories for debug information.
36
37 %description debuginfo -l pl
38 Ten pakiet udostêpnia wspólne katalogi dla plików z informacjami dla
39 debuggera.
40
41 %prep
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 install -d \
47         $RPM_BUILD_ROOT/{initrd,selinux,sys} \
48         $RPM_BUILD_ROOT/etc/{X11/xinit/xinitrc.d,certs,security,sysconfig/wmstyle,xdg/autostart} \
49         $RPM_BUILD_ROOT/home/{users,services} \
50         $RPM_BUILD_ROOT/lib/{firmware,security} \
51         $RPM_BUILD_ROOT/usr/include/security \
52         $RPM_BUILD_ROOT/usr/lib/{cgi-bin,debug,pkgconfig} \
53         $RPM_BUILD_ROOT/usr/share/{gnome/help,man/man{n,l},man/pl/mann,pkgconfig,sounds,themes/Default,wallpapers,wm-properties,xsessions} \
54         $RPM_BUILD_ROOT/usr/src/{debug,examples} \
55         $RPM_BUILD_ROOT/var/lock/subsys \
56         $RPM_BUILD_ROOT{%{_aclocaldir},%{_desktopdir}/docklets,%{_iconsdir},%{_pixmapsdir}} \
57         $RPM_BUILD_ROOT%{_fontsdir}/{{100,75}dpi,OTF,Speedo,Type1/{afm,pfm},TTF,cyrillic,local,misc} \
58         $RPM_BUILD_ROOT{%{_idldir},%{_privsepdir}}
59
60 %if "%{_lib}" == "lib64"
61 install -d \
62         $RPM_BUILD_ROOT/lib64/security \
63         $RPM_BUILD_ROOT/usr/lib64/pkgconfig \
64         $RPM_BUILD_ROOT/usr/lib64/browser-plugins
65 %else
66         $RPM_BUILD_ROOT/usr/lib/browser-plugins
67 %endif
68
69 %clean
70 cd $RPM_BUILD_ROOT
71
72 # %{_rpmfilename} is not expanded, so use
73 # %{name}-%{version}-%{release}.%{buildarch}.rpm
74 RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
75 RPMFILE2=%{name}-debuginfo-%{version}-%{release}.%{_target_cpu}.rpm
76 TMPFILE=%{name}-%{version}.tmp$$
77 # note: we must exclude from check all existing dirs belonging to FHS
78 find . | sed -e 's|^\.||g' -e 's|^$||g' | sort | grep -v $TMPFILE | grep -E -v '^/(etc|etc/X11|home|lib|lib64|usr|usr/include|usr/lib|usr/lib64|usr/share|usr/share/man|usr/share/man/pl|usr/src|var|var/lock)$' > $TMPFILE
79
80 # find finds also '.', so use option -B for diff
81 rpm -qpl %{_rpmdir}/$RPMFILE %{_rpmdir}/$RPMFILE2 | grep -v '^/$' | sort | diff -uB $TMPFILE - || :
82
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %dir /etc/X11/xinit
88 %dir /etc/X11/xinit/xinitrc.d
89 %attr(751,root,root) %dir /etc/certs
90 %attr(751,root,root) %dir /etc/security
91 %dir /etc/sysconfig
92 %dir /etc/sysconfig/wmstyle
93 %dir /etc/xdg
94 %dir /etc/xdg/autostart
95 %dir /home/users
96 %attr(751,root,adm) %dir /home/services
97 %dir /initrd
98 %dir /lib/firmware
99 %dir /lib/security
100 %dir /selinux
101 %dir /sys
102 %dir /usr/include/security
103 %dir /usr/lib/cgi-bin
104 %dir /usr/lib/pkgconfig
105 %dir /usr/share/gnome
106 %dir /usr/share/gnome/help
107 %dir /usr/share/man/man[nl]
108 %lang(pl) %dir /usr/share/man/pl/mann
109 %dir /usr/share/pkgconfig
110 %dir /usr/share/sounds
111 %dir /usr/share/themes
112 %dir /usr/share/themes/Default
113 %dir /usr/share/wallpapers
114 %dir /usr/share/wm-properties
115 %dir /usr/share/xsessions
116 %dir /usr/src/examples
117 %attr(700,root,root) %dir /var/lock/subsys
118 %dir %{_aclocaldir}
119 %dir %{_desktopdir}
120 %dir %{_desktopdir}/docklets
121 %dir %{_iconsdir}
122 %dir %{_pixmapsdir}
123 %{_fontsdir}
124 %dir %{_idldir}
125 %dir %{_privsepdir}
126 %if "%{_lib}" == "lib64"
127 %dir /lib64/security
128 %dir /usr/lib64/pkgconfig
129 %dir /usr/lib64/browser-plugins
130 %else
131 %dir /usr/lib/browser-plugins
132 %endif
133
134 %files debuginfo
135 %defattr(644,root,root,755)
136 %dir /usr/lib/debug
137 %dir /usr/src/debug
This page took 0.128506 seconds and 4 git commands to generate.