]> git.pld-linux.org Git - packages/filesystem.git/blob - filesystem.spec
- typo
[packages/filesystem.git] / filesystem.spec
1
2 %define         _enable_debug_packages  0
3
4 Summary:        Common directories
5 Summary(pl):    Wspólne katalogi
6 Name:           filesystem
7 Version:        3.0
8 Release:        13
9 License:        GPL
10 Group:          Base
11 BuildRequires:  automake
12 Requires:       FHS >= 2.3-15
13 Provides:       browser-plugins(%{_target_base_arch})
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 # directory for "privilege separation" chroot
17 %define         _privsepdir     /usr/share/empty
18 # directory for *.idl files (for CORBA implementations)
19 %define         _idldir         /usr/share/idl
20
21 %description
22 This package contains common directories for packages that extend some
23 programs functionality, but don't require them themselves.
24
25 %description -l pl
26 Ten pakiet zawiera wspólne katalogi dla pakietów rozszerzaj±cych
27 funkcjonalno¶æ programów, ale nie wymagaj±cych ich.
28
29 %package debuginfo
30 Summary:        Common directories for debug information
31 Summary(pl):    Wspólne katalogi dla plików z informacjami dla debuggera
32 Group:          Development/Debug
33 Requires:       %{name} = %{version}-%{release}
34
35 %description debuginfo
36 This package provides common directories for debug information.
37
38 %description debuginfo -l pl
39 Ten pakiet udostêpnia wspólne katalogi dla plików z informacjami dla
40 debuggera.
41
42 %prep
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 install -d \
48         $RPM_BUILD_ROOT/{initrd,selinux,sys} \
49         $RPM_BUILD_ROOT/etc/{X11/xinit/xinitrc.d,certs,security,sysconfig/wmstyle,xdg/autostart} \
50         $RPM_BUILD_ROOT/home/{users,services} \
51         $RPM_BUILD_ROOT/lib/{firmware,security} \
52         $RPM_BUILD_ROOT/usr/include/security \
53         $RPM_BUILD_ROOT/usr/lib/{cgi-bin,debug,pkgconfig} \
54         $RPM_BUILD_ROOT/usr/share/{gnome/help,man/man{n,l},man/pl/mann,pkgconfig,sounds,themes/Default,wallpapers,wm-properties,xsessions} \
55         $RPM_BUILD_ROOT/usr/src/{debug,examples} \
56         $RPM_BUILD_ROOT/var/lock/subsys \
57         $RPM_BUILD_ROOT{%{_aclocaldir},%{_desktopdir}/docklets,%{_iconsdir},%{_pixmapsdir}} \
58         $RPM_BUILD_ROOT%{_fontsdir}/{{100,75}dpi,OTF,Speedo,Type1/{afm,pfm},TTF,cyrillic,local,misc} \
59         $RPM_BUILD_ROOT{%{_idldir},%{_privsepdir}}
60
61 install -d \
62 %if "%{_lib}" == "lib64"
63         $RPM_BUILD_ROOT/lib64/security \
64         $RPM_BUILD_ROOT/usr/lib64/pkgconfig \
65         $RPM_BUILD_ROOT/usr/lib64/browser-plugins
66 %else
67         $RPM_BUILD_ROOT/usr/lib/browser-plugins
68 %endif
69
70 %clean
71 cd $RPM_BUILD_ROOT
72
73 # %{_rpmfilename} is not expanded, so use
74 # %{name}-%{version}-%{release}.%{buildarch}.rpm
75 RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
76 RPMFILE2=%{name}-debuginfo-%{version}-%{release}.%{_target_cpu}.rpm
77 TMPFILE=%{name}-%{version}.tmp$$
78 # note: we must exclude from check all existing dirs belonging to FHS
79 find . | sed -e 's|^\.||g' -e 's|^$||g' | sort | grep -v $TMPFILE | grep -E -v '^/(etc|etc/X11|home|lib|lib64|usr|usr/include|usr/lib|usr/lib64|usr/share|usr/share/man|usr/share/man/pl|usr/src|var|var/lock)$' > $TMPFILE
80
81 # find finds also '.', so use option -B for diff
82 rpm -qpl %{_rpmdir}/$RPMFILE %{_rpmdir}/$RPMFILE2 | grep -v '^/$' | sort | diff -uB $TMPFILE - || :
83
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %dir /etc/X11/xinit
89 %dir /etc/X11/xinit/xinitrc.d
90 %attr(751,root,root) %dir /etc/certs
91 %attr(751,root,root) %dir /etc/security
92 %dir /etc/sysconfig
93 %dir /etc/sysconfig/wmstyle
94 %dir /etc/xdg
95 %dir /etc/xdg/autostart
96 %dir /home/users
97 %attr(751,root,adm) %dir /home/services
98 %dir /initrd
99 %dir /lib/firmware
100 %dir /lib/security
101 %dir /selinux
102 %dir /sys
103 %dir /usr/include/security
104 %dir /usr/lib/cgi-bin
105 %dir /usr/lib/pkgconfig
106 %dir /usr/share/gnome
107 %dir /usr/share/gnome/help
108 %dir /usr/share/man/man[nl]
109 %lang(pl) %dir /usr/share/man/pl/mann
110 %dir /usr/share/pkgconfig
111 %dir /usr/share/sounds
112 %dir /usr/share/themes
113 %dir /usr/share/themes/Default
114 %dir /usr/share/wallpapers
115 %dir /usr/share/wm-properties
116 %dir /usr/share/xsessions
117 %dir /usr/src/examples
118 %attr(700,root,root) %dir /var/lock/subsys
119 %dir %{_aclocaldir}
120 %dir %{_desktopdir}
121 %dir %{_desktopdir}/docklets
122 %dir %{_iconsdir}
123 %dir %{_pixmapsdir}
124 %{_fontsdir}
125 %dir %{_idldir}
126 %dir %{_privsepdir}
127 %if "%{_lib}" == "lib64"
128 %dir /lib64/security
129 %dir /usr/lib64/pkgconfig
130 %dir /usr/lib64/browser-plugins
131 %else
132 %dir /usr/lib/browser-plugins
133 %endif
134
135 %files debuginfo
136 %defattr(644,root,root,755)
137 %dir /usr/lib/debug
138 %dir /usr/src/debug
This page took 0.044589 seconds and 4 git commands to generate.