]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- up to 1.1.2
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # How to deal with ffmpeg/opencv checken-egg problem:
3 #       1. make-request -r --without opencv ffmpeg.spec
4 #       2. make-request -r opencv.spec
5 #       3. bump release of ffmpeg.spec
6 #       4. make-request -r ffmpeg.spec
7 #
8 # Conditional build:
9 %bcond_with     nonfree         # non free options of package (currently: faac)
10 %bcond_with     aacplus         # AAC+ encoding via libaacplus (requires nonfree)
11 %bcond_with     fdk_aac         # AAC encoding via libfdk_aac (requires nonfree)
12 %bcond_without  caca            # textual display using libcaca
13 %bcond_without  flite           # flite voice synthesis support
14 %bcond_without  frei0r          # frei0r video filtering
15 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
16 %bcond_without  openal          # OpenAL 1.1 capture support
17 %bcond_without  opencv          # OpenCV video filtering
18 %bcond_without  pulseaudio      # PulseAudio input support
19 %bcond_without  soxr            # SoX Resampler support
20 %bcond_without  x264            # x264 encoder
21 %bcond_without  utvideo         # Ut Video decoder
22 %bcond_without  va              # VAAPI (Video Acceleration API)
23 %bcond_without  vpx             # VP8, a high-quality video codec
24 %bcond_without  doc             # don't build docs
25
26 Summary:        FFmpeg - a very fast video and audio converter
27 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
28 Name:           ffmpeg
29 Version:        1.1.2
30 Release:        1
31 # LGPL or GPL, chosen at configure time (GPL version is more featured)
32 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
33 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
34 License:        GPL v3+ with LGPL v3+ parts
35 Group:          Applications/Multimedia
36 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
37 # Source0-md5:  7434c0b38be2ce9c4344d067cc0067f5
38 Source1:        ffserver.init
39 Source2:        ffserver.sysconfig
40 Source3:        ffserver.conf
41 Patch0:         %{name}-gsm.patch
42 Patch1:         %{name}-opencv24.patch
43 Patch2:         %{name}-utvideo.patch
44 URL:            http://www.ffmpeg.org/
45 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
46 BuildRequires:  SDL-devel >= 1.2.1
47 BuildRequires:  alsa-lib-devel
48 BuildRequires:  bzip2-devel
49 BuildRequires:  celt-devel >= 0.11.0
50 %{?with_nonfree:BuildRequires:  faac-devel}
51 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
52 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
53 BuildRequires:  fontconfig-devel
54 BuildRequires:  freetype-devel
55 %{?with_frei0r:BuildRequires:   frei0r-devel}
56 %ifarch ppc
57 # require version with altivec support fixed
58 BuildRequires:  gcc >= 5:3.3.2-3
59 %endif
60 BuildRequires:  gnutls-devel
61 BuildRequires:  jack-audio-connection-kit-devel
62 BuildRequires:  lame-libs-devel >= 3.98.3
63 %{?with_aacplus:BuildRequires:  libaacplus-devel >= 2.0.0}
64 BuildRequires:  libass-devel
65 BuildRequires:  libavc1394-devel
66 BuildRequires:  libbluray-devel
67 %{?with_caca:BuildRequires:     libcaca-devel}
68 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
69 BuildRequires:  libdc1394-devel >= 2
70 BuildRequires:  libgsm-devel
71 BuildRequires:  libiec61883-devel
72 BuildRequires:  libmodplug-devel
73 BuildRequires:  libnut-devel
74 BuildRequires:  libraw1394-devel >= 2
75 BuildRequires:  librtmp-devel
76 BuildRequires:  libtheora-devel >= 1.0-0.beta3
77 BuildRequires:  libtool >= 2:1.4d-3
78 BuildRequires:  libv4l-devel
79 %{?with_va:BuildRequires:       libva-devel >= 1.0.3}
80 BuildRequires:  libvdpau-devel >= 0.2
81 BuildRequires:  libvorbis-devel
82 %{?with_vpx:BuildRequires:      libvpx-devel >= 0.9.7}
83 # X264_BUILD >= 118
84 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
85 %ifarch %{ix86}
86 %ifnarch i386 i486
87 BuildRequires:  nasm
88 %endif
89 %endif
90 BuildRequires:  opencore-amr-devel
91 %{?with_opencv:BuildRequires:   opencv-devel}
92 BuildRequires:  openjpeg-devel >= 1.5
93 BuildRequires:  opus-devel
94 BuildRequires:  perl-Encode
95 BuildRequires:  perl-tools-pod
96 BuildRequires:  pkgconfig
97 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
98 BuildRequires:  rpmbuild(macros) >= 1.470
99 BuildRequires:  schroedinger-devel
100 %{?with_soxr:BuildRequires:     soxr-devel}
101 BuildRequires:  speex-devel >= 1:1.2-rc1
102 %{?with_doc:BuildRequires:      tetex}
103 %{?with_doc:BuildRequires:      texi2html}
104 %{?with_doc:BuildRequires:      texinfo}
105 BuildRequires:  twolame-devel
106 %{?with_utvideo:BuildRequires:  utvideo-devel >= 12}
107 BuildRequires:  vo-aacenc-devel
108 BuildRequires:  vo-amrwbenc-devel
109 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
110 BuildRequires:  xavs-devel
111 BuildRequires:  xorg-lib-libX11-devel
112 BuildRequires:  xorg-lib-libXext-devel
113 BuildRequires:  xorg-lib-libXfixes-devel
114 BuildRequires:  xvid-devel >= 1:1.1.0
115 BuildRequires:  yasm
116 BuildRequires:  zlib-devel
117 %{?with_autoreqdep:BuildConflicts:      libpostproc}
118 # overflows maximum hash table size
119 BuildConflicts: pdksh < 5.2.14-57
120 Requires:       %{name}-libs = %{version}-%{release}
121 %{?with_utvideo:Requires:       utvideo >= 12}
122 %{?with_ilbc:Requires:  webrtc-libilbc}
123 Requires:       xvid >= 1:1.1.0
124 Obsoletes:      libpostproc
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
128
129 %define         specflags       -fno-strict-aliasing
130
131 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
132 %define         specflags_ia32  -fomit-frame-pointer
133 # -mmmx is needed to enable <mmintrin.h> code.
134 %define         specflags_i586  -mmmx
135 %define         specflags_i686  -mmmx
136 %define         specflags_ppc   -fPIC
137
138 %description
139 FFmpeg is a complete solution to record, convert and stream audio and
140 video. It is a command line tool to convert one video file format to
141 another. It also supports grabbing and encoding in real time from a TV
142 card.
143
144 %description -l pl.UTF-8
145 FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
146 strumieni dźwięku i obrazu. Jest to działające z linii poleceń
147 narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
148 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
149 telewizyjnej.
150
151 %package libs
152 Summary:        ffmpeg libraries
153 Summary(pl.UTF-8):      Biblioteki ffmpeg
154 Group:          Libraries
155
156 %description libs
157 This package contains the ffmpeg shared libraries:
158 - the codec library (libavcodec). It supports most existing encoding
159   formats (MPEG, DivX, MPEG4, AC3, DV...),
160 - demuxer library (libavformat). It supports most existing file
161   formats (AVI, MPEG, OGG, Matroska, ASF...),
162 - video postprocessing library (libpostproc).
163
164 %description libs -l pl.UTF-8
165 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
166 - bibliotekę kodeków (libavcodec); obsługuje większość istniejących
167   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
168 - bibliotekę demuksera (libavformat); obsługuje większość istniejących
169   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
170 - bibliotekę postprocessingu (libpostproc).
171
172 %package devel
173 Summary:        ffmpeg header files
174 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
175 Group:          Development/Libraries
176 Requires:       %{name}-libs = %{version}-%{release}
177 # Libs.private from *.pc (unreasonably they are all the same)
178 Requires:       SDL-devel >= 1.2.1
179 Requires:       alsa-lib-devel
180 Requires:       bzip2-devel
181 Requires:       celt-devel >= 0.11.0
182 %{?with_nonfree:Requires:       faac-devel}
183 %{?with_fdk_aac:Requires:       fdk-aac-devel}
184 Requires:       fontconfig-devel
185 Requires:       freetype-devel
186 Requires:       jack-audio-connection-kit-devel
187 %{?with_flite:Requires: flite-devel >= 1.4}
188 Requires:       lame-libs-devel >= 3.98.3
189 %{?with_aacplus:Requires:       libaacplus-devel >= 2.0.0}
190 Requires:       libass-devel
191 Requires:       libavc1394-devel
192 Requires:       libbluray-devel
193 %{?with_caca:Requires:  libcaca-devel}
194 Requires:       libcdio-paranoia-devel >= 0.90-2
195 Requires:       libdc1394-devel >= 2
196 Requires:       libgsm-devel
197 Requires:       libiec61883-devel
198 Requires:       libmodplug-devel
199 Requires:       libnut-devel
200 Requires:       libraw1394-devel >= 2
201 Requires:       librtmp-devel
202 Requires:       libtheora-devel >= 1.0-0.beta3
203 %{?with_va:Requires:    libva-devel >= 1.0.3}
204 Requires:       libvorbis-devel
205 %{?with_vpx:Requires:   libvpx-devel >= 0.9.7}
206 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
207 Requires:       opencore-amr-devel
208 %{?with_opencv:Requires:        opencv-devel}
209 Requires:       openjpeg-devel >= 1.5
210 Requires:       schroedinger-devel
211 %{?with_soxr:Requires:  soxr-devel}
212 Requires:       speex-devel >= 1:1.2-rc1
213 Requires:       twolame-devel
214 %{?with_utvideo:Requires:       utvideo-devel >= 12}
215 Requires:       vo-aacenc-devel
216 Requires:       vo-amrwbenc-devel
217 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
218 Requires:       xavs-devel
219 Requires:       xorg-lib-libXext-devel
220 Requires:       xorg-lib-libXfixes-devel
221 Requires:       xvid-devel >= 1:1.1.0
222 Requires:       zlib-devel
223 Obsoletes:      libpostproc-devel
224
225 %description devel
226 ffmpeg header files.
227
228 %description devel -l pl.UTF-8
229 Pliki nagłówkowe ffmpeg.
230
231 %package static
232 Summary:        ffmpeg static libraries
233 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
234 Group:          Development/Libraries
235 Requires:       %{name}-devel = %{version}-%{release}
236
237 %description static
238 ffmpeg static libraries (libavcodec and libavformat).
239
240 %description static -l pl.UTF-8
241 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
242
243 %package ffplay
244 Summary:        FFplay - SDL-based media player
245 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
246 Group:          Applications/Multimedia
247 Requires:       %{name}-libs = %{version}-%{release}
248
249 %description ffplay
250 FFplay is a very simple and portable media player using the FFmpeg
251 libraries and the SDL library. It is mostly used as a test bench for
252 the various APIs of FFmpeg.
253
254 %description ffplay -l pl.UTF-8
255 FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
256 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
257 testowania różnych API FFmpeg.
258
259 %package ffserver
260 Summary:        FFserver video server
261 Summary(pl.UTF-8):      FFserver - serwer strumieni obrazu
262 Group:          Daemons
263 Requires(post,preun):   /sbin/chkconfig
264 Requires:       %{name}-libs = %{version}-%{release}
265 Requires:       rc-scripts >= 0.4.0.10
266
267 %description ffserver
268 FFserver is a streaming server for both audio and video. It supports
269 several live feeds, streaming from files and time shifting on live
270 feeds (you can seek to positions in the past on each live feed,
271 provided you specify a big enough feed storage in ffserver.conf).
272
273 %description ffserver -l pl.UTF-8
274 FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
275 źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
276 czasie dla źródeł na żywo (można przeskakiwać na położenia w
277 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
278 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
279
280 %prep
281 %setup -q
282 %patch0 -p1
283 %patch1 -p1
284 %patch2 -p1
285
286 # package the grep result for mplayer, the result formatted as ./mplayer/configure
287 cat <<EOF > ffmpeg-avconfig
288 #! /bin/sh
289 _libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
290 _libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
291 _libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
292 _libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
293 _libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
294 _libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
295 _libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
296 EOF
297 cat <<'EOF' >> ffmpeg-avconfig
298
299 case "$1" in
300 --decoders)
301         echo $_libavdecoders_all
302         ;;
303 --encoders)
304         echo $_libavencoders_all
305         ;;
306 --parsers)
307         echo $_libavparsers_all
308         ;;
309 --bsfs)
310         echo $_libavbsfs_all
311         ;;
312 --demuxers)
313         echo $_libavdemuxers_all
314         ;;
315 --muxers)
316         echo $_libavmuxers_all
317         ;;
318 --protocols)
319         echo $_libavprotocols_all
320         ;;
321 *)
322         cat <<USAGE
323 Usage: $0 [OPTION]
324 Options:
325   --decoders
326   --encoders
327   --parsers
328   --bsfs
329   --demuxers
330   --muxers
331   --protocols
332 USAGE
333         exit 1;;
334 esac
335
336 exit 0
337 EOF
338
339 %build
340 # notes:
341 # - it's not autoconf configure
342 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
343 ./configure \
344         --arch=%{_target_base_arch} \
345         --prefix=%{_prefix} \
346         --libdir=%{_libdir} \
347         --shlibdir=%{_libdir} \
348         --mandir=%{_mandir} \
349         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
350         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
351         --cc="%{__cc}" \
352         --disable-debug \
353         --disable-optimizations \
354         --disable-stripping \
355         --enable-avfilter \
356         --enable-avresample \
357         --enable-gnutls \
358         --enable-gpl \
359         --enable-version3 \
360         --enable-fontconfig \
361         %{?with_frei0r:--enable-frei0r} \
362         %{?with_aacplus:--enable-libaacplus} \
363         --enable-libass \
364         --enable-libbluray \
365         %{?with_caca:--enable-libcaca} \
366         --enable-libcelt \
367         --enable-libcdio \
368         --enable-libdc1394 \
369         %{?with_fdk_aac:--enable-libfdk-aac} \
370         %{?with_flite:--enable-libflite} \
371         --enable-libfreetype \
372         --enable-libgsm \
373         --enable-libiec61883 \
374         %{?with_ilbc:--enable-libilbc} \
375         --enable-libmodplug \
376         --enable-libmp3lame \
377         --enable-libnut \
378         --enable-libopencore-amrnb \
379         --enable-libopencore-amrwb \
380         %{?with_opencv:--enable-libopencv} \
381         --enable-libopenjpeg \
382         --enable-libopus \
383         %{?with_pulseaudio:--enable-libpulse} \
384         --enable-librtmp \
385         --enable-libschroedinger \
386         %{?with_soxr:--enable-libsoxr} \
387         --enable-libspeex \
388         --enable-libtheora \
389         --enable-libtwolame \
390         %{?with_utvideo:--enable-libutvideo} \
391         --enable-libv4l2 \
392         --enable-libvo-aacenc \
393         --enable-libvo-amrwbenc \
394         --enable-libvorbis \
395         %{?with_vpx:--enable-libvpx} \
396         %{?with_x264:--enable-libx264} \
397         --enable-libxavs \
398         --enable-libxvid \
399         %{?with_openal:--enable-openal} \
400         --enable-postproc \
401         --enable-pthreads \
402         --enable-shared \
403         --enable-swscale \
404         %{?with_va:--enable-vaapi} \
405         --enable-vdpau \
406         --enable-x11grab \
407 %ifnarch %{ix86} %{x8664}
408         --disable-mmx \
409 %endif
410 %ifarch i386 i486
411         --disable-mmx \
412 %endif
413 %if %{with nonfree}
414         --enable-nonfree \
415         --enable-libfaac \
416 %endif
417         --enable-runtime-cpudetect
418
419 # force oldscaler build
420 %{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
421
422 %{__make} \
423         V=1
424
425 # CC_O to add -c to commandline. makefile should be patched
426 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
427
428 %install
429 rm -rf $RPM_BUILD_ROOT
430 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
431         $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
432         $RPM_BUILD_ROOT/var/{cache,log}/ffserver
433
434 %{__make} install install-headers \
435         DESTDIR=$RPM_BUILD_ROOT \
436         V=1
437
438 # install nonstandard, non-public headers manually
439 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
440 for a in libavutil/*/bswap.h; do
441         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
442 done
443 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
444 # for lim-omx ffmpeg components
445 cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
446
447 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
448 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
449 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
450 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
451 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
452
453 # install as ffmpeg-avconfig to avoid with possible programs looking for
454 # ffmpeg-config and expecting --libs output from it which is not implemented
455 # simple to do (by querying pkgconfig), but why?
456 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
457
458 # fix man page
459 %if %{with doc}
460 install -d $RPM_BUILD_ROOT%{_mandir}/man3
461 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/lib*.3 $RPM_BUILD_ROOT%{_mandir}/man3
462 %endif
463
464 %clean
465 rm -rf $RPM_BUILD_ROOT
466
467 %post   libs -p /sbin/ldconfig
468 %postun libs -p /sbin/ldconfig
469
470 %pre ffserver
471 %groupadd -g 167 ffserver
472 %useradd -g ffserver -u 167 ffserver
473
474 %post ffserver
475 /sbin/chkconfig --add ffserver
476 %service ffserver restart
477
478 %preun ffserver
479 if [ "$1" = 0 ]; then
480         %service ffserver stop
481         /sbin/chkconfig --del ffserver
482 fi
483
484 %postun ffserver
485 if [ "$1" = 0 ]; then
486         %userremove ffserver
487         %groupremove ffserver
488 fi
489
490 %files
491 %defattr(644,root,root,755)
492 %doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
493 %attr(755,root,root) %{_bindir}/ffmpeg
494 %attr(755,root,root) %{_bindir}/ffprobe
495 %attr(755,root,root) %{_bindir}/qt-faststart
496 %dir %{_datadir}/ffmpeg
497 %{_datadir}/ffmpeg/*.ffpreset
498 %{_datadir}/ffmpeg/ffprobe.xsd
499 %if %{with doc}
500 %{_mandir}/man1/ffmpeg.1*
501 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
502 %{_mandir}/man1/ffmpeg-codecs.1*
503 %{_mandir}/man1/ffmpeg-devices.1*
504 %{_mandir}/man1/ffmpeg-filters.1*
505 %{_mandir}/man1/ffmpeg-formats.1*
506 %{_mandir}/man1/ffmpeg-protocols.1*
507 %{_mandir}/man1/ffmpeg-resampler.1*
508 %{_mandir}/man1/ffmpeg-scaler.1*
509 %{_mandir}/man1/ffmpeg-utils.1*
510 %{_mandir}/man1/ffprobe.1*
511 %endif
512
513 %files libs
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
516 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.54
517 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
518 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.54
519 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
520 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
521 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
522 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.54
523 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
524 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.1
525 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
526 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.52
527 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
528 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
529 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
530 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
531 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
532 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
533
534 %files devel
535 %defattr(644,root,root,755)
536 %doc doc/optimization.txt
537 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
538 %attr(755,root,root) %{_libdir}/libavcodec.so
539 %attr(755,root,root) %{_libdir}/libavdevice.so
540 %attr(755,root,root) %{_libdir}/libavfilter.so
541 %attr(755,root,root) %{_libdir}/libavformat.so
542 %attr(755,root,root) %{_libdir}/libavresample.so
543 %attr(755,root,root) %{_libdir}/libavutil.so
544 %attr(755,root,root) %{_libdir}/libpostproc.so
545 %attr(755,root,root) %{_libdir}/libswresample.so
546 %attr(755,root,root) %{_libdir}/libswscale.so
547 %{_includedir}/ffmpeg
548 %{_includedir}/libavcodec
549 %{_includedir}/libavdevice
550 %{_includedir}/libavfilter
551 %{_includedir}/libavformat
552 %{_includedir}/libavresample
553 %{_includedir}/libavutil
554 %{_includedir}/libpostproc
555 %{_includedir}/libswresample
556 %{_includedir}/libswscale
557 %{_pkgconfigdir}/libavcodec.pc
558 %{_pkgconfigdir}/libavdevice.pc
559 %{_pkgconfigdir}/libavfilter.pc
560 %{_pkgconfigdir}/libavformat.pc
561 %{_pkgconfigdir}/libavresample.pc
562 %{_pkgconfigdir}/libavutil.pc
563 %{_pkgconfigdir}/libpostproc.pc
564 %{_pkgconfigdir}/libswresample.pc
565 %{_pkgconfigdir}/libswscale.pc
566 %if %{with doc}
567 %{_mandir}/man3/libavcodec.3*
568 %{_mandir}/man3/libavdevice.3*
569 %{_mandir}/man3/libavfilter.3*
570 %{_mandir}/man3/libavformat.3*
571 %{_mandir}/man3/libavutil.3*
572 %{_mandir}/man3/libswresample.3*
573 %{_mandir}/man3/libswscale.3*
574 %endif
575
576 %files static
577 %defattr(644,root,root,755)
578 %{_libdir}/libavcodec.a
579 %{_libdir}/libavdevice.a
580 %{_libdir}/libavfilter.a
581 %{_libdir}/libavformat.a
582 %{_libdir}/libavresample.a
583 %{_libdir}/libavutil.a
584 %{_libdir}/libpostproc.a
585 %{_libdir}/libswresample.a
586 %{_libdir}/libswscale.a
587
588 %files ffplay
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{_bindir}/ffplay
591 %{?with_doc:%{_mandir}/man1/ffplay.1*}
592
593 %files ffserver
594 %defattr(644,root,root,755)
595 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
596 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
597 %attr(755,root,root) %{_sbindir}/ffserver
598 %attr(754,root,root) /etc/rc.d/init.d/ffserver
599 %{?with_doc:%{_mandir}/man1/ffserver.1*}
600 %dir %attr(770,root,ffserver) /var/cache/ffserver
601 %dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.075283 seconds and 4 git commands to generate.