]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- up to 2.1; oldscaler is gone long time ago
[packages/ffmpeg.git] / ffmpeg.spec
1 # TODO: libzmq ?
2 #
3 # How to deal with ffmpeg/opencv checken-egg problem:
4 #       1. make-request -r --without opencv ffmpeg.spec
5 #       2. make-request -r opencv.spec
6 #       3. bump release of ffmpeg.spec
7 #       4. make-request -r ffmpeg.spec
8 #
9 # Conditional build:
10 %bcond_with     nonfree         # non free options of package (currently: faac)
11 %bcond_with     aacplus         # AAC+ encoding via libaacplus (requires nonfree)
12 %bcond_with     fdk_aac         # AAC encoding via libfdk_aac (requires nonfree)
13 %bcond_without  caca            # textual display using libcaca
14 %bcond_without  flite           # flite voice synthesis support
15 %bcond_without  frei0r          # frei0r video filtering
16 %bcond_without  gme             # Game Music Emu support
17 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
18 %bcond_without  openal          # OpenAL 1.1 capture support
19 %bcond_with     opencl          # OpenCL code [OpenCL 1.2, but Mesa 9.1.x headers don't suffice]
20 %bcond_without  opencv          # OpenCV video filtering
21 %bcond_without  pulseaudio      # PulseAudio input support
22 %bcond_without  quvi            # quvi input support
23 %bcond_without  shine           # shine fixed-point MP3 encoder
24 %bcond_without  soxr            # SoX Resampler support
25 %bcond_without  x264            # x264 encoder
26 %bcond_without  utvideo         # Ut Video decoder
27 %bcond_without  va              # VAAPI (Video Acceleration API)
28 %bcond_without  vidstab         # vid.stab video stabilization support
29 %bcond_without  vpx             # VP8, a high-quality video codec
30 %bcond_without  wavpack         # wavpack encoding support
31 %bcond_without  zmq             # 0MQ message passing
32 %bcond_without  doc             # don't build docs
33
34 Summary:        FFmpeg - a very fast video and audio converter
35 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
36 Name:           ffmpeg
37 Version:        2.1
38 Release:        1
39 # LGPL or GPL, chosen at configure time (GPL version is more featured)
40 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
41 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
42 License:        GPL v3+ with LGPL v3+ parts
43 Group:          Applications/Multimedia
44 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
45 # Source0-md5:  4ec1cedd4c7753512462f70b347c338a
46 Source1:        ffserver.init
47 Source2:        ffserver.sysconfig
48 Source3:        ffserver.conf
49 Patch0:         %{name}-opencv24.patch
50 URL:            http://www.ffmpeg.org/
51 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
52 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.2}
53 BuildRequires:  SDL-devel >= 1.2.1
54 BuildRequires:  alsa-lib-devel
55 BuildRequires:  bzip2-devel
56 BuildRequires:  celt-devel >= 0.11.0
57 %{?with_nonfree:BuildRequires:  faac-devel}
58 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
59 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
60 BuildRequires:  fontconfig-devel
61 BuildRequires:  freetype-devel
62 %{?with_frei0r:BuildRequires:   frei0r-devel}
63 %{?with_gme:BuildRequires:      game-music-emu-devel}
64 %ifarch ppc
65 # require version with altivec support fixed
66 BuildRequires:  gcc >= 5:3.3.2-3
67 %endif
68 BuildRequires:  gnutls-devel
69 BuildRequires:  jack-audio-connection-kit-devel
70 BuildRequires:  lame-libs-devel >= 3.98.3
71 %{?with_aacplus:BuildRequires:  libaacplus-devel >= 2.0.0}
72 BuildRequires:  libass-devel
73 BuildRequires:  libavc1394-devel
74 BuildRequires:  libbluray-devel
75 %{?with_caca:BuildRequires:     libcaca-devel}
76 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
77 BuildRequires:  libdc1394-devel >= 2
78 BuildRequires:  libgsm-devel
79 BuildRequires:  libiec61883-devel
80 BuildRequires:  libmodplug-devel
81 BuildRequires:  libnut-devel
82 %{?with_quvi:BuildRequires:     libquvi-devel}
83 BuildRequires:  libraw1394-devel >= 2
84 BuildRequires:  librtmp-devel
85 BuildRequires:  libtheora-devel >= 1.0-0.beta3
86 BuildRequires:  libtool >= 2:1.4d-3
87 BuildRequires:  libv4l-devel
88 %{?with_va:BuildRequires:       libva-devel >= 1.0.3}
89 BuildRequires:  libvdpau-devel >= 0.2
90 BuildRequires:  libvorbis-devel
91 %{?with_vpx:BuildRequires:      libvpx-devel >= 0.9.7}
92 %{?with_shine:BuildRequires:    shine-devel}
93 # X264_BUILD >= 118
94 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
95 %ifarch %{ix86}
96 %ifnarch i386 i486
97 BuildRequires:  nasm
98 %endif
99 %endif
100 BuildRequires:  opencore-amr-devel
101 %{?with_opencv:BuildRequires:   opencv-devel}
102 BuildRequires:  openjpeg-devel >= 1.5
103 BuildRequires:  opus-devel
104 BuildRequires:  perl-Encode
105 BuildRequires:  perl-tools-pod
106 BuildRequires:  pkgconfig
107 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
108 BuildRequires:  rpmbuild(macros) >= 1.470
109 BuildRequires:  schroedinger-devel
110 BuildRequires:  shine-devel >= 3.0.0
111 %{?with_soxr:BuildRequires:     soxr-devel}
112 BuildRequires:  speex-devel >= 1:1.2-rc1
113 %{?with_doc:BuildRequires:      tetex}
114 %{?with_doc:BuildRequires:      texi2html}
115 %{?with_doc:BuildRequires:      texinfo}
116 BuildRequires:  twolame-devel
117 %{?with_utvideo:BuildRequires:  utvideo-devel >= 12}
118 %{?with_vidstab:BuildRequires:  vid.stab-devel}
119 BuildRequires:  vo-aacenc-devel
120 BuildRequires:  vo-amrwbenc-devel
121 %{?with_wavpack:BuildRequires:  wavpack-devel}
122 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
123 BuildRequires:  xavs-devel
124 BuildRequires:  xorg-lib-libX11-devel
125 BuildRequires:  xorg-lib-libXext-devel
126 BuildRequires:  xorg-lib-libXfixes-devel
127 BuildRequires:  xvid-devel >= 1:1.1.0
128 BuildRequires:  yasm
129 %{?with_zmq:BuildRequires:      zeromq-devel}
130 BuildRequires:  zlib-devel
131 %{?with_autoreqdep:BuildConflicts:      libpostproc}
132 # overflows maximum hash table size
133 BuildConflicts: pdksh < 5.2.14-57
134 Requires:       %{name}-libs = %{version}-%{release}
135 %{?with_utvideo:Requires:       utvideo >= 12}
136 %{?with_ilbc:Requires:  webrtc-libilbc}
137 Requires:       xvid >= 1:1.1.0
138 Obsoletes:      libpostproc
139 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
140
141 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
142
143 %define         specflags       -fno-strict-aliasing
144
145 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
146 %define         specflags_ia32  -fomit-frame-pointer
147 # -mmmx is needed to enable <mmintrin.h> code.
148 %define         specflags_i586  -mmmx
149 %define         specflags_i686  -mmmx
150 %define         specflags_ppc   -fPIC
151
152 %description
153 FFmpeg is a complete solution to record, convert and stream audio and
154 video. It is a command line tool to convert one video file format to
155 another. It also supports grabbing and encoding in real time from a TV
156 card.
157
158 %description -l pl.UTF-8
159 FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
160 strumieni dźwięku i obrazu. Jest to działające z linii poleceń
161 narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
162 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
163 telewizyjnej.
164
165 %package libs
166 Summary:        ffmpeg libraries
167 Summary(pl.UTF-8):      Biblioteki ffmpeg
168 Group:          Libraries
169
170 %description libs
171 This package contains the ffmpeg shared libraries:
172 - the codec library (libavcodec). It supports most existing encoding
173   formats (MPEG, DivX, MPEG4, AC3, DV...),
174 - demuxer library (libavformat). It supports most existing file
175   formats (AVI, MPEG, OGG, Matroska, ASF...),
176 - video postprocessing library (libpostproc).
177
178 %description libs -l pl.UTF-8
179 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
180 - bibliotekę kodeków (libavcodec); obsługuje większość istniejących
181   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
182 - bibliotekę demuksera (libavformat); obsługuje większość istniejących
183   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
184 - bibliotekę postprocessingu (libpostproc).
185
186 %package devel
187 Summary:        ffmpeg header files
188 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
189 Group:          Development/Libraries
190 Requires:       %{name}-libs = %{version}-%{release}
191 # Libs.private from *.pc (unreasonably they are all the same)
192 %{?with_opencl:Requires:        OpenCL-devel >= 1.2}
193 Requires:       SDL-devel >= 1.2.1
194 Requires:       alsa-lib-devel
195 Requires:       bzip2-devel
196 Requires:       celt-devel >= 0.11.0
197 %{?with_nonfree:Requires:       faac-devel}
198 %{?with_fdk_aac:Requires:       fdk-aac-devel}
199 %{?with_flite:Requires: flite-devel >= 1.4}
200 Requires:       fontconfig-devel
201 Requires:       freetype-devel
202 %{?with_gme:Requires:   game-music-emu-devel}
203 Requires:       jack-audio-connection-kit-devel
204 Requires:       lame-libs-devel >= 3.98.3
205 %{?with_aacplus:Requires:       libaacplus-devel >= 2.0.0}
206 Requires:       libass-devel
207 Requires:       libavc1394-devel
208 Requires:       libbluray-devel
209 %{?with_caca:Requires:  libcaca-devel}
210 Requires:       libcdio-paranoia-devel >= 0.90-2
211 Requires:       libdc1394-devel >= 2
212 Requires:       libgsm-devel
213 Requires:       libiec61883-devel
214 Requires:       libmodplug-devel
215 Requires:       libnut-devel
216 %{?with_quvi:Requires:  libquvi-devel}
217 Requires:       libraw1394-devel >= 2
218 Requires:       librtmp-devel
219 Requires:       libtheora-devel >= 1.0-0.beta3
220 %{?with_va:Requires:    libva-devel >= 1.0.3}
221 Requires:       libvorbis-devel
222 %{?with_vpx:Requires:   libvpx-devel >= 0.9.7}
223 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
224 Requires:       opencore-amr-devel
225 %{?with_opencv:Requires:        opencv-devel}
226 Requires:       openjpeg-devel >= 1.5
227 Requires:       schroedinger-devel
228 %{?with_shine:Requires: shine-devel}
229 %{?with_soxr:Requires:  soxr-devel}
230 Requires:       speex-devel >= 1:1.2-rc1
231 Requires:       twolame-devel
232 %{?with_utvideo:Requires:       utvideo-devel >= 12}
233 %{?with_vidstab:Requires:       vid.stab-devel}
234 Requires:       vo-aacenc-devel
235 Requires:       vo-amrwbenc-devel
236 %{?with_wavpack:Requires:       wavpack-devel}
237 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
238 Requires:       xavs-devel
239 Requires:       xorg-lib-libXext-devel
240 Requires:       xorg-lib-libXfixes-devel
241 Requires:       xvid-devel >= 1:1.1.0
242 %{?with_zmq:Requires:   zeromq-devel}
243 Requires:       zlib-devel
244 Obsoletes:      libpostproc-devel
245
246 %description devel
247 ffmpeg header files.
248
249 %description devel -l pl.UTF-8
250 Pliki nagłówkowe ffmpeg.
251
252 %package static
253 Summary:        ffmpeg static libraries
254 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
255 Group:          Development/Libraries
256 Requires:       %{name}-devel = %{version}-%{release}
257
258 %description static
259 ffmpeg static libraries (libavcodec and libavformat).
260
261 %description static -l pl.UTF-8
262 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
263
264 %package ffplay
265 Summary:        FFplay - SDL-based media player
266 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
267 Group:          Applications/Multimedia
268 Requires:       %{name}-libs = %{version}-%{release}
269
270 %description ffplay
271 FFplay is a very simple and portable media player using the FFmpeg
272 libraries and the SDL library. It is mostly used as a test bench for
273 the various APIs of FFmpeg.
274
275 %description ffplay -l pl.UTF-8
276 FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
277 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
278 testowania różnych API FFmpeg.
279
280 %package ffserver
281 Summary:        FFserver video server
282 Summary(pl.UTF-8):      FFserver - serwer strumieni obrazu
283 Group:          Daemons
284 Requires(post,preun):   /sbin/chkconfig
285 Requires:       %{name}-libs = %{version}-%{release}
286 Requires:       rc-scripts >= 0.4.0.10
287
288 %description ffserver
289 FFserver is a streaming server for both audio and video. It supports
290 several live feeds, streaming from files and time shifting on live
291 feeds (you can seek to positions in the past on each live feed,
292 provided you specify a big enough feed storage in ffserver.conf).
293
294 %description ffserver -l pl.UTF-8
295 FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
296 źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
297 czasie dla źródeł na żywo (można przeskakiwać na położenia w
298 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
299 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
300
301 %package doc
302 Summary:        Manual for ffmpeg
303 Summary(fr.UTF-8):      Documentation pour ffmpeg
304 Summary(it.UTF-8):      Documentazione di ffmpeg
305 Summary(pl.UTF-8):      Podręcznik dla ffmpeg
306 Group:          Documentation
307 %if "%{_rpmversion}" >= "5"
308 BuildArch:      noarch
309 %endif
310
311 %description doc
312 Documentation for ffmpeg.
313
314 %description doc -l fr.UTF-8
315 Documentation pour ffmpeg.
316
317 %description doc -l it.UTF-8
318 Documentazione di ffmpeg.
319
320 %description doc -l pl.UTF-8
321 Dokumentacja do ffmpeg.
322
323 %prep
324 %setup -q
325 %patch0 -p1
326
327 # package the grep result for mplayer, the result formatted as ./mplayer/configure
328 cat <<EOF > ffmpeg-avconfig
329 #! /bin/sh
330 libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
331 libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
332 libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
333 libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
334 libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
335 libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
336 libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
337 libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
338 libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
339 EOF
340 cat <<'EOF' >> ffmpeg-avconfig
341
342 case "$1" in
343 --decoders)
344         echo $libavdecoders_all
345         ;;
346 --encoders)
347         echo $libavencoders_all
348         ;;
349 --parsers)
350         echo $libavparsers_all
351         ;;
352 --bsfs)
353         echo $libavbsfs_all
354         ;;
355 --demuxers)
356         echo $libavdemuxers_all
357         ;;
358 --muxers)
359         echo $libavmuxers_all
360         ;;
361 --protocols)
362         echo $libavprotocols_all
363         ;;
364 --hwaccels)
365         echo $libavhwaccels_all
366         ;;
367 --filters)
368         echo $libavfilters_all
369         ;;
370 *)
371         cat <<USAGE
372 Usage: $0 [OPTION]
373 Options:
374   --decoders
375   --encoders
376   --parsers
377   --bsfs
378   --demuxers
379   --muxers
380   --protocols
381   --hwaccels
382   --filters
383 USAGE
384         exit 1;;
385 esac
386
387 exit 0
388 EOF
389
390 %build
391 # notes:
392 # - it's not autoconf configure
393 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
394 ./configure \
395         --arch=%{_target_base_arch} \
396         --prefix=%{_prefix} \
397         --libdir=%{_libdir} \
398         --shlibdir=%{_libdir} \
399         --mandir=%{_mandir} \
400         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
401         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
402         --cc="%{__cc}" \
403         --disable-debug \
404         --disable-optimizations \
405         --disable-stripping \
406         --enable-avfilter \
407         --enable-avresample \
408         --enable-gnutls \
409         --enable-gpl \
410         --enable-version3 \
411         --enable-fontconfig \
412         %{?with_frei0r:--enable-frei0r} \
413         %{?with_aacplus:--enable-libaacplus} \
414         --enable-libass \
415         --enable-libbluray \
416         %{?with_caca:--enable-libcaca} \
417         --enable-libcelt \
418         --enable-libcdio \
419         --enable-libdc1394 \
420         %{?with_fdk_aac:--enable-libfdk-aac} \
421         %{?with_flite:--enable-libflite} \
422         --enable-libfreetype \
423         %{?with_gme:--enable-libgme} \
424         --enable-libgsm \
425         --enable-libiec61883 \
426         %{?with_ilbc:--enable-libilbc} \
427         --enable-libmodplug \
428         --enable-libmp3lame \
429         --enable-libnut \
430         --enable-libopencore-amrnb \
431         --enable-libopencore-amrwb \
432         %{?with_opencv:--enable-libopencv} \
433         --enable-libopenjpeg \
434         --enable-libopus \
435         %{?with_pulseaudio:--enable-libpulse} \
436         %{?with_quvi:--enable-libquvi} \
437         --enable-librtmp \
438         --enable-libschroedinger \
439         %{?with_shine:--enable-libshine} \
440         %{?with_soxr:--enable-libsoxr} \
441         --enable-libspeex \
442         --enable-libtheora \
443         --enable-libtwolame \
444         %{?with_utvideo:--enable-libutvideo} \
445         --enable-libv4l2 \
446         %{?with_vidstab:--enable-libvidstab} \
447         --enable-libvo-aacenc \
448         --enable-libvo-amrwbenc \
449         --enable-libvorbis \
450         %{?with_vpx:--enable-libvpx} \
451         %{?with_wavpack:--enable-libwavpack} \
452         %{?with_x264:--enable-libx264} \
453         --enable-libxavs \
454         --enable-libxvid \
455         %{?with_zmq:--enable-libzmq} \
456         %{?with_openal:--enable-openal} \
457         %{?with_opencl:--enable-opencl} \
458         --enable-postproc \
459         --enable-pthreads \
460         --enable-shared \
461         --enable-swscale \
462         %{!?with_va:--disable-vaapi} \
463         --enable-x11grab \
464 %ifnarch %{ix86} %{x8664}
465         --disable-mmx \
466 %endif
467 %ifarch i386 i486
468         --disable-mmx \
469 %endif
470 %if %{with nonfree}
471         --enable-nonfree \
472         --enable-libfaac \
473 %endif
474         --enable-runtime-cpudetect
475
476 %{__make} \
477         V=1
478
479 # CC_O to add -c to commandline. makefile should be patched
480 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
481
482 %install
483 rm -rf $RPM_BUILD_ROOT
484 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
485         $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
486         $RPM_BUILD_ROOT/var/{cache,log}/ffserver
487
488 %{__make} install install-headers \
489         DESTDIR=$RPM_BUILD_ROOT \
490         V=1
491
492 # install nonstandard, non-public headers manually
493 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
494 for a in libavutil/*/bswap.h; do
495         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
496 done
497 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
498 # for lim-omx ffmpeg components
499 cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
500
501 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
502 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
503 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
504 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
505 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
506
507 # install as ffmpeg-avconfig to avoid with possible programs looking for
508 # ffmpeg-config and expecting --libs output from it which is not implemented
509 # simple to do (by querying pkgconfig), but why?
510 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
511
512 %clean
513 rm -rf $RPM_BUILD_ROOT
514
515 %post   libs -p /sbin/ldconfig
516 %postun libs -p /sbin/ldconfig
517
518 %pre ffserver
519 %groupadd -g 167 ffserver
520 %useradd -g ffserver -u 167 ffserver
521
522 %post ffserver
523 /sbin/chkconfig --add ffserver
524 %service ffserver restart
525
526 %preun ffserver
527 if [ "$1" = 0 ]; then
528         %service ffserver stop
529         /sbin/chkconfig --del ffserver
530 fi
531
532 %postun ffserver
533 if [ "$1" = 0 ]; then
534         %userremove ffserver
535         %groupremove ffserver
536 fi
537
538 %files
539 %defattr(644,root,root,755)
540 %doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES}
541 %attr(755,root,root) %{_bindir}/ffmpeg
542 %attr(755,root,root) %{_bindir}/ffprobe
543 %attr(755,root,root) %{_bindir}/qt-faststart
544 %dir %{_datadir}/ffmpeg
545 %{_datadir}/ffmpeg/*.ffpreset
546 %{_datadir}/ffmpeg/ffprobe.xsd
547 %if %{with doc}
548 %{_mandir}/man1/ffmpeg.1*
549 %{_mandir}/man1/ffmpeg-all.1*
550 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
551 %{_mandir}/man1/ffmpeg-codecs.1*
552 %{_mandir}/man1/ffmpeg-devices.1*
553 %{_mandir}/man1/ffmpeg-filters.1*
554 %{_mandir}/man1/ffmpeg-formats.1*
555 %{_mandir}/man1/ffmpeg-protocols.1*
556 %{_mandir}/man1/ffmpeg-resampler.1*
557 %{_mandir}/man1/ffmpeg-scaler.1*
558 %{_mandir}/man1/ffmpeg-utils.1*
559 %{_mandir}/man1/ffprobe.1*
560 %{_mandir}/man1/ffprobe-all.1*
561 %endif
562
563 %files libs
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
566 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.55
567 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
568 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.55
569 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
570 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
571 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
572 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.55
573 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
574 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.1
575 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
576 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.52
577 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
578 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
579 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
580 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
581 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
582 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
583
584 %files devel
585 %defattr(644,root,root,755)
586 %doc doc/optimization.txt
587 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
588 %attr(755,root,root) %{_libdir}/libavcodec.so
589 %attr(755,root,root) %{_libdir}/libavdevice.so
590 %attr(755,root,root) %{_libdir}/libavfilter.so
591 %attr(755,root,root) %{_libdir}/libavformat.so
592 %attr(755,root,root) %{_libdir}/libavresample.so
593 %attr(755,root,root) %{_libdir}/libavutil.so
594 %attr(755,root,root) %{_libdir}/libpostproc.so
595 %attr(755,root,root) %{_libdir}/libswresample.so
596 %attr(755,root,root) %{_libdir}/libswscale.so
597 %{_includedir}/ffmpeg
598 %{_includedir}/libavcodec
599 %{_includedir}/libavdevice
600 %{_includedir}/libavfilter
601 %{_includedir}/libavformat
602 %{_includedir}/libavresample
603 %{_includedir}/libavutil
604 %{_includedir}/libpostproc
605 %{_includedir}/libswresample
606 %{_includedir}/libswscale
607 %{_pkgconfigdir}/libavcodec.pc
608 %{_pkgconfigdir}/libavdevice.pc
609 %{_pkgconfigdir}/libavfilter.pc
610 %{_pkgconfigdir}/libavformat.pc
611 %{_pkgconfigdir}/libavresample.pc
612 %{_pkgconfigdir}/libavutil.pc
613 %{_pkgconfigdir}/libpostproc.pc
614 %{_pkgconfigdir}/libswresample.pc
615 %{_pkgconfigdir}/libswscale.pc
616 %if %{with doc}
617 %{_mandir}/man3/libavcodec.3*
618 %{_mandir}/man3/libavdevice.3*
619 %{_mandir}/man3/libavfilter.3*
620 %{_mandir}/man3/libavformat.3*
621 %{_mandir}/man3/libavutil.3*
622 %{_mandir}/man3/libswresample.3*
623 %{_mandir}/man3/libswscale.3*
624 %endif
625
626 %files static
627 %defattr(644,root,root,755)
628 %{_libdir}/libavcodec.a
629 %{_libdir}/libavdevice.a
630 %{_libdir}/libavfilter.a
631 %{_libdir}/libavformat.a
632 %{_libdir}/libavresample.a
633 %{_libdir}/libavutil.a
634 %{_libdir}/libpostproc.a
635 %{_libdir}/libswresample.a
636 %{_libdir}/libswscale.a
637
638 %files ffplay
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_bindir}/ffplay
641 %if %{with doc}
642 %{_mandir}/man1/ffplay.1*
643 %{_mandir}/man1/ffplay-all.1*
644 %endif
645
646 %files ffserver
647 %defattr(644,root,root,755)
648 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
649 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
650 %attr(755,root,root) %{_sbindir}/ffserver
651 %attr(754,root,root) /etc/rc.d/init.d/ffserver
652 %if %{with doc}
653 %{_mandir}/man1/ffserver.1*
654 %{_mandir}/man1/ffserver-all.1*
655 %endif
656 %dir %attr(770,root,ffserver) /var/cache/ffserver
657 %dir %attr(770,root,ffserver) /var/log/ffserver
658
659 %if %{with doc}
660 %files doc
661 %defattr(644,root,root,755)
662 %doc doc/*.html
663 %endif
This page took 0.072057 seconds and 4 git commands to generate.