]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- updated to 1.2
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # How to deal with ffmpeg/opencv checken-egg problem:
3 #       1. make-request -r --without opencv ffmpeg.spec
4 #       2. make-request -r opencv.spec
5 #       3. bump release of ffmpeg.spec
6 #       4. make-request -r ffmpeg.spec
7 #
8 # Conditional build:
9 %bcond_with     nonfree         # non free options of package (currently: faac)
10 %bcond_with     aacplus         # AAC+ encoding via libaacplus (requires nonfree)
11 %bcond_with     fdk_aac         # AAC encoding via libfdk_aac (requires nonfree)
12 %bcond_without  caca            # textual display using libcaca
13 %bcond_without  flite           # flite voice synthesis support
14 %bcond_without  frei0r          # frei0r video filtering
15 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
16 %bcond_without  openal          # OpenAL 1.1 capture support
17 %bcond_without  opencv          # OpenCV video filtering
18 %bcond_without  pulseaudio      # PulseAudio input support
19 %bcond_without  soxr            # SoX Resampler support
20 %bcond_without  x264            # x264 encoder
21 %bcond_without  utvideo         # Ut Video decoder
22 %bcond_without  va              # VAAPI (Video Acceleration API)
23 %bcond_without  vpx             # VP8, a high-quality video codec
24 %bcond_without  doc             # don't build docs
25
26 Summary:        FFmpeg - a very fast video and audio converter
27 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
28 Name:           ffmpeg
29 Version:        1.2
30 Release:        1
31 # LGPL or GPL, chosen at configure time (GPL version is more featured)
32 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
33 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
34 License:        GPL v3+ with LGPL v3+ parts
35 Group:          Applications/Multimedia
36 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
37 # Source0-md5:  c871d20559cb64c015b5cf0858812a56
38 Source1:        ffserver.init
39 Source2:        ffserver.sysconfig
40 Source3:        ffserver.conf
41 Patch0:         %{name}-opencv24.patch
42 Patch1:         %{name}-utvideo.patch
43 URL:            http://www.ffmpeg.org/
44 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
45 BuildRequires:  SDL-devel >= 1.2.1
46 BuildRequires:  alsa-lib-devel
47 BuildRequires:  bzip2-devel
48 BuildRequires:  celt-devel >= 0.11.0
49 %{?with_nonfree:BuildRequires:  faac-devel}
50 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
51 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
52 BuildRequires:  fontconfig-devel
53 BuildRequires:  freetype-devel
54 %{?with_frei0r:BuildRequires:   frei0r-devel}
55 %ifarch ppc
56 # require version with altivec support fixed
57 BuildRequires:  gcc >= 5:3.3.2-3
58 %endif
59 BuildRequires:  gnutls-devel
60 BuildRequires:  jack-audio-connection-kit-devel
61 BuildRequires:  lame-libs-devel >= 3.98.3
62 %{?with_aacplus:BuildRequires:  libaacplus-devel >= 2.0.0}
63 BuildRequires:  libass-devel
64 BuildRequires:  libavc1394-devel
65 BuildRequires:  libbluray-devel
66 %{?with_caca:BuildRequires:     libcaca-devel}
67 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
68 BuildRequires:  libdc1394-devel >= 2
69 BuildRequires:  libgsm-devel
70 BuildRequires:  libiec61883-devel
71 BuildRequires:  libmodplug-devel
72 BuildRequires:  libnut-devel
73 BuildRequires:  libraw1394-devel >= 2
74 BuildRequires:  librtmp-devel
75 BuildRequires:  libtheora-devel >= 1.0-0.beta3
76 BuildRequires:  libtool >= 2:1.4d-3
77 BuildRequires:  libv4l-devel
78 %{?with_va:BuildRequires:       libva-devel >= 1.0.3}
79 BuildRequires:  libvdpau-devel >= 0.2
80 BuildRequires:  libvorbis-devel
81 %{?with_vpx:BuildRequires:      libvpx-devel >= 0.9.7}
82 # X264_BUILD >= 118
83 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
84 %ifarch %{ix86}
85 %ifnarch i386 i486
86 BuildRequires:  nasm
87 %endif
88 %endif
89 BuildRequires:  opencore-amr-devel
90 %{?with_opencv:BuildRequires:   opencv-devel}
91 BuildRequires:  openjpeg-devel >= 1.5
92 BuildRequires:  opus-devel
93 BuildRequires:  perl-Encode
94 BuildRequires:  perl-tools-pod
95 BuildRequires:  pkgconfig
96 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
97 BuildRequires:  rpmbuild(macros) >= 1.470
98 BuildRequires:  schroedinger-devel
99 %{?with_soxr:BuildRequires:     soxr-devel}
100 BuildRequires:  speex-devel >= 1:1.2-rc1
101 %{?with_doc:BuildRequires:      tetex}
102 %{?with_doc:BuildRequires:      texi2html}
103 %{?with_doc:BuildRequires:      texinfo}
104 BuildRequires:  twolame-devel
105 %{?with_utvideo:BuildRequires:  utvideo-devel >= 12}
106 BuildRequires:  vo-aacenc-devel
107 BuildRequires:  vo-amrwbenc-devel
108 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
109 BuildRequires:  xavs-devel
110 BuildRequires:  xorg-lib-libX11-devel
111 BuildRequires:  xorg-lib-libXext-devel
112 BuildRequires:  xorg-lib-libXfixes-devel
113 BuildRequires:  xvid-devel >= 1:1.1.0
114 BuildRequires:  yasm
115 BuildRequires:  zlib-devel
116 %{?with_autoreqdep:BuildConflicts:      libpostproc}
117 # overflows maximum hash table size
118 BuildConflicts: pdksh < 5.2.14-57
119 Requires:       %{name}-libs = %{version}-%{release}
120 %{?with_utvideo:Requires:       utvideo >= 12}
121 %{?with_ilbc:Requires:  webrtc-libilbc}
122 Requires:       xvid >= 1:1.1.0
123 Obsoletes:      libpostproc
124 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
125
126 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
127
128 %define         specflags       -fno-strict-aliasing
129
130 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
131 %define         specflags_ia32  -fomit-frame-pointer
132 # -mmmx is needed to enable <mmintrin.h> code.
133 %define         specflags_i586  -mmmx
134 %define         specflags_i686  -mmmx
135 %define         specflags_ppc   -fPIC
136
137 %description
138 FFmpeg is a complete solution to record, convert and stream audio and
139 video. It is a command line tool to convert one video file format to
140 another. It also supports grabbing and encoding in real time from a TV
141 card.
142
143 %description -l pl.UTF-8
144 FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
145 strumieni dźwięku i obrazu. Jest to działające z linii poleceń
146 narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
147 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
148 telewizyjnej.
149
150 %package libs
151 Summary:        ffmpeg libraries
152 Summary(pl.UTF-8):      Biblioteki ffmpeg
153 Group:          Libraries
154
155 %description libs
156 This package contains the ffmpeg shared libraries:
157 - the codec library (libavcodec). It supports most existing encoding
158   formats (MPEG, DivX, MPEG4, AC3, DV...),
159 - demuxer library (libavformat). It supports most existing file
160   formats (AVI, MPEG, OGG, Matroska, ASF...),
161 - video postprocessing library (libpostproc).
162
163 %description libs -l pl.UTF-8
164 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
165 - bibliotekę kodeków (libavcodec); obsługuje większość istniejących
166   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
167 - bibliotekę demuksera (libavformat); obsługuje większość istniejących
168   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
169 - bibliotekę postprocessingu (libpostproc).
170
171 %package devel
172 Summary:        ffmpeg header files
173 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
174 Group:          Development/Libraries
175 Requires:       %{name}-libs = %{version}-%{release}
176 # Libs.private from *.pc (unreasonably they are all the same)
177 Requires:       SDL-devel >= 1.2.1
178 Requires:       alsa-lib-devel
179 Requires:       bzip2-devel
180 Requires:       celt-devel >= 0.11.0
181 %{?with_nonfree:Requires:       faac-devel}
182 %{?with_fdk_aac:Requires:       fdk-aac-devel}
183 Requires:       fontconfig-devel
184 Requires:       freetype-devel
185 Requires:       jack-audio-connection-kit-devel
186 %{?with_flite:Requires: flite-devel >= 1.4}
187 Requires:       lame-libs-devel >= 3.98.3
188 %{?with_aacplus:Requires:       libaacplus-devel >= 2.0.0}
189 Requires:       libass-devel
190 Requires:       libavc1394-devel
191 Requires:       libbluray-devel
192 %{?with_caca:Requires:  libcaca-devel}
193 Requires:       libcdio-paranoia-devel >= 0.90-2
194 Requires:       libdc1394-devel >= 2
195 Requires:       libgsm-devel
196 Requires:       libiec61883-devel
197 Requires:       libmodplug-devel
198 Requires:       libnut-devel
199 Requires:       libraw1394-devel >= 2
200 Requires:       librtmp-devel
201 Requires:       libtheora-devel >= 1.0-0.beta3
202 %{?with_va:Requires:    libva-devel >= 1.0.3}
203 Requires:       libvorbis-devel
204 %{?with_vpx:Requires:   libvpx-devel >= 0.9.7}
205 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
206 Requires:       opencore-amr-devel
207 %{?with_opencv:Requires:        opencv-devel}
208 Requires:       openjpeg-devel >= 1.5
209 Requires:       schroedinger-devel
210 %{?with_soxr:Requires:  soxr-devel}
211 Requires:       speex-devel >= 1:1.2-rc1
212 Requires:       twolame-devel
213 %{?with_utvideo:Requires:       utvideo-devel >= 12}
214 Requires:       vo-aacenc-devel
215 Requires:       vo-amrwbenc-devel
216 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
217 Requires:       xavs-devel
218 Requires:       xorg-lib-libXext-devel
219 Requires:       xorg-lib-libXfixes-devel
220 Requires:       xvid-devel >= 1:1.1.0
221 Requires:       zlib-devel
222 Obsoletes:      libpostproc-devel
223
224 %description devel
225 ffmpeg header files.
226
227 %description devel -l pl.UTF-8
228 Pliki nagłówkowe ffmpeg.
229
230 %package static
231 Summary:        ffmpeg static libraries
232 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
233 Group:          Development/Libraries
234 Requires:       %{name}-devel = %{version}-%{release}
235
236 %description static
237 ffmpeg static libraries (libavcodec and libavformat).
238
239 %description static -l pl.UTF-8
240 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
241
242 %package ffplay
243 Summary:        FFplay - SDL-based media player
244 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
245 Group:          Applications/Multimedia
246 Requires:       %{name}-libs = %{version}-%{release}
247
248 %description ffplay
249 FFplay is a very simple and portable media player using the FFmpeg
250 libraries and the SDL library. It is mostly used as a test bench for
251 the various APIs of FFmpeg.
252
253 %description ffplay -l pl.UTF-8
254 FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
255 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
256 testowania różnych API FFmpeg.
257
258 %package ffserver
259 Summary:        FFserver video server
260 Summary(pl.UTF-8):      FFserver - serwer strumieni obrazu
261 Group:          Daemons
262 Requires(post,preun):   /sbin/chkconfig
263 Requires:       %{name}-libs = %{version}-%{release}
264 Requires:       rc-scripts >= 0.4.0.10
265
266 %description ffserver
267 FFserver is a streaming server for both audio and video. It supports
268 several live feeds, streaming from files and time shifting on live
269 feeds (you can seek to positions in the past on each live feed,
270 provided you specify a big enough feed storage in ffserver.conf).
271
272 %description ffserver -l pl.UTF-8
273 FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
274 źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
275 czasie dla źródeł na żywo (można przeskakiwać na położenia w
276 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
277 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
278
279 %prep
280 %setup -q
281 %patch0 -p1
282 %patch1 -p1
283
284 # package the grep result for mplayer, the result formatted as ./mplayer/configure
285 cat <<EOF > ffmpeg-avconfig
286 #! /bin/sh
287 _libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
288 _libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
289 _libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
290 _libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
291 _libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
292 _libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
293 _libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
294 EOF
295 cat <<'EOF' >> ffmpeg-avconfig
296
297 case "$1" in
298 --decoders)
299         echo $_libavdecoders_all
300         ;;
301 --encoders)
302         echo $_libavencoders_all
303         ;;
304 --parsers)
305         echo $_libavparsers_all
306         ;;
307 --bsfs)
308         echo $_libavbsfs_all
309         ;;
310 --demuxers)
311         echo $_libavdemuxers_all
312         ;;
313 --muxers)
314         echo $_libavmuxers_all
315         ;;
316 --protocols)
317         echo $_libavprotocols_all
318         ;;
319 *)
320         cat <<USAGE
321 Usage: $0 [OPTION]
322 Options:
323   --decoders
324   --encoders
325   --parsers
326   --bsfs
327   --demuxers
328   --muxers
329   --protocols
330 USAGE
331         exit 1;;
332 esac
333
334 exit 0
335 EOF
336
337 %build
338 # notes:
339 # - it's not autoconf configure
340 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
341 ./configure \
342         --arch=%{_target_base_arch} \
343         --prefix=%{_prefix} \
344         --libdir=%{_libdir} \
345         --shlibdir=%{_libdir} \
346         --mandir=%{_mandir} \
347         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
348         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
349         --cc="%{__cc}" \
350         --disable-debug \
351         --disable-optimizations \
352         --disable-stripping \
353         --enable-avfilter \
354         --enable-avresample \
355         --enable-gnutls \
356         --enable-gpl \
357         --enable-version3 \
358         --enable-fontconfig \
359         %{?with_frei0r:--enable-frei0r} \
360         %{?with_aacplus:--enable-libaacplus} \
361         --enable-libass \
362         --enable-libbluray \
363         %{?with_caca:--enable-libcaca} \
364         --enable-libcelt \
365         --enable-libcdio \
366         --enable-libdc1394 \
367         %{?with_fdk_aac:--enable-libfdk-aac} \
368         %{?with_flite:--enable-libflite} \
369         --enable-libfreetype \
370         --enable-libgsm \
371         --enable-libiec61883 \
372         %{?with_ilbc:--enable-libilbc} \
373         --enable-libmodplug \
374         --enable-libmp3lame \
375         --enable-libnut \
376         --enable-libopencore-amrnb \
377         --enable-libopencore-amrwb \
378         %{?with_opencv:--enable-libopencv} \
379         --enable-libopenjpeg \
380         --enable-libopus \
381         %{?with_pulseaudio:--enable-libpulse} \
382         --enable-librtmp \
383         --enable-libschroedinger \
384         %{?with_soxr:--enable-libsoxr} \
385         --enable-libspeex \
386         --enable-libtheora \
387         --enable-libtwolame \
388         %{?with_utvideo:--enable-libutvideo} \
389         --enable-libv4l2 \
390         --enable-libvo-aacenc \
391         --enable-libvo-amrwbenc \
392         --enable-libvorbis \
393         %{?with_vpx:--enable-libvpx} \
394         %{?with_x264:--enable-libx264} \
395         --enable-libxavs \
396         --enable-libxvid \
397         %{?with_openal:--enable-openal} \
398         --enable-postproc \
399         --enable-pthreads \
400         --enable-shared \
401         --enable-swscale \
402         %{?with_va:--enable-vaapi} \
403         --enable-vdpau \
404         --enable-x11grab \
405 %ifnarch %{ix86} %{x8664}
406         --disable-mmx \
407 %endif
408 %ifarch i386 i486
409         --disable-mmx \
410 %endif
411 %if %{with nonfree}
412         --enable-nonfree \
413         --enable-libfaac \
414 %endif
415         --enable-runtime-cpudetect
416
417 # force oldscaler build
418 %{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
419
420 %{__make} \
421         V=1
422
423 # CC_O to add -c to commandline. makefile should be patched
424 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
425
426 %install
427 rm -rf $RPM_BUILD_ROOT
428 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
429         $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
430         $RPM_BUILD_ROOT/var/{cache,log}/ffserver
431
432 %{__make} install install-headers \
433         DESTDIR=$RPM_BUILD_ROOT \
434         V=1
435
436 # install nonstandard, non-public headers manually
437 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
438 for a in libavutil/*/bswap.h; do
439         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
440 done
441 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
442 # for lim-omx ffmpeg components
443 cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
444
445 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
446 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
447 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
448 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
449 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
450
451 # install as ffmpeg-avconfig to avoid with possible programs looking for
452 # ffmpeg-config and expecting --libs output from it which is not implemented
453 # simple to do (by querying pkgconfig), but why?
454 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
455
456 # fix man page
457 %if %{with doc}
458 install -d $RPM_BUILD_ROOT%{_mandir}/man3
459 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/lib*.3 $RPM_BUILD_ROOT%{_mandir}/man3
460 %endif
461
462 %clean
463 rm -rf $RPM_BUILD_ROOT
464
465 %post   libs -p /sbin/ldconfig
466 %postun libs -p /sbin/ldconfig
467
468 %pre ffserver
469 %groupadd -g 167 ffserver
470 %useradd -g ffserver -u 167 ffserver
471
472 %post ffserver
473 /sbin/chkconfig --add ffserver
474 %service ffserver restart
475
476 %preun ffserver
477 if [ "$1" = 0 ]; then
478         %service ffserver stop
479         /sbin/chkconfig --del ffserver
480 fi
481
482 %postun ffserver
483 if [ "$1" = 0 ]; then
484         %userremove ffserver
485         %groupremove ffserver
486 fi
487
488 %files
489 %defattr(644,root,root,755)
490 %doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
491 %attr(755,root,root) %{_bindir}/ffmpeg
492 %attr(755,root,root) %{_bindir}/ffprobe
493 %attr(755,root,root) %{_bindir}/qt-faststart
494 %dir %{_datadir}/ffmpeg
495 %{_datadir}/ffmpeg/*.ffpreset
496 %{_datadir}/ffmpeg/ffprobe.xsd
497 %if %{with doc}
498 %{_mandir}/man1/ffmpeg.1*
499 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
500 %{_mandir}/man1/ffmpeg-codecs.1*
501 %{_mandir}/man1/ffmpeg-devices.1*
502 %{_mandir}/man1/ffmpeg-filters.1*
503 %{_mandir}/man1/ffmpeg-formats.1*
504 %{_mandir}/man1/ffmpeg-protocols.1*
505 %{_mandir}/man1/ffmpeg-resampler.1*
506 %{_mandir}/man1/ffmpeg-scaler.1*
507 %{_mandir}/man1/ffmpeg-utils.1*
508 %{_mandir}/man1/ffprobe.1*
509 %endif
510
511 %files libs
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
514 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.54
515 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
516 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.54
517 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
518 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
519 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
520 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.54
521 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
522 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.1
523 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
524 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.52
525 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
526 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
527 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
528 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
529 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
530 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
531
532 %files devel
533 %defattr(644,root,root,755)
534 %doc doc/optimization.txt
535 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
536 %attr(755,root,root) %{_libdir}/libavcodec.so
537 %attr(755,root,root) %{_libdir}/libavdevice.so
538 %attr(755,root,root) %{_libdir}/libavfilter.so
539 %attr(755,root,root) %{_libdir}/libavformat.so
540 %attr(755,root,root) %{_libdir}/libavresample.so
541 %attr(755,root,root) %{_libdir}/libavutil.so
542 %attr(755,root,root) %{_libdir}/libpostproc.so
543 %attr(755,root,root) %{_libdir}/libswresample.so
544 %attr(755,root,root) %{_libdir}/libswscale.so
545 %{_includedir}/ffmpeg
546 %{_includedir}/libavcodec
547 %{_includedir}/libavdevice
548 %{_includedir}/libavfilter
549 %{_includedir}/libavformat
550 %{_includedir}/libavresample
551 %{_includedir}/libavutil
552 %{_includedir}/libpostproc
553 %{_includedir}/libswresample
554 %{_includedir}/libswscale
555 %{_pkgconfigdir}/libavcodec.pc
556 %{_pkgconfigdir}/libavdevice.pc
557 %{_pkgconfigdir}/libavfilter.pc
558 %{_pkgconfigdir}/libavformat.pc
559 %{_pkgconfigdir}/libavresample.pc
560 %{_pkgconfigdir}/libavutil.pc
561 %{_pkgconfigdir}/libpostproc.pc
562 %{_pkgconfigdir}/libswresample.pc
563 %{_pkgconfigdir}/libswscale.pc
564 %if %{with doc}
565 %{_mandir}/man3/libavcodec.3*
566 %{_mandir}/man3/libavdevice.3*
567 %{_mandir}/man3/libavfilter.3*
568 %{_mandir}/man3/libavformat.3*
569 %{_mandir}/man3/libavutil.3*
570 %{_mandir}/man3/libswresample.3*
571 %{_mandir}/man3/libswscale.3*
572 %endif
573
574 %files static
575 %defattr(644,root,root,755)
576 %{_libdir}/libavcodec.a
577 %{_libdir}/libavdevice.a
578 %{_libdir}/libavfilter.a
579 %{_libdir}/libavformat.a
580 %{_libdir}/libavresample.a
581 %{_libdir}/libavutil.a
582 %{_libdir}/libpostproc.a
583 %{_libdir}/libswresample.a
584 %{_libdir}/libswscale.a
585
586 %files ffplay
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_bindir}/ffplay
589 %{?with_doc:%{_mandir}/man1/ffplay.1*}
590
591 %files ffserver
592 %defattr(644,root,root,755)
593 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
594 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
595 %attr(755,root,root) %{_sbindir}/ffserver
596 %attr(754,root,root) /etc/rc.d/init.d/ffserver
597 %{?with_doc:%{_mandir}/man1/ffserver.1*}
598 %dir %attr(770,root,ffserver) /var/cache/ffserver
599 %dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.090823 seconds and 4 git commands to generate.