]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
move html docs to -doc subpackage
[packages/ffmpeg.git] / ffmpeg.spec
1 # TODO: libzmq ?
2 #
3 # How to deal with ffmpeg/opencv checken-egg problem:
4 #       1. make-request -r --without opencv ffmpeg.spec
5 #       2. make-request -r opencv.spec
6 #       3. bump release of ffmpeg.spec
7 #       4. make-request -r ffmpeg.spec
8 #
9 # Conditional build:
10 %bcond_with     nonfree         # non free options of package (currently: faac)
11 %bcond_with     aacplus         # AAC+ encoding via libaacplus (requires nonfree)
12 %bcond_with     fdk_aac         # AAC encoding via libfdk_aac (requires nonfree)
13 %bcond_without  caca            # textual display using libcaca
14 %bcond_without  flite           # flite voice synthesis support
15 %bcond_without  frei0r          # frei0r video filtering
16 %bcond_without  gme             # Game Music Emu support
17 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
18 %bcond_without  openal          # OpenAL 1.1 capture support
19 %bcond_with     opencl          # OpenCL code [OpenCL 1.2, but Mesa 9.1.x headers don't suffice]
20 %bcond_without  opencv          # OpenCV video filtering
21 %bcond_without  pulseaudio      # PulseAudio input support
22 %bcond_without  quvi            # quvi input support
23 %bcond_without  shine           # shine fixed-point MP3 encoder
24 %bcond_without  soxr            # SoX Resampler support
25 %bcond_without  x264            # x264 encoder
26 %bcond_without  utvideo         # Ut Video decoder
27 %bcond_without  va              # VAAPI (Video Acceleration API)
28 %bcond_without  vidstab         # vid.stab video stabilization support
29 %bcond_without  vpx             # VP8, a high-quality video codec
30 %bcond_without  wavpack         # wavpack encoding support
31 %bcond_without  zmq             # 0MQ message passing
32 %bcond_without  doc             # don't build docs
33
34 Summary:        FFmpeg - a very fast video and audio converter
35 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
36 Name:           ffmpeg
37 Version:        2.0.1
38 Release:        2
39 # LGPL or GPL, chosen at configure time (GPL version is more featured)
40 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
41 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
42 License:        GPL v3+ with LGPL v3+ parts
43 Group:          Applications/Multimedia
44 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
45 # Source0-md5:  dd71a1baedb2daa3e4d21e0651daa918
46 Source1:        ffserver.init
47 Source2:        ffserver.sysconfig
48 Source3:        ffserver.conf
49 Patch0:         %{name}-opencv24.patch
50 URL:            http://www.ffmpeg.org/
51 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
52 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.2}
53 BuildRequires:  SDL-devel >= 1.2.1
54 BuildRequires:  alsa-lib-devel
55 BuildRequires:  bzip2-devel
56 BuildRequires:  celt-devel >= 0.11.0
57 %{?with_nonfree:BuildRequires:  faac-devel}
58 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
59 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
60 BuildRequires:  fontconfig-devel
61 BuildRequires:  freetype-devel
62 %{?with_frei0r:BuildRequires:   frei0r-devel}
63 %{?with_gme:BuildRequires:      game-music-emu-devel}
64 %ifarch ppc
65 # require version with altivec support fixed
66 BuildRequires:  gcc >= 5:3.3.2-3
67 %endif
68 BuildRequires:  gnutls-devel
69 BuildRequires:  jack-audio-connection-kit-devel
70 BuildRequires:  lame-libs-devel >= 3.98.3
71 %{?with_aacplus:BuildRequires:  libaacplus-devel >= 2.0.0}
72 BuildRequires:  libass-devel
73 BuildRequires:  libavc1394-devel
74 BuildRequires:  libbluray-devel
75 %{?with_caca:BuildRequires:     libcaca-devel}
76 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
77 BuildRequires:  libdc1394-devel >= 2
78 BuildRequires:  libgsm-devel
79 BuildRequires:  libiec61883-devel
80 BuildRequires:  libmodplug-devel
81 BuildRequires:  libnut-devel
82 %{?with_quvi:BuildRequires:     libquvi-devel}
83 BuildRequires:  libraw1394-devel >= 2
84 BuildRequires:  librtmp-devel
85 BuildRequires:  libtheora-devel >= 1.0-0.beta3
86 BuildRequires:  libtool >= 2:1.4d-3
87 BuildRequires:  libv4l-devel
88 %{?with_va:BuildRequires:       libva-devel >= 1.0.3}
89 BuildRequires:  libvdpau-devel >= 0.2
90 BuildRequires:  libvorbis-devel
91 %{?with_vpx:BuildRequires:      libvpx-devel >= 0.9.7}
92 %{?with_shine:BuildRequires:    shine-devel}
93 # X264_BUILD >= 118
94 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
95 %ifarch %{ix86}
96 %ifnarch i386 i486
97 BuildRequires:  nasm
98 %endif
99 %endif
100 BuildRequires:  opencore-amr-devel
101 %{?with_opencv:BuildRequires:   opencv-devel}
102 BuildRequires:  openjpeg-devel >= 1.5
103 BuildRequires:  opus-devel
104 BuildRequires:  perl-Encode
105 BuildRequires:  perl-tools-pod
106 BuildRequires:  pkgconfig
107 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
108 BuildRequires:  rpmbuild(macros) >= 1.470
109 BuildRequires:  schroedinger-devel
110 %{?with_soxr:BuildRequires:     soxr-devel}
111 BuildRequires:  speex-devel >= 1:1.2-rc1
112 %{?with_doc:BuildRequires:      tetex}
113 %{?with_doc:BuildRequires:      texi2html}
114 %{?with_doc:BuildRequires:      texinfo}
115 BuildRequires:  twolame-devel
116 %{?with_utvideo:BuildRequires:  utvideo-devel >= 12}
117 %{?with_vidstab:BuildRequires:  vid.stab-devel}
118 BuildRequires:  vo-aacenc-devel
119 BuildRequires:  vo-amrwbenc-devel
120 %{?with_wavpack:BuildRequires:  wavpack-devel}
121 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
122 BuildRequires:  xavs-devel
123 BuildRequires:  xorg-lib-libX11-devel
124 BuildRequires:  xorg-lib-libXext-devel
125 BuildRequires:  xorg-lib-libXfixes-devel
126 BuildRequires:  xvid-devel >= 1:1.1.0
127 BuildRequires:  yasm
128 %{?with_zmq:BuildRequires:      zeromq-devel}
129 BuildRequires:  zlib-devel
130 %{?with_autoreqdep:BuildConflicts:      libpostproc}
131 # overflows maximum hash table size
132 BuildConflicts: pdksh < 5.2.14-57
133 Requires:       %{name}-libs = %{version}-%{release}
134 %{?with_utvideo:Requires:       utvideo >= 12}
135 %{?with_ilbc:Requires:  webrtc-libilbc}
136 Requires:       xvid >= 1:1.1.0
137 Obsoletes:      libpostproc
138 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
139
140 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
141
142 %define         specflags       -fno-strict-aliasing
143
144 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
145 %define         specflags_ia32  -fomit-frame-pointer
146 # -mmmx is needed to enable <mmintrin.h> code.
147 %define         specflags_i586  -mmmx
148 %define         specflags_i686  -mmmx
149 %define         specflags_ppc   -fPIC
150
151 %description
152 FFmpeg is a complete solution to record, convert and stream audio and
153 video. It is a command line tool to convert one video file format to
154 another. It also supports grabbing and encoding in real time from a TV
155 card.
156
157 %description -l pl.UTF-8
158 FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
159 strumieni dźwięku i obrazu. Jest to działające z linii poleceń
160 narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
161 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
162 telewizyjnej.
163
164 %package libs
165 Summary:        ffmpeg libraries
166 Summary(pl.UTF-8):      Biblioteki ffmpeg
167 Group:          Libraries
168
169 %description libs
170 This package contains the ffmpeg shared libraries:
171 - the codec library (libavcodec). It supports most existing encoding
172   formats (MPEG, DivX, MPEG4, AC3, DV...),
173 - demuxer library (libavformat). It supports most existing file
174   formats (AVI, MPEG, OGG, Matroska, ASF...),
175 - video postprocessing library (libpostproc).
176
177 %description libs -l pl.UTF-8
178 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
179 - bibliotekę kodeków (libavcodec); obsługuje większość istniejących
180   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
181 - bibliotekę demuksera (libavformat); obsługuje większość istniejących
182   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
183 - bibliotekę postprocessingu (libpostproc).
184
185 %package devel
186 Summary:        ffmpeg header files
187 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
188 Group:          Development/Libraries
189 Requires:       %{name}-libs = %{version}-%{release}
190 # Libs.private from *.pc (unreasonably they are all the same)
191 %{?with_opencl:Requires:        OpenCL-devel >= 1.2}
192 Requires:       SDL-devel >= 1.2.1
193 Requires:       alsa-lib-devel
194 Requires:       bzip2-devel
195 Requires:       celt-devel >= 0.11.0
196 %{?with_nonfree:Requires:       faac-devel}
197 %{?with_fdk_aac:Requires:       fdk-aac-devel}
198 %{?with_flite:Requires: flite-devel >= 1.4}
199 Requires:       fontconfig-devel
200 Requires:       freetype-devel
201 %{?with_gme:Requires:   game-music-emu-devel}
202 Requires:       jack-audio-connection-kit-devel
203 Requires:       lame-libs-devel >= 3.98.3
204 %{?with_aacplus:Requires:       libaacplus-devel >= 2.0.0}
205 Requires:       libass-devel
206 Requires:       libavc1394-devel
207 Requires:       libbluray-devel
208 %{?with_caca:Requires:  libcaca-devel}
209 Requires:       libcdio-paranoia-devel >= 0.90-2
210 Requires:       libdc1394-devel >= 2
211 Requires:       libgsm-devel
212 Requires:       libiec61883-devel
213 Requires:       libmodplug-devel
214 Requires:       libnut-devel
215 %{?with_quvi:Requires:  libquvi-devel}
216 Requires:       libraw1394-devel >= 2
217 Requires:       librtmp-devel
218 Requires:       libtheora-devel >= 1.0-0.beta3
219 %{?with_va:Requires:    libva-devel >= 1.0.3}
220 Requires:       libvorbis-devel
221 %{?with_vpx:Requires:   libvpx-devel >= 0.9.7}
222 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
223 Requires:       opencore-amr-devel
224 %{?with_opencv:Requires:        opencv-devel}
225 Requires:       openjpeg-devel >= 1.5
226 Requires:       schroedinger-devel
227 %{?with_shine:Requires: shine-devel}
228 %{?with_soxr:Requires:  soxr-devel}
229 Requires:       speex-devel >= 1:1.2-rc1
230 Requires:       twolame-devel
231 %{?with_utvideo:Requires:       utvideo-devel >= 12}
232 %{?with_vidstab:Requires:       vid.stab-devel}
233 Requires:       vo-aacenc-devel
234 Requires:       vo-amrwbenc-devel
235 %{?with_wavpack:Requires:       wavpack-devel}
236 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
237 Requires:       xavs-devel
238 Requires:       xorg-lib-libXext-devel
239 Requires:       xorg-lib-libXfixes-devel
240 Requires:       xvid-devel >= 1:1.1.0
241 %{?with_zmq:Requires:   zeromq-devel}
242 Requires:       zlib-devel
243 Obsoletes:      libpostproc-devel
244
245 %description devel
246 ffmpeg header files.
247
248 %description devel -l pl.UTF-8
249 Pliki nagłówkowe ffmpeg.
250
251 %package static
252 Summary:        ffmpeg static libraries
253 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
254 Group:          Development/Libraries
255 Requires:       %{name}-devel = %{version}-%{release}
256
257 %description static
258 ffmpeg static libraries (libavcodec and libavformat).
259
260 %description static -l pl.UTF-8
261 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
262
263 %package ffplay
264 Summary:        FFplay - SDL-based media player
265 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
266 Group:          Applications/Multimedia
267 Requires:       %{name}-libs = %{version}-%{release}
268
269 %description ffplay
270 FFplay is a very simple and portable media player using the FFmpeg
271 libraries and the SDL library. It is mostly used as a test bench for
272 the various APIs of FFmpeg.
273
274 %description ffplay -l pl.UTF-8
275 FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
276 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
277 testowania różnych API FFmpeg.
278
279 %package ffserver
280 Summary:        FFserver video server
281 Summary(pl.UTF-8):      FFserver - serwer strumieni obrazu
282 Group:          Daemons
283 Requires(post,preun):   /sbin/chkconfig
284 Requires:       %{name}-libs = %{version}-%{release}
285 Requires:       rc-scripts >= 0.4.0.10
286
287 %description ffserver
288 FFserver is a streaming server for both audio and video. It supports
289 several live feeds, streaming from files and time shifting on live
290 feeds (you can seek to positions in the past on each live feed,
291 provided you specify a big enough feed storage in ffserver.conf).
292
293 %description ffserver -l pl.UTF-8
294 FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
295 źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
296 czasie dla źródeł na żywo (można przeskakiwać na położenia w
297 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
298 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
299
300 %package doc
301 Summary:        Manual for ffmpeg
302 Summary(fr.UTF-8):      Documentation pour ffmpeg
303 Summary(it.UTF-8):      Documentazione di ffmpeg
304 Summary(pl.UTF-8):      Podręcznik dla ffmpeg
305 Group:          Documentation
306 %if "%{_rpmversion}" >= "5"
307 BuildArch:      noarch
308 %endif
309
310 %description doc
311 Documentation for ffmpeg.
312
313 %description doc -l fr.UTF-8
314 Documentation pour ffmpeg.
315
316 %description doc -l it.UTF-8
317 Documentazione di ffmpeg.
318
319 %description doc -l pl.UTF-8
320 Dokumentacja do ffmpeg.
321
322 %prep
323 %setup -q
324 %patch0 -p1
325
326 # package the grep result for mplayer, the result formatted as ./mplayer/configure
327 cat <<EOF > ffmpeg-avconfig
328 #! /bin/sh
329 libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
330 libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
331 libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
332 libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
333 libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
334 libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
335 libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
336 libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
337 libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
338 EOF
339 cat <<'EOF' >> ffmpeg-avconfig
340
341 case "$1" in
342 --decoders)
343         echo $libavdecoders_all
344         ;;
345 --encoders)
346         echo $libavencoders_all
347         ;;
348 --parsers)
349         echo $libavparsers_all
350         ;;
351 --bsfs)
352         echo $libavbsfs_all
353         ;;
354 --demuxers)
355         echo $libavdemuxers_all
356         ;;
357 --muxers)
358         echo $libavmuxers_all
359         ;;
360 --protocols)
361         echo $libavprotocols_all
362         ;;
363 --hwaccels)
364         echo $libavhwaccels_all
365         ;;
366 --filters)
367         echo $libavfilters_all
368         ;;
369 *)
370         cat <<USAGE
371 Usage: $0 [OPTION]
372 Options:
373   --decoders
374   --encoders
375   --parsers
376   --bsfs
377   --demuxers
378   --muxers
379   --protocols
380   --hwaccels
381   --filters
382 USAGE
383         exit 1;;
384 esac
385
386 exit 0
387 EOF
388
389 %build
390 # notes:
391 # - it's not autoconf configure
392 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
393 ./configure \
394         --arch=%{_target_base_arch} \
395         --prefix=%{_prefix} \
396         --libdir=%{_libdir} \
397         --shlibdir=%{_libdir} \
398         --mandir=%{_mandir} \
399         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
400         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
401         --cc="%{__cc}" \
402         --disable-debug \
403         --disable-optimizations \
404         --disable-stripping \
405         --enable-avfilter \
406         --enable-avresample \
407         --enable-gnutls \
408         --enable-gpl \
409         --enable-version3 \
410         --enable-fontconfig \
411         %{?with_frei0r:--enable-frei0r} \
412         %{?with_aacplus:--enable-libaacplus} \
413         --enable-libass \
414         --enable-libbluray \
415         %{?with_caca:--enable-libcaca} \
416         --enable-libcelt \
417         --enable-libcdio \
418         --enable-libdc1394 \
419         %{?with_fdk_aac:--enable-libfdk-aac} \
420         %{?with_flite:--enable-libflite} \
421         --enable-libfreetype \
422         %{?with_gme:--enable-libgme} \
423         --enable-libgsm \
424         --enable-libiec61883 \
425         %{?with_ilbc:--enable-libilbc} \
426         --enable-libmodplug \
427         --enable-libmp3lame \
428         --enable-libnut \
429         --enable-libopencore-amrnb \
430         --enable-libopencore-amrwb \
431         %{?with_opencv:--enable-libopencv} \
432         --enable-libopenjpeg \
433         --enable-libopus \
434         %{?with_pulseaudio:--enable-libpulse} \
435         %{?with_quvi:--enable-libquvi} \
436         --enable-librtmp \
437         --enable-libschroedinger \
438         %{?with_shine:--enable-libshine} \
439         %{?with_soxr:--enable-libsoxr} \
440         --enable-libspeex \
441         --enable-libtheora \
442         --enable-libtwolame \
443         %{?with_utvideo:--enable-libutvideo} \
444         --enable-libv4l2 \
445         %{?with_vidstab:--enable-libvidstab} \
446         --enable-libvo-aacenc \
447         --enable-libvo-amrwbenc \
448         --enable-libvorbis \
449         %{?with_vpx:--enable-libvpx} \
450         %{?with_wavpack:--enable-libwavpack} \
451         %{?with_x264:--enable-libx264} \
452         --enable-libxavs \
453         --enable-libxvid \
454         %{?with_zmq:--enable-libzmq} \
455         %{?with_openal:--enable-openal} \
456         %{?with_opencl:--enable-opencl} \
457         --enable-postproc \
458         --enable-pthreads \
459         --enable-shared \
460         --enable-swscale \
461         %{!?with_va:--disable-vaapi} \
462         --enable-x11grab \
463 %ifnarch %{ix86} %{x8664}
464         --disable-mmx \
465 %endif
466 %ifarch i386 i486
467         --disable-mmx \
468 %endif
469 %if %{with nonfree}
470         --enable-nonfree \
471         --enable-libfaac \
472 %endif
473         --enable-runtime-cpudetect
474
475 # force oldscaler build
476 %{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
477
478 %{__make} \
479         V=1
480
481 # CC_O to add -c to commandline. makefile should be patched
482 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
483
484 %install
485 rm -rf $RPM_BUILD_ROOT
486 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
487         $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
488         $RPM_BUILD_ROOT/var/{cache,log}/ffserver
489
490 %{__make} install install-headers \
491         DESTDIR=$RPM_BUILD_ROOT \
492         V=1
493
494 # install nonstandard, non-public headers manually
495 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
496 for a in libavutil/*/bswap.h; do
497         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
498 done
499 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
500 # for lim-omx ffmpeg components
501 cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
502
503 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
504 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
505 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
506 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
507 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
508
509 # install as ffmpeg-avconfig to avoid with possible programs looking for
510 # ffmpeg-config and expecting --libs output from it which is not implemented
511 # simple to do (by querying pkgconfig), but why?
512 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
513
514 %clean
515 rm -rf $RPM_BUILD_ROOT
516
517 %post   libs -p /sbin/ldconfig
518 %postun libs -p /sbin/ldconfig
519
520 %pre ffserver
521 %groupadd -g 167 ffserver
522 %useradd -g ffserver -u 167 ffserver
523
524 %post ffserver
525 /sbin/chkconfig --add ffserver
526 %service ffserver restart
527
528 %preun ffserver
529 if [ "$1" = 0 ]; then
530         %service ffserver stop
531         /sbin/chkconfig --del ffserver
532 fi
533
534 %postun ffserver
535 if [ "$1" = 0 ]; then
536         %userremove ffserver
537         %groupremove ffserver
538 fi
539
540 %files
541 %defattr(644,root,root,755)
542 %doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES}
543 %attr(755,root,root) %{_bindir}/ffmpeg
544 %attr(755,root,root) %{_bindir}/ffprobe
545 %attr(755,root,root) %{_bindir}/qt-faststart
546 %dir %{_datadir}/ffmpeg
547 %{_datadir}/ffmpeg/*.ffpreset
548 %{_datadir}/ffmpeg/ffprobe.xsd
549 %if %{with doc}
550 %{_mandir}/man1/ffmpeg.1*
551 %{_mandir}/man1/ffmpeg-all.1*
552 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
553 %{_mandir}/man1/ffmpeg-codecs.1*
554 %{_mandir}/man1/ffmpeg-devices.1*
555 %{_mandir}/man1/ffmpeg-filters.1*
556 %{_mandir}/man1/ffmpeg-formats.1*
557 %{_mandir}/man1/ffmpeg-protocols.1*
558 %{_mandir}/man1/ffmpeg-resampler.1*
559 %{_mandir}/man1/ffmpeg-scaler.1*
560 %{_mandir}/man1/ffmpeg-utils.1*
561 %{_mandir}/man1/ffprobe.1*
562 %{_mandir}/man1/ffprobe-all.1*
563 %endif
564
565 %files libs
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
568 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.55
569 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
570 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.55
571 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
572 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
573 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
574 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.55
575 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
576 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.1
577 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
578 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.52
579 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
580 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
581 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
582 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
583 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
584 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
585
586 %files devel
587 %defattr(644,root,root,755)
588 %doc doc/optimization.txt
589 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
590 %attr(755,root,root) %{_libdir}/libavcodec.so
591 %attr(755,root,root) %{_libdir}/libavdevice.so
592 %attr(755,root,root) %{_libdir}/libavfilter.so
593 %attr(755,root,root) %{_libdir}/libavformat.so
594 %attr(755,root,root) %{_libdir}/libavresample.so
595 %attr(755,root,root) %{_libdir}/libavutil.so
596 %attr(755,root,root) %{_libdir}/libpostproc.so
597 %attr(755,root,root) %{_libdir}/libswresample.so
598 %attr(755,root,root) %{_libdir}/libswscale.so
599 %{_includedir}/ffmpeg
600 %{_includedir}/libavcodec
601 %{_includedir}/libavdevice
602 %{_includedir}/libavfilter
603 %{_includedir}/libavformat
604 %{_includedir}/libavresample
605 %{_includedir}/libavutil
606 %{_includedir}/libpostproc
607 %{_includedir}/libswresample
608 %{_includedir}/libswscale
609 %{_pkgconfigdir}/libavcodec.pc
610 %{_pkgconfigdir}/libavdevice.pc
611 %{_pkgconfigdir}/libavfilter.pc
612 %{_pkgconfigdir}/libavformat.pc
613 %{_pkgconfigdir}/libavresample.pc
614 %{_pkgconfigdir}/libavutil.pc
615 %{_pkgconfigdir}/libpostproc.pc
616 %{_pkgconfigdir}/libswresample.pc
617 %{_pkgconfigdir}/libswscale.pc
618 %if %{with doc}
619 %{_mandir}/man3/libavcodec.3*
620 %{_mandir}/man3/libavdevice.3*
621 %{_mandir}/man3/libavfilter.3*
622 %{_mandir}/man3/libavformat.3*
623 %{_mandir}/man3/libavutil.3*
624 %{_mandir}/man3/libswresample.3*
625 %{_mandir}/man3/libswscale.3*
626 %endif
627
628 %files static
629 %defattr(644,root,root,755)
630 %{_libdir}/libavcodec.a
631 %{_libdir}/libavdevice.a
632 %{_libdir}/libavfilter.a
633 %{_libdir}/libavformat.a
634 %{_libdir}/libavresample.a
635 %{_libdir}/libavutil.a
636 %{_libdir}/libpostproc.a
637 %{_libdir}/libswresample.a
638 %{_libdir}/libswscale.a
639
640 %files ffplay
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_bindir}/ffplay
643 %if %{with doc}
644 %{_mandir}/man1/ffplay.1*
645 %{_mandir}/man1/ffplay-all.1*
646 %endif
647
648 %files ffserver
649 %defattr(644,root,root,755)
650 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
651 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
652 %attr(755,root,root) %{_sbindir}/ffserver
653 %attr(754,root,root) /etc/rc.d/init.d/ffserver
654 %if %{with doc}
655 %{_mandir}/man1/ffserver.1*
656 %{_mandir}/man1/ffserver-all.1*
657 %endif
658 %dir %attr(770,root,ffserver) /var/cache/ffserver
659 %dir %attr(770,root,ffserver) /var/log/ffserver
660
661 %if %{with doc}
662 %files doc
663 %defattr(644,root,root,755)
664 %doc doc/*.html
665 %endif
This page took 0.091718 seconds and 4 git commands to generate.