]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- started update to 2.0 (note: new sonames; ffmpeg 1.2.x left on ffmpeg-1.2 branch)
[packages/ffmpeg.git] / ffmpeg.spec
1 # TODO: libshine, libvidstab, libzmq, opencl ?
2 #
3 # How to deal with ffmpeg/opencv checken-egg problem:
4 #       1. make-request -r --without opencv ffmpeg.spec
5 #       2. make-request -r opencv.spec
6 #       3. bump release of ffmpeg.spec
7 #       4. make-request -r ffmpeg.spec
8 #
9 # Conditional build:
10 %bcond_with     nonfree         # non free options of package (currently: faac)
11 %bcond_with     aacplus         # AAC+ encoding via libaacplus (requires nonfree)
12 %bcond_with     fdk_aac         # AAC encoding via libfdk_aac (requires nonfree)
13 %bcond_without  caca            # textual display using libcaca
14 %bcond_without  flite           # flite voice synthesis support
15 %bcond_without  frei0r          # frei0r video filtering
16 %bcond_without  gme             # Game Music Emu support
17 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
18 %bcond_without  openal          # OpenAL 1.1 capture support
19 %bcond_without  opencv          # OpenCV video filtering
20 %bcond_without  pulseaudio      # PulseAudio input support
21 %bcond_without  quvi            # quvi input support
22 %bcond_without  soxr            # SoX Resampler support
23 %bcond_without  x264            # x264 encoder
24 %bcond_without  utvideo         # Ut Video decoder
25 %bcond_without  va              # VAAPI (Video Acceleration API)
26 %bcond_without  vpx             # VP8, a high-quality video codec
27 %bcond_without  wavpack         # wavpack encoding support
28 %bcond_without  doc             # don't build docs
29
30 Summary:        FFmpeg - a very fast video and audio converter
31 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
32 Name:           ffmpeg
33 Version:        2.0
34 Release:        1
35 # LGPL or GPL, chosen at configure time (GPL version is more featured)
36 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
37 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
38 License:        GPL v3+ with LGPL v3+ parts
39 Group:          Applications/Multimedia
40 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
41 # Source0-md5:  13a0feb74474f89052f6b8ba1bce46be
42 Source1:        ffserver.init
43 Source2:        ffserver.sysconfig
44 Source3:        ffserver.conf
45 Patch0:         %{name}-opencv24.patch
46 URL:            http://www.ffmpeg.org/
47 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
48 BuildRequires:  SDL-devel >= 1.2.1
49 BuildRequires:  alsa-lib-devel
50 BuildRequires:  bzip2-devel
51 BuildRequires:  celt-devel >= 0.11.0
52 %{?with_nonfree:BuildRequires:  faac-devel}
53 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
54 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
55 BuildRequires:  fontconfig-devel
56 BuildRequires:  freetype-devel
57 %{?with_frei0r:BuildRequires:   frei0r-devel}
58 %{?with_gme:BuildRequires:      game-music-emu-devel}
59 %ifarch ppc
60 # require version with altivec support fixed
61 BuildRequires:  gcc >= 5:3.3.2-3
62 %endif
63 BuildRequires:  gnutls-devel
64 BuildRequires:  jack-audio-connection-kit-devel
65 BuildRequires:  lame-libs-devel >= 3.98.3
66 %{?with_aacplus:BuildRequires:  libaacplus-devel >= 2.0.0}
67 BuildRequires:  libass-devel
68 BuildRequires:  libavc1394-devel
69 BuildRequires:  libbluray-devel
70 %{?with_caca:BuildRequires:     libcaca-devel}
71 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
72 BuildRequires:  libdc1394-devel >= 2
73 BuildRequires:  libgsm-devel
74 BuildRequires:  libiec61883-devel
75 BuildRequires:  libmodplug-devel
76 BuildRequires:  libnut-devel
77 %{?with_quvi:BuildRequires:     libquvi-devel}
78 BuildRequires:  libraw1394-devel >= 2
79 BuildRequires:  librtmp-devel
80 BuildRequires:  libtheora-devel >= 1.0-0.beta3
81 BuildRequires:  libtool >= 2:1.4d-3
82 BuildRequires:  libv4l-devel
83 %{?with_va:BuildRequires:       libva-devel >= 1.0.3}
84 BuildRequires:  libvdpau-devel >= 0.2
85 BuildRequires:  libvorbis-devel
86 %{?with_vpx:BuildRequires:      libvpx-devel >= 0.9.7}
87 # X264_BUILD >= 118
88 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
89 %ifarch %{ix86}
90 %ifnarch i386 i486
91 BuildRequires:  nasm
92 %endif
93 %endif
94 BuildRequires:  opencore-amr-devel
95 %{?with_opencv:BuildRequires:   opencv-devel}
96 BuildRequires:  openjpeg-devel >= 1.5
97 BuildRequires:  opus-devel
98 BuildRequires:  perl-Encode
99 BuildRequires:  perl-tools-pod
100 BuildRequires:  pkgconfig
101 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
102 BuildRequires:  rpmbuild(macros) >= 1.470
103 BuildRequires:  schroedinger-devel
104 %{?with_soxr:BuildRequires:     soxr-devel}
105 BuildRequires:  speex-devel >= 1:1.2-rc1
106 %{?with_doc:BuildRequires:      tetex}
107 %{?with_doc:BuildRequires:      texi2html}
108 %{?with_doc:BuildRequires:      texinfo}
109 BuildRequires:  twolame-devel
110 %{?with_utvideo:BuildRequires:  utvideo-devel >= 12}
111 BuildRequires:  vo-aacenc-devel
112 BuildRequires:  vo-amrwbenc-devel
113 %{?with_wavpack:BuildRequires:  wavpack-devel}
114 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
115 BuildRequires:  xavs-devel
116 BuildRequires:  xorg-lib-libX11-devel
117 BuildRequires:  xorg-lib-libXext-devel
118 BuildRequires:  xorg-lib-libXfixes-devel
119 BuildRequires:  xvid-devel >= 1:1.1.0
120 BuildRequires:  yasm
121 BuildRequires:  zlib-devel
122 %{?with_autoreqdep:BuildConflicts:      libpostproc}
123 # overflows maximum hash table size
124 BuildConflicts: pdksh < 5.2.14-57
125 Requires:       %{name}-libs = %{version}-%{release}
126 %{?with_utvideo:Requires:       utvideo >= 12}
127 %{?with_ilbc:Requires:  webrtc-libilbc}
128 Requires:       xvid >= 1:1.1.0
129 Obsoletes:      libpostproc
130 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
131
132 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
133
134 %define         specflags       -fno-strict-aliasing
135
136 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
137 %define         specflags_ia32  -fomit-frame-pointer
138 # -mmmx is needed to enable <mmintrin.h> code.
139 %define         specflags_i586  -mmmx
140 %define         specflags_i686  -mmmx
141 %define         specflags_ppc   -fPIC
142
143 %description
144 FFmpeg is a complete solution to record, convert and stream audio and
145 video. It is a command line tool to convert one video file format to
146 another. It also supports grabbing and encoding in real time from a TV
147 card.
148
149 %description -l pl.UTF-8
150 FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
151 strumieni dźwięku i obrazu. Jest to działające z linii poleceń
152 narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
153 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
154 telewizyjnej.
155
156 %package libs
157 Summary:        ffmpeg libraries
158 Summary(pl.UTF-8):      Biblioteki ffmpeg
159 Group:          Libraries
160
161 %description libs
162 This package contains the ffmpeg shared libraries:
163 - the codec library (libavcodec). It supports most existing encoding
164   formats (MPEG, DivX, MPEG4, AC3, DV...),
165 - demuxer library (libavformat). It supports most existing file
166   formats (AVI, MPEG, OGG, Matroska, ASF...),
167 - video postprocessing library (libpostproc).
168
169 %description libs -l pl.UTF-8
170 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
171 - bibliotekę kodeków (libavcodec); obsługuje większość istniejących
172   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
173 - bibliotekę demuksera (libavformat); obsługuje większość istniejących
174   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
175 - bibliotekę postprocessingu (libpostproc).
176
177 %package devel
178 Summary:        ffmpeg header files
179 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
180 Group:          Development/Libraries
181 Requires:       %{name}-libs = %{version}-%{release}
182 # Libs.private from *.pc (unreasonably they are all the same)
183 Requires:       SDL-devel >= 1.2.1
184 Requires:       alsa-lib-devel
185 Requires:       bzip2-devel
186 Requires:       celt-devel >= 0.11.0
187 %{?with_nonfree:Requires:       faac-devel}
188 %{?with_fdk_aac:Requires:       fdk-aac-devel}
189 Requires:       fontconfig-devel
190 Requires:       freetype-devel
191 %{?with_gme:Requires:   game-music-emu-devel}
192 Requires:       jack-audio-connection-kit-devel
193 %{?with_flite:Requires: flite-devel >= 1.4}
194 Requires:       lame-libs-devel >= 3.98.3
195 %{?with_aacplus:Requires:       libaacplus-devel >= 2.0.0}
196 Requires:       libass-devel
197 Requires:       libavc1394-devel
198 Requires:       libbluray-devel
199 %{?with_caca:Requires:  libcaca-devel}
200 Requires:       libcdio-paranoia-devel >= 0.90-2
201 Requires:       libdc1394-devel >= 2
202 Requires:       libgsm-devel
203 Requires:       libiec61883-devel
204 Requires:       libmodplug-devel
205 Requires:       libnut-devel
206 %{?with_quvi:Requires:  libquvi-devel}
207 Requires:       libraw1394-devel >= 2
208 Requires:       librtmp-devel
209 Requires:       libtheora-devel >= 1.0-0.beta3
210 %{?with_va:Requires:    libva-devel >= 1.0.3}
211 Requires:       libvorbis-devel
212 %{?with_vpx:Requires:   libvpx-devel >= 0.9.7}
213 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
214 Requires:       opencore-amr-devel
215 %{?with_opencv:Requires:        opencv-devel}
216 Requires:       openjpeg-devel >= 1.5
217 Requires:       schroedinger-devel
218 %{?with_soxr:Requires:  soxr-devel}
219 Requires:       speex-devel >= 1:1.2-rc1
220 Requires:       twolame-devel
221 %{?with_utvideo:Requires:       utvideo-devel >= 12}
222 Requires:       vo-aacenc-devel
223 Requires:       vo-amrwbenc-devel
224 %{?with_wavpack:Requires:       wavpack-devel}
225 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
226 Requires:       xavs-devel
227 Requires:       xorg-lib-libXext-devel
228 Requires:       xorg-lib-libXfixes-devel
229 Requires:       xvid-devel >= 1:1.1.0
230 Requires:       zlib-devel
231 Obsoletes:      libpostproc-devel
232
233 %description devel
234 ffmpeg header files.
235
236 %description devel -l pl.UTF-8
237 Pliki nagłówkowe ffmpeg.
238
239 %package static
240 Summary:        ffmpeg static libraries
241 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
242 Group:          Development/Libraries
243 Requires:       %{name}-devel = %{version}-%{release}
244
245 %description static
246 ffmpeg static libraries (libavcodec and libavformat).
247
248 %description static -l pl.UTF-8
249 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
250
251 %package ffplay
252 Summary:        FFplay - SDL-based media player
253 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
254 Group:          Applications/Multimedia
255 Requires:       %{name}-libs = %{version}-%{release}
256
257 %description ffplay
258 FFplay is a very simple and portable media player using the FFmpeg
259 libraries and the SDL library. It is mostly used as a test bench for
260 the various APIs of FFmpeg.
261
262 %description ffplay -l pl.UTF-8
263 FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
264 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
265 testowania różnych API FFmpeg.
266
267 %package ffserver
268 Summary:        FFserver video server
269 Summary(pl.UTF-8):      FFserver - serwer strumieni obrazu
270 Group:          Daemons
271 Requires(post,preun):   /sbin/chkconfig
272 Requires:       %{name}-libs = %{version}-%{release}
273 Requires:       rc-scripts >= 0.4.0.10
274
275 %description ffserver
276 FFserver is a streaming server for both audio and video. It supports
277 several live feeds, streaming from files and time shifting on live
278 feeds (you can seek to positions in the past on each live feed,
279 provided you specify a big enough feed storage in ffserver.conf).
280
281 %description ffserver -l pl.UTF-8
282 FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
283 źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
284 czasie dla źródeł na żywo (można przeskakiwać na położenia w
285 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
286 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
287
288 %prep
289 %setup -q
290 %patch0 -p1
291
292 # package the grep result for mplayer, the result formatted as ./mplayer/configure
293 cat <<EOF > ffmpeg-avconfig
294 #! /bin/sh
295 libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
296 libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
297 libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
298 libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
299 libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
300 libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
301 libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
302 libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
303 libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
304 EOF
305 cat <<'EOF' >> ffmpeg-avconfig
306
307 case "$1" in
308 --decoders)
309         echo $libavdecoders_all
310         ;;
311 --encoders)
312         echo $libavencoders_all
313         ;;
314 --parsers)
315         echo $libavparsers_all
316         ;;
317 --bsfs)
318         echo $libavbsfs_all
319         ;;
320 --demuxers)
321         echo $libavdemuxers_all
322         ;;
323 --muxers)
324         echo $libavmuxers_all
325         ;;
326 --protocols)
327         echo $libavprotocols_all
328         ;;
329 --hwaccels)
330         echo $libavhwaccels_all
331         ;;
332 --filters)
333         echo $libavfilters_all
334         ;;
335 *)
336         cat <<USAGE
337 Usage: $0 [OPTION]
338 Options:
339   --decoders
340   --encoders
341   --parsers
342   --bsfs
343   --demuxers
344   --muxers
345   --protocols
346   --hwaccels
347   --filters
348 USAGE
349         exit 1;;
350 esac
351
352 exit 0
353 EOF
354
355 %build
356 # notes:
357 # - it's not autoconf configure
358 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
359 ./configure \
360         --arch=%{_target_base_arch} \
361         --prefix=%{_prefix} \
362         --libdir=%{_libdir} \
363         --shlibdir=%{_libdir} \
364         --mandir=%{_mandir} \
365         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
366         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
367         --cc="%{__cc}" \
368         --disable-debug \
369         --disable-optimizations \
370         --disable-stripping \
371         --enable-avfilter \
372         --enable-avresample \
373         --enable-gnutls \
374         --enable-gpl \
375         --enable-version3 \
376         --enable-fontconfig \
377         %{?with_frei0r:--enable-frei0r} \
378         %{?with_aacplus:--enable-libaacplus} \
379         --enable-libass \
380         --enable-libbluray \
381         %{?with_caca:--enable-libcaca} \
382         --enable-libcelt \
383         --enable-libcdio \
384         --enable-libdc1394 \
385         %{?with_fdk_aac:--enable-libfdk-aac} \
386         %{?with_flite:--enable-libflite} \
387         --enable-libfreetype \
388         %{?with_gme:--enable-libgme} \
389         --enable-libgsm \
390         --enable-libiec61883 \
391         %{?with_ilbc:--enable-libilbc} \
392         --enable-libmodplug \
393         --enable-libmp3lame \
394         --enable-libnut \
395         --enable-libopencore-amrnb \
396         --enable-libopencore-amrwb \
397         %{?with_opencv:--enable-libopencv} \
398         --enable-libopenjpeg \
399         --enable-libopus \
400         %{?with_pulseaudio:--enable-libpulse} \
401         %{?with_quvi:--enable-libquvi} \
402         --enable-librtmp \
403         --enable-libschroedinger \
404         %{?with_soxr:--enable-libsoxr} \
405         --enable-libspeex \
406         --enable-libtheora \
407         --enable-libtwolame \
408         %{?with_utvideo:--enable-libutvideo} \
409         --enable-libv4l2 \
410         --enable-libvo-aacenc \
411         --enable-libvo-amrwbenc \
412         --enable-libvorbis \
413         %{?with_vpx:--enable-libvpx} \
414         %{?with_wavpack:--enable-libwavpack} \
415         %{?with_x264:--enable-libx264} \
416         --enable-libxavs \
417         --enable-libxvid \
418         %{?with_openal:--enable-openal} \
419         --enable-postproc \
420         --enable-pthreads \
421         --enable-shared \
422         --enable-swscale \
423         %{!?with_va:--disable-vaapi} \
424         --enable-x11grab \
425 %ifnarch %{ix86} %{x8664}
426         --disable-mmx \
427 %endif
428 %ifarch i386 i486
429         --disable-mmx \
430 %endif
431 %if %{with nonfree}
432         --enable-nonfree \
433         --enable-libfaac \
434 %endif
435         --enable-runtime-cpudetect
436
437 # force oldscaler build
438 %{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
439
440 %{__make} \
441         V=1
442
443 # CC_O to add -c to commandline. makefile should be patched
444 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
445
446 %install
447 rm -rf $RPM_BUILD_ROOT
448 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
449         $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
450         $RPM_BUILD_ROOT/var/{cache,log}/ffserver
451
452 %{__make} install install-headers \
453         DESTDIR=$RPM_BUILD_ROOT \
454         V=1
455
456 # install nonstandard, non-public headers manually
457 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
458 for a in libavutil/*/bswap.h; do
459         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
460 done
461 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
462 # for lim-omx ffmpeg components
463 cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
464
465 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
466 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
467 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
468 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
469 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
470
471 # install as ffmpeg-avconfig to avoid with possible programs looking for
472 # ffmpeg-config and expecting --libs output from it which is not implemented
473 # simple to do (by querying pkgconfig), but why?
474 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
475
476 %clean
477 rm -rf $RPM_BUILD_ROOT
478
479 %post   libs -p /sbin/ldconfig
480 %postun libs -p /sbin/ldconfig
481
482 %pre ffserver
483 %groupadd -g 167 ffserver
484 %useradd -g ffserver -u 167 ffserver
485
486 %post ffserver
487 /sbin/chkconfig --add ffserver
488 %service ffserver restart
489
490 %preun ffserver
491 if [ "$1" = 0 ]; then
492         %service ffserver stop
493         /sbin/chkconfig --del ffserver
494 fi
495
496 %postun ffserver
497 if [ "$1" = 0 ]; then
498         %userremove ffserver
499         %groupremove ffserver
500 fi
501
502 %files
503 %defattr(644,root,root,755)
504 %doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
505 %attr(755,root,root) %{_bindir}/ffmpeg
506 %attr(755,root,root) %{_bindir}/ffprobe
507 %attr(755,root,root) %{_bindir}/qt-faststart
508 %dir %{_datadir}/ffmpeg
509 %{_datadir}/ffmpeg/*.ffpreset
510 %{_datadir}/ffmpeg/ffprobe.xsd
511 %if %{with doc}
512 %{_mandir}/man1/ffmpeg.1*
513 %{_mandir}/man1/ffmpeg-all.1*
514 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
515 %{_mandir}/man1/ffmpeg-codecs.1*
516 %{_mandir}/man1/ffmpeg-devices.1*
517 %{_mandir}/man1/ffmpeg-filters.1*
518 %{_mandir}/man1/ffmpeg-formats.1*
519 %{_mandir}/man1/ffmpeg-protocols.1*
520 %{_mandir}/man1/ffmpeg-resampler.1*
521 %{_mandir}/man1/ffmpeg-scaler.1*
522 %{_mandir}/man1/ffmpeg-utils.1*
523 %{_mandir}/man1/ffprobe.1*
524 %{_mandir}/man1/ffprobe-all.1*
525 %endif
526
527 %files libs
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
530 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.55
531 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
532 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.55
533 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
534 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
535 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
536 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.55
537 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
538 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.1
539 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
540 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.52
541 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
542 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
543 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
544 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
545 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
546 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
547
548 %files devel
549 %defattr(644,root,root,755)
550 %doc doc/optimization.txt
551 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
552 %attr(755,root,root) %{_libdir}/libavcodec.so
553 %attr(755,root,root) %{_libdir}/libavdevice.so
554 %attr(755,root,root) %{_libdir}/libavfilter.so
555 %attr(755,root,root) %{_libdir}/libavformat.so
556 %attr(755,root,root) %{_libdir}/libavresample.so
557 %attr(755,root,root) %{_libdir}/libavutil.so
558 %attr(755,root,root) %{_libdir}/libpostproc.so
559 %attr(755,root,root) %{_libdir}/libswresample.so
560 %attr(755,root,root) %{_libdir}/libswscale.so
561 %{_includedir}/ffmpeg
562 %{_includedir}/libavcodec
563 %{_includedir}/libavdevice
564 %{_includedir}/libavfilter
565 %{_includedir}/libavformat
566 %{_includedir}/libavresample
567 %{_includedir}/libavutil
568 %{_includedir}/libpostproc
569 %{_includedir}/libswresample
570 %{_includedir}/libswscale
571 %{_pkgconfigdir}/libavcodec.pc
572 %{_pkgconfigdir}/libavdevice.pc
573 %{_pkgconfigdir}/libavfilter.pc
574 %{_pkgconfigdir}/libavformat.pc
575 %{_pkgconfigdir}/libavresample.pc
576 %{_pkgconfigdir}/libavutil.pc
577 %{_pkgconfigdir}/libpostproc.pc
578 %{_pkgconfigdir}/libswresample.pc
579 %{_pkgconfigdir}/libswscale.pc
580 %if %{with doc}
581 %{_mandir}/man3/libavcodec.3*
582 %{_mandir}/man3/libavdevice.3*
583 %{_mandir}/man3/libavfilter.3*
584 %{_mandir}/man3/libavformat.3*
585 %{_mandir}/man3/libavutil.3*
586 %{_mandir}/man3/libswresample.3*
587 %{_mandir}/man3/libswscale.3*
588 %endif
589
590 %files static
591 %defattr(644,root,root,755)
592 %{_libdir}/libavcodec.a
593 %{_libdir}/libavdevice.a
594 %{_libdir}/libavfilter.a
595 %{_libdir}/libavformat.a
596 %{_libdir}/libavresample.a
597 %{_libdir}/libavutil.a
598 %{_libdir}/libpostproc.a
599 %{_libdir}/libswresample.a
600 %{_libdir}/libswscale.a
601
602 %files ffplay
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_bindir}/ffplay
605 %if %{with doc}
606 %{_mandir}/man1/ffplay.1*
607 %{_mandir}/man1/ffplay-all.1*
608 %endif
609
610 %files ffserver
611 %defattr(644,root,root,755)
612 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
613 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
614 %attr(755,root,root) %{_sbindir}/ffserver
615 %attr(754,root,root) /etc/rc.d/init.d/ffserver
616 %if %{with doc}
617 %{_mandir}/man1/ffserver.1*
618 %{_mandir}/man1/ffserver-all.1*
619 %endif
620 %dir %attr(770,root,ffserver) /var/cache/ffserver
621 %dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.14959 seconds and 4 git commands to generate.