]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- add -kill-mabi_altivec.patch
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # TODO: update for lzo 2.x (currently only lzo 1.x is supported)
3 #
4 # Conditional build:
5 %bcond_with     amr             # build 3GPP Adaptive Multi Rate (AMR) speech codec
6 %bcond_without  autoreqdep      # don't care about package name deps generated by rpm
7 %bcond_without  imlib2          # don't build imlib2 vhook module
8 %bcond_with     lzo             # build with LZO support
9 #
10 %define         _snap   2006-12-04
11 %define         snap    %(echo %{_snap} | tr -d -)
12 %define         _rel 0.4
13 Summary:        Realtime audio/video encoder and streaming server
14 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
15 Name:           ffmpeg
16 Version:        0.4.9
17 Release:        3.%{snap}.%{_rel}
18 # LGPL or GPL, chosen at configure time (GPL version is more featured)
19 # (postprocessing, a52, xvid, x264, dts, faad)
20 License:        GPL with LGPL parts
21 Group:          Applications/Multimedia
22 #Source0:       http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
23 #Source0:       ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
24 #Source0:       %{name}-%{snap}.tar.bz2
25 Source0:        http://ffmpeg.mplayerhq.hu/%{name}-export-snapshot.tar.bz2
26 # Source0-md5:  5be2e4d1e326bb7809205a3401204621
27 Source1:        ffserver.init
28 Source2:        ffserver.sysconfig
29 Source3:        ffserver.conf
30 Patch0:         %{name}-libtool.patch
31 Patch1:         %{name}-libdir.patch
32 Patch2:         %{name}-gcc4.patch
33 Patch3:         %{name}-system-amr.patch
34 Patch4:         %{name}-x264-symbol.patch
35 Patch5:         %{name}-as_needed.patch
36 Patch6:         %{name}-kill-mabi_altivec.patch
37 URL:            http://ffmpeg.mplayerhq.hu/
38 BuildRequires:  SDL-devel
39 %if %{with amr}
40 BuildRequires:  amrnb-devel
41 BuildRequires:  amrwb-devel >= 5.3.0
42 %endif
43 BuildRequires:  faac-devel
44 BuildRequires:  faad2-devel
45 BuildRequires:  freetype-devel
46 %ifarch ppc
47 # require version with altivec support fixed
48 BuildRequires:  gcc >= 5:3.3.2-3
49 %endif
50 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
51 BuildRequires:  lame-libs-devel
52 BuildRequires:  libdts-devel
53 BuildRequires:  libgsm-devel
54 BuildRequires:  libtheora-devel
55 BuildRequires:  libtool >= 2:1.4d-3
56 BuildRequires:  libvorbis-devel
57 BuildRequires:  libx264-devel >= 0.1.2-1.20061024_2245.1
58 #%{?with_lzo:BuildRequires:     lzo-devel < 2.0}
59 %ifarch %{ix86}
60 %ifnarch i386 i486
61 BuildRequires:  nasm
62 %endif
63 %endif
64 BuildRequires:  perl-tools-pod
65 BuildRequires:  rpmbuild(macros) >= 1.268
66 BuildRequires:  tetex
67 BuildRequires:  texinfo
68 %{?with_amr:BuildRequires:      unzip}
69 BuildRequires:  xvid-devel >= 1:1.1.0
70 BuildRequires:  zlib-devel
71 %{?with_autoreqdep:BuildConflicts:      libpostproc}
72 Requires:       %{name}-libs = %{version}-%{release}
73 Requires:       xvid >= 1:1.1.0
74 Obsoletes:      libpostproc
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
78
79 %define         specflags       -fno-strict-aliasing
80
81 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
82 %define         specflags_ia32  -fomit-frame-pointer
83 # -mmmx is needed to enable <mmintrin.h> code.
84 %define         specflags_i586  -mmmx
85 %define         specflags_i686  -mmmx
86
87 %description
88 ffmpeg is a hyper fast realtime audio/video encoder and streaming
89 server. It can grab from a standard Video4Linux video source and
90 convert it into several file formats based on DCT/motion compensation
91 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
92 compatible stream.
93
94 %description -l pl
95 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
96 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
97 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
98 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
99 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
100 strumienia kompatybilnego z AC3.
101
102 %package libs
103 Summary:        ffmpeg libraries
104 Summary(pl):    Biblioteki ffmpeg
105 Group:          Libraries
106
107 %description libs
108 This package contains ffmpeg shared libraries.
109
110 %description libs -l pl
111 Ten pakiet zawiera biblioteki wspó³dzielone ffmpeg.
112
113 %package devel
114 Summary:        ffmpeg header files
115 Summary(pl):    Pliki nag³ówkowe ffmpeg
116 Group:          Development/Libraries
117 Requires:       %{name}-libs = %{version}-%{release}
118 # for libavcodec:
119 %if %{with amr}
120 Requires:       amrnb-devel
121 Requires:       amrwb-devel >= 5.3.0
122 %endif
123 Requires:       faac-devel
124 Requires:       faad2-devel
125 Requires:       lame-libs-devel
126 Requires:       libdts-devel
127 Requires:       libgsm-devel
128 Requires:       libtheora-devel
129 Requires:       libvorbis-devel
130 Requires:       libx264-devel >= 0.1.2-1.20060828_2245.1
131 #%{?with_lzo:Requires:  lzo-devel < 2.0}
132 Requires:       xvid-devel >= 1:1.1.0
133 Requires:       zlib-devel
134 Obsoletes:      libpostproc-devel
135
136 %description devel
137 ffmpeg header files.
138
139 %description devel -l pl
140 Pliki nag³ówkowe ffmpeg.
141
142 %package static
143 Summary:        ffmpeg static libraries
144 Summary(pl):    Statyczne biblioteki ffmpeg
145 Group:          Development/Libraries
146 Requires:       %{name}-devel = %{version}-%{release}
147
148 %description static
149 ffmpeg static libraries (libavcodec and libavformat).
150
151 %description static -l pl
152 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
153
154 %package ffplay
155 Summary:        FFplay - SDL-based media player
156 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
157 Group:          Applications/Multimedia
158 Requires:       %{name}-libs = %{version}-%{release}
159
160 %description ffplay
161 FFplay is a very simple and portable media player using the FFmpeg
162 libraries and the SDL library. It is mostly used as a test bench for
163 the various APIs of FFmpeg.
164
165 %description ffplay -l pl
166 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
167 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
168 testowania ró¿nych API FFmpeg.
169
170 %package vhook-imlib2
171 Summary:        imlib2 based hook
172 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
173 Group:          Libraries
174 Requires:       %{name}-libs = %{version}-%{release}
175
176 %description vhook-imlib2
177 This module implements a text overlay for a video image. Currently it
178 supports a fixed overlay or reading the text from a file. The string
179 is passed through strftime so that it is easy to imprint the date and
180 time onto the image.
181
182 %description vhook-imlib2 -l pl
183 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
184 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
185 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
186 obrazie.
187
188 %package ffserver
189 Summary:        FFserver video server
190 Summary(pl):    FFserver - serwer strumieni obrazu
191 Group:          Daemons
192 Requires(post,preun):   /sbin/chkconfig
193 Requires:       %{name}-libs = %{version}-%{release}
194 Requires:       rc-scripts >= 0.4.0.10
195
196 %description ffserver
197 FFserver is a streaming server for both audio and video. It supports
198 several live feeds, streaming from files and time shifting on live
199 feeds (you can seek to positions in the past on each live feed,
200 provided you specify a big enough feed storage in ffserver.conf).
201
202 %description ffserver -l pl
203 FFserver to serwer strumieni dla d¼wiêku i obrazu. Obs³uguje kilka
204 ¼róde³ na ¿ywo, przekazywanie strumieni z plików i przesuwanie w
205 czasie dla ¼róde³ na ¿ywo (mo¿na przeskakiwaæ na po³o¿enia w
206 przesz³o¶ci dla ka¿dego ¼ród³a na ¿ywo, pod warunkiem odpowiednio
207 du¿ej przestrzeni na dane skonfigurowanej w ffserver.conf).
208
209 %prep
210 %setup -q -n %{name}-export-%{_snap}
211 %patch0 -p1
212 %patch1 -p1
213 %patch2 -p1
214 #%patch3 -p1 NEEDS UPDATE
215 %patch4 -p1
216 #%patch5 -p1 MIGHT BE UNNECCESSARY
217 %patch6 -p1
218
219 %build
220 # notes:
221 # - it's not autoconf configure
222 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
223 ./configure \
224         --prefix=%{_prefix} \
225         --libdir=%{_libdir} \
226         --shlibdir=%{_libdir} \
227         --mandir=%{_mandir} \
228         --disable-strip \
229         --enable-a52 \
230         --enable-a52bin \
231         --enable-dts \
232         --enable-faac \
233         --enable-faad \
234         --enable-faadbin \
235         --enable-gpl \
236         --enable-libgsm \
237         --enable-libogg \
238         --enable-mp3lame \
239         --enable-pp \
240         --enable-pthreads \
241         --enable-shared \
242         --enable-vorbis \
243         --enable-x264 \
244         --enable-xvid \
245 %ifnarch %{ix86} %{x8664}
246         --disable-mmx \
247 %endif
248 %ifarch i386 i486
249         --disable-mmx \
250 %endif
251 %if %{with amr}
252         --enable-amr_nb \
253         --enable-amr_wb \
254 %endif
255         --cc="%{__cc}" \
256         --extra-cflags="%{rpmcflags}" \
257         --extra-ldflags="%{rpmldflags}" \
258         --disable-debug \
259         --disable-opts \
260
261 # GONE?
262 #       %{!?with_lzo:--disable-lzo} \
263 #       --enable-theora \
264 #       --tune=generic
265
266 %{__make}
267
268 %install
269 rm -rf $RPM_BUILD_ROOT
270 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
271         $RPM_BUILD_ROOT/var/{cache,log}/ffserver
272
273 %{__make} install \
274         DESTDIR=$RPM_BUILD_ROOT
275
276 install xvmc_render.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
277 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
278 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
279 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
280 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
281
282 %clean
283 rm -rf $RPM_BUILD_ROOT
284
285 %post libs      -p /sbin/ldconfig
286 %postun libs    -p /sbin/ldconfig
287
288 %pre ffserver
289 %groupadd -g 167 ffserver
290 %useradd -g ffserver -u 167 ffserver
291
292 %post ffserver
293 /sbin/chkconfig --add ffserver
294 %service ffserver restart
295
296 %preun ffserver
297 if [ "$1" = 0 ]; then
298         %service ffserver stop
299         /sbin/chkconfig --del ffserver
300 fi
301
302 %postun ffserver
303 if [ "$1" = 0 ]; then
304         %userremove ffserver
305         %groupremove ffserver
306 fi
307
308 %files
309 %defattr(644,root,root,755)
310 %doc Changelog README doc/*.html doc/TODO
311 %attr(755,root,root) %{_bindir}/ffmpeg
312 %{_mandir}/man1/ffmpeg.1*
313
314 %files libs
315 %defattr(644,root,root,755)
316 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
317 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
318 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
319 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
320 %dir %{_libdir}/vhook
321 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
322 %attr(755,root,root) %{_libdir}/vhook/fish.so
323 %attr(755,root,root) %{_libdir}/vhook/null.so
324 %attr(755,root,root) %{_libdir}/vhook/ppm.so
325 %attr(755,root,root) %{_libdir}/vhook/watermark.so
326
327 %files devel
328 %defattr(644,root,root,755)
329 %doc doc/optimization.txt
330 %attr(755,root,root) %{_libdir}/libavcodec.so
331 %attr(755,root,root) %{_libdir}/libavformat.so
332 %attr(755,root,root) %{_libdir}/libavutil.so
333 %attr(755,root,root) %{_libdir}/libpostproc.so
334 %{_libdir}/lib*.la
335 %{_includedir}/ffmpeg
336 %{_includedir}/postproc
337 %{_pkgconfigdir}/*.pc
338
339 %files static
340 %defattr(644,root,root,755)
341 %{_libdir}/lib*.a
342
343 %files ffplay
344 %defattr(644,root,root,755)
345 %attr(755,root,root) %{_bindir}/ffplay
346 %{_mandir}/man1/ffplay.1*
347
348 %if %{with imlib2}
349 %files vhook-imlib2
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
352 %endif
353
354 %files ffserver
355 %defattr(644,root,root,755)
356 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
357 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
358 %attr(755,root,root) %{_sbindir}/ffserver
359 %attr(754,root,root) /etc/rc.d/init.d/ffserver
360 %{_mandir}/man1/ffserver.1*
361 %dir %attr(770,root,ffserver) /var/cache/ffserver
362 %dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.076242 seconds and 4 git commands to generate.