]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
f7c60446c5d16e9ceb2b02b58cb8b3bdcd8a42a6
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2          # we can safely play without it :-)
4 %bcond_without  autoreqdep      # don't care about package name deps generated by rpm
5 #
6 Summary:        Realtime audio/video encoder and streaming server
7 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
8 Name:           ffmpeg
9 Version:        0.4.9
10 %define snap    20060129
11 Release:        3.%{snap}.4
12 # LGPL or GPL, chosen at configure time (GPL version is more featured)
13 License:        GPL
14 Group:          Daemons
15 #Source0:       http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
16 #Source0:       ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
17 Source0:        %{name}-%{snap}.tar.bz2
18 # Source0-md5:  d8ea09431d6c0c91bfd35e0ca74a67e1
19 Patch0:         %{name}-libtool.patch
20 Patch1:         %{name}-libdir.patch
21 Patch2:         %{name}-gcc4.patch
22 URL:            http://ffmpeg.sourceforge.net/
23 BuildRequires:  SDL-devel
24 BuildRequires:  faac-devel
25 BuildRequires:  faad2-devel
26 BuildRequires:  freetype-devel
27 %ifarch ppc
28 # require version with altivec support fixed
29 BuildRequires:  gcc >= 5:3.3.2-3
30 %endif
31 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
32 BuildRequires:  lame-libs-devel
33 BuildRequires:  libdts-devel
34 BuildRequires:  libtheora-devel
35 BuildRequires:  libtool >= 2:1.4d-3
36 BuildRequires:  libvorbis-devel
37 %ifarch %{ix86}
38 %ifnarch i386 i486
39 BuildRequires:  nasm
40 %endif
41 %endif
42 BuildRequires:  perl-tools-pod
43 BuildRequires:  tetex
44 BuildRequires:  texinfo
45 BuildRequires:  xvid-devel >= 1:1.1.0
46 BuildRequires:  zlib-devel
47 %{?with_autoreqdep:BuildConflicts:      libpostproc}
48 Requires:       xvid >= 1:1.1.0
49 Obsoletes:      libpostproc
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
53
54 %define         specflags       -fno-strict-aliasing
55
56 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
57 %define         specflags_ia32  -fomit-frame-pointer
58 # -mmmx is needed to enable <mmintrin.h> code.
59 %define         specflags_i586  -mmmx
60 %define         specflags_i686  -mmmx
61
62 %description
63 ffmpeg is a hyper fast realtime audio/video encoder and streaming
64 server. It can grab from a standard Video4Linux video source and
65 convert it into several file formats based on DCT/motion compensation
66 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
67 compatible stream.
68
69 This package contains also ffmpeg shared libraries (libavcodec and
70 libavformat).
71
72 %description -l pl
73 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
74 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
75 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
76 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
77 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
78 strumienia kompatybilnego z AC3.
79
80 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
81 libavformat).
82
83 %package devel
84 Summary:        ffmpeg header files
85 Summary(pl):    Pliki nag³ówkowe ffmpeg
86 Group:          Development/Libraries
87 Requires:       %{name} = %{version}-%{release}
88 Obsoletes:      libpostproc-devel
89 # for libavcodec:
90 Requires:       faac-devel
91 Requires:       lame-libs-devel
92 Requires:       libdts-devel
93 Requires:       libtheora-devel
94 Requires:       libvorbis-devel
95 Requires:       xvid-devel >= 1:1.1.0
96 Requires:       zlib-devel
97
98 %description devel
99 ffmpeg header files.
100
101 %description devel -l pl
102 Pliki nag³ówkowe ffmpeg.
103
104 %package static
105 Summary:        ffmpeg static libraries
106 Summary(pl):    Statyczne biblioteki ffmpeg
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109
110 %description static
111 ffmpeg static libraries (libavcodec and libavformat).
112
113 %description static -l pl
114 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
115
116 %package ffplay
117 Summary:        FFplay - SDL-based media player
118 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
119 Group:          Applications/Multimedia
120 Requires:       %{name} = %{version}-%{release}
121
122 %description ffplay
123 FFplay is a very simple and portable media player using the FFmpeg
124 libraries and the SDL library. It is mostly used as a test bench for
125 the various APIs of FFmpeg.
126
127 %description ffplay -l pl
128 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
129 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
130 testowania ró¿nych API FFmpeg.
131
132 %package vhook-imlib2
133 Summary:        imlib2 based hook
134 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
135 Group:          Libraries
136 Requires:       %{name} = %{version}-%{release}
137
138 %description vhook-imlib2
139 This module implements a text overlay for a video image. Currently it
140 supports a fixed overlay or reading the text from a file. The string
141 is passed through strftime so that it is easy to imprint the date and
142 time onto the image.
143
144 %description vhook-imlib2 -l pl
145 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
146 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
147 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
148 obrazie.
149
150 %prep
151 %setup -q -n ffmpeg
152 %patch0 -p1
153 %patch1 -p1
154 %patch2 -p1
155
156 %build
157 # notes:
158 # - it's not autoconf configure
159 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
160 #   (-fPIC takes one)
161 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
162 ./configure \
163         --prefix=%{_prefix} \
164         --libdir=%{_libdir} \
165         --mandir=%{_mandir} \
166         --disable-strip \
167         --enable-a52 \
168         --enable-dts \
169         --enable-faac \
170         --enable-faad \
171         --enable-faadbin \
172         --enable-gpl \
173         --enable-libogg \
174         --enable-mp3lame \
175         --enable-pp \
176         --enable-pthreads \
177         --enable-shared \
178         --enable-theora \
179         --enable-vorbis \
180         --enable-xvid \
181 %ifnarch %{ix86} %{x8664}
182         --disable-mmx \
183 %endif
184 %ifarch i386 i486
185         --disable-mmx \
186 %endif
187         --cc="%{__cc}" \
188         --extra-cflags="%{rpmcflags}" \
189         --extra-ldflags="%{rpmldflags}" \
190         --disable-debug \
191         --disable-opts \
192         --tune=generic
193
194 %{__make} \
195         BUILD_DOC=yes
196
197 %install
198 rm -rf $RPM_BUILD_ROOT
199 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
200
201 %{__make} install \
202         DESTDIR=$RPM_BUILD_ROOT
203
204 install xvmc_render.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
205
206 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
207 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
208
209 %clean
210 rm -rf $RPM_BUILD_ROOT
211
212 %post   -p /sbin/ldconfig
213 %postun -p /sbin/ldconfig
214
215 %files
216 %defattr(644,root,root,755)
217 %doc Changelog README doc/*.html
218 %attr(755,root,root) %{_bindir}/ffmpeg
219 %attr(755,root,root) %{_sbindir}/ffserver
220 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
221 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
222 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
223 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
224 %dir %{_libdir}/vhook
225 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
226 %attr(755,root,root) %{_libdir}/vhook/fish.so
227 %attr(755,root,root) %{_libdir}/vhook/null.so
228 %attr(755,root,root) %{_libdir}/vhook/ppm.so
229 %attr(755,root,root) %{_libdir}/vhook/watermark.so
230 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
231 %{_mandir}/man1/ffmpeg.1*
232 %{_mandir}/man1/ffserver.1*
233
234 %files devel
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_libdir}/libavcodec.so
237 %attr(755,root,root) %{_libdir}/libavformat.so
238 %attr(755,root,root) %{_libdir}/libavutil.so
239 %attr(755,root,root) %{_libdir}/libpostproc.so
240 %{_libdir}/lib*.la
241 %{_includedir}/ffmpeg
242 %{_includedir}/postproc
243 %{_pkgconfigdir}/*.pc
244
245 %files static
246 %defattr(644,root,root,755)
247 %{_libdir}/lib*.a
248
249 %files ffplay
250 %defattr(644,root,root,755)
251 %attr(755,root,root) %{_bindir}/ffplay
252 %{_mandir}/man1/ffplay.1*
253
254 %if %{with imlib2}
255 %files vhook-imlib2
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
258 %endif
This page took 0.038033 seconds and 3 git commands to generate.