]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
f2b3ff4a60ec5ed04dfefd4339a6bb51fece251c
[packages/ffmpeg.git] / ffmpeg.spec
1 # TODO: libzmq ?
2 #
3 # How to deal with ffmpeg/opencv checken-egg problem:
4 #       1. make-request -r --without opencv ffmpeg.spec
5 #       2. make-request -r opencv.spec
6 #       3. bump release of ffmpeg.spec
7 #       4. make-request -r ffmpeg.spec
8 #
9 # Conditional build:
10 %bcond_with     nonfree         # non free options of package (currently: faac)
11 %bcond_with     aacplus         # AAC+ encoding via libaacplus (requires nonfree)
12 %bcond_with     fdk_aac         # AAC encoding via libfdk_aac (requires nonfree)
13 %bcond_without  caca            # textual display using libcaca
14 %bcond_without  flite           # flite voice synthesis support
15 %bcond_without  frei0r          # frei0r video filtering
16 %bcond_without  gme             # Game Music Emu support
17 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
18 %bcond_without  openal          # OpenAL 1.1 capture support
19 %bcond_with     opencl          # OpenCL code [OpenCL 1.2, but Mesa 9.1.x headers don't suffice]
20 %bcond_without  opencv          # OpenCV video filtering
21 %bcond_without  pulseaudio      # PulseAudio input support
22 %bcond_without  quvi            # quvi input support
23 %bcond_without  shine           # shine fixed-point MP3 encoder
24 %bcond_without  soxr            # SoX Resampler support
25 %bcond_without  x264            # x264 encoder
26 %bcond_without  utvideo         # Ut Video decoder
27 %bcond_without  va              # VAAPI (Video Acceleration API)
28 %bcond_without  vidstab         # vid.stab video stabilization support
29 %bcond_without  vpx             # VP8, a high-quality video codec
30 %bcond_without  wavpack         # wavpack encoding support
31 %bcond_without  zmq             # 0MQ message passing
32 %bcond_without  doc             # don't build docs
33
34 Summary:        FFmpeg - a very fast video and audio converter
35 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
36 Name:           ffmpeg
37 Version:        2.0.1
38 Release:        1.1
39 # LGPL or GPL, chosen at configure time (GPL version is more featured)
40 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
41 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
42 License:        GPL v3+ with LGPL v3+ parts
43 Group:          Applications/Multimedia
44 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
45 # Source0-md5:  dd71a1baedb2daa3e4d21e0651daa918
46 Source1:        ffserver.init
47 Source2:        ffserver.sysconfig
48 Source3:        ffserver.conf
49 Patch0:         %{name}-opencv24.patch
50 URL:            http://www.ffmpeg.org/
51 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
52 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.2}
53 BuildRequires:  SDL-devel >= 1.2.1
54 BuildRequires:  alsa-lib-devel
55 BuildRequires:  bzip2-devel
56 BuildRequires:  celt-devel >= 0.11.0
57 %{?with_nonfree:BuildRequires:  faac-devel}
58 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
59 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
60 BuildRequires:  fontconfig-devel
61 BuildRequires:  freetype-devel
62 %{?with_frei0r:BuildRequires:   frei0r-devel}
63 %{?with_gme:BuildRequires:      game-music-emu-devel}
64 %ifarch ppc
65 # require version with altivec support fixed
66 BuildRequires:  gcc >= 5:3.3.2-3
67 %endif
68 BuildRequires:  gnutls-devel
69 BuildRequires:  jack-audio-connection-kit-devel
70 BuildRequires:  lame-libs-devel >= 3.98.3
71 %{?with_aacplus:BuildRequires:  libaacplus-devel >= 2.0.0}
72 BuildRequires:  libass-devel
73 BuildRequires:  libavc1394-devel
74 BuildRequires:  libbluray-devel
75 %{?with_caca:BuildRequires:     libcaca-devel}
76 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
77 BuildRequires:  libdc1394-devel >= 2
78 BuildRequires:  libgsm-devel
79 BuildRequires:  libiec61883-devel
80 BuildRequires:  libmodplug-devel
81 BuildRequires:  libnut-devel
82 %{?with_quvi:BuildRequires:     libquvi-devel}
83 BuildRequires:  libraw1394-devel >= 2
84 BuildRequires:  librtmp-devel
85 %{?with_shine:BuildRequires:    shine-devel}
86 BuildRequires:  libtheora-devel >= 1.0-0.beta3
87 BuildRequires:  libtool >= 2:1.4d-3
88 BuildRequires:  libv4l-devel
89 %{?with_va:BuildRequires:       libva-devel >= 1.0.3}
90 BuildRequires:  libvdpau-devel >= 0.2
91 BuildRequires:  libvorbis-devel
92 %{?with_vpx:BuildRequires:      libvpx-devel >= 0.9.7}
93 # X264_BUILD >= 118
94 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
95 %ifarch %{ix86}
96 %ifnarch i386 i486
97 BuildRequires:  nasm
98 %endif
99 %endif
100 BuildRequires:  opencore-amr-devel
101 %{?with_opencv:BuildRequires:   opencv-devel}
102 BuildRequires:  openjpeg-devel >= 1.5
103 BuildRequires:  opus-devel
104 BuildRequires:  perl-Encode
105 BuildRequires:  perl-tools-pod
106 BuildRequires:  pkgconfig
107 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
108 BuildRequires:  rpmbuild(macros) >= 1.470
109 BuildRequires:  schroedinger-devel
110 %{?with_soxr:BuildRequires:     soxr-devel}
111 BuildRequires:  speex-devel >= 1:1.2-rc1
112 %{?with_doc:BuildRequires:      tetex}
113 %{?with_doc:BuildRequires:      texi2html}
114 %{?with_doc:BuildRequires:      texinfo}
115 BuildRequires:  twolame-devel
116 %{?with_utvideo:BuildRequires:  utvideo-devel >= 12}
117 %{?with_vidstab:BuildRequires:  vid.stab-devel}
118 BuildRequires:  vo-aacenc-devel
119 BuildRequires:  vo-amrwbenc-devel
120 %{?with_wavpack:BuildRequires:  wavpack-devel}
121 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
122 BuildRequires:  xavs-devel
123 BuildRequires:  xorg-lib-libX11-devel
124 BuildRequires:  xorg-lib-libXext-devel
125 BuildRequires:  xorg-lib-libXfixes-devel
126 BuildRequires:  xvid-devel >= 1:1.1.0
127 BuildRequires:  yasm
128 %{?with_zmq:BuildRequires:      zeromq-devel}
129 BuildRequires:  zlib-devel
130 %{?with_autoreqdep:BuildConflicts:      libpostproc}
131 # overflows maximum hash table size
132 BuildConflicts: pdksh < 5.2.14-57
133 Requires:       %{name}-libs = %{version}-%{release}
134 %{?with_utvideo:Requires:       utvideo >= 12}
135 %{?with_ilbc:Requires:  webrtc-libilbc}
136 Requires:       xvid >= 1:1.1.0
137 Obsoletes:      libpostproc
138 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
139
140 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
141
142 %define         specflags       -fno-strict-aliasing
143
144 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
145 %define         specflags_ia32  -fomit-frame-pointer
146 # -mmmx is needed to enable <mmintrin.h> code.
147 %define         specflags_i586  -mmmx
148 %define         specflags_i686  -mmmx
149 %define         specflags_ppc   -fPIC
150
151 %description
152 FFmpeg is a complete solution to record, convert and stream audio and
153 video. It is a command line tool to convert one video file format to
154 another. It also supports grabbing and encoding in real time from a TV
155 card.
156
157 %description -l pl.UTF-8
158 FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
159 strumieni dźwięku i obrazu. Jest to działające z linii poleceń
160 narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
161 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
162 telewizyjnej.
163
164 %package libs
165 Summary:        ffmpeg libraries
166 Summary(pl.UTF-8):      Biblioteki ffmpeg
167 Group:          Libraries
168
169 %description libs
170 This package contains the ffmpeg shared libraries:
171 - the codec library (libavcodec). It supports most existing encoding
172   formats (MPEG, DivX, MPEG4, AC3, DV...),
173 - demuxer library (libavformat). It supports most existing file
174   formats (AVI, MPEG, OGG, Matroska, ASF...),
175 - video postprocessing library (libpostproc).
176
177 %description libs -l pl.UTF-8
178 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
179 - bibliotekę kodeków (libavcodec); obsługuje większość istniejących
180   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
181 - bibliotekę demuksera (libavformat); obsługuje większość istniejących
182   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
183 - bibliotekę postprocessingu (libpostproc).
184
185 %package devel
186 Summary:        ffmpeg header files
187 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
188 Group:          Development/Libraries
189 Requires:       %{name}-libs = %{version}-%{release}
190 # Libs.private from *.pc (unreasonably they are all the same)
191 %{?with_opencl:Requires:        OpenCL-devel >= 1.2}
192 Requires:       SDL-devel >= 1.2.1
193 Requires:       alsa-lib-devel
194 Requires:       bzip2-devel
195 Requires:       celt-devel >= 0.11.0
196 %{?with_nonfree:Requires:       faac-devel}
197 %{?with_fdk_aac:Requires:       fdk-aac-devel}
198 Requires:       fontconfig-devel
199 Requires:       freetype-devel
200 %{?with_gme:Requires:   game-music-emu-devel}
201 Requires:       jack-audio-connection-kit-devel
202 %{?with_flite:Requires: flite-devel >= 1.4}
203 Requires:       lame-libs-devel >= 3.98.3
204 %{?with_aacplus:Requires:       libaacplus-devel >= 2.0.0}
205 Requires:       libass-devel
206 Requires:       libavc1394-devel
207 Requires:       libbluray-devel
208 %{?with_caca:Requires:  libcaca-devel}
209 Requires:       libcdio-paranoia-devel >= 0.90-2
210 Requires:       libdc1394-devel >= 2
211 Requires:       libgsm-devel
212 Requires:       libiec61883-devel
213 Requires:       libmodplug-devel
214 Requires:       libnut-devel
215 %{?with_quvi:Requires:  libquvi-devel}
216 Requires:       libraw1394-devel >= 2
217 Requires:       librtmp-devel
218 Requires:       libtheora-devel >= 1.0-0.beta3
219 %{?with_va:Requires:    libva-devel >= 1.0.3}
220 Requires:       libvorbis-devel
221 %{?with_vpx:Requires:   libvpx-devel >= 0.9.7}
222 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
223 Requires:       opencore-amr-devel
224 %{?with_opencv:Requires:        opencv-devel}
225 Requires:       openjpeg-devel >= 1.5
226 Requires:       schroedinger-devel
227 %{?with_shine:Requires: shine-devel}
228 %{?with_soxr:Requires:  soxr-devel}
229 Requires:       speex-devel >= 1:1.2-rc1
230 Requires:       twolame-devel
231 %{?with_utvideo:Requires:       utvideo-devel >= 12}
232 %{?with_vidstab:Requires:       vid.stab-devel}
233 Requires:       vo-aacenc-devel
234 Requires:       vo-amrwbenc-devel
235 %{?with_wavpack:Requires:       wavpack-devel}
236 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
237 Requires:       xavs-devel
238 Requires:       xorg-lib-libXext-devel
239 Requires:       xorg-lib-libXfixes-devel
240 Requires:       xvid-devel >= 1:1.1.0
241 %{?with_zmq:Requires:   zeromq-devel}
242 Requires:       zlib-devel
243 Obsoletes:      libpostproc-devel
244
245 %description devel
246 ffmpeg header files.
247
248 %description devel -l pl.UTF-8
249 Pliki nagłówkowe ffmpeg.
250
251 %package static
252 Summary:        ffmpeg static libraries
253 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
254 Group:          Development/Libraries
255 Requires:       %{name}-devel = %{version}-%{release}
256
257 %description static
258 ffmpeg static libraries (libavcodec and libavformat).
259
260 %description static -l pl.UTF-8
261 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
262
263 %package ffplay
264 Summary:        FFplay - SDL-based media player
265 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
266 Group:          Applications/Multimedia
267 Requires:       %{name}-libs = %{version}-%{release}
268
269 %description ffplay
270 FFplay is a very simple and portable media player using the FFmpeg
271 libraries and the SDL library. It is mostly used as a test bench for
272 the various APIs of FFmpeg.
273
274 %description ffplay -l pl.UTF-8
275 FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
276 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
277 testowania różnych API FFmpeg.
278
279 %package ffserver
280 Summary:        FFserver video server
281 Summary(pl.UTF-8):      FFserver - serwer strumieni obrazu
282 Group:          Daemons
283 Requires(post,preun):   /sbin/chkconfig
284 Requires:       %{name}-libs = %{version}-%{release}
285 Requires:       rc-scripts >= 0.4.0.10
286
287 %description ffserver
288 FFserver is a streaming server for both audio and video. It supports
289 several live feeds, streaming from files and time shifting on live
290 feeds (you can seek to positions in the past on each live feed,
291 provided you specify a big enough feed storage in ffserver.conf).
292
293 %description ffserver -l pl.UTF-8
294 FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
295 źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
296 czasie dla źródeł na żywo (można przeskakiwać na położenia w
297 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
298 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
299
300 %prep
301 %setup -q
302 %patch0 -p1
303
304 # package the grep result for mplayer, the result formatted as ./mplayer/configure
305 cat <<EOF > ffmpeg-avconfig
306 #! /bin/sh
307 libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
308 libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
309 libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
310 libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
311 libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
312 libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
313 libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
314 libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
315 libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
316 EOF
317 cat <<'EOF' >> ffmpeg-avconfig
318
319 case "$1" in
320 --decoders)
321         echo $libavdecoders_all
322         ;;
323 --encoders)
324         echo $libavencoders_all
325         ;;
326 --parsers)
327         echo $libavparsers_all
328         ;;
329 --bsfs)
330         echo $libavbsfs_all
331         ;;
332 --demuxers)
333         echo $libavdemuxers_all
334         ;;
335 --muxers)
336         echo $libavmuxers_all
337         ;;
338 --protocols)
339         echo $libavprotocols_all
340         ;;
341 --hwaccels)
342         echo $libavhwaccels_all
343         ;;
344 --filters)
345         echo $libavfilters_all
346         ;;
347 *)
348         cat <<USAGE
349 Usage: $0 [OPTION]
350 Options:
351   --decoders
352   --encoders
353   --parsers
354   --bsfs
355   --demuxers
356   --muxers
357   --protocols
358   --hwaccels
359   --filters
360 USAGE
361         exit 1;;
362 esac
363
364 exit 0
365 EOF
366
367 %build
368 # notes:
369 # - it's not autoconf configure
370 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
371 ./configure \
372         --arch=%{_target_base_arch} \
373         --prefix=%{_prefix} \
374         --libdir=%{_libdir} \
375         --shlibdir=%{_libdir} \
376         --mandir=%{_mandir} \
377         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
378         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
379         --cc="%{__cc}" \
380         --disable-debug \
381         --disable-optimizations \
382         --disable-stripping \
383         --enable-avfilter \
384         --enable-avresample \
385         --enable-gnutls \
386         --enable-gpl \
387         --enable-version3 \
388         --enable-fontconfig \
389         %{?with_frei0r:--enable-frei0r} \
390         %{?with_aacplus:--enable-libaacplus} \
391         --enable-libass \
392         --enable-libbluray \
393         %{?with_caca:--enable-libcaca} \
394         --enable-libcelt \
395         --enable-libcdio \
396         --enable-libdc1394 \
397         %{?with_fdk_aac:--enable-libfdk-aac} \
398         %{?with_flite:--enable-libflite} \
399         --enable-libfreetype \
400         %{?with_gme:--enable-libgme} \
401         --enable-libgsm \
402         --enable-libiec61883 \
403         %{?with_ilbc:--enable-libilbc} \
404         --enable-libmodplug \
405         --enable-libmp3lame \
406         --enable-libnut \
407         --enable-libopencore-amrnb \
408         --enable-libopencore-amrwb \
409         %{?with_opencv:--enable-libopencv} \
410         --enable-libopenjpeg \
411         --enable-libopus \
412         %{?with_pulseaudio:--enable-libpulse} \
413         %{?with_quvi:--enable-libquvi} \
414         --enable-librtmp \
415         --enable-libschroedinger \
416         %{?with_shine:--enable-libshine} \
417         %{?with_soxr:--enable-libsoxr} \
418         --enable-libspeex \
419         --enable-libtheora \
420         --enable-libtwolame \
421         %{?with_utvideo:--enable-libutvideo} \
422         --enable-libv4l2 \
423         %{?with_vidstab:--enable-libvidstab} \
424         --enable-libvo-aacenc \
425         --enable-libvo-amrwbenc \
426         --enable-libvorbis \
427         %{?with_vpx:--enable-libvpx} \
428         %{?with_wavpack:--enable-libwavpack} \
429         %{?with_x264:--enable-libx264} \
430         --enable-libxavs \
431         --enable-libxvid \
432         %{?with_zmq:--enable-libzmq} \
433         %{?with_openal:--enable-openal} \
434         %{?with_opencl:--enable-opencl} \
435         --enable-postproc \
436         --enable-pthreads \
437         --enable-shared \
438         --enable-swscale \
439         %{!?with_va:--disable-vaapi} \
440         --enable-x11grab \
441 %ifnarch %{ix86} %{x8664}
442         --disable-mmx \
443 %endif
444 %ifarch i386 i486
445         --disable-mmx \
446 %endif
447 %if %{with nonfree}
448         --enable-nonfree \
449         --enable-libfaac \
450 %endif
451         --enable-runtime-cpudetect
452
453 # force oldscaler build
454 %{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
455
456 %{__make} \
457         V=1
458
459 # CC_O to add -c to commandline. makefile should be patched
460 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
461
462 %install
463 rm -rf $RPM_BUILD_ROOT
464 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
465         $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
466         $RPM_BUILD_ROOT/var/{cache,log}/ffserver
467
468 %{__make} install install-headers \
469         DESTDIR=$RPM_BUILD_ROOT \
470         V=1
471
472 # install nonstandard, non-public headers manually
473 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
474 for a in libavutil/*/bswap.h; do
475         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
476 done
477 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
478 # for lim-omx ffmpeg components
479 cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
480
481 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
482 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
483 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
484 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
485 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
486
487 # install as ffmpeg-avconfig to avoid with possible programs looking for
488 # ffmpeg-config and expecting --libs output from it which is not implemented
489 # simple to do (by querying pkgconfig), but why?
490 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
491
492 %clean
493 rm -rf $RPM_BUILD_ROOT
494
495 %post   libs -p /sbin/ldconfig
496 %postun libs -p /sbin/ldconfig
497
498 %pre ffserver
499 %groupadd -g 167 ffserver
500 %useradd -g ffserver -u 167 ffserver
501
502 %post ffserver
503 /sbin/chkconfig --add ffserver
504 %service ffserver restart
505
506 %preun ffserver
507 if [ "$1" = 0 ]; then
508         %service ffserver stop
509         /sbin/chkconfig --del ffserver
510 fi
511
512 %postun ffserver
513 if [ "$1" = 0 ]; then
514         %userremove ffserver
515         %groupremove ffserver
516 fi
517
518 %files
519 %defattr(644,root,root,755)
520 %doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
521 %attr(755,root,root) %{_bindir}/ffmpeg
522 %attr(755,root,root) %{_bindir}/ffprobe
523 %attr(755,root,root) %{_bindir}/qt-faststart
524 %dir %{_datadir}/ffmpeg
525 %{_datadir}/ffmpeg/*.ffpreset
526 %{_datadir}/ffmpeg/ffprobe.xsd
527 %if %{with doc}
528 %{_mandir}/man1/ffmpeg.1*
529 %{_mandir}/man1/ffmpeg-all.1*
530 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
531 %{_mandir}/man1/ffmpeg-codecs.1*
532 %{_mandir}/man1/ffmpeg-devices.1*
533 %{_mandir}/man1/ffmpeg-filters.1*
534 %{_mandir}/man1/ffmpeg-formats.1*
535 %{_mandir}/man1/ffmpeg-protocols.1*
536 %{_mandir}/man1/ffmpeg-resampler.1*
537 %{_mandir}/man1/ffmpeg-scaler.1*
538 %{_mandir}/man1/ffmpeg-utils.1*
539 %{_mandir}/man1/ffprobe.1*
540 %{_mandir}/man1/ffprobe-all.1*
541 %endif
542
543 %files libs
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
546 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.55
547 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
548 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.55
549 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
550 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
551 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
552 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.55
553 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
554 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.1
555 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
556 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.52
557 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
558 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
559 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
560 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
561 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
562 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
563
564 %files devel
565 %defattr(644,root,root,755)
566 %doc doc/optimization.txt
567 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
568 %attr(755,root,root) %{_libdir}/libavcodec.so
569 %attr(755,root,root) %{_libdir}/libavdevice.so
570 %attr(755,root,root) %{_libdir}/libavfilter.so
571 %attr(755,root,root) %{_libdir}/libavformat.so
572 %attr(755,root,root) %{_libdir}/libavresample.so
573 %attr(755,root,root) %{_libdir}/libavutil.so
574 %attr(755,root,root) %{_libdir}/libpostproc.so
575 %attr(755,root,root) %{_libdir}/libswresample.so
576 %attr(755,root,root) %{_libdir}/libswscale.so
577 %{_includedir}/ffmpeg
578 %{_includedir}/libavcodec
579 %{_includedir}/libavdevice
580 %{_includedir}/libavfilter
581 %{_includedir}/libavformat
582 %{_includedir}/libavresample
583 %{_includedir}/libavutil
584 %{_includedir}/libpostproc
585 %{_includedir}/libswresample
586 %{_includedir}/libswscale
587 %{_pkgconfigdir}/libavcodec.pc
588 %{_pkgconfigdir}/libavdevice.pc
589 %{_pkgconfigdir}/libavfilter.pc
590 %{_pkgconfigdir}/libavformat.pc
591 %{_pkgconfigdir}/libavresample.pc
592 %{_pkgconfigdir}/libavutil.pc
593 %{_pkgconfigdir}/libpostproc.pc
594 %{_pkgconfigdir}/libswresample.pc
595 %{_pkgconfigdir}/libswscale.pc
596 %if %{with doc}
597 %{_mandir}/man3/libavcodec.3*
598 %{_mandir}/man3/libavdevice.3*
599 %{_mandir}/man3/libavfilter.3*
600 %{_mandir}/man3/libavformat.3*
601 %{_mandir}/man3/libavutil.3*
602 %{_mandir}/man3/libswresample.3*
603 %{_mandir}/man3/libswscale.3*
604 %endif
605
606 %files static
607 %defattr(644,root,root,755)
608 %{_libdir}/libavcodec.a
609 %{_libdir}/libavdevice.a
610 %{_libdir}/libavfilter.a
611 %{_libdir}/libavformat.a
612 %{_libdir}/libavresample.a
613 %{_libdir}/libavutil.a
614 %{_libdir}/libpostproc.a
615 %{_libdir}/libswresample.a
616 %{_libdir}/libswscale.a
617
618 %files ffplay
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_bindir}/ffplay
621 %if %{with doc}
622 %{_mandir}/man1/ffplay.1*
623 %{_mandir}/man1/ffplay-all.1*
624 %endif
625
626 %files ffserver
627 %defattr(644,root,root,755)
628 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
629 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
630 %attr(755,root,root) %{_sbindir}/ffserver
631 %attr(754,root,root) /etc/rc.d/init.d/ffserver
632 %if %{with doc}
633 %{_mandir}/man1/ffserver.1*
634 %{_mandir}/man1/ffserver-all.1*
635 %endif
636 %dir %attr(770,root,ffserver) /var/cache/ffserver
637 %dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.06751 seconds and 3 git commands to generate.