]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
cfd946a73ffccf94fa69c71e260462302c29325c
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2          # we can safely play without it :-)
4 %bcond_without  autoreqdep      # don't care about package name deps generated by rpm
5 #
6 Summary:        Realtime audio/video encoder and streaming server
7 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
8 Name:           ffmpeg
9 Version:        0.4.9
10 %define snap    20050806
11 Release:        3.%{snap}.1
12 # LGPL or GPL, chosen at configure time (GPL version is more featured)
13 License:        GPL
14 Group:          Daemons
15 #Source0:       http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
16 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
17 # Source0-md5:  f5ea3dd877c5df5b60356053642cf542
18 Patch0:         %{name}-libtool.patch
19 Patch1:         %{name}-libdir.patch
20 URL:            http://ffmpeg.sourceforge.net/
21 BuildRequires:  SDL-devel
22 BuildRequires:  faac-devel
23 BuildRequires:  freetype-devel
24 %ifarch ppc
25 # require version with altivec support fixed
26 BuildRequires:  gcc >= 5:3.3.2-3
27 %endif
28 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
29 BuildRequires:  lame-libs-devel
30 BuildRequires:  libtheora-devel
31 BuildRequires:  libtool >= 2:1.4d-3
32 BuildRequires:  libvorbis-devel
33 %ifarch %{ix86}
34 %ifnarch i386 i486
35 BuildRequires:  nasm
36 %endif
37 %endif
38 BuildRequires:  perl-tools-pod
39 BuildRequires:  tetex
40 BuildRequires:  texinfo
41 BuildRequires:  zlib-devel
42 %{?with_autoreqdep:BuildConflicts:      libpostproc}
43 Obsoletes:      libpostproc
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
47
48 %description
49 ffmpeg is a hyper fast realtime audio/video encoder and streaming
50 server. It can grab from a standard Video4Linux video source and
51 convert it into several file formats based on DCT/motion compensation
52 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
53 compatible stream.
54
55 This package contains also ffmpeg shared libraries (libavcodec and
56 libavformat).
57
58 %description -l pl
59 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
60 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
61 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
62 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
63 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
64 strumienia kompatybilnego z AC3.
65
66 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
67 libavformat).
68
69 %package devel
70 Summary:        ffmpeg header files
71 Summary(pl):    Pliki nag³ówkowe ffmpeg
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Obsoletes:      libpostproc-devel
75
76 %description devel
77 ffmpeg header files.
78
79 %description devel -l pl
80 Pliki nag³ówkowe ffmpeg.
81
82 %package static
83 Summary:        ffmpeg static libraries
84 Summary(pl):    Statyczne biblioteki ffmpeg
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 ffmpeg static libraries (libavcodec and libavformat).
90
91 %description static -l pl
92 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
93
94 %package ffplay
95 Summary:        FFplay - SDL-based media player
96 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
97 Group:          Applications/Multimedia
98 Requires:       %{name} = %{version}-%{release}
99
100 %description ffplay
101 FFplay is a very simple and portable media player using the FFmpeg
102 libraries and the SDL library. It is mostly used as a test bench for
103 the various APIs of FFmpeg.
104
105 %description ffplay -l pl
106 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
107 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
108 testowania ró¿nych API FFmpeg.
109
110 %package vhook-imlib2
111 Summary:        imlib2 based hook
112 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
113 Group:          Libraries
114 Requires:       %{name} = %{version}-%{release}
115
116 %description vhook-imlib2
117 This module implements a text overlay for a video image. Currently it
118 supports a fixed overlay or reading the text from a file. The string
119 is passed through strftime so that it is easy to imprint the date and
120 time onto the image.
121
122 %description vhook-imlib2 -l pl
123 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
124 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
125 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
126 obrazie.
127
128 %prep
129 %setup -q -n FFMpeg-%{snap}
130 %patch0 -p1
131 %patch1 -p1
132
133 %build
134 # notes:
135 # - it's not autoconf configure
136 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
137 #   (-fPIC takes one)
138 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
139 ./configure \
140         --prefix=%{_prefix} \
141         --libdir=%{_libdir} \
142         --mandir=%{_mandir} \
143         --disable-strip \
144         --enable-a52bin \
145         --enable-faac \
146         --enable-faadbin \
147         --enable-gpl \
148         --enable-libogg \
149         --enable-mp3lame \
150         --enable-pp \
151         --enable-pthreads \
152         --enable-shared \
153         --enable-shared-pp \
154         --enable-theora \
155         --enable-vorbis \
156 %ifnarch %{ix86}
157         --disable-mmx \
158 %endif
159 %ifarch i386 i486
160         --disable-mmx \
161 %endif
162         --cc="%{__cc}" \
163         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
164         --extra-ldflags="%{rpmldflags}" \
165         --disable-debug \
166         --disable-opts \
167         --tune=generic
168
169 %{__make} \
170         BUILD_DOC=yes \
171         LIBVERSION=%{snap}
172
173 %install
174 rm -rf $RPM_BUILD_ROOT
175 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
176
177 %{__make} install \
178         DESTDIR=$RPM_BUILD_ROOT
179
180 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
181 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %post   -p /sbin/ldconfig
187 %postun -p /sbin/ldconfig
188
189 %files
190 %defattr(644,root,root,755)
191 %doc Changelog README doc/*.html
192 %attr(755,root,root) %{_bindir}/ffmpeg
193 %attr(755,root,root) %{_sbindir}/ffserver
194 %attr(755,root,root) %{_libdir}/libavcodec-*.so
195 %attr(755,root,root) %{_libdir}/libavformat-*.so
196 %attr(755,root,root) %{_libdir}/libavutil-*.so
197 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
198 %dir %{_libdir}/vhook
199 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
200 %attr(755,root,root) %{_libdir}/vhook/fish.so
201 %attr(755,root,root) %{_libdir}/vhook/null.so
202 %attr(755,root,root) %{_libdir}/vhook/ppm.so
203 %attr(755,root,root) %{_libdir}/vhook/watermark.so
204 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
205 %{_mandir}/man1/ffmpeg.1*
206 %{_mandir}/man1/ffserver.1*
207
208 %files devel
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_libdir}/libavcodec.so
211 %attr(755,root,root) %{_libdir}/libavformat.so
212 %attr(755,root,root) %{_libdir}/libavutil.so
213 %attr(755,root,root) %{_libdir}/libpostproc.so
214 %{_libdir}/lib*.la
215 %{_includedir}/ffmpeg
216 %{_includedir}/postproc
217 %{_pkgconfigdir}/*.pc
218
219 %files static
220 %defattr(644,root,root,755)
221 %{_libdir}/lib*.a
222
223 %files ffplay
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{_bindir}/ffplay
226 %{_mandir}/man1/ffplay.1*
227
228 %if %{with imlib2}
229 %files vhook-imlib2
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
232 %endif
This page took 0.034724 seconds and 3 git commands to generate.