]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
c4347c16a2de10e04185325e87f904ea69ec6284
[packages/ffmpeg.git] / ffmpeg.spec
1 # TODO
2 # - libnut enabled   no (http://www.nut-container.org/)
3 #
4 # Conditional build:
5 %bcond_with     nonfree         # non free options of package
6 %bcond_without  autoreqdep      # don't care about package name deps generated by rpm
7 %bcond_without  imlib2          # don't build imlib2 vhook module
8
9 Summary:        FFmpeg is a very fast video and audio converter
10 Summary(pl.UTF-8):      Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
11 Name:           ffmpeg
12 Version:        0.6
13 Release:        4
14 # LGPL or GPL, chosen at configure time (GPL version is more featured)
15 # (postprocessing, ac3, xvid, x264, faad)
16 License:        GPL v3+ with LGPL v3+ parts
17 Group:          Applications/Multimedia
18 Source0:        http://ffmpeg.mplayerhq.hu/releases/%{name}-%{version}.tar.bz2
19 # Source0-md5:  d6142a9a5821d6a6262a6edb903faa24
20 Source1:        ffserver.init
21 Source2:        ffserver.sysconfig
22 Source3:        ffserver.conf
23 Patch0:         %{name}-bug-803.patch
24 Patch1:         %{name}-gsm.patch
25 Patch2:         faadbin-libfaadname.patch
26 # vhook is gone. this patch needs different approach
27 #PatchX: imagewidth.patch
28 URL:            http://www.ffmpeg.org/
29 BuildRequires:  SDL-devel
30 BuildRequires:  dirac-devel >= 1.0.0
31 BuildRequires:  faac-devel
32 BuildRequires:  faad2-devel
33 BuildRequires:  freetype-devel
34 %ifarch ppc
35 # require version with altivec support fixed
36 BuildRequires:  gcc >= 5:3.3.2-3
37 %endif
38 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.3.0}
39 BuildRequires:  lame-libs-devel
40 BuildRequires:  libdc1394-devel
41 BuildRequires:  libgsm-devel
42 BuildRequires:  libraw1394-devel
43 BuildRequires:  libtheora-devel >= 1.0-0.beta3
44 BuildRequires:  libtool >= 2:1.4d-3
45 BuildRequires:  libva-devel >= 1.0.3
46 BuildRequires:  libvdpau-devel
47 BuildRequires:  libvorbis-devel
48 BuildRequires:  libvpx-devel >= 0.9.1
49 # X264_BUILD >= 83
50 BuildRequires:  libx264-devel >= 0.1.3-1.20100424_2245.1
51 BuildRequires:  opencore-amr-devel
52 BuildRequires:  openjpeg-devel >= 1.3-2
53 BuildRequires:  speex-devel >= 1:1.2-rc1
54 %ifarch %{ix86}
55 %ifnarch i386 i486
56 BuildRequires:  nasm
57 %endif
58 %endif
59 BuildRequires:  perl-Encode
60 BuildRequires:  perl-tools-pod
61 BuildRequires:  pkgconfig
62 BuildRequires:  rpmbuild(macros) >= 1.470
63 BuildRequires:  schroedinger-devel
64 BuildRequires:  tetex
65 BuildRequires:  texi2html
66 BuildRequires:  texinfo
67 BuildRequires:  xvid-devel >= 1:1.1.0
68 BuildRequires:  zlib-devel
69 %{?with_autoreqdep:BuildConflicts:      libpostproc}
70 Requires:       %{name}-libs = %{version}-%{release}
71 Requires:       xvid >= 1:1.1.0
72 Obsoletes:      libpostproc
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
76
77 %define         specflags       -fno-strict-aliasing
78
79 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
80 %define         specflags_ia32  -fomit-frame-pointer
81 # -mmmx is needed to enable <mmintrin.h> code.
82 %define         specflags_i586  -mmmx
83 %define         specflags_i686  -mmmx
84 %define         specflags_ppc   -fPIC
85
86 %description
87 FFmpeg is a complete solution to record, convert and stream audio and
88 video. It is a command line tool to convert one video file format to
89 another. It also supports grabbing and encoding in real time from a TV
90 card.
91
92 %description -l pl.UTF-8
93 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
94 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucać dane
95 ze standardowego urządzenia Video4Linux i przekonwertować je w kilka
96 formatów plików bazujących na kodowaniu DCT/kompensacji ruchu. Dźwięk
97 jest kompresowany do strumienia MPEG audio layer 2 lub używając
98 strumienia kompatybilnego z AC3.
99
100 %package libs
101 Summary:        ffmpeg libraries
102 Summary(pl.UTF-8):      Biblioteki ffmpeg
103 Group:          Libraries
104
105 %description libs
106 This package contains:
107 - the codec library from the ffmpeg project. It supports most existing
108   encoding formats (MPEG, DivX, MPEG4, AC3, DV...),
109 - demuxer library from the ffmpeg project. It supports most existing
110   file formats (AVI, MPEG, OGG, Matroska, ASF...),
111 - video postprocessing library from the ffmpeg project.
112
113 %description libs -l pl.UTF-8
114 Ten pakiet zawiera biblioteki współdzielone ffmpeg.
115
116 %package devel
117 Summary:        ffmpeg header files
118 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
119 Group:          Development/Libraries
120 Requires:       %{name}-libs = %{version}-%{release}
121 # for libavcodec:
122 Requires:       dirac-devel
123 Requires:       faac-devel
124 Requires:       faad2-devel
125 Requires:       lame-libs-devel
126 Requires:       libgsm-devel
127 Requires:       libraw1394-devel
128 Requires:       libtheora-devel >= 1.0-0.alpha7
129 Requires:       libvorbis-devel
130 Requires:       libx264-devel >= 0.1.2-1.20060828_2245.1
131 Requires:       xvid-devel >= 1:1.1.0
132 Requires:       zlib-devel
133 Obsoletes:      libpostproc-devel
134
135 %description devel
136 ffmpeg header files.
137
138 %description devel -l pl.UTF-8
139 Pliki nagłówkowe ffmpeg.
140
141 %package static
142 Summary:        ffmpeg static libraries
143 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
144 Group:          Development/Libraries
145 Requires:       %{name}-devel = %{version}-%{release}
146
147 %description static
148 ffmpeg static libraries (libavcodec and libavformat).
149
150 %description static -l pl.UTF-8
151 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
152
153 %package ffplay
154 Summary:        FFplay - SDL-based media player
155 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
156 Group:          Applications/Multimedia
157 Requires:       %{name}-libs = %{version}-%{release}
158
159 %description ffplay
160 FFplay is a very simple and portable media player using the FFmpeg
161 libraries and the SDL library. It is mostly used as a test bench for
162 the various APIs of FFmpeg.
163
164 %description ffplay -l pl.UTF-8
165 FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
166 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
167 testowania różnych API FFmpeg.
168
169 %package ffserver
170 Summary:        FFserver video server
171 Summary(pl.UTF-8):      FFserver - serwer strumieni obrazu
172 Group:          Daemons
173 Requires(post,preun):   /sbin/chkconfig
174 Requires:       %{name}-libs = %{version}-%{release}
175 Requires:       rc-scripts >= 0.4.0.10
176
177 %description ffserver
178 FFserver is a streaming server for both audio and video. It supports
179 several live feeds, streaming from files and time shifting on live
180 feeds (you can seek to positions in the past on each live feed,
181 provided you specify a big enough feed storage in ffserver.conf).
182
183 %description ffserver -l pl.UTF-8
184 FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
185 źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
186 czasie dla źródeł na żywo (można przeskakiwać na położenia w
187 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
188 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
189
190 %prep
191 %setup -q
192 %patch0 -p1
193 %patch1 -p0
194 %patch2 -p1
195
196 # package the grep result for mplayer, the result formatted as ./mplayer/configure
197 cat <<EOF > ffmpeg-avconfig
198 #! /bin/sh
199 _libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
200 _libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
201 _libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
202 _libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
203 _libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
204 _libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
205 _libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
206 EOF
207 cat <<'EOF' >> ffmpeg-avconfig
208
209 case "$1" in
210 --decoders)
211         echo $_libavdecoders_all
212         ;;
213 --encoders)
214         echo $_libavencoders_all
215         ;;
216 --parsers)
217         echo $_libavparsers_all
218         ;;
219 --bsfs)
220         echo $_libavbsfs_all
221         ;;
222 --demuxers)
223         echo $_libavdemuxers_all
224         ;;
225 --muxers)
226         echo $_libavmuxers_all
227         ;;
228 --protocols)
229         echo $_libavprotocols_all
230         ;;
231 *)
232         cat <<USAGE
233 Usage: $0 [OPTION]
234 Options:
235   --decoders
236   --encoders
237   --parsers
238   --bsfs
239   --demuxers
240   --muxers
241   --protocols
242 USAGE
243         exit 1;;
244 esac
245
246 exit 0
247 EOF
248
249 %build
250 # notes:
251 # - it's not autoconf configure
252 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
253 ./configure \
254         --arch=%{_target_base_arch} \
255         --prefix=%{_prefix} \
256         --libdir=%{_libdir} \
257         --shlibdir=%{_libdir} \
258         --mandir=%{_mandir} \
259         --cc="%{__cc}" \
260         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
261         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
262         --disable-debug \
263         --disable-optimizations \
264         --disable-stripping \
265         --enable-avfilter \
266         --enable-gpl \
267         --enable-version3 \
268         --enable-libdc1394 \
269         --enable-libdirac \
270         --enable-libfaad \
271         --enable-libgsm \
272         --enable-libmp3lame \
273         --enable-libschroedinger \
274         --enable-libspeex \
275         --enable-libtheora \
276         --enable-libvorbis \
277         --enable-libvpx \
278         --enable-libx264 \
279         --enable-libxvid \
280         --enable-libopencore-amrnb \
281         --enable-libopencore-amrwb \
282         --enable-libopenjpeg \
283         --enable-postproc \
284         --enable-pthreads \
285         --enable-shared \
286         --enable-swscale \
287         --enable-vdpau \
288         --enable-x11grab \
289 %ifnarch %{ix86} %{x8664}
290         --disable-mmx \
291 %endif
292 %ifarch i386 i486
293         --disable-mmx \
294 %endif
295 %if %{with nonfree}
296         --enable-nonfree \
297         --enable-libfaac \
298 %endif
299         --enable-runtime-cpudetect
300
301 # force oldscaler build
302 sed -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
303
304 %{__make}
305
306 %install
307 rm -rf $RPM_BUILD_ROOT
308 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
309         $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
310         $RPM_BUILD_ROOT/var/{cache,log}/ffserver
311
312 %{__make} install \
313         DESTDIR=$RPM_BUILD_ROOT
314
315 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
316 cp -a libavutil/intreadwrite.h $RPM_BUILD_ROOT%{_includedir}/libavutil
317 cp -a libavutil/bswap.h $RPM_BUILD_ROOT%{_includedir}/libavutil
318 cp -a libavutil/common.h $RPM_BUILD_ROOT%{_includedir}/libavutil
319 cp -a libavutil/mem.h $RPM_BUILD_ROOT%{_includedir}/libavutil
320 for a in libavutil/*/bswap.h; do
321         install -D $a $RPM_BUILD_ROOT%{_includedir}/$a
322 done
323 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
324 cp -a libavformat/avio.h $RPM_BUILD_ROOT%{_includedir}/libavformat
325
326 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
327 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
328 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
329 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
330
331 # install as ffmpeg-avconfig to avoid with possible programs looking for
332 # ffmpeg-config and expecting --libs output from it which is not implemented
333 # simple to do (by querying pkgconfig), but why?
334 install ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
335
336 %clean
337 rm -rf $RPM_BUILD_ROOT
338
339 %post libs      -p /sbin/ldconfig
340 %postun libs    -p /sbin/ldconfig
341
342 %pre ffserver
343 %groupadd -g 167 ffserver
344 %useradd -g ffserver -u 167 ffserver
345
346 %post ffserver
347 /sbin/chkconfig --add ffserver
348 %service ffserver restart
349
350 %preun ffserver
351 if [ "$1" = 0 ]; then
352         %service ffserver stop
353         /sbin/chkconfig --del ffserver
354 fi
355
356 %postun ffserver
357 if [ "$1" = 0 ]; then
358         %userremove ffserver
359         %groupremove ffserver
360 fi
361
362 %files
363 %defattr(644,root,root,755)
364 %doc Changelog README doc/*.html doc/TODO
365 %attr(755,root,root) %{_bindir}/ffmpeg
366 %attr(755,root,root) %{_bindir}/ffprobe
367 %dir %{_datadir}/ffmpeg
368 %{_datadir}/ffmpeg/*.ffpreset
369 %{_mandir}/man1/ffmpeg.1*
370 %{_mandir}/man1/ffprobe.1*
371
372 %files libs
373 %defattr(644,root,root,755)
374 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
375 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.52
376 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
377 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.52
378 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
379 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.1
380 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
381 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.52
382 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
383 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.50
384 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
385 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.51
386 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
387 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.0
388
389 %files devel
390 %defattr(644,root,root,755)
391 %doc doc/optimization.txt
392 %attr(755,root,root) %{_libdir}/libavcodec.so
393 %attr(755,root,root) %{_libdir}/libavdevice.so
394 %attr(755,root,root) %{_libdir}/libavfilter.so
395 %attr(755,root,root) %{_libdir}/libavformat.so
396 %attr(755,root,root) %{_libdir}/libavutil.so
397 %attr(755,root,root) %{_libdir}/libpostproc.so
398 %attr(755,root,root) %{_libdir}/libswscale.so
399 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
400 %{_includedir}/ffmpeg
401 %{_includedir}/libavcodec
402 %{_includedir}/libavdevice
403 %{_includedir}/libavfilter
404 %{_includedir}/libavformat
405 %{_includedir}/libavutil
406 %{_includedir}/libpostproc
407 %{_includedir}/libswscale
408 %{_pkgconfigdir}/*.pc
409
410 %files static
411 %defattr(644,root,root,755)
412 %{_libdir}/lib*.a
413
414 %files ffplay
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{_bindir}/ffplay
417 %{_mandir}/man1/ffplay.1*
418
419 %files ffserver
420 %defattr(644,root,root,755)
421 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
422 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
423 %attr(755,root,root) %{_sbindir}/ffserver
424 %attr(754,root,root) /etc/rc.d/init.d/ffserver
425 %{_mandir}/man1/ffserver.1*
426 %dir %attr(770,root,ffserver) /var/cache/ffserver
427 %dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.045719 seconds and 2 git commands to generate.