]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
93a31691c5f942688059e1e5a4bf3fd902cfc12c
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib   # we can safely play without it :-)
4 #
5 Summary:        Realtime audio/video encoder and streaming server
6 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
7 Name:           ffmpeg
8 Version:        0.4.8
9 Release:        4
10 License:        LGPL/GPL
11 Group:          Daemons
12 Source0:        http://dl.sourceforge.net/ffmpeg/%{name}-%{version}.tar.gz
13 # Source0-md5:  e00d47614ba1afd99ad2ea387e782dd9
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-imlib2.patch
16 Patch2:         %{name}-libtool.patch
17 Patch3:         %{name}-lib64.patch
18 URL:            http://ffmpeg.sourceforge.net/
19 BuildRequires:  SDL-devel
20 BuildRequires:  freetype-devel
21 %ifarch ppc
22 # require version with altivec support fixed
23 BuildRequires:  gcc >= 5:3.3.2-3
24 %endif
25 %{?with_imlib:BuildRequires:    imlib2-devel >= 1.1.0-2}
26 BuildRequires:  libtool >= 2:1.4d-3
27 %ifarch i586 i686 athlon
28 BuildRequires:  nasm
29 %endif
30 BuildRequires:  zlib-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
34
35 %description
36 ffmpeg is a hyper fast realtime audio/video encoder and streaming
37 server. It can grab from a standard Video4Linux video source and
38 convert it into several file formats based on DCT/motion compensation
39 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
40 compatible stream.
41
42 This package contains also ffmpeg shared libraries (libavcodec and
43 libavformat).
44
45 %description -l pl
46 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
47 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
48 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
49 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
50 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
51 strumienia kompatybilnego z AC3.
52
53 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
54 libavformat).
55
56 %package ffplay
57 Summary:        FFplay - SDL-based media player
58 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
59 Group:          Applications/Multimedia
60 Requires:       %{name} = %{version}
61
62 %description ffplay
63 FFplay is a very simple and portable media player using the FFmpeg
64 libraries and the SDL library. It is mostly used as a test bench for
65 the various APIs of FFmpeg.
66
67 %description ffplay -l pl
68 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
69 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
70 testowania ró¿nych API FFmpeg.
71
72 %package vhook-imlib2
73 Summary:        imlib2 based hook
74 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
75 Group:          Libraries
76 Requires:       %{name} = %{version}
77
78 %description vhook-imlib2
79 This module implements a text overlay for a video image. Currently it
80 supports a fixed overlay or reading the text from a file. The string
81 is passed through strftime so that it is easy to imprint the date and
82 time onto the image.
83
84 %description vhook-imlib2 -l pl
85 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
86 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
87 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
88 obrazie.
89
90 %package devel
91 Summary:        ffmpeg header files
92 Summary(pl):    Pliki nag³ówkowe ffmpeg
93 Group:          Development/Libraries
94 Requires:       %{name} = %{version}
95
96 %description devel
97 ffmpeg header files.
98
99 %description devel -l pl
100 Pliki nag³ówkowe ffmpeg.
101
102 %package static
103 Summary:        ffmpeg static libraries
104 Summary(pl):    Statyczne biblioteki ffmpeg
105 Group:          Development/Libraries
106 Requires:       %{name}-devel = %{version}
107
108 %description static
109 ffmpeg static libraries (libavcodec and libavformat).
110
111 %description static -l pl
112 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
113
114 %prep
115 %setup -q
116 %patch0 -p1
117 %patch1 -p1
118 %patch2 -p1
119 %ifarch amd64
120 %patch3 -p1
121 %endif
122
123 %build
124 # notes:
125 # - it's not autoconf configure
126 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
127 #   (-fPIC takes one)
128 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
129 ./configure \
130         --prefix=%{_prefix} \
131         --mandir=%{_mandir} \
132         --enable-shared \
133         --enable-a52bin \
134         --enable-faadbin \
135 %ifnarch i586 i686 athlon
136         --disable-mmx \
137 %endif
138         --cc="%{__cc}" \
139         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
140         --extra-ldflags="%{rpmldflags}" \
141         --disable-debug \
142         --disable-opts \
143         --tune=generic
144
145 %{__make}
146
147 %{__make} -C doc
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
157 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %doc Changelog README doc/*.html
168 %attr(755,root,root) %{_bindir}/ffmpeg
169 %attr(755,root,root) %{_sbindir}/ffserver
170 %attr(755,root,root) %{_libdir}/libavcodec-*.so
171 %attr(755,root,root) %{_libdir}/libavformat-*.so
172 %dir %{_libdir}/vhook
173 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
174 %attr(755,root,root) %{_libdir}/vhook/fish.so
175 %attr(755,root,root) %{_libdir}/vhook/null.so
176 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ffserver.conf
177 %{_mandir}/man1/ffmpeg.1*
178 %{_mandir}/man1/ffserver.1*
179
180 %files ffplay
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_bindir}/ffplay
183 %{_mandir}/man1/ffplay.1*
184
185 %if %{with imlib}
186 %files vhook-imlib2
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
189 %endif
190
191 %files devel
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/libavcodec.so
194 %attr(755,root,root) %{_libdir}/libavformat.so
195 %{_libdir}/lib*.la
196 %{_includedir}/ffmpeg
197
198 %files static
199 %defattr(644,root,root,755)
200 %{_libdir}/lib*.a
This page took 0.050716 seconds and 3 git commands to generate.