]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
79b18aff0e8352f77df998d4e6cbb8bdc239f515
[packages/ffmpeg.git] / ffmpeg.spec
1
2 # Conditional build:
3 # _without_imlib        - we can safetly play without it :-)
4
5
6 Summary:        Realtime audio/video encoder and streaming server
7 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
8 Name:           ffmpeg
9 Version:        0.4.6
10 Release:        1
11 License:        LGPL/GPL
12 Group:          Daemons
13 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/ffmpeg/%{name}-%{version}.tar.gz
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-imlib2.patch
16 Patch2:         %{name}-libtool.patch
17 URL:            http://ffmpeg.sourceforge.net/
18 %{!?_without_imlib:BuildRequires:       imlib2-devel}
19 BuildRequires:  libtool >= 1:1.4.2-9
20 %ifarch i586 i686 athlon
21 BuildRequires:  nasm
22 %endif
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 ffmpeg is a hyper fast realtime audio/video encoder and streaming
28 server. It can grab from a standard Video4Linux video source and
29 convert it into several file formats based on DCT/motion compensation
30 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
31 compatible stream.
32
33 This package contains also ffmpeg shared libraries (libavcodec and
34 libavformat).
35
36 %description -l pl
37 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
38 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
39 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
40 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
41 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
42 strumienia kompatybilnego z AC3.
43
44 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
45 libavformat).
46
47 %package vhook-imlib2
48 Summary:        imlib2 based hook
49 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
50 Group:          Libraries
51 Requires:       %{name} = %{version}
52
53 %description vhook-imlib2
54 This module implements a text overlay for a video image. Currently it
55 supports a fixed overlay or reading the text from a file. The string
56 is passed through strftime so that it is easy to imprint the date and
57 time onto the image.
58
59 %description vhook-imlib2 -l pl
60 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
61 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
62 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
63 obrazie.
64
65 %package devel
66 Summary:        ffmpeg header files
67 Summary(pl):    Pliki nag³ówkowe ffmpeg
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}
70
71 %description devel
72 ffmpeg header files.
73
74 %description devel -l pl
75 Pliki nag³ówkowe ffmpeg.
76
77 %package static
78 Summary:        ffmpeg static libraries
79 Summary(pl):    Statyczne biblioteki ffmpeg
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}
82
83 %description static
84 ffmpeg static libraries (libavcodec and libavformat).
85
86 %description static -l pl
87 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94
95 %build
96 # note: it's not autoconf configure
97 ./configure \
98         --prefix=%{_prefix} \
99         --enable-shared \
100         --enable-a52bin \
101 %ifnarch i586 i686 athlon
102         --disable-mmx
103 %endif
104
105 # note: -fomit-frame-pointer is always needed on x86 due to lack of registers
106 #       (-fPIC takes one)
107 %{__make} \
108         OPT="%{rpmcflags} -fomit-frame-pointer -I/usr/X11R6/include" \
109         LDOPT="%{rpmldflags} -L/usr/X11R6/lib"
110
111 %{__make} -C doc
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
121 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc Changelog README doc/*.html
132 %attr(755,root,root) %{_bindir}/*
133 %attr(755,root,root) %{_sbindir}/*
134 %attr(755,root,root) %{_libdir}/libavcodec-*.so
135 %attr(755,root,root) %{_libdir}/libavformat-*.so
136 %dir %{_libdir}/vhook
137 %attr(755,root,root) %{_libdir}/vhook/null.so
138 %attr(755,root,root) %{_libdir}/vhook/fish.so
139 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.conf
140
141 %files vhook-imlib2
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libavcodec.so
148 %attr(755,root,root) %{_libdir}/libavformat.so
149 %{_libdir}/lib*.la
150 %{_includedir}/ffmpeg
151
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/lib*.a
This page took 0.316262 seconds and 3 git commands to generate.