]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
7034b678260558b112cda090154524947cc16a31
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2          # we can safely play without it :-)
4 %bcond_without  autoreqdep      # don't care about package name deps generated by rpm
5 #
6 Summary:        Realtime audio/video encoder and streaming server
7 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
8 Name:           ffmpeg
9 Version:        0.4.9
10 %define snap    20060129
11 Release:        3.%{snap}.8
12 # LGPL or GPL, chosen at configure time (GPL version is more featured)
13 License:        GPL
14 Group:          Daemons
15 #Source0:       http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
16 #Source0:       ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
17 Source0:        %{name}-%{snap}.tar.bz2
18 # Source0-md5:  d8ea09431d6c0c91bfd35e0ca74a67e1
19 Patch0:         %{name}-libtool.patch
20 Patch1:         %{name}-libdir.patch
21 Patch2:         %{name}-gcc4.patch
22 URL:            http://ffmpeg.sourceforge.net/
23 BuildRequires:  SDL-devel
24 BuildRequires:  faac-devel
25 BuildRequires:  faad2-devel
26 BuildRequires:  freetype-devel
27 %ifarch ppc
28 # require version with altivec support fixed
29 BuildRequires:  gcc >= 5:3.3.2-3
30 %endif
31 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
32 BuildRequires:  lame-libs-devel
33 #BuildRequires: libx264-devel
34 BuildRequires:  libdts-devel
35 BuildRequires:  libgsm-devel
36 BuildRequires:  libtheora-devel
37 BuildRequires:  libtool >= 2:1.4d-3
38 BuildRequires:  libvorbis-devel
39 BuildRequires:  lzo-devel
40 %ifarch %{ix86}
41 %ifnarch i386 i486
42 BuildRequires:  nasm
43 %endif
44 %endif
45 BuildRequires:  perl-tools-pod
46 BuildRequires:  tetex
47 BuildRequires:  texinfo
48 BuildRequires:  xvid-devel >= 1:1.1.0
49 BuildRequires:  zlib-devel
50 %{?with_autoreqdep:BuildConflicts:      libpostproc}
51 Requires:       xvid >= 1:1.1.0
52 Obsoletes:      libpostproc
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
56
57 %define         specflags       -fno-strict-aliasing
58
59 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
60 %define         specflags_ia32  -fomit-frame-pointer
61 # -mmmx is needed to enable <mmintrin.h> code.
62 %define         specflags_i586  -mmmx
63 %define         specflags_i686  -mmmx
64
65 %description
66 ffmpeg is a hyper fast realtime audio/video encoder and streaming
67 server. It can grab from a standard Video4Linux video source and
68 convert it into several file formats based on DCT/motion compensation
69 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
70 compatible stream.
71
72 This package contains also ffmpeg shared libraries (libavcodec and
73 libavformat).
74
75 %description -l pl
76 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
77 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
78 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
79 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
80 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
81 strumienia kompatybilnego z AC3.
82
83 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
84 libavformat).
85
86 %package devel
87 Summary:        ffmpeg header files
88 Summary(pl):    Pliki nag³ówkowe ffmpeg
89 Group:          Development/Libraries
90 Requires:       %{name} = %{version}-%{release}
91 Obsoletes:      libpostproc-devel
92 # for libavcodec:
93 Requires:       faac-devel
94 Requires:       lame-libs-devel
95 Requires:       libdts-devel
96 Requires:       libgsm-devel
97 Requires:       libtheora-devel
98 Requires:       libvorbis-devel
99 Requires:       xvid-devel >= 1:1.1.0
100 Requires:       zlib-devel
101
102 %description devel
103 ffmpeg header files.
104
105 %description devel -l pl
106 Pliki nag³ówkowe ffmpeg.
107
108 %package static
109 Summary:        ffmpeg static libraries
110 Summary(pl):    Statyczne biblioteki ffmpeg
111 Group:          Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113
114 %description static
115 ffmpeg static libraries (libavcodec and libavformat).
116
117 %description static -l pl
118 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
119
120 %package ffplay
121 Summary:        FFplay - SDL-based media player
122 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
123 Group:          Applications/Multimedia
124 Requires:       %{name} = %{version}-%{release}
125
126 %description ffplay
127 FFplay is a very simple and portable media player using the FFmpeg
128 libraries and the SDL library. It is mostly used as a test bench for
129 the various APIs of FFmpeg.
130
131 %description ffplay -l pl
132 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
133 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
134 testowania ró¿nych API FFmpeg.
135
136 %package vhook-imlib2
137 Summary:        imlib2 based hook
138 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
139 Group:          Libraries
140 Requires:       %{name} = %{version}-%{release}
141
142 %description vhook-imlib2
143 This module implements a text overlay for a video image. Currently it
144 supports a fixed overlay or reading the text from a file. The string
145 is passed through strftime so that it is easy to imprint the date and
146 time onto the image.
147
148 %description vhook-imlib2 -l pl
149 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
150 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
151 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
152 obrazie.
153
154 %prep
155 %setup -q -n ffmpeg
156 %patch0 -p1
157 %patch1 -p1
158 %patch2 -p1
159
160 %build
161 # notes:
162 # - it's not autoconf configure
163 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
164 ./configure \
165         --prefix=%{_prefix} \
166         --libdir=%{_libdir} \
167         --mandir=%{_mandir} \
168         --disable-strip \
169         --enable-a52 \
170         --enable-a52bin \
171         --enable-dts \
172         --enable-faac \
173         --enable-faad \
174         --enable-faadbin \
175         --enable-gpl \
176         --enable-libgsm \
177         --enable-libogg \
178         --enable-mp3lame \
179         --enable-pp \
180         --enable-pthreads \
181         --enable-shared \
182         --enable-theora \
183         --enable-vorbis \
184         --enable-xvid \
185         --disable-x264 \ # disable for now, the version we have is too old
186 %ifnarch %{ix86} %{x8664}
187         --disable-mmx \
188 %endif
189 %ifarch i386 i486
190         --disable-mmx \
191 %endif
192         --cc="%{__cc}" \
193         --extra-cflags="%{rpmcflags}" \
194         --extra-ldflags="%{rpmldflags}" \
195         --disable-debug \
196         --disable-opts \
197         --tune=generic
198
199 %{__make} \
200         BUILD_DOC=yes
201
202 %install
203 rm -rf $RPM_BUILD_ROOT
204 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
205
206 %{__make} install \
207         DESTDIR=$RPM_BUILD_ROOT
208
209 install xvmc_render.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
210
211 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
212 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
213
214 %clean
215 rm -rf $RPM_BUILD_ROOT
216
217 %post   -p /sbin/ldconfig
218 %postun -p /sbin/ldconfig
219
220 %files
221 %defattr(644,root,root,755)
222 %doc Changelog README doc/*.html
223 %attr(755,root,root) %{_bindir}/ffmpeg
224 %attr(755,root,root) %{_sbindir}/ffserver
225 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
226 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
227 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
228 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
229 %dir %{_libdir}/vhook
230 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
231 %attr(755,root,root) %{_libdir}/vhook/fish.so
232 %attr(755,root,root) %{_libdir}/vhook/null.so
233 %attr(755,root,root) %{_libdir}/vhook/ppm.so
234 %attr(755,root,root) %{_libdir}/vhook/watermark.so
235 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
236 %{_mandir}/man1/ffmpeg.1*
237 %{_mandir}/man1/ffserver.1*
238
239 %files devel
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{_libdir}/libavcodec.so
242 %attr(755,root,root) %{_libdir}/libavformat.so
243 %attr(755,root,root) %{_libdir}/libavutil.so
244 %attr(755,root,root) %{_libdir}/libpostproc.so
245 %{_libdir}/lib*.la
246 %{_includedir}/ffmpeg
247 %{_includedir}/postproc
248 %{_pkgconfigdir}/*.pc
249
250 %files static
251 %defattr(644,root,root,755)
252 %{_libdir}/lib*.a
253
254 %files ffplay
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{_bindir}/ffplay
257 %{_mandir}/man1/ffplay.1*
258
259 %if %{with imlib2}
260 %files vhook-imlib2
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
263 %endif
This page took 0.101776 seconds and 3 git commands to generate.