]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
3556ae221f414095264747971a4428b8861fe0f4
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib   # we can safely play without it :-)
4 #
5 Summary:        Realtime audio/video encoder and streaming server
6 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
7 Name:           ffmpeg
8 Version:        0.4.8
9 Release:        4
10 License:        LGPL/GPL
11 Group:          Daemons
12 Source0:        http://dl.sourceforge.net/ffmpeg/%{name}-%{version}.tar.gz
13 # Source0-md5:  e00d47614ba1afd99ad2ea387e782dd9
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-imlib2.patch
16 Patch2:         %{name}-libtool.patch
17 Patch3:         %{name}-lib64.patch
18 Patch4:         %{name}-gcc34.patch
19 URL:            http://ffmpeg.sourceforge.net/
20 BuildRequires:  SDL-devel
21 BuildRequires:  freetype-devel
22 %ifarch ppc
23 # require version with altivec support fixed
24 BuildRequires:  gcc >= 5:3.3.2-3
25 %endif
26 %{?with_imlib:BuildRequires:    imlib2-devel >= 1.1.0-2}
27 BuildRequires:  libtool >= 2:1.4d-3
28 %ifarch i586 i686 athlon
29 BuildRequires:  nasm
30 %endif
31 BuildRequires:  zlib-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
35
36 %description
37 ffmpeg is a hyper fast realtime audio/video encoder and streaming
38 server. It can grab from a standard Video4Linux video source and
39 convert it into several file formats based on DCT/motion compensation
40 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
41 compatible stream.
42
43 This package contains also ffmpeg shared libraries (libavcodec and
44 libavformat).
45
46 %description -l pl
47 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
48 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
49 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
50 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
51 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
52 strumienia kompatybilnego z AC3.
53
54 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
55 libavformat).
56
57 %package ffplay
58 Summary:        FFplay - SDL-based media player
59 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
60 Group:          Applications/Multimedia
61 Requires:       %{name} = %{version}
62
63 %description ffplay
64 FFplay is a very simple and portable media player using the FFmpeg
65 libraries and the SDL library. It is mostly used as a test bench for
66 the various APIs of FFmpeg.
67
68 %description ffplay -l pl
69 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
70 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
71 testowania ró¿nych API FFmpeg.
72
73 %package vhook-imlib2
74 Summary:        imlib2 based hook
75 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
76 Group:          Libraries
77 Requires:       %{name} = %{version}
78
79 %description vhook-imlib2
80 This module implements a text overlay for a video image. Currently it
81 supports a fixed overlay or reading the text from a file. The string
82 is passed through strftime so that it is easy to imprint the date and
83 time onto the image.
84
85 %description vhook-imlib2 -l pl
86 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
87 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
88 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
89 obrazie.
90
91 %package devel
92 Summary:        ffmpeg header files
93 Summary(pl):    Pliki nag³ówkowe ffmpeg
94 Group:          Development/Libraries
95 Requires:       %{name} = %{version}
96
97 %description devel
98 ffmpeg header files.
99
100 %description devel -l pl
101 Pliki nag³ówkowe ffmpeg.
102
103 %package static
104 Summary:        ffmpeg static libraries
105 Summary(pl):    Statyczne biblioteki ffmpeg
106 Group:          Development/Libraries
107 Requires:       %{name}-devel = %{version}
108
109 %description static
110 ffmpeg static libraries (libavcodec and libavformat).
111
112 %description static -l pl
113 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
114
115 %prep
116 %setup -q
117 %patch0 -p1
118 %patch1 -p1
119 %patch2 -p1
120 %ifarch amd64
121 %patch3 -p1
122 %endif
123 %patch4 -p1
124
125 %build
126 # notes:
127 # - it's not autoconf configure
128 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
129 #   (-fPIC takes one)
130 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
131 ./configure \
132         --prefix=%{_prefix} \
133         --mandir=%{_mandir} \
134         --enable-shared \
135         --enable-a52bin \
136         --enable-faadbin \
137 %ifnarch i586 i686 athlon
138         --disable-mmx \
139 %endif
140         --cc="%{__cc}" \
141         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
142         --extra-ldflags="%{rpmldflags}" \
143         --disable-debug \
144         --disable-opts \
145         --tune=generic
146
147 %{__make}
148 %{__make} -C doc
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
153
154 %{__make} install \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
158 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %files
167 %defattr(644,root,root,755)
168 %doc Changelog README doc/*.html
169 %attr(755,root,root) %{_bindir}/ffmpeg
170 %attr(755,root,root) %{_sbindir}/ffserver
171 %attr(755,root,root) %{_libdir}/libavcodec-*.so
172 %attr(755,root,root) %{_libdir}/libavformat-*.so
173 %dir %{_libdir}/vhook
174 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
175 %attr(755,root,root) %{_libdir}/vhook/fish.so
176 %attr(755,root,root) %{_libdir}/vhook/null.so
177 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ffserver.conf
178 %{_mandir}/man1/ffmpeg.1*
179 %{_mandir}/man1/ffserver.1*
180
181 %files ffplay
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_bindir}/ffplay
184 %{_mandir}/man1/ffplay.1*
185
186 %if %{with imlib}
187 %files vhook-imlib2
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
190 %endif
191
192 %files devel
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/libavcodec.so
195 %attr(755,root,root) %{_libdir}/libavformat.so
196 %{_libdir}/lib*.la
197 %{_includedir}/ffmpeg
198
199 %files static
200 %defattr(644,root,root,755)
201 %{_libdir}/lib*.a
This page took 0.114747 seconds and 3 git commands to generate.