]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
258e2b2b8b798c383af77bc36500cacdd29221db
[packages/ffmpeg.git] / ffmpeg.spec
1 # TODO: libzmq ?
2 #
3 # How to deal with ffmpeg/opencv checken-egg problem:
4 #       1. make-request -r --without opencv ffmpeg.spec
5 #       2. make-request -r opencv.spec
6 #       3. bump release of ffmpeg.spec
7 #       4. make-request -r ffmpeg.spec
8 #
9 # Conditional build:
10 %bcond_with     nonfree         # non free options of package (currently: faac)
11 %bcond_with     aacplus         # AAC+ encoding via libaacplus (requires nonfree)
12 %bcond_with     fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
13 %bcond_without  caca            # textual display using libcaca
14 %bcond_without  flite           # flite voice synthesis support
15 %bcond_without  frei0r          # frei0r video filtering
16 %bcond_without  gme             # Game Music Emu support
17 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
18 %bcond_without  ladspa          # LADSPA audio filtering
19 %bcond_without  ssh             # SFTP protocol support via libssh
20 %bcond_without  openal          # OpenAL 1.1 capture support
21 %bcond_with     opencl          # OpenCL code [OpenCL 1.2, but Mesa 9.1.x headers don't suffice]
22 %bcond_without  opencv          # OpenCV video filtering
23 %bcond_without  pulseaudio      # PulseAudio input support
24 %bcond_without  quvi            # quvi input support
25 %bcond_without  shine           # shine fixed-point MP3 encoder
26 %bcond_without  soxr            # SoX Resampler support
27 %bcond_without  x264            # x264 encoder
28 %bcond_without  utvideo         # Ut Video decoder
29 %bcond_without  va              # VAAPI (Video Acceleration API)
30 %bcond_without  vidstab         # vid.stab video stabilization support
31 %bcond_without  vpx             # VP8, a high-quality video codec
32 %bcond_without  wavpack         # wavpack encoding support
33 %bcond_without  zmq             # 0MQ message passing
34 %bcond_without  zvbi            # teletext via libzvbi
35 %bcond_without  doc             # don't build docs
36
37 Summary:        FFmpeg - a very fast video and audio converter
38 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
39 Name:           ffmpeg
40 Version:        2.1.1
41 Release:        4
42 # LGPL or GPL, chosen at configure time (GPL version is more featured)
43 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
44 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
45 License:        GPL v3+ with LGPL v3+ parts
46 Group:          Applications/Multimedia
47 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
48 # Source0-md5:  2719ab2b3311ac3775b9cdeb66c54849
49 Source1:        ffserver.init
50 Source2:        ffserver.sysconfig
51 Source3:        ffserver.conf
52 Patch0:         %{name}-opencv24.patch
53 Patch1:         freetype2.patch
54 URL:            http://www.ffmpeg.org/
55 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
56 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.2}
57 BuildRequires:  SDL-devel >= 1.2.1
58 BuildRequires:  alsa-lib-devel
59 BuildRequires:  bzip2-devel
60 BuildRequires:  celt-devel >= 0.11.0
61 %{?with_nonfree:BuildRequires:  faac-devel}
62 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
63 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
64 BuildRequires:  fontconfig-devel
65 BuildRequires:  freetype-devel
66 %{?with_frei0r:BuildRequires:   frei0r-devel}
67 %{?with_gme:BuildRequires:      game-music-emu-devel}
68 %ifarch ppc
69 # require version with altivec support fixed
70 BuildRequires:  gcc >= 5:3.3.2-3
71 %endif
72 BuildRequires:  gnutls-devel
73 BuildRequires:  jack-audio-connection-kit-devel
74 %{?with_ladspa:BuildRequires:   ladspa-devel}
75 BuildRequires:  lame-libs-devel >= 3.98.3
76 %{?with_aacplus:BuildRequires:  libaacplus-devel >= 2.0.0}
77 BuildRequires:  libass-devel
78 BuildRequires:  libavc1394-devel
79 BuildRequires:  libbluray-devel
80 %{?with_caca:BuildRequires:     libcaca-devel}
81 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
82 BuildRequires:  libdc1394-devel >= 2
83 BuildRequires:  libgsm-devel
84 BuildRequires:  libiec61883-devel
85 BuildRequires:  libmodplug-devel
86 BuildRequires:  libnut-devel
87 %{?with_quvi:BuildRequires:     libquvi-devel}
88 BuildRequires:  libraw1394-devel >= 2
89 BuildRequires:  librtmp-devel
90 %{?with_ssh:BuildRequires:      libssh-devel}
91 BuildRequires:  libtheora-devel >= 1.0-0.beta3
92 BuildRequires:  libtool >= 2:1.4d-3
93 BuildRequires:  libv4l-devel
94 %{?with_va:BuildRequires:       libva-devel >= 1.0.3}
95 BuildRequires:  libvdpau-devel >= 0.2
96 BuildRequires:  libvorbis-devel
97 %{?with_vpx:BuildRequires:      libvpx-devel >= 0.9.7}
98 # X264_BUILD >= 118
99 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
100 %ifarch %{ix86}
101 %ifnarch i386 i486
102 BuildRequires:  nasm
103 %endif
104 %endif
105 BuildRequires:  opencore-amr-devel
106 %{?with_opencv:BuildRequires:   opencv-devel}
107 BuildRequires:  openjpeg-devel >= 1.5
108 BuildRequires:  opus-devel
109 BuildRequires:  perl-Encode
110 BuildRequires:  perl-tools-pod
111 BuildRequires:  pkgconfig
112 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
113 BuildRequires:  rpmbuild(macros) >= 1.470
114 BuildRequires:  schroedinger-devel
115 %{?with_shine:BuildRequires:    shine-devel >= 3.0.0}
116 %{?with_soxr:BuildRequires:     soxr-devel}
117 BuildRequires:  speex-devel >= 1:1.2-rc1
118 %{?with_doc:BuildRequires:      tetex}
119 %{?with_doc:BuildRequires:      texi2html}
120 %{?with_doc:BuildRequires:      texinfo}
121 BuildRequires:  twolame-devel
122 %{?with_utvideo:BuildRequires:  utvideo-devel >= 12}
123 %{?with_vidstab:BuildRequires:  vid.stab-devel}
124 BuildRequires:  vo-aacenc-devel
125 BuildRequires:  vo-amrwbenc-devel
126 %{?with_wavpack:BuildRequires:  wavpack-devel}
127 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
128 BuildRequires:  xavs-devel
129 BuildRequires:  xorg-lib-libX11-devel
130 BuildRequires:  xorg-lib-libXext-devel
131 BuildRequires:  xorg-lib-libXfixes-devel
132 BuildRequires:  xvid-devel >= 1:1.1.0
133 BuildRequires:  yasm
134 %{?with_zmq:BuildRequires:      zeromq-devel}
135 %{?with_zvbi:BuildRequires:     zvbi-devel}
136 BuildRequires:  zlib-devel
137 %{?with_autoreqdep:BuildConflicts:      libpostproc}
138 # overflows maximum hash table size
139 BuildConflicts: pdksh < 5.2.14-57
140 Requires:       %{name}-libs = %{version}-%{release}
141 %{?with_utvideo:Requires:       utvideo >= 12}
142 %{?with_ilbc:Requires:  webrtc-libilbc}
143 Requires:       xvid >= 1:1.1.0
144 Obsoletes:      libpostproc
145 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
146
147 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
148
149 %define         specflags       -fno-strict-aliasing
150
151 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
152 %define         specflags_ia32  -fomit-frame-pointer
153 # -mmmx is needed to enable <mmintrin.h> code.
154 %define         specflags_i586  -mmmx
155 %define         specflags_i686  -mmmx
156 %define         specflags_ppc   -fPIC
157
158 %description
159 FFmpeg is a complete solution to record, convert and stream audio and
160 video. It is a command line tool to convert one video file format to
161 another. It also supports grabbing and encoding in real time from a TV
162 card.
163
164 %description -l pl.UTF-8
165 FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
166 strumieni dźwięku i obrazu. Jest to działające z linii poleceń
167 narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
168 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
169 telewizyjnej.
170
171 %package libs
172 Summary:        ffmpeg libraries
173 Summary(pl.UTF-8):      Biblioteki ffmpeg
174 Group:          Libraries
175
176 %description libs
177 This package contains the ffmpeg shared libraries:
178 - the codec library (libavcodec). It supports most existing encoding
179   formats (MPEG, DivX, MPEG4, AC3, DV...),
180 - demuxer library (libavformat). It supports most existing file
181   formats (AVI, MPEG, OGG, Matroska, ASF...),
182 - video postprocessing library (libpostproc).
183
184 %description libs -l pl.UTF-8
185 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
186 - bibliotekę kodeków (libavcodec); obsługuje większość istniejących
187   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
188 - bibliotekę demuksera (libavformat); obsługuje większość istniejących
189   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
190 - bibliotekę postprocessingu (libpostproc).
191
192 %package devel
193 Summary:        ffmpeg header files
194 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
195 Group:          Development/Libraries
196 Requires:       %{name}-libs = %{version}-%{release}
197 # Libs.private from *.pc (unreasonably they are all the same)
198 %{?with_opencl:Requires:        OpenCL-devel >= 1.2}
199 Requires:       SDL-devel >= 1.2.1
200 Requires:       alsa-lib-devel
201 Requires:       bzip2-devel
202 Requires:       celt-devel >= 0.11.0
203 %{?with_nonfree:Requires:       faac-devel}
204 %{?with_fdk_aac:Requires:       fdk-aac-devel}
205 %{?with_flite:Requires: flite-devel >= 1.4}
206 Requires:       fontconfig-devel
207 Requires:       freetype-devel
208 %{?with_gme:Requires:   game-music-emu-devel}
209 Requires:       jack-audio-connection-kit-devel
210 Requires:       lame-libs-devel >= 3.98.3
211 %{?with_aacplus:Requires:       libaacplus-devel >= 2.0.0}
212 Requires:       libass-devel
213 Requires:       libavc1394-devel
214 Requires:       libbluray-devel
215 %{?with_caca:Requires:  libcaca-devel}
216 Requires:       libcdio-paranoia-devel >= 0.90-2
217 Requires:       libdc1394-devel >= 2
218 Requires:       libgsm-devel
219 Requires:       libiec61883-devel
220 Requires:       libmodplug-devel
221 Requires:       libnut-devel
222 %{?with_quvi:Requires:  libquvi-devel}
223 Requires:       libraw1394-devel >= 2
224 Requires:       librtmp-devel
225 Requires:       libtheora-devel >= 1.0-0.beta3
226 %{?with_va:Requires:    libva-devel >= 1.0.3}
227 Requires:       libvorbis-devel
228 %{?with_vpx:Requires:   libvpx-devel >= 0.9.7}
229 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
230 Requires:       opencore-amr-devel
231 %{?with_opencv:Requires:        opencv-devel}
232 Requires:       openjpeg-devel >= 1.5
233 Requires:       schroedinger-devel
234 %{?with_shine:Requires: shine-devel >= 3.0.0}
235 %{?with_soxr:Requires:  soxr-devel}
236 Requires:       speex-devel >= 1:1.2-rc1
237 Requires:       twolame-devel
238 %{?with_utvideo:Requires:       utvideo-devel >= 12}
239 %{?with_vidstab:Requires:       vid.stab-devel}
240 Requires:       vo-aacenc-devel
241 Requires:       vo-amrwbenc-devel
242 %{?with_wavpack:Requires:       wavpack-devel}
243 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
244 Requires:       xavs-devel
245 Requires:       xorg-lib-libXext-devel
246 Requires:       xorg-lib-libXfixes-devel
247 Requires:       xvid-devel >= 1:1.1.0
248 %{?with_zmq:Requires:   zeromq-devel}
249 Requires:       zlib-devel
250 Obsoletes:      libpostproc-devel
251
252 %description devel
253 ffmpeg header files.
254
255 %description devel -l pl.UTF-8
256 Pliki nagłówkowe ffmpeg.
257
258 %package static
259 Summary:        ffmpeg static libraries
260 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
261 Group:          Development/Libraries
262 Requires:       %{name}-devel = %{version}-%{release}
263
264 %description static
265 ffmpeg static libraries (libavcodec and libavformat).
266
267 %description static -l pl.UTF-8
268 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
269
270 %package ffplay
271 Summary:        FFplay - SDL-based media player
272 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
273 Group:          Applications/Multimedia
274 Requires:       %{name}-libs = %{version}-%{release}
275
276 %description ffplay
277 FFplay is a very simple and portable media player using the FFmpeg
278 libraries and the SDL library. It is mostly used as a test bench for
279 the various APIs of FFmpeg.
280
281 %description ffplay -l pl.UTF-8
282 FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
283 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
284 testowania różnych API FFmpeg.
285
286 %package ffserver
287 Summary:        FFserver video server
288 Summary(pl.UTF-8):      FFserver - serwer strumieni obrazu
289 Group:          Daemons
290 Requires(post,preun):   /sbin/chkconfig
291 Requires:       %{name}-libs = %{version}-%{release}
292 Requires:       rc-scripts >= 0.4.0.10
293
294 %description ffserver
295 FFserver is a streaming server for both audio and video. It supports
296 several live feeds, streaming from files and time shifting on live
297 feeds (you can seek to positions in the past on each live feed,
298 provided you specify a big enough feed storage in ffserver.conf).
299
300 %description ffserver -l pl.UTF-8
301 FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
302 źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
303 czasie dla źródeł na żywo (można przeskakiwać na położenia w
304 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
305 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
306
307 %package doc
308 Summary:        Manual for ffmpeg
309 Summary(fr.UTF-8):      Documentation pour ffmpeg
310 Summary(it.UTF-8):      Documentazione di ffmpeg
311 Summary(pl.UTF-8):      Podręcznik dla ffmpeg
312 Group:          Documentation
313 %if "%{_rpmversion}" >= "5"
314 BuildArch:      noarch
315 %endif
316
317 %description doc
318 Documentation for ffmpeg.
319
320 %description doc -l fr.UTF-8
321 Documentation pour ffmpeg.
322
323 %description doc -l it.UTF-8
324 Documentazione di ffmpeg.
325
326 %description doc -l pl.UTF-8
327 Dokumentacja do ffmpeg.
328
329 %prep
330 %setup -q
331 %patch0 -p1
332 %patch1 -p1
333
334 # package the grep result for mplayer, the result formatted as ./mplayer/configure
335 cat <<EOF > ffmpeg-avconfig
336 #! /bin/sh
337 libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
338 libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
339 libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
340 libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
341 libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
342 libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
343 libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
344 libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
345 libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
346 EOF
347 cat <<'EOF' >> ffmpeg-avconfig
348
349 case "$1" in
350 --decoders)
351         echo $libavdecoders_all
352         ;;
353 --encoders)
354         echo $libavencoders_all
355         ;;
356 --parsers)
357         echo $libavparsers_all
358         ;;
359 --bsfs)
360         echo $libavbsfs_all
361         ;;
362 --demuxers)
363         echo $libavdemuxers_all
364         ;;
365 --muxers)
366         echo $libavmuxers_all
367         ;;
368 --protocols)
369         echo $libavprotocols_all
370         ;;
371 --hwaccels)
372         echo $libavhwaccels_all
373         ;;
374 --filters)
375         echo $libavfilters_all
376         ;;
377 *)
378         cat <<USAGE
379 Usage: $0 [OPTION]
380 Options:
381   --decoders
382   --encoders
383   --parsers
384   --bsfs
385   --demuxers
386   --muxers
387   --protocols
388   --hwaccels
389   --filters
390 USAGE
391         exit 1;;
392 esac
393
394 exit 0
395 EOF
396
397 %build
398 # notes:
399 # - it's not autoconf configure
400 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
401 ./configure \
402         --arch=%{_target_base_arch} \
403         --prefix=%{_prefix} \
404         --libdir=%{_libdir} \
405         --shlibdir=%{_libdir} \
406         --mandir=%{_mandir} \
407         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
408         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
409         --cc="%{__cc}" \
410         --disable-debug \
411         --disable-optimizations \
412         --disable-stripping \
413         --enable-avfilter \
414         --enable-avresample \
415         --enable-gnutls \
416         --enable-gpl \
417         --enable-version3 \
418         --enable-fontconfig \
419         %{?with_frei0r:--enable-frei0r} \
420         %{?with_ladspa:--enable-ladspa} \
421         %{?with_aacplus:--enable-libaacplus} \
422         --enable-libass \
423         --enable-libbluray \
424         %{?with_caca:--enable-libcaca} \
425         --enable-libcelt \
426         --enable-libcdio \
427         --enable-libdc1394 \
428         %{?with_fdk_aac:--enable-libfdk-aac} \
429         %{?with_flite:--enable-libflite} \
430         --enable-libfreetype \
431         %{?with_gme:--enable-libgme} \
432         --enable-libgsm \
433         --enable-libiec61883 \
434         %{?with_ilbc:--enable-libilbc} \
435         --enable-libmodplug \
436         --enable-libmp3lame \
437         --enable-libnut \
438         --enable-libopencore-amrnb \
439         --enable-libopencore-amrwb \
440         %{?with_opencv:--enable-libopencv} \
441         --enable-libopenjpeg \
442         --enable-libopus \
443         %{?with_pulseaudio:--enable-libpulse} \
444         %{?with_quvi:--enable-libquvi} \
445         --enable-librtmp \
446         --enable-libschroedinger \
447         %{?with_shine:--enable-libshine} \
448         %{?with_soxr:--enable-libsoxr} \
449         --enable-libspeex \
450         %{?with_ssh:--enable-libssh} \
451         --enable-libtheora \
452         --enable-libtwolame \
453         %{?with_utvideo:--enable-libutvideo} \
454         --enable-libv4l2 \
455         %{?with_vidstab:--enable-libvidstab} \
456         --enable-libvo-aacenc \
457         --enable-libvo-amrwbenc \
458         --enable-libvorbis \
459         %{?with_vpx:--enable-libvpx} \
460         %{?with_wavpack:--enable-libwavpack} \
461         %{?with_x264:--enable-libx264} \
462         --enable-libxavs \
463         --enable-libxvid \
464         %{?with_zmq:--enable-libzmq} \
465         %{?with_zvbi:--enable-libzvbi} \
466         %{?with_openal:--enable-openal} \
467         %{?with_opencl:--enable-opencl} \
468         --enable-postproc \
469         --enable-pthreads \
470         --enable-shared \
471         --enable-swscale \
472         %{!?with_va:--disable-vaapi} \
473         --enable-x11grab \
474 %ifnarch %{ix86} %{x8664}
475         --disable-mmx \
476 %endif
477 %ifarch i386 i486
478         --disable-mmx \
479 %endif
480 %if %{with nonfree}
481         --enable-nonfree \
482         --enable-libfaac \
483 %endif
484         --enable-runtime-cpudetect
485
486 %{__make} \
487         V=1
488
489 # CC_O to add -c to commandline. makefile should be patched
490 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
491
492 %install
493 rm -rf $RPM_BUILD_ROOT
494 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
495         $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
496         $RPM_BUILD_ROOT/var/{cache,log}/ffserver
497
498 %{__make} install install-headers \
499         DESTDIR=$RPM_BUILD_ROOT \
500         V=1
501
502 # install nonstandard, non-public headers manually
503 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
504 for a in libavutil/*/bswap.h; do
505         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
506 done
507 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
508 # for lim-omx ffmpeg components
509 cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
510
511 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
512 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
513 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
514 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
515 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
516
517 # install as ffmpeg-avconfig to avoid with possible programs looking for
518 # ffmpeg-config and expecting --libs output from it which is not implemented
519 # simple to do (by querying pkgconfig), but why?
520 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
521
522 %clean
523 rm -rf $RPM_BUILD_ROOT
524
525 %post   libs -p /sbin/ldconfig
526 %postun libs -p /sbin/ldconfig
527
528 %pre ffserver
529 %groupadd -g 167 ffserver
530 %useradd -g ffserver -u 167 ffserver
531
532 %post ffserver
533 /sbin/chkconfig --add ffserver
534 %service ffserver restart
535
536 %preun ffserver
537 if [ "$1" = 0 ]; then
538         %service ffserver stop
539         /sbin/chkconfig --del ffserver
540 fi
541
542 %postun ffserver
543 if [ "$1" = 0 ]; then
544         %userremove ffserver
545         %groupremove ffserver
546 fi
547
548 %files
549 %defattr(644,root,root,755)
550 %doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES}
551 %attr(755,root,root) %{_bindir}/ffmpeg
552 %attr(755,root,root) %{_bindir}/ffprobe
553 %attr(755,root,root) %{_bindir}/qt-faststart
554 %dir %{_datadir}/ffmpeg
555 %{_datadir}/ffmpeg/*.ffpreset
556 %{_datadir}/ffmpeg/ffprobe.xsd
557 %if %{with doc}
558 %{_mandir}/man1/ffmpeg.1*
559 %{_mandir}/man1/ffmpeg-all.1*
560 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
561 %{_mandir}/man1/ffmpeg-codecs.1*
562 %{_mandir}/man1/ffmpeg-devices.1*
563 %{_mandir}/man1/ffmpeg-filters.1*
564 %{_mandir}/man1/ffmpeg-formats.1*
565 %{_mandir}/man1/ffmpeg-protocols.1*
566 %{_mandir}/man1/ffmpeg-resampler.1*
567 %{_mandir}/man1/ffmpeg-scaler.1*
568 %{_mandir}/man1/ffmpeg-utils.1*
569 %{_mandir}/man1/ffprobe.1*
570 %{_mandir}/man1/ffprobe-all.1*
571 %endif
572
573 %files libs
574 %defattr(644,root,root,755)
575 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
576 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.55
577 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
578 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.55
579 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
580 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
581 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
582 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.55
583 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
584 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.1
585 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
586 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.52
587 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
588 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
589 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
590 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
591 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
592 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
593
594 %files devel
595 %defattr(644,root,root,755)
596 %doc doc/optimization.txt
597 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
598 %attr(755,root,root) %{_libdir}/libavcodec.so
599 %attr(755,root,root) %{_libdir}/libavdevice.so
600 %attr(755,root,root) %{_libdir}/libavfilter.so
601 %attr(755,root,root) %{_libdir}/libavformat.so
602 %attr(755,root,root) %{_libdir}/libavresample.so
603 %attr(755,root,root) %{_libdir}/libavutil.so
604 %attr(755,root,root) %{_libdir}/libpostproc.so
605 %attr(755,root,root) %{_libdir}/libswresample.so
606 %attr(755,root,root) %{_libdir}/libswscale.so
607 %{_includedir}/ffmpeg
608 %{_includedir}/libavcodec
609 %{_includedir}/libavdevice
610 %{_includedir}/libavfilter
611 %{_includedir}/libavformat
612 %{_includedir}/libavresample
613 %{_includedir}/libavutil
614 %{_includedir}/libpostproc
615 %{_includedir}/libswresample
616 %{_includedir}/libswscale
617 %{_pkgconfigdir}/libavcodec.pc
618 %{_pkgconfigdir}/libavdevice.pc
619 %{_pkgconfigdir}/libavfilter.pc
620 %{_pkgconfigdir}/libavformat.pc
621 %{_pkgconfigdir}/libavresample.pc
622 %{_pkgconfigdir}/libavutil.pc
623 %{_pkgconfigdir}/libpostproc.pc
624 %{_pkgconfigdir}/libswresample.pc
625 %{_pkgconfigdir}/libswscale.pc
626 %if %{with doc}
627 %{_mandir}/man3/libavcodec.3*
628 %{_mandir}/man3/libavdevice.3*
629 %{_mandir}/man3/libavfilter.3*
630 %{_mandir}/man3/libavformat.3*
631 %{_mandir}/man3/libavutil.3*
632 %{_mandir}/man3/libswresample.3*
633 %{_mandir}/man3/libswscale.3*
634 %endif
635
636 %files static
637 %defattr(644,root,root,755)
638 %{_libdir}/libavcodec.a
639 %{_libdir}/libavdevice.a
640 %{_libdir}/libavfilter.a
641 %{_libdir}/libavformat.a
642 %{_libdir}/libavresample.a
643 %{_libdir}/libavutil.a
644 %{_libdir}/libpostproc.a
645 %{_libdir}/libswresample.a
646 %{_libdir}/libswscale.a
647
648 %files ffplay
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_bindir}/ffplay
651 %if %{with doc}
652 %{_mandir}/man1/ffplay.1*
653 %{_mandir}/man1/ffplay-all.1*
654 %endif
655
656 %files ffserver
657 %defattr(644,root,root,755)
658 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
659 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
660 %attr(755,root,root) %{_sbindir}/ffserver
661 %attr(754,root,root) /etc/rc.d/init.d/ffserver
662 %if %{with doc}
663 %{_mandir}/man1/ffserver.1*
664 %{_mandir}/man1/ffserver-all.1*
665 %endif
666 %dir %attr(770,root,ffserver) /var/cache/ffserver
667 %dir %attr(770,root,ffserver) /var/log/ffserver
668
669 %if %{with doc}
670 %files doc
671 %defattr(644,root,root,755)
672 %doc doc/*.html
673 %endif
This page took 0.080088 seconds and 3 git commands to generate.