]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- patch: gcc4
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2          # we can safely play without it :-)
4 %bcond_without  autoreqdep      # don't care about package name deps generated by rpm
5 #
6 Summary:        Realtime audio/video encoder and streaming server
7 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
8 Name:           ffmpeg
9 Version:        0.4.9
10 Release:        0.pre1.1
11 # LGPL or GPL, chosen at configure time (GPL version is more featured)
12 License:        GPL
13 Group:          Daemons
14 Source0:        http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
15 # Source0-md5:  ea5587e3c66d50b1503b82ac4179c303
16 Patch0:         %{name}-imlib2.patch
17 Patch1:         %{name}-libtool.patch
18 Patch2:         %{name}-gcc4.patch
19 URL:            http://ffmpeg.sourceforge.net/
20 BuildRequires:  SDL-devel
21 BuildRequires:  freetype-devel
22 %ifarch ppc
23 # require version with altivec support fixed
24 BuildRequires:  gcc >= 5:3.3.2-3
25 %endif
26 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
27 BuildRequires:  libtool >= 2:1.4d-3
28 BuildRequires:  faac-devel
29 %ifarch %{ix86}
30 %ifnarch i386 i486
31 BuildRequires:  nasm
32 %endif
33 %endif
34 BuildRequires:  perl-tools-pod
35 BuildRequires:  tetex
36 BuildRequires:  texinfo
37 BuildRequires:  zlib-devel
38 BuildRequires:  lame-libs-devel
39 BuildRequires:  libvorbis-devel
40 %{?with_autoreqdep:BuildConflicts:      libpostproc}
41 Obsoletes:      libpostproc
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
45
46 %description
47 ffmpeg is a hyper fast realtime audio/video encoder and streaming
48 server. It can grab from a standard Video4Linux video source and
49 convert it into several file formats based on DCT/motion compensation
50 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
51 compatible stream.
52
53 This package contains also ffmpeg shared libraries (libavcodec and
54 libavformat).
55
56 %description -l pl
57 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
58 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
59 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
60 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
61 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
62 strumienia kompatybilnego z AC3.
63
64 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
65 libavformat).
66
67 %package devel
68 Summary:        ffmpeg header files
69 Summary(pl):    Pliki nag³ówkowe ffmpeg
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Obsoletes:      libpostproc-devel
73
74 %description devel
75 ffmpeg header files.
76
77 %description devel -l pl
78 Pliki nag³ówkowe ffmpeg.
79
80 %package static
81 Summary:        ffmpeg static libraries
82 Summary(pl):    Statyczne biblioteki ffmpeg
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 ffmpeg static libraries (libavcodec and libavformat).
88
89 %description static -l pl
90 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
91
92 %package ffplay
93 Summary:        FFplay - SDL-based media player
94 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
95 Group:          Applications/Multimedia
96 Requires:       %{name} = %{version}-%{release}
97
98 %description ffplay
99 FFplay is a very simple and portable media player using the FFmpeg
100 libraries and the SDL library. It is mostly used as a test bench for
101 the various APIs of FFmpeg.
102
103 %description ffplay -l pl
104 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
105 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
106 testowania ró¿nych API FFmpeg.
107
108 %package vhook-imlib2
109 Summary:        imlib2 based hook
110 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
111 Group:          Libraries
112 Requires:       %{name} = %{version}-%{release}
113
114 %description vhook-imlib2
115 This module implements a text overlay for a video image. Currently it
116 supports a fixed overlay or reading the text from a file. The string
117 is passed through strftime so that it is easy to imprint the date and
118 time onto the image.
119
120 %description vhook-imlib2 -l pl
121 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
122 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
123 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
124 obrazie.
125
126 %prep
127 %setup -q -n ffmpeg-0.4.9-pre1
128 %patch0 -p1
129 %patch1 -p1
130 %patch2 -p1
131
132 %build
133 # notes:
134 # - it's not autoconf configure
135 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
136 #   (-fPIC takes one)
137 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
138 ./configure \
139         --prefix=%{_prefix} \
140         --libdir=%{_libdir} \
141         --mandir=%{_mandir} \
142         --enable-a52bin \
143         --enable-faac \
144         --enable-faadbin \
145         --enable-pthreads \
146         --enable-gpl \
147         --enable-pp \
148         --enable-shared \
149         --enable-shared-pp \
150         --enable-mp3lame \
151         --enable-vorbis \
152 %ifnarch %{ix86}
153         --disable-mmx \
154 %endif
155 %ifarch i386 i486
156         --disable-mmx \
157 %endif
158         --cc="%{__cc}" \
159         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
160         --extra-ldflags="%{rpmldflags}" \
161         --disable-debug \
162         --disable-opts \
163         --tune=generic
164
165 %{__make} \
166         BUILD_DOC=yes
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
171
172 %{__make} install \
173         DESTDIR=$RPM_BUILD_ROOT
174
175 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
176 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post   -p /sbin/ldconfig
182 %postun -p /sbin/ldconfig
183
184 %files
185 %defattr(644,root,root,755)
186 %doc Changelog README doc/*.html
187 %attr(755,root,root) %{_bindir}/ffmpeg
188 %attr(755,root,root) %{_sbindir}/ffserver
189 %attr(755,root,root) %{_libdir}/libavcodec-*.so
190 %attr(755,root,root) %{_libdir}/libavformat-*.so
191 %attr(755,root,root) %{_libdir}/libpostproc.so.*
192 %dir %{_libdir}/vhook
193 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
194 %attr(755,root,root) %{_libdir}/vhook/fish.so
195 %attr(755,root,root) %{_libdir}/vhook/null.so
196 %attr(755,root,root) %{_libdir}/vhook/ppm.so
197 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ffserver.conf
198 %{_mandir}/man1/ffmpeg.1*
199 %{_mandir}/man1/ffserver.1*
200
201 %files devel
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libdir}/libavcodec.so
204 %attr(755,root,root) %{_libdir}/libavformat.so
205 %attr(755,root,root) %{_libdir}/libpostproc.so
206 %{_libdir}/lib*.la
207 %{_includedir}/ffmpeg
208 %{_includedir}/postproc
209
210 %files static
211 %defattr(644,root,root,755)
212 %{_libdir}/lib*.a
213
214 %files ffplay
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_bindir}/ffplay
217 %{_mandir}/man1/ffplay.1*
218
219 %if %{with imlib2}
220 %files vhook-imlib2
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
223 %endif
This page took 0.052882 seconds and 3 git commands to generate.